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SI 5 User Guide 
 

The D-Tools System Integrator version 5 (SI5) User Guide was designed for Microsoft Visio 

2003/2007, AutoCAD Version 2006/2009 and D-Tools SI5 system integration software. 

This document and its contents is the copyright of D-Tools, Inc. 2007. All rights reserved. 

Any redistribution or reproduction of part or all of the contents in any form is prohibited other than 

the following: 

9 you may print or download to a local hard disk extracts for your personal and non-

commercial use only 

9 you may copy the content to individual third parties for their personal use. 

You may not, except with our express written permission, distribute or commercially exploit the 

content. Nor may you transmit it or store it in any other website or other form of electronic 

retrieval system. 

Product and technology names mentioned in this material are the registered trademarks of their 

respected companies. 
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Welcome to D-Tools SI5! 
Welcome to the growing family of D-Tools System Integrator (SI) users!  I want to thank you 

for putting your confidence in D-Tools software.  We know that D-Tools SI5 will be a powerful 

enhancement to your system integration business.  D-Tools SI is the leader in complete system 

integration software and has been proven by thousands of system integration companies that are 

already using it to more effectively design, engineer, document, estimate, sell, install, and manage 

their low voltage projects.  In fact, many companies have seen the software pay for itself in the 

first project through increased efficiencies throughout the company. 

This latest version of D-Tools SI has been extensively tested on various computer platforms, but it 

has not been tested on the most important one… yours.  Give it a try, run through a sample 

project, test it, and by all means, please don’t hesitate to contact us to report any issues or 

questions so we can continue to improve the software.  You will receive free in-version updates to 

our product over time as we continue to hone the product and add even more enhancements.  We 

want you to be successful with this product.  Feel free to contact us with ideas and thoughts about 

the program.  Some of our best enhancements have come from users just like you. 

While D-Tools has been designed to be simple to use, it is also a very deep and full functioned 

software product.  I have included some ideas you can use to make a smoother transition from 

your previous design, estimating and business management procedures to D-Tools SI: 

• Take a moment to peruse the user guide included with the software before jumping right in.  

This guide is full of tips, tricks and detailed information that will help you get the most from 

the software. 

• Your corporate product database is one of your most important business assets.  Take the 

time to prepare your database by following the steps outlined in the Manage My Product 

Data (MMPD) interface.  MMPD was specifically designed to easily allow you to add, edit and 

enhance your product data.  In addition don’t forget to make frequent backups of your D-

Tools SI database and projects. 

• Open one of the sample projects included in your software.  See how we have created 

packages, accessories and miscellaneous labor costs.  Run all the reports you have available 

with this demo project.  Finally, take a small project that you have completed in the past, 

one that is successful and you are happy with.  This will allow you to get familiar with the 

program and begin to create a custom database of your most used products. 
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I highly recommend product training.  Although not a requirement, product trainings are 

reasonably priced and are offered regionally throughout the year.  We offer a number of regional, 

on-site or web based trainings.  Trainings are an excellent way to shorten the learning curve and 

quickly get up to speed.  For more information about trainings visit: 

 http://www.d-tools.com/index.php/support/training-sub 

It is our hope to always keep product data current and free for you to use.  You can help in this 

regard by encouraging the manufacturers and reps you deal with to join the Manufacturer Vantage 

Point Partner Program.  Please have them e-mail mvp@d-tools.com for more information. 

Thank you again for your purchase.  If you take the time to implement the software into your 

everyday business practices, I know that you will join the growing group of companies using 

System Integrator who are seeing tremendous results!  Please contact me if I can be of any 

additional help.  

Sincerely, 

 

Adam Stone 

President 

adam@d-tools.com 

 

http://www.d-tools.com/index.php/support/training-sub
mailto:mvp@d-tools.com
mailto:adam@d-tools.com
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About This Guide 
This is guide is undergoing constant revision.  You may find that some sections are not consistent 

with the screens or functionality you see.  Feel free to contact us over any discrepancies and we 

will update these sections as quickly as possible.  You may download the most recent versions via 

the following links: 

Installation and Administration Guide 
http://downloads.d-

tools.com/si5/documents/training/SI_5_Installation_and_Administration_Guide.pdf 

User Guide 
http://downloads.d-tools.com/si5/documents/training/SI_5_User_Guide.pdf 

Help Videos 
http://downloads.d-tools.com:80/si5/documents/SI5_Help_Videos.html 

Tutorial 
http://downloads.d-tools.com/si5/documents/training/SI_5_Tutorial.pdf 

This document along with the SI 5 Tutorial and the Installation and Administration Guide will help 

maximize the return on your D-Tools investment.  SI 5 is a very feature rich product.  If you have 

specific questions, scan the Table Of Contents or look for keywords in the index.  If you find we 

have left out something, please let us know.  We are releasing this document in PDF format so that 

it may be more easily updated as SI 5 continues to evolve.  Please give us you feedback.  We want 

to know how we can further improve both our products and our documentation.   

Please report any errors, omissions or suggestions to bugs@d-tools.com.  

Thanks, 

The SI5 Documentation Team 

Seth Enos senos@d-tools.com 

Randall Bownds randyb@d-tools.com 

 

http://downloads.d-tools.com/si5/documents/training/SI_5_User_Guide.pdf
http://downloads.d-tools.com/si5/documents/SI5_Help_Videos.html
http://downloads.d-tools.com/si5/documents/training/SI_5_Tutorial.pdf
mailto:bugs@d-tools.com
mailto:senos@d-tools.com
mailto:randyb@d-tools.com
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Pre-Implementation 
This section is designed to help you prepare for a successful D-Tools System Integrator 5 (SI 5) 

implementation.  SI 5 is a very flexible tool that can conform to a wide range of business needs.  

Our intent is help you understand the issues and gather the necessary information that will result 

in a successful implementation. 

SI 5 Licensing 
For a complete discussion of SI 5 Licensing issues please see the SI 5 Installation and 

Administration Guide.  

Infrastructure Planning 
Setting up the proper network configuration and appropriate computer resources can make a 

significant difference in the performance of the SI 5 application suite.  The ideal designer 

workstation would have dual screens allowing easy viewing of both the Product data and drawings 

at the same time.  If you have more than one SI 5 license, you need to provide access to a 

computer to serve as the “D-Tools Server”.  A server class computer is not required.  In most 

cases, a modest performing desktop computer with a high speed network adapter is all that is 

necessary.  If you happen to have a server that is already running SQL Server, then this would be 

an ideal machine to host the SI 5 server databases. Whatever machine you choose should be 

included in your daily backup procedure. 

Recommended Hardware Requirements 

These recommendations are based on our experience and should be considered in order to have an 

acceptable computing experience.  These recommendations assume that you are using Visio or 

AutoCAD to complete drawings with SI 5. 

Processor: Intel Core Duo, 2.0 GHz 

Memory: 2 GB of RAM 

Hard Disk: 2 GB of available space 

Optical Drive: DVD-ROM 

Display: Dual XGA (1024 x 768) or higher resolution monitors. 

Operating System: US-English version of Microsoft Windows XP SP 2 or Vista 
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Small LAN (multiple licenses of SI 5) 

Best:....Provide a dedicated server with backup capability to host the SI 5 server databases.  

Good:...Provide a workstation with backup capability to host the SI 5 server databases.  This 

machine would need to share files with all other SI 5 users and stay online at all times 

while others are using any of the SI 5 applications. 
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Server Database Locations 

Best: Use an existing server running SQL Server 2000 SP3 or better.  

Better:  Install LANSync on a dedicated server.  This will install the SQL Server Express Edition. 

Good: Install LANSync on a desktop workstation. This will install the SQL Server Express Edition. 
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Data Architecture 

SI 5 operates in a distributed architecture.  Changes made to the Local Products Database 

stored on each user’s computer are updated to the Server Products Database via LANSync at 

times to be determined by the user.  These changes are propagated to all users based on each 

user’s update strategy.  This means that you may at any time disconnect an individual user from 

the network since you will be using the local Master Table Database.  The next time the user 

connects; all changes will be propagated to the other users via the server.  LANSync module keeps 

all Product information in sync between the users. 

LANSync maintains the Server Projects Database which keeps track of all projects that are 

checked into the server.  All shared Projects are “checked-in” to the server.  To modify a Project it 

must first be “checked out” .  During checkout the Project is copied to the user’s local hard drive. 

Once checked out, the user may disconnect from the network and take the Project home or into 

the field.  Once the Project modifications are complete, the Project is checked back in to the 

LANSync server for possible editing by other users.  While the Project is “checked-out”, other 

users may view the Project and run reports, but no modifications are allowed.  Due to the graphical 

nature of SI 5 Projects a lot of information may move between the server and the user’s computer.  

A high speed network is required to provide optimal SI 5 performance. 

Product Data and Pricing 
A key to early success with SI 5 depends on the quality of the data you have to begin your first 

Project.  Ideally you would like to begin with a database of Products you use today.  D-Tools has a 

large Product database available for download.  However, we suggest that you only download the 

data you need.  See “Downloading Products” on page 121. 

Gathering Existing Data 

Identify the sources of the data you use today, such as QuickBooks, spreadsheets or an existing 

Product database.  Use this list as a basis for downloading Product data from D-Tools.  If you 

currently manage your Products in your accounting system you may use QuickLinks to link the D-

Tools Products to your accounting Items, see QuickLinks on page 609.  Once you load your 

Product Database you may update prices by a) syncing with your accounting data via QuickLinks or 

b) use the MMPD spreadsheet export/import process. 

Accessories 

An accessory is a Product that is often needed to properly configure or install another Product.  For 

example, a mount may need to be sold with a High Definition TV installation.  In this case there 
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may be many mount options to choose from.  Once a Product is in the database it can be listed as 

an accessory to another Product.  So each time the parent Product is chosen, you could be 

prompted to select from a list of accessories that have been pre-assigned to the parent Product.  

You may choose to set up the accessories in advance for Products you often quote.  However, 

accessory assignment can occur as needed during proposal generation.  Once you make an 

accessory assignment, SI 5 will store this assignment for future use.  Accessories may NOT include 

other Accessories.  In other words you cannot nest accessories. 

For more details on managing “Accessories” see page 84. 

Packages 

Packages are a very powerful concept in SI 5.  It is recommended that you look for every 

opportunity to “package” systems or subsystems.  Once the packages are in place, quotes and 

proposals can be rapidly generated without sacrificing accuracy.  Time spent on the front end 

creating packages will be paid for the second time they are used. 

Look for packaging opportunities as you create your first Project.  Don’t attempt to create ALL of 

the packages for your business before starting your first Project.  Let the number of packages and 

the level of detail included evolve to fit your business model.    

For more details on managing “Packages” see page 93. 

Labor 
SI 5 offers a wide variety of options for quoting and estimating labor.  One method is to estimate 

the amount of labor required to install an individual Product.  Once each Product has an accurate 

number of install hours, the total Project labor amount is calculated by summing up the labor 

associated with each component.  This approach is very flexible and has many advantages.  

However, the Product labor estimate will fluctuate from business to business and there are no 

known published labor standards for our industry.  D-Tools provides labor hour estimates 

associated with its downloadable Product data.  However, these are ESTIMATES and should not be 

used to quote labor for your business until they are verified by your specific business processes. 

You also have the option of not calculating labor per Product.  Instead you can add Products of 

Category “Labor” as line items to your Projects.  These are called Labor Products, Labor Items, and 

Labor Line Items throughout the interface and documentation. 

If you have a successful labor estimating strategy, use it.  You can create as many unique labor 

Products in the database as you wish.  These labor Products may also be associated with Packages.   
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If you are looking to improve labor estimating, SI 5 has all the tools you need but there is no silver 

bullet.  You must track actual labor on a daily basis to produce reliable future estimates.  You may 

treat labor estimating as an art or a science.  It’s your choice. 

For more details see Price Tab on pg. 73 and Labor Products on pg. 137 for details. 

Choosing a Labor Methodology 

If you are successful at estimating labor, do not change your methodology unless you have 

benchmarked the alternative.  Both methods can be successful; however the “labor per product” 

method is preferred.  For either labor estimating method to be successful, one must track 

forecasted vs. actual labor and make adjustments accordingly.  Timesheets should be recorded 

daily and associated with work orders if at all possible.  SI 5 allows you to capture the time 

information required to improve the estimates over time. 

If your estimate exceeds the price the client is willing to pay, do not lower the hour estimates.  

Instead, provide a labor dollar discount.  It is important to track true forecasted vs. actual labor 

regardless of price.  Do not skew the data by modifying labor estimates driven by price decisions.  

Labor per Product 

This is the preferred method, but it does take time develop an accurate model.  The labor 

estimates provided with the SI 5 data will NOT accurately represent your business.  They are only a 

starting point.  If you wish to use this method, we suggest capturing actual labor over several 

Projects.  The more granular the data the better the future estimate.  It is suggested that you use 

your existing labor estimating method until you can demonstrate improved accuracy via the labor 

per Product method. See Price Tab on pg. 73 for details. 

Labor Products/Labor Items/Labor Line Items 

These entities are referred to by many names throughout the software and documentation.  Many 

organizations begin estimating labor by breaking a Project into logical tasks and assigning labor 

recourses to each task.  Even in this method, we would suggest breaking the Project into as many 

task categories as possible.  The more well thought the Project plan the better your labor 

estimates.  Project managers with input from lead installers typically provide the best estimates.  

This is particularly true for retrofit Projects where the labor may vary drastically.  See Labor 

Products on pg. 137 for details. 
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Determining Labor Rates 

Your accountant should be involved in determining appropriate labor rates.  It will be important for 

them to understand how SI 5 generates labor estimates and the options that are available.  As a 

starting point, each labor group should have a fully burdened labor cost and selling price.  The 

labor groups would include anyone with direct labor charges to a Project, including: a) Installers, b) 

Project Managers, c) Designers or Engineers, d) Programmers e) Misc .  Each labor group may also 

have different rates by Phase.  For example you may need to create a “Finish Overtime” phase if 

you take on a project knowing that overtime will be required.  Ideally, you will want to pass these 

additional costs on to the client.  A default “Programming” phase is included with SI 5 to track 

programming labor.  However, you will still need to provide the cost and margin data.  See the D-

Tools forum for a sample spreadsheet that will help calculate burdened labor costs (http://www.d-

tools.us/showthread.php?t=1211). 

Labor Factor Calculations 

Within each Phase, there are four labor entries (Base Labor, Misc. Labor, Mgt. Labor, and Design 

Labor).  Let’s assume you sell labor at the following rates; Installation $49/hr, Project Managers 

$77/hr, Design services $63/hr and other Misc Labor $70/hr.  Yes, we know you would be out of 

business, but hey it’s just an example.  When you indicate that a Product requires 10 hrs of labor, 

the “Labor” section is used to determine the base selling price of the total installed labor for the 

Product.  In this case that would be 10 hrs x $49/hr = $490.  In addition, there is a “Factor” 

associated with Management, Misc. Labor and Design.  This Factor may be used anyway you see 

fit, but most often it is used to recover other direct labor costs such as Project Management and 

Engineering/Design costs.  For instance if you have one full time Project manager and ten full time 

installers, you would need to include .1 hrs of PM time for each Installer Hour.  If you have two 

engineers that spend 50% of their time on sold Projects, then you would need a Design Factor of .1 

to account for this direct cost.  A scheduler may be accounted for under the Misc. Labor entry.  In 

the example below we assume that no Misc. Labor is used in the Trim phase.  So the selling price 

of one hour of Trim would be:  

http://www.d-tools.us/showthread.php?t=1211
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Selling Price of Trim Labor = Number of Trim Hours x (49.00 + 7.70 + 6.3) or $63/hr. 

 

Accounting Considerations 

Global Parameters 

These settings allow you to tailor the application to your locale.  Settings include: Measurement 

Unit, Currency Symbol, Date Format and Tax Code.  Modifying the Tax Code will change the values 

you see when viewing Accounting Rates.  Choose the appropriate Tax Code before moving on to 

Setup Accounting. 

Taxes  

SI 5 provides a wide variety of tax estimation methods.  The recommended method will depend on 

the tax rules imposed on your client.  For most organizations, tax on goods (Sales Tax) and 

services (Labor Sales Tax) will be sufficient.  If more complex tax calculations are required, 

consider using the Canadian Tax Code.   

Tax rates and other global settings may be customized for each Project (see Section “D-Tools-

>Options” on page 280). 

More details on Taxes on pg. 57. 

Contract Percentages - Progress Billing 

If your business uses progressive billing, Contract Percentages is where the billing percentages are 

managed.  You should set these percentages and descriptions to the values that are most often 
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used by your organization.  Each new Project will initially have these values.  You are able to 

modify the percentages and descriptions on a project by project basis.  These percentages are used 

to calculate the installed price for each description.  This information is shown on the Contract 

report providing the client a detailed payment schedule with signature page.  

 

For more information see “Payment Schedule” on page 283. 

Misc. Parts %  

This percentage can be used for any purpose you choose.  However it is most often used to 

account for the cost of consumable Products.  If you choose to use this percentage for some other 

purpose, such as to estimate freight charges, you will need to modify the client report label to 

match your intended use.  The Misc. Parts% is applied to all Non-Labor Products and is taxed as 

equipment. 

Equipment +/- % 

This percentage operates just like the Misc Parts%.  It is used to provide a percentage adjustment 

for all non-labor Project line items. This value can be negative in order to give a discount. 

The Misc. Parts % and Equipment +/- % factors are used as part of the Installed Price 

calculation and are subject to the same tax as other non-labor Products.  These will show up as 

separate line items in the project summary section of client reports.  These two factors can be used 

in any way you choose such as Freight and Equipment Discounts.  However, you may need to 

modify the client report labels to match your intended use.  



Pre-Implementation Guide  

Revised February 19, 2009 

28 

Inventory 

Inventory is not managed directly by SI 5.  However, SI 5 QuickLinks (an optional SI 5 module) 

can create Purchase Orders, Estimates and Invoices which may be processed by QuickBooks.  

These accounting procedures can make adjustments to physical inventory within QuickBooks.   

Purchasing 

SI 5 has a set of reports that may be used to generate Purchase Orders for an individual Project.  

Purchase orders may be generated in one of the three following ways 

1) A Purchase Order Report is run from with SI 5.  This report is faxed to your vendor(s) or used 

to reenter the Purchase Order(s) by hand in your accounting system. 

2) OrderTools is a built-in Purchase Order system in SI 5.  It has no links to any accounting 

software and the POs are created on a per Project basis. For more information on Order Tools 

see “D-Tools->Update Case 

Use this to update the case settings within a project if you have made changes to your default case 

settings in the MMPD interface.  A window will open showing what will be changed.  You can 

uncheck any products you do not wish to change: 

 

3) D-Tools->OrderTools” on page 291. 

4) Products for a single project may be automatically transferred to purchase orders for supported 

accounting systems, reducing data entry time and errors.  QuickLinks is required. 

5) Products across multiple projects may be automatically transferred to purchase orders for 

supported accounting systems, reducing data entry time and errors.  QuickLinks is an optional 

license.  
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Time Tracking 

Time tracking is extremely important for both job costing and labor forecasting.  Time should be 

recorded in the accounting system to provide accurate job cost information.  If you are using the 

“labor per product” method of estimating labor, then you also need to use the SI 5 Work Order 

system to record actual time required to complete the Work Order.  It is not necessary to track 

time for each individual Product.  SI 5 will allow you to distribute time across multiple Products in 

proportion to the original estimate.  If these time tracking procedures are consistently used, labor 

forecasting will become more accurate over time. 

P&L by Project 

All SI 5 Projects should be associated with the same Project name in your accounting software.  If 

you use QuickLinks, the Project name association is handled automatically.  All Invoices, 

Purchases, and Payroll costs can be tracked via your accounting software to create a Project profit 

and loss statement.  SI 5 estimates Project gross profit but does not provide accurate Job Cost 

analysis.  Use your accounting software for all financial analysis and reporting. 

Accounting ID mask   

The accounting ID mask defines the way QuickLinks names and groups SI 5 items in your 

accounting software.  The mask is of the form: 

MMMMMMMM OOOOOOOOOOOOO, where the number of “M”s represented the first number of 

characters of the Manufacturer name.  The “O”s represent the first number of characters of the 

Model number.  It is recommended that a non-colon separator such as a space “ “ be used between 

the Ms and Os.  If a colon “:” is used as the separator character, all model#s will show up as a 

sub-item of the Manufacturer in QuickLinks.  While this provides a nice hierarchical view of the 

items in QuickBooks, it is very restrictive.  In some accounting systems such as QuickBooks, all 

sub-items must be of the same type (Inventory or Non-Inventory) as the parent item.  If you ever 

wish to mix Inventory and Non-Inventory parts within a vendor, use ANY separator other than a 

“:”, such as the space. The non-colon separator provides the most flexibility for item assignment.  

However, if you intend to code all Products as Inventory Parts, then use the “:” as a separator. 

For more details see QuickLinks on pg. 582. 

Project Workflow 

Project Status  

Develop an exhaustive list of possible Project statuses. Prefix each status with a number to provide 

order to the list (e.g., 01-Proposal Under Development, 02-Proposal Complete, 03-Proposal Under 
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Review… xx-As-Built Drawings Complete).  Put them in the order in which they would normally 

occur in your project work flow. (See “Project Statuses:” on page 46.) 

Staff Types   

Prepare a list of names of those individuals that may participate in the creation and/or delivery of a 

Project.  This would include Sales, Designers, Engineers, Project Managers, Lead Installers and 

members of the Installation Team.  (See “Staff Types and Members:” on page 45.) 

Staff Members 

This may include the names of your Sales, Designers, Engineers, Project Managers, Lead Installers 

and members of the Installation Team.  (See “Staff Types and Members:” on page 45.) 

Phases  

Each Equipment and Labor Product can be assigned to a Phase.  You may name a Phase anything 

you like.  The Phases should correspond to the possible events in your Project delivery 

methodology.  At a minimum, most companies will have a Rough-In, Finish and Programming 

Phase.  Remember that if you are using the “labor per product” estimating method, you will need 

to define labor rates for each Phase you create. (See “Phases:” on page 50.) 

Component ID Format  
A unique ID is assigned to each Product that is added to a Project.  These IDs show up on drawings 

and wire labels.  Work with your engineering and install team to construct a component ID schema 

that best suits your business.  (See “Component ID Format:” on page 55.) 

Company Information  
All company contact information is completely editable.  Company information will show up on 

almost all SI 5 reports, particularly client reports.  (See “Company Information:” on page 43.) 

Company Logo  
SI 5 allows your logo to be shown on client reports.  Any JPG or BMP file is acceptable.  (See 

“Company Information:” on page 43.) 

Project ID Format 
Each Project may have both a Project Name and Project Number (ID).  In many cases the Project 

Number is a more convenient way to identify a Project.  A common Project Prefix would be the first 
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“N” digits of the Client Name.  Using the Project Number Format will enable auto generation of 

unique Project Number when a new project is created.  However, you may enter any Project 

Number you wish.  It is strongly suggested that the Project Number be unique.  (See “Project 

Number Format:” on page 57.) 

Case Settings  
This allows you to decide how you want text to appear within the database and on reports.  The AV 

industry has a lot of abbreviations.  If you see abbreviations that are not correct (Ipod rather than 

iPod) use the Exceptions link to add corrected abbreviations to the existing list.  (See 

“Formatting” on page 164.) 

I/O Definitions  
Review the lists associated with Label, Signal and Terminal.  Make sure the terminology you use is 

represented in these lists.    (See “I/O Lists” on page 162.) 

Default Wire Length  
Enter your most typical wire pull length.  When wires are placed in your drawings you may be 

prompted to provide a wire length.  The value entered will be presented as the default.    (See 

“Project:” on page 44.) 

Equipment Categories  
Each Product in the SI 5 database must be assigned a category.  Care should be taken when 

assigning Products to categories since many Products may logically exist in more than one 

category.  Your team should review your current Products lines and consistently apply categories.  

This will particularly help individuals without extensive Product knowledge find Products to include 

in the Project.  The sales reports can group Products by Category within a Location or Zone.  (See 

“Categories” on page 161.) 

Locations  
SI 5 provides a wide range of options for specifying the location of Products and the associated 

labor within a Project.  The level of Location detail required by your organization should be carefully 

considered before implementing your first Project.  In some locales, wire label standards require 

detailed location information as provided by the SI 5 default types.  However the requirement for 

this level of detail is the exception.  SI 5 provides five levels of location types that creates a top to 

bottom hierarchy.  The default Location Types are Campus, Building, Floor, Room and Closet.  You 

may use one or more of these Types and they can be renamed.  You may also use only one 
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location if you like.  If you choose to use only one Location Type, a “Room” could be called “First 

Floor Master Bedroom”, providing sufficient detail for both proposals and installation reports.  

However if you need to sort or group Products by floor or building, you will need to assign multiple 

Location Types to your Project. 

Each individual location may also include a detailed text description.  These descriptions may be 

included on proposal reports further defining the requirements or limitations of your system.  It is 

highly recommended that these text fields be used for more complex systems to provide functional 

detail for each location.  This level of specification with the proposal will help reduce 

misunderstandings in scope that could lead to future payment disputes.    (See “Location Types 

and Locations:” on page 47.) 

Location Types 

SI 5 provides five “Types” of locations.  These Types are listed in a parent/child hierarchical list.  

Only define the number of Types that you would typically use in a Project.  Do not use more Types 

than necessary.  Unless you need to group, sort or in some other way view data by Location Type, 

we recommend that you start with Type (Room).  (See “Location Types and Locations:” on page 

47.) 

Location Names 

Each Location Type may have as many name/description pairs as you like.  As mentioned above, if 

you only use one Location Type (Room), you may have a Room named “First Floor Master 

Bedroom” on your Location List.  Populate your Location List with the names you use most often.  

You may add more items to the Location List at any time. 

The description field is best used to provide detailed scope of work or requirements for a particular 

Location.  A  “By Location” proposal report will show the Location Descriptions on the proposal.  

This is an excellent way to carefully review system functionality on a Location by Location basis 

with the client.  As a result, when you first set up SI 5 there is no need to populate the description 

fields, since these descriptions will typically change from Project to Project.  (See “Location Types 

and Locations:” on page 47) 

Zones  
Zones are another way to group Products in a Project.  Reports can be generated by Zone or by 

Location within Zone.  Think about how clients may wish to view groups of Products on a proposal.  

Zones may include detailed text descriptions that flow to the sales reports giving you the 

opportunity to clearly define the scope and functionality of a particular Zone.   
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Many residential users will use Zones to define disciplines such as Audio, Security and Central Vac.  

In the commercial sector one may consider using Zones to provide high level category grouping by 

placing all the Products associated with the sound system, video and Projection and control in 

separate Zones.  (See “Zones:” on page 48) 

Users and Groups 
Access to SI 5 requires a Username and a Password.  Basically, Users get assigned Groups, and 

Groups contain your permissions for functionality within SI 5.Your system or SI 5 administrator 

should be the only person with access to the SI 5 Administration Console.  How you intend to use 

SI 5 within your organization will determine the Group settings.  These setting let you restrict 

changes to data and access to many functions within SI 5.  Define the roles within your 

organization and then match the needs of each of the roles to a particular group.  For small 

organizations where everyone wears a lot of hats, you may provide all rights to all users.  For 

larger organizations with divisions of labor, rights and permissions may be customized for a specific 

role. See the SI 5 Installation and Administration Guide for more details. 

Work Order Resources  
Work Orders may be assigned to individuals (Fred) or groups (Install Team 1).  This interface 

allows you to define the resources that are used to fill work orders.  A code field is provided for use 

in accounting if required.  Codes are used in QuickBooks time reporting to further identify labor 

expenses on the P&L.  Typical codes could include IN=Installation, PM=Project Management, 

EN=Engineering, etc. 

Training 
Your rate of return on your SI 5 investment is directly proportional to the quality and extent of the 

training you receive. This training is possible from one of many sources including; knowledgeable 

coworkers, D-Tools staff and D-Tools Certified Partners.  Training options include Regional 

Classroom events, D-Tools University (DTU), one-to-one web based education (Getting Started 

Web Series) and one-to-many web based education (MIT).  The amount and depth of the training 

will depend on how you intend to use the SI 5 application.  To make full use of SI 5’s capabilities, 

knowledge of other applications such as Visio, AutoCAD, Excel, Word and QuickBooks may also be 

required. (http://www.d-tools.com/index.php/support/training-sub) 

Implementation Services 
Many of our most successful clients are those who took advantage of the skills and experience of 

our Certified Partners.  These partners provide a wide range of implementation and data services.  

http://www.d-tools.com/index.php/support/training-sub
http://www.d-tools.com/index.php/partners/certified
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We encourage you to engage them as early as possible in your deployment process. 

(http://www.d-tools.com/index.php/partners/certified) 
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Launching SI 5 
To launch SI 5, you can either double-click the SI 5 icon on your desktop, select from your Start 

menu, or click the SI 5 Icon in your Quick Launch bar (depending on what options you selected 

when you installed SI 5) 

 

 

  

Navigator 
The main user interface for System Integrator 5 (SI 5) is called the SI 5 Navigator, or 

Navigator for short.  The Navigator displays when you launch the SI 5 application.  
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........There are eight primary interfaces in the Navigator that are represented by buttons along 

the bottom left side of the screen: Start, Manage Data, Clients and Contacts, Projects, 

Reports, Orders and Accounting, Scheduling, and Setup. 

........The Display Area displays the screen or sub-screen based on your Tab selection and/or 

Task Pane selections.  

........The Task Pane list links to functions that are available to you based on your Tab 

selections that you have chosen.  

 .......The Menu Options offer additional functions and an alternate way to make selections in 

the Navigator.  

 ....... The D-Tools News section displays the latest news from us as well as the occasional 

Hotfix. 
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Most of the Menu Options are just an alternative way to accomplish a function that is available 

elsewhere in the Navigator.  One notable exception is detailed below. 
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Disconnecting From the SI 5.5 Server 
This option is primarily for laptop users that need to work away from your network.  Your status 

can be verified by clicking File on the menu bar.  When connected to the SI 5.5. Server, you will 

have the options of disconnecting should you need to remove yourself from your network: 

  

The “connected” symbol also displays in the lower left had corner of the Navigator interface.  The 

symbol is grayed out when disconnected: 

 

 

It is important that you check out any projects that you wish to work on prior to taking yourself 

offline.  An example of when you would take yourself offline would be if you are working on a 

laptop and wish to work away from your office network.  When you choose to take yourself offline 

you will see the following prompt reminding you to check out any projects that you wish to edit 

while offline: 
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If you want to be able to review but not edit a project while you are offline, you must use the 

“Make project available offline” function.  See Project Functions pg. 205 for details of these 

functions.   

When you are disconnected from the SI 5.5 Server, SI 5 will launch without you being prompted to 

login.  That is a clear indication that you are not connected to the SI 5.5 Server. You will not be 

able to use many of the functions within SI 5 including the Orders and Accounting interface or the 

Scheduling interface.  You will not be able to check-in/out projects or synchronize your database 

while offline. 

When you choose to disconnect from the SI 5.5 Server you effectively “cache” your license of SI 

5.5. locally to your machine.  This means that one license from your “license pool” will be 

unavailable to all other users of SI 5 on your network while you have that license “checked out” to 

you.  To add your license back into the “license pool”: 

1) Connect your machine you your network 

2)  Launch SI 5 

3)  Select File->Connect to SI5.5 Server 

 

 

 

4) Close SI 5 

Once connected you will have full functionality of SI 5 and should synchronize your database and 

check in and projects to update the copy on the server. 
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Start 
The Start screen displays when you launch SI 5.  The Task Pane displays links to commonly used 

functions.  There are links to latest news relating to D-Tools, SI 5 and other SI 5 activities.  Look in 

the “News” section for information concerning updates and service packs for SI 5. 
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Setup 

 

The setup tab is where you configure your default settings for SI 5.  If this is your initial setup of SI 

5, there is a “Run Application Setup Wizard” link in the Task Pane that will open a wizard to guide 

you through the setup: 

 

The Application Setup Wizard guides you through filling out essential data for SI 5 to function 

properly.   
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You can use the Wizard or you can simply type in the information on the Application Settings, 

Application Project Settings, and Formatting tabs: 
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You must click the [Edit] button to make changes to these settings .   

Application Settings 
Many of these values can be modified from within a Project. 

 

Company Information: 
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Enter your company information here.  Use the [Browse…] button to locate and insert a .jpg of 

your company logo.  Your company information and logo will display on most of the reports within 

SI 5. 

Project: 

 

Project Folder - This is where you set the default path for where your local SI 5 Projects are 

stored.  This folder should be on the local machine and not on a server.  There is a completely 

separate folder that is created on your server during install for projects that are checked-in.  This 

foldThe factory default for XP is C:\Documents and Settings\*username\My Documents\D-

Tools SI5 Projects (C:\Users\*username\Documents\D-Tools SI 5 Projects for Vista). 

*username = your Windows login. 

Default Wire Length - This is the default wire length for Wire and Cable products in your 

database assigned to the Rough-In Phase.  This number can be changed on a per project basis via 

D-Tools->Options. 

Measurement Units – Choose between US or Metric. If you choose “US”: height, 

width, and depth will be in inches while wire length will be in feet.  If you choose 

“Metric”: height, width, and depth will be in millimeters while wire length will be in meters. 

Price: 

 

Price Type A-C - Name the three levels of pricing in SI 5.  Each product in SI 5 can have up to 

three pricing levels.  If you only use one price per product, use “A” as this is the default for 

projects. 

Equipment +/- (%) – This is a percentage that will be added to all non-labor Products (Products 

not assigned to the Category “Labor”) in a Project based on the Unit Price of the Product.  This 

number can be positive or negative.  This setting can be overridden on a per Phase basis.  
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Misc Parts (%) -  This is a percentage that will be added to all non-labor Products (Products not 

assigned to the Category “Labor”) in a Project based on the Unit Price of the Product. This setting 

can be overridden on a per Phase basis.  

The Misc Parts % and Equipment +/- % factors are used as part of the Installed Price 

calculation and are subject to the same tax as other non-labor Products.  These will show up as 

separate line items in the project summary section of client reports.  These two factors can be used 

in any way you choose such as Freight and Equipment Discounts.  However, you may need to 

modify the client report labels to match your intended use. The default labels for Misc Parts % and 

Equipment +/- % are “Misc Parts” and “Equipment Adjustment”, respectively. 

 

Tax: 

 

Tax Code - Choose from between Standard, Canada, Australia, and New Zealand.   

Sales Tax Rate (%) – Enter sales tax rate  

Labor Sales Tax Rate (%) – Enter labor sales tax rate  

For a complete discussion of SI 5 tax related issues see “Taxes” beginning on page 57. 

Staff Types and Members: 
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You can have up to four Staff Types in SI 5 and any number of Members.  Use the , ,  to 

add, edit, and delete Staff Members.  Use the  to move Members up and down in the list. 

When creating a project you can select these names from dropdown fields. 

Project Statuses: 

 

This lists the Project Statuses for Projects. Use the  and  buttons to add and delete Statuses 

and the  buttons to arrange the list.  When creating a project you can select these values 

from a dropdown field.  Project Statuses are project level designations that let everyone involved 

on a project know what milestone a project is at for any given time. 

Project Custom Property Name Settings: 
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Here you can name the ten custom properties associated with Projects.  These fields are 255 

characters in length and can be used for any additional information you wish to add to a project. 

Application Project Settings 
The following settings provide the default values when starting a new project.  Many of these 

values can be modified from within a Project. 

 

Location Types and Locations: 
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This is where you setup your default Location Types and then create a list of default Locations 

for each Location Type.  Locations are a way to group products on SI 5 reports.  Locations are 

for identifying where equipment is being installed in a project.  You can use up to five levels to 

identify your Location Types hierarchy.  In the screen shot above, only three levels have been 

added to the Location Types hierarchy: Building, Floor, Room.  An example using all five levels is: 

Campus, Building, Floor, Room, Closet.  Whatever hierarchy you choose to use, just make sure 

that it makes sense when read from top to bottom.  Building->Closet->Floor, for example, does 

not make sense. 

Use the , ,  to add, edit, and delete Location Types and use the  to move Location 

Types up and down in the list.  These buttons are handy because this is a hierarchy and should 

flow from the top down.  

To add a new Location, first select the Location Type then scroll to the bottom of the Locations 

grid: 

 

There are three fields for each Location: Comp ID, Name, and Description.  The Comp ID field 

by default is the first five characters of the Name field.  But you could changes this to be the room 

numbers from an architectural floor plan plot, for example.  The Comp Id for Locations can be used 

in your Component ID Format, see pg. 55 

Zones: 
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This is where you setup your default Zones list.  Use the , ,  to add, edit, and delete Zones 

from the list.  Zones are another way to group Products in a Project.  Think of Zones as “Systems” 

or “Disciplines” for a project.  Reports can be generated by Zone or by Location within Zone.  Think 

about how clients may wish to view groups of Products on a proposal.  Zones may include detailed 

text descriptions that flow to the sales reports giving you the opportunity to clearly define the 

scope and functionality of a particular Zone.   

Many residential users will use Zones to define disciplines such as Audio, Security, and Central Vac.  

In the commercial sector one may consider using Zones to provide high level category grouping by 

placing all the Products associated with the Sound System, Video and Projection, and Control in 

separate Zones.   

For more information on “Location and Zone Configuration” see page 241. 
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Phases: 

 

Phases are the primary way in which Labor is charged for products in SI 5.  Every product can be 

assigned a Phase and a Unit Labor Hour to automatically calculate how much labor to charge for 

installation.  The settings for the product shown below would charge 1.5 hours of the “Finish” labor 

rate that you have set. 

 

This is where you create your default Phases and their associated labor values.  Although there are 

many Phases in the default list, there are really four that you will use primarily: Rough-In, Trim, 

Programming, and Finish.  When you download products from D-Tools (see Downloading 

Products  on pg. 121) they will be assigned one of three Phases: Rough-In, Trim, or Finish.  

Programming is a phase that is more often used for “Labor Line Items” see Labor  on  pg. 137.   
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Use the  and  buttons to add or delete Phases and use the  to move Phases up and down 

in the list.  To edit any fields for a Phase, select the Phase on the left and then edit the fields on 

the right.   

Each Phase is broken down into four sections: Base Labor, Misc. Labor, Mgt. Labor and Design 

Labor.  There are eight columns for each section: Cost/Hr, Price/Hr, Margin (%), Factor (%), 

Difficulty (%), Time Multiplier (%), Factored Cost/Hr, and Factored Price/Hr. 

Field Description 

Cost/Hr: How much labor costs you per hour 

Price/Hr: How much you charge the client per hour of labor 

Margin (%): The margin between Cost/Hr and Price/Hr 

Factor (%): What percentage of each Base Labor hour you are charging the client.  

This number is always 100% for the Base Labor but you will most 

likely vary the Misc., Mgt., and Design percentages.  This will affect 

the number of hours used in calculations.  For example a Design Labor 

factor of 25% would mean that you would include .25 hrs (15 

minutes) of Design Labor for each hour of Base Labor (Install Labor). 

Difficulty (%) This field is a multiplier for hours and it affects the Base and Misc. 

hours only. This number should be set to 100% here under the Setup 

tab but can be changed on a per project basis if you wish to increase 

the number of hours charged for Base and Misc. Labor.  For example, 

if you change this number to 200% for the Rough-In Phase within a 

project, you would charge twice the amount of hours for Rough-In 

than usual. 

Time Multiplier (%) These numbers show the details of what is being multiplied.  These 

are links that will show how each field is calculated. 
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Field Description 

Factored Cost/Hr: This field cannot be edited.  It is your Cost/Hr based on the number 

you enter for the Factor(%) 

Factored Price/Hr: This field cannot be edited.  It is your Price/Hr based on the number 

you enter for the Factor(%) 
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The “Show Head End Dialog for Wires in Projects” option opens the Assign Head End form 

when you add an item associated with this Phase to a Project.   

 

In the Assign Head End dialog box you can select the Head End, Wire Length, and Terminations for 

the wire.  This options really only applies to the Rough-In Phase (or whatever you have named 

your Phase that contains bulk wire). All products that are assigned the Category of “Wire and 

Cable” and assigned to the “Rough-In” Phase will be affected by this setting. This option will charge 

materials and labor by the foot for any Wire and Cable products associated with the Phase.  

The “Ignore Labor Calculations” checkbox is an option to have no labor calculations compute for 

a particular Phase.  You might use this option within a Project, for example, where you were not 

charging labor and only want to charge a client for the equipment within a particular Phase.  You 

may also use this option if you want to use your products of Category “Labor” instead of the Labor 

Hours associated with the Products for that Phase. 
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The Phase Specific Adjustments section for each allows you to set a Misc Parts % and 

Equipment +/- % on a per Phase basis. When you check the “Override Project Defaults for 

this Phase” box, these values will override the Misc Parts % and Equipment +/- % settings on 

the Application Settings tab. Using these price adjustment settings on a per Phase basis gives you 

more control and accuracy than if you charge a percentage across the board for all products in a 

project.  See pg. 27 for details on these fields..   

Contract Percentages: 

 

This is where you setup your default Contract Percentages.  Use the  and  buttons to add or 

delete rows.  If you wish to revert to the original settings, click the  to revert back to the 

original settings.  The Contract Percentages print on the default Contract report in SI 5.  Contract 

Percentages can be changed on per project basis.   
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Formatting 

Component ID Format: 

 

This is where you set the default Component ID for Products added to a Project.  The 

Component ID is a unique identifier assigned to each Product that is added to a Project.  The 

Component ID is customizable and can be modified on a per Project basis if you choose.  The 

Component ID Format form consists of three columns: Type, Value, and Length. 

A unique Component ID is assigned to each Product when it is added to a Project.  The format of 

the Component ID is determined by the Component ID Format form above with the addition of 

a sequence number, all separated by dashes “-“.  The sequence number will increment as Products 

are added to the Project.  The form of the Component ID should be carefully considered.  It will 

be shown on drawings and used as a reference throughout SI 5.  It should be long enough to 

provide reference clarity, but short enough to not clutter complex drawings. 

Type – you choose either “Field” or “Text”.  “Field” allows you to choose a product property in the 

Value dropdown.  If you choose “Text”, you will type in a value in the Value cell.  Although “Text” 
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is an option, it really doesn’t make sense to use it here.  The reason being, the Component ID 

Format is used for every Product that you add to a Project to uniquely identify that Product.  If you 

use “Text” in the Component ID format, every product will have the same text shown in the 

Component ID.  Using Fields is a much better way to uniquely identify Products.  “Type” and 

“Model” are popular Value choices. 

Value – if “Field” is selected in the Type cell, then use the dropdown in the Value cell to pick a field 

from the Product Properties for a Product.  If “Text” is selected in the Type cell then type in a value 

in the cell. 

Length – the number entered in this cell determines how many characters you are pulling from 

the Fields that you selected.   

The buttons allow you to add new rows or delete existing rows.  You can also move existing rows 

up or down in the list.  See section “Component ID” on page 279 for information on changing the 

Component ID within a project. 

Example: In this example, the Component ID Format is as shown below (first 

three characters of the Zone name followed by first four characters of the Type 

name).  

 

You add a wire to a Project of Type “Audio” and assign it to the “Distributed Audio” 

Zone.  The Component ID that will be generated for this Product will be: DIS-AUDI-

001. If you add another run of the same wire to the Project, its Component ID will 

be: DIS-AUDI-002. 

 “Type” is an available field for Products in your database and is used extensively 

throughout SI 5. 
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Project Number Format: 

 

This is where you set the default Project Number for Projects.  The functionality of Project Number 

Format is the same as for the Component ID Format.  The only difference is that the “values” 

available are based on Project properties rather than Product Properties.  Project Numbers will 

automatically be assigned based on this format unless you type something into the “Project 

Number” field within a project.  Project Numbers are never checked for uniqueness so there is the 

possibility that you could have duplicate project numbers. 

Taxes 
SI 5 provides a lot of flexibility when it comes to calculating taxes on client proposals.  However, 

all tax values presented should be considered estimates.  Your accounting system will provide the 

definitive tax calculations for reporting to your friendly tax authorities.  Creative taxation seems to 

be on the rise.  Individual tax rates may apply at the municipal, regional, state/provincial and 

national level.  These rates may apply differently depending on the use of product or how it is sold.  

SI 5 can handle most of these tax situations. 
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For a Product to be taxed one must: 

1) Choose the most appropriate Tax Code in the Navigator via Setup tab->Application Settings 

tab->Tax section:  

 

2) You can choose either Standard, Australia, New Zealand, Canada:  
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3) Set the default rates tax rates that apply to you.  The fields you see will depend on the Tax 

Code you selected.  These are your default tax rates meaning that they will initially apply to any 

Project you create.  You may modify tax rates on a per Project basis when necessary. 

Standard – has separate fields for Sales Tax and Labor Sales Tax. 

Australia – has just a Sales Tax field.  When you see “Sales Tax Rate”, think GST.  

No tax is charged on labor in Projects.  Ignore the “Labor Sales Tax Rate” row. 

New Zealand – has just a Sales Tax field.  When you see “Sales Tax Rate”, think 

GST.  Tax is applied to all labor in a Project.  Ignore the “Labor Sales Tax Rate” row. 

Canada – There are multiple tax codes listed and you have the option of adding PST 

Tax and/or GST  Tax to the various Tax Codes. 

4) Check the “Taxable” box for the Product on the Product Properties form.  Or in the case of 

Canada, select the appropriate Tax Code(s) as described later in this section.  

 

Choosing the Appropriate Tax Method 

Use the following rules to determine which Tax Code best suits your needs.  Just because you do 

not live/work in Canada does not mean that you can’t choose to use the Canada Tax Code.  Each 

Tax Code has a specific functionality, so choose the one that works best for you.   
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Once the Tax Method is set you may adjust the default rates.  The user interface depends on the 

Tax Code selected (see below). 

Since SI 5 allows the user to more easily modify client reports, making changes to 

labels is very straight forward.  Pick any Tax Method that best fits your needs and 

then modify the report descriptions to anything you choose.  For a complete 

description of Reports see page 471. 

Standard 

This method allows you to have one tax rate for Non-Labor Products (Equipment, Wire and 

Speakers) and another rate for Labor. 

   

Labor and Sales Tax will show as separate line items on client reports.  Sales Tax is applied to the 

sum of Equipment+Equipment Adjustment+Misc Parts.  Misc Costs are NOT taxed in any of 

the Tax Codes.  Labor Sales Tax is applied to the total labor selling price, referred to as Install 

Labor.  The Install Labor amount may include Install, Design, Management, and Miscellaneous 

labor.  Products of Class “Labor” are also included in the Install Labor figure. 
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Australia 

Australia uses the came calculations as “Standard” except Labor is not taxed.  The client report 

label will show “GST:”.   

 

Example: Sales Tax is set to .07.  For this Project, GST Tax = 

.07*(26110.00+913.85) = 1,891.67 

 

 

New Zealand 

The New Zealand Tax Code is the same as “Australia” except Equipment and Labor are taxed at the 

same rate.  Only one rate is shown but it is applied to both Equipment & Labor.  The client report 

label will show “GST:”   
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Example: Sales Tax (GST) is set to .07.  For this Project, GST Tax = 

.07*(.07(26110+522.20-522.20+5619.53) = 2,221.07  
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Canada 

The Canada Tax Code option is by far the most complex.  Let’s start with the report and work 

backwards.  There are two reported tax values that can be reported, GST Tax and PST Tax.  Each 

Product, with the exception of Products of Class “Labor”, has three fields by which to assign tax 

rates; Purchase Tax Code, Sales Tax and Labor Sales Tax.  You may assign each of these 

fields one of the following Tax Codes (E, G, P, S, Z) as shown below.  These codes correspond to 

the rows in the Canadian Tax Table and to those used in the Canadian version of QuickBooks. 

 

 

Purchase Tax Code:  The Tax Rates for the letter associated with this code are applied to the 

Cost, not the Unit Price, of Non-Labor Products.  This code does not apply to Labor Products.  This 

code is NOT used in any D-Tools standard report or computation. 

Sales Tax:  The Tax Rates for the letter associated with this code are applied to the Unit Price of 

Products (with the exception of Products of Category “Labor”…noticing a pattern here?). 
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Labor Sales Tax:  The Tax Rates for the letter associated with this code are applied to the selling 

price of Labor and Products of Category “Labor”.   

Example:  Let’s assume we are using the following Tax Table.  These values are not 

actual Canadian tax values, but are used for explanation purposes only.  Not even 

Canadians would attempt taxes like these.   

 

Then assign the codes to a Product by using the dropdowns as shown below. 

 

The “P” code is applied to the product Unit Price, the “S” code is applied to the total 

labor price as defined by 2 hours of Finish labor, and the “G” does nothing as the 

Purchase Tax Code is not used at all in SI 5. 
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PST= .07*[Unit Price] +.09*[Labor Price] 

GST= .08*[Unit Price] +.1*[Labor Price] 

The ability to mix and match these rates provides a lot of flexibility. 

Canadian taxes will show up on standard reports as follows: 

 

Manage Data 

 

The Navigation Bar on the left side of the screen contains mainly links to help documents for the 

various interfaces within the Manage My Product Data (MMPD) interface.  However, a few are 

actual functions. 
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The “Sync product data” link allows you to synchronize your local database with the server 

database.  See LANSync on pg. 167 for additional info. 

 

In order to do add/edit/delete data you must click the “Open Manage My Product Data” link and the 

MMPD interface will open in its own window. 
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There are five tabs available in the MMPD interface: Product Grid, Product Explorer, Download, 

Import, and Administration.  You can also access these screens using the View option on the 

menu bar. 
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Product Data 
Before we get into the mechanics of creating and editing Products, let’s explore the characteristics 

of D-Tools data.  Each record in your database is referred to as a Product.  There are three 

required fields for a product: Manufacturer, Model, and Category. There are four Types of 

Products in your database as determined by the Category Type: “Equipment”, “Labor”, “Speakers”, 

and “Wire” (see Categories on pg. 161 for details on Category Type).  Each Product has many 

editable fields that you can utilize to meet your particular business requirements.  The Category 

Type determines what the available fields for that particular Product are.  For example, there are 

no Height, Width, and Depth fields for “Wire” Type Products (instead there are Diameter and 

Length fields).  

This is an example of the Product Properties form for a Product in SI 5.  Each field will be detailed 

below, but not necessarily for this particular Product. 
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There are functionality buttons along the bottom of the screen: 

 

[Help] Opens a digital version of the SI 5 User’s Guide.  

[Feedback] Opens an online form for reporting errors that you find in data that 

you downloaded from D-Tools, Inc.  

[Extended Data] This opens a link to a D-Tools server that hosts additional downloads 

for the Product.  These additional downloads may be brochures, 

manuals, and/or images.  Not every Product has Extended Data 
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associated with it.  All user’s have access to the Extended Data for 

Manufacturer’s Vantage Point (MVP) data.  Client’s who have 

enrolled in our Data Subscription program will have access to 

Extended Data for non-Partner data as well. 

[Format Active Field] This option allows you apply one of the following formatting options 

to any field that is in focus i.e. the field with the cursor: ALL CAPS, 

Sentence case, or Title Case.  There are four fields that this option 

may not work for: Category, Manufacturer, Model, and Description.  

This is because these fields have a global setting that may override 

the selection you make on an individual Product.  These global 

settings are under the Administration tab in the MMPD interface.  

See “Formatting” on page 164. 

[Save] Saves changes made to the Product 

[Cancel] Does not save the changes made to a Product and closes the tab. 

 

There are three main areas on this form: Product Details, Image, and the Tabs. 

The user interface will vary depending on from where in SI 5 you are viewing/editing 

the Product, i.e. within the Manage My Product Data interface, within a Text, Visio, or 

AutoCAD project. Within a Project, Project specific options/fields will display: 
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Product Details 

There are three required fields that uniquely identify each Product in your database: Category, 

Manufacturer, and Model.  To add a new Category or Manufacturer to your database, click the 

[New] link next to the appropriate field. 

 

Type:  The Type field allows you to further identify the product beyond the Category. To add a new 

Type simply type the new one into the field.  There is no way to delete from this list. This Type field 

is different from the Category Type field mentioned above.  

SKU:  This field is optional and can be used for a Manufacturer’s part number or your own internal 

numbering system for identifying parts. 

Discontinued:  This dropdown allows you to identify whether a Product has been discontinued by 

the manufacturer. 

Status:  This dropdown allows you to mark Products as “Approved” or “Unapproved”.  Unapproved 

Products do not synchronize via LANSync. 

Hyperlink:  This field is used to store the URL for the Product.  This can be any URL you choose, 

e.g. the manufacturer’s website, a PDF of the cut sheet, etc.  
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Image 

 

This section displays the JPG image associated with the Product.  Here you can add an image or 

remove the current image using the links.  This image will be used by default in Visio on a Line 

Page and is displayed on some of the stock Proposal reports.  Any image you import will be 

converted to a .jpg and scaled accordingly for use within SI 5. 

Product Tabs 

 

Description Tab 

Product Description:  The Product description is a basic description of the Product.  This 

description can be displayed on client reports, install reports and purchasing documents, or used to 

find Products via search.  This field is also passed to QuickBooks through QuickLinks by default. 

There is a 255 character limit to this field. 
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Client Description:  If this field is filled in it will be used on Client proposals instead of the 

Product Description to provide a more marketing oriented description.  There is no character limit 

to this decription. 

Price Tab 

 

There are three sections under the Price tab: Price, Installation, and Accounting. 

Price 

MSRP:  Manufacturer Suggested Retail Price - this is for reference only and can be used as the 

basis for Unit Cost and Unit Price calculations. It does not appear in reports nor does it get used in 

project pricing calculations. 

Price Type:  You can have up to three pricing levels for each Product. The names of these fields 

default to A, B, and C, but can be changed in the Navigator, see “Application Settings” on page 

44. 

Unit Cost:  What one unit of the Product costs you. 

Unit Price:  The price you charge for one unit of this Product.  

Margin:  Profit represented as a percentage of Unit Price (preferred). 

Markup: Profit represented as a percentage of Unit Cost. 

There are two handy formulas to use for markup and margin.  Remember to convert 

percentages to decimals for the following calculations. 

Unit Price = Unit Cost / (1 - Margin) 
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Margin = (Unit Price-Unit Cost)/Unit Price 

Unit Price = Unit Cost * (1 + Markup)  

Markup= (Unit Price-Unit Cost)/Unit Cost 

Example: Unit Cost is 1700 and you add a 40% markup to your products.  Your Unit 

Price will be 1700 * (1 + .40) = 2380.   

A 40% margin for the same product would yield a Unit Price of 1700/(1-.40) = 

2833.33.  

Options link will open the following form and allow you to change the view and pricing 

methodology: 
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Update Price link will open the following form allowing you to determine Product pricing in various 

ways.  

 

Estimated Install Price:  This shows you what the estimated install price for the product is based 

on your default Phase and tax settings from the Setup tab.  Click the [View] button to see the 

detail: 

 

Installation 
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Phase:  This dropdown allows you to choose the Phase when the Product is being installed.  Labor 

rates are Phase specific. 

Unit Labor Hours:  Number of labor hours associated with the Product. This number is multiplied 

by the labor rate set for the Phase. 

Labor is calculated for each Product in a Project based on the Phase rates and the Unit Labor Hours 

assigned to the Product.  You also have the option of creating Labor Products (also called Labor 

Items or Labor Line Items) to add labor to a project.  See Labor Products on pg. 137. 

Accounting 

 

Item Number:  This field holds the item number of the corresponding Product from your 

QuickBooks database.  This value is generated by the QuickLinks interface.   

Vendor Name:  This field is for the default vendor associated with the corresponding QuickBooks 

Item and is established through the QuickLinks interface. 

These fields should only be edited/set from within the accounting software interface 

such as QuickLinks (optional product), or by importing from a CSV file via the 

Import tab.  Modifying these fields is not recommended for non-administrators. See 

QuickLinks pg. 582 for more details. 

Taxable:  Choose whether or not the item is taxable.  See Taxes on pg. 57 for details. 

If you set your Tax Code to Canadian under your International Options, you will have 

dropdowns for assigning Purchase Tax Code, Sales Tax, and Labor Sales Tax rather 
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than the “Taxable” checkbox. 

 

 

Specifications Tab 

 

Height, Width, and Depth:  These values will either be in inches or millimeters, depending on 

your Measurement Units setting (see “Application Settings” on page 44).  Height and width are 

used in Visio and AutoCAD on the Elevation pages to determine the size of the shape or block.  

Width and depth are used in Visio and AutoCAD on the Plan view pages when you use a Scaled Plan 

shape or block. 

Amps, Voltage, BTU, and Weight:  These fields do not have any effect on any functions within 

SI 5; however, custom reports may be generated to make use of these fields for engineering and 

installation analysis purposes. 

Rack Mounted:  Converts the Height value to Rack Units through the magic of math.  When 

checked, the Height field will gray out and the Rack Units field will populate. This calculation rounds 

up. 
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Inputs and Outputs:  Inputs and outputs are used in Visio and AutoCAD on the Schematic pages, 

which are then used to generate wire connection reports.  The shapes and blocks will automatically 

populate with the inputs and outputs that are listed in this section.  Clicking the [Edit Inputs and 

Outputs in I/O Studio] will open the I/O Studio. 

I/O Studio 

 

To open the I/O Studio for more than one product, select multiple products on either 

the Product Grid tab or in the PDM within a project and then click the  button.  

When you do this, more than one product will display in the I/O Browser: 
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If you are within a project, the Component ID will display next to the product. 

The left side of the form will either display the I/O Browser or your Saved Configurations depending 

on which tab along the bottom you’ve selected: 

 

Saved Configurations are generally commonly used combinations of Terminal, Signal, and Label.  

When viewing saved configuration, you can select multiple products by using Shift or Ctrl on your 

keyboard, filter any column using the filter buttons, and right click to add ports to either/both the 

Inputs/Outputs, remove from the list, or copy the configuration(s): 

 

The bottom of the list has these right-click options, plus the ability to change quantity and a very 

handy “Auto increment label if quantity is greater than 1” option: 
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The “Auto increment…” function will automatically add a “1” to your first label and count up from 

there when adding more than one of the same I/O configuration to a product. 

The right-side of the I/O Studio form (and the majority of the interface) displays the Inputs and the 

Outputs for the selected product each of which have their own separate command buttons: 

 

You can select multiple I/Os by using the Ctrl or Shift buttons on your keyboard. 

.......Opens the Add New I/O form 

 

......Deletes the selected I/Os 

.......Cuts the selected I/Os 
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.......Copies the selected I/Os 

.......Pastes copied or cut I/Os 

..Move Up/Move Down buttons allow you to choose the order of display for I/Os 

.......Duplicates the selected I/Os 

......Saves the selected I/Os to your Saved Configurations list 

You can also access these functions by right-clicking on the form.  This form also displays the 

keyboard shortcuts for these commands: 

 

Another way to Add I/Os to a product is to select one or more I/Os from the Saved Configuration 

list and then drag and drop over to the Inputs or Outputs section on the form: 

 

And yet another way to add an I/O is to scroll to the bottom of the list and use the dropdowns to a 

new record: 
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Accessories Tab 

 

Accessories are Products that are associated with a primary, or “parent” Product.  Here you can 

[Add] or [Delete] accessories to a Product.  Accessory management is a critical component that 

will improve design productivity and reduce errors in the final bill of materials.  For a complete 

discussion see Accessories on pg. 84.   
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Instead of using the [Add] button, you can drag and drop from the Product Tree to 

add Accessories within in the Product Explorer interface.  

 

Visualizations Tab 

 

The radio buttons allow you to toggle between editing settings for Visio and AutoCAD. 

Visio stencil and shape mappings:  The dropdowns on this tab allow you to pick a Shape from a 

Stencil to assign to the Product for three of the four page types in Visio: Line, Elevation, and Plan.  

There is also the option of assigning Shapes for Side View. You do not have to use these 

dropdowns unless you want to override the default shape that drops on each of these pages.   

AutoCAD drawing and block mappings:  The Visio description above also applies to AutoCAD, 

with the exception of AutoCAD terminology and there are no Side View or Schematic options. 
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Custom Properties Tab 

 

Keywords 1-3: These fields are used to be filters to help you find a Product quickly when adding 

the Products to a Project. We are phasing out their use for future releases so these can be treated 

like additional Custom Property fields.  

Custom Property1-10: These are ten fields that are user definable.  For information on defining 

these fields, see “Custom Properties” on page 165. 

Accessories 
Proper Accessory management will significantly improve design productivity and reduce errors.  For 

instance, once you find the proper mount for a display and associate it as an accessory to the 

display, you never have to look it up again.  However, keep in mind that Accessories cannot have 

Accessories, so this association can only go one level deep. 

Adding Accessories to a Product from the MMPD Interface 

To add an accessory to a Product, you just have to be in the Product Properties.  You can do this on 

either the Product Explorer or Product Grid views within the MMPD interface. 
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Open the Product Properties form and click the Accessories tab. 
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Click [Add].  The Add Product form opens: 

 

Use the filters to select the item you want to add as an Accessory then click [OK].  The selected 

Product will be listed as an Accessory: 
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The “Prompt” and “Recommend”  checkboxes determine whether the Accessory will add 

automatically or not to a Project when the “parent” Product is added:  

 

Prompt and Recommend both checked: the “Include” checkbox will be pre-checked as shown 

in the first Product above 

Prompt checked: the “Include” checkbox will not be pre-checked as shown in the second Product 

above 

Neither checked: the Accessory adds automatically to the Project without prompting 

The Edit link in the “Visualizations” column will open the Accessory Visualizations – Visio form:  

 

When a “parent” Product is dragged from the Project DataMatrix (PDM) to a drawing page in Visio, 

shapes for the Accessories for that Product do not automatically drop on the drawing page.  This is 

because the “Hidden” column is checked by default for each drawing page type as shown above.  If 

you want certain Accessories to drop shapes automatically with the “parent” Product on certain 

drawing page types, uncheck the appropriate box. 

For the most part, you may not ever need to change the default Visualizations 

settings for Accessories. If you want a shape in Visio for an Accessory, simply drag 

it from the PDM.   
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Adding an Accessory to a Product within a Project 

If the Product is already in the PDM, double click the item to open the Product Properties form.  

The remaining steps are exactly the same as when adding an Accessory within MMPD. 

Once you close the Product Properties for the Product, you will be prompted whether 

or not to update your Master Table database.  This prompt only applies to the 

“parent” Product, not the Accessories. 

 

If you choose [Yes], you will then be prompted whether or not to update the Master 

Table for the “parent” Product with the Accessories you have added.  Choose [Yes] 

if you want the Accessories added to be a global change, [No] if you only want them 

as Accessories for the “parent” Product within that Project. 

 

 

Example:  You want to add a programming labor line item, interconnect cables, and 

a rack shelf to a processor as Accessories.  You want the programming Labor Line 

Item to add automatically, you want to prompt and recommend the interconnect 

cables, and prompt but not recommend the rack shelf since the processor won’t be 

rack mounted in every project. 

1) Open the Product Properties for a processor and click the Accessories tab: 
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2) Click the [Add] button.  The Add Product form will open: 

  

3) Use the filters to select the Labor Product you wish to add click [OK].  The 

Product will display in the grid on the Accessories tab.  Uncheck the “Prompt” 

and “Recommend” checkboxes. 
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4) Repeat steps 2-3 to add the remaining two Accessories.  For the interconnect 

cable don’t uncheck anything, for the rack shelf uncheck the “Recommend” 

checkbox. 

 

5) Add the Product to a Project.  The Add Accessories for Manufacturer form opens: 

 

The Labor Product that did not have the “Prompt” box checked is not listed in the 

prompt box shown above and it will automatically add to the Project.  The “Include” 

box on this form is not pre-checked for the rack shelf because the “Recommend” box 

was unchecked. 

Assigning Locations to Accessories 

Accessories inherit the Location and Zone assigned to the “parent” Product.  See “Assigning 

Locations and Zones” on page 299. 
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Packages 
Packages are a group of Products that provide a convenient way to add multiple Products a Project 

at one time.  The price of the Package is the sum of the Products in the Package and the labor 

calculated for a Package is the sum of the labor for each Product in the Package.  Discounts may 

also be applied Packages to provide special pricing. 

Package Form 
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A Package Name is required, the Description is optional.  Products that you add to a Package 

may have Accessories associated with them and you may or may not want Accessories included in 

the Package.  The “Accessory Options” section allows you to select the desired accessory behavior 

for each Package.   

The Reports Options section has two options: 

1) Summarize in Client Reports – Only the Package Name and Description will show in Line 

Item reports, unless you override this option.  See “Report Parameters” on page 485 for more 

detail. 

2) Ignore Labor Calculations on Equipment and Wire Products – this option ignores all labor 

calculations for all non-Labor Products in the Package.  It is assumed that you would add a 

Product of Category “Labor” to the Package to account for the labor. See Labor  pg. 137. 

In the ‘Package Contents” section of the form you can [Add] or [Delete] Products as well as 

adjust the price of the Package. 

Creating a Package within the MMPD 

Example: You want to create a 4-Port Media Plate Package that contains the back 

box, a faceplate, four inserts, and four wires.  You are trying to hit a specific price of 

$100 for the Package including labor (minus taxes).  

1) Open MMPD and click the Product Explorer tab.  Click the Add Product or a 

Package dropdown arrow next to the button and select Package: 
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An Add Package tab has been added to the interface 

 

2) Type in a Package name and a Description (optional): 
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3) Under Accessory Options check both the “Summarize in Client reports” and 

“Ignore Labor Calculations on Equipment and Wire Products” boxes.  

“Summarize in Client reports” is selected so that plate detail will not show on 

the reports. There is no need for clients to see that much detail on a plate 

Package.  “Ignore Labor Calculations on Equipment and Wire Products” is 

selected to allow a flat labor rate to be assigned to each plate by using a Product 

of Category “Labor”.  Otherwise the labor would be calculated based on the hours 

associated with each piece of equipment and units (ft) of wire. 

 

4) Click [Add].  The Add Product form will open.  Select a Product and then click 

[OK].   

 

The Product is added to the “Package Contents” section:  
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5) Continue adding Products the back box, inserts, etc...  Another way to add 

Products is to drag and drop them from the Product Tree.  In this step the F 

connector inserts for the plate are added to the Package: 

 

6) Adjust the quantity to two for the F connector insert by clicking in the field and 

typing: 
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7) Add the wire.  The only difference when adding wire is that you will be prompted 

with the Head End form if it is a “Rough-In” wire.  

 

8) Pick a “general” Head End and Wire length.  These can be changed when adding 

the Package to a Project. 
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9) After adding your wires, add a labor product to the Package.  The labor product in 

this example has a fixed price of $50 (as shown below).   
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Once all of the Products and the optional jpg Image have been added to the 

Package, it will look similar to the following: 

 

The Base Price does not include Labor, Tax, Misc Parts% or Equipment +/- 

adjustments.  Labor and taxes only calculate when the Package is added to a Project.  

This is true even for Products of Category “Labor” that are in the Package.   
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Looking back on the criteria for this Package, we need to adjust the Base Price to 

$50 so that the total price of the Package including Labor (but excluding sales tax) 

equals $100.  To make this adjustment, type “50.00” in the “Package Price” field.  

The Discount percentage will automatically calculate for you: 

 

10) Click [Save] when finished. 

Creating a Package within a Project 

There are a couple of ways to create a Package from within a Project.  The first way is within the 

Project DataMatrix (PDM). 
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Select the Products in the PDM that you want in the Package (hold down Ctrl to select multiple 

Products).  Move your cursor over one of the selected Products then right-click->Add->Create 

New Package. 

 

The D-Tools Packages form opens.  Fill in a Package Name and a Description if desired and click 

[OK] when done. 

 

You will be prompted to update the MasterTable. 

 



 SI5 User and Administration Guide 103

The second way to create a Package within a Project is by selecting Products on a drawing page in 

Visio or a sheet in AutoCAD. 

To select multiple shapes use the Ctrl key or you can left mouse click and marquee select the 

items.  In the shot below, I have selected all items in a surround system, then right-click->D-tools-

>Create New Package: 

 

The D-Tools Package form opens as shown in the previous example. 
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Adding a Package to a Project 

Within a Project there are three ways to add a Package. 

1) Drag and Drop – Packages are listed at the bottom of the Product explorer section of each the 

interface.  You can left mouse click and then drag and drop the Package over to the Project 

DataMatrix. 

 

2) The second way to add a Package to a Project is to click the dropdown arrow next to the  

button and select Add Package.  The Package Properties form will open and you may make 

your selections. 

 

3) A third way to add a Package is to right-click any Product in the PDM and select Add-

>Package.  The Package Properties form will open and you can make your selections. 
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Editing Package within the MMPD Interface 

Edit Packages through MMPD by selecting the Product Explorer tab.  Double-click the Package from 

the Product Tree and then make changes: 
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Editing Packages within a Project 

Double-click the Package name in the PDM, the Packages Properties form will open.   

 

Make changes and then click [Save]. You will be prompted whether or not to update the 

MasterTable with your changes: 

 



 SI5 User and Administration Guide 107

Editing Packages when adding to a Project 

When using the Add Package from within a project, you can uncheck any products you don’t want 

added to the project or you can use the [Add] button to add additional products to a package on 

the fly: 
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Assigning Locations to Packages 

There is a Location section on the Packages Properties form that allows you to select a Location 

and Zone for the Package.  If not all items in a Package are being installed in the same location, for 

example a security Package where the sensors will be in different locations, there is the 

“Equipment in Package can be in different Location/Zone” option. 
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When this box is checked, you would not assign the Locations on the Package Properties form, 

you would assign the Locations to the Products in the PDM. 
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Additional Package Properties 

By default, all items in a Package drop on a Visio page when a Package is dragged from the PDM to 

a drawing page.  If you scroll all the way to the right in the “Package Contents” section of the 

Package Properties form, you will see columns and checkboxes for each of the four drawing page 

types in Visio: Line, Elevation, Plan, and Schematic.  These checkboxes allow you to override the 

default action and not have a shape drop for a Product on a particular drawing page type in Visio.  

This may save you the step of having to remove unwanted detail from the drawings when the 

package is placed. 

 

If you create a package that is used a lot, it may be worth the effort to use the above 

technique to manage what is shown on the drawings when a complete Package is placed 

on a particular view.  However a similar result is achieved by dragging individual Products from the 

Package to the particular drawing page using the PDM.   
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Product Grid  

 

One way to manage the Products in your database is through the Product Grid screen.  This 

screen allows you to see multiple Products in your database in a grid format.  From this screen you 

can add, edit, copy, and delete any Product in your database. 

You cannot manage Packages on this interface.  Use the Product Explorer 

interface to edit Packages. 

You can filter your Products using the Manufacturer, Category, Type, Phase and Search tabs on the 
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left-hand side of the screen.  You also have the options “Display discontinued products” and 

“Display only unapproved products”.   

  

Along the top of the grid you have the following option buttons: [Add Product], [Edit Product], 

[Copy Product], [Delete Product], [Add and Remove Columns, Groups], [Sort], [Print], 

[Export], [Update Price], and [Open in I/O Studio].e 

.......Add a new Product to your MasterTable database 

.......Edit an existing Product 

.......Copy an existing Product 

.......Delete an existing Product 

.......Refreshes the Groups displayed in the grid.  This button is inactive until you choose to 

group the products in your grid, see the next option. 
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.......Add and Remove Columns, Groups - this option allows you to modify the grid layout.  This 

opens a form: 

 

.......Sort - you can sort up to three levels deep, ascending or descending 

You can also access the Columns/Grouping, Refresh Groups, and  Sort options by 

right-clicking any column heading.  When you right-click a column heading, you will 

see some additional functions: 

 

 

Right Click Command Description 

AutoFit Column Resizes the selected column to the width of the 

longest string 

AutoFit Rows Resizes all rows to the same height 

Sort Ascending Sorts the selected column by value: lowest to highest 

(alternative = left mouse click once in a column 

heading) 

Sort Descending Sorts the selected column by value: highest to lowest 

(alternative = left mouse click once in a column 

heading) 
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.......Print - prints the contents of the Product Grid 

.......Export - this allows you to export the contents of the Product Grid to an Excel 

spreadsheet. 

.......Update Price - this option allows you to update multiple Products at one time 

Example: You want to change the markup on all of your Sonance outdoor speakers 

to 40%. 

Use the tabs to select: Manufacturer = Sonance, Category = Speakers, Type = 

Outdoor.  The Product Grid will filter based on the criteria. 

 

Our MVP data partners have asked that we not show cost data if possible. 

Select the products you want to update.  To select multiple products use standard 

Windows selection controls by holding down <Shift> or <Ctrl> on your keyboard 

while selecting with the mouse. 

  



 SI5 User and Administration Guide 115

Click .  The Update Price form will open: 

 

Select what Price Type you are updating and enter a Markup as a percentage (40 = 

40%) then click [Update]. 

.......Open in I/O Studio – this will launch the I/O studio for one or multiple products selected in 

the grid.  See the Specifications Tab section on page 77 for details. 

You can also access many of the functions described above by right-clicking any row 

in the Product Grid.  When you right-click a row, you will see some additional 

functions: 
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Right Click Command Description 

View Extended Data Resizes the selected column to the width of the 

longest string 

Web Specs Resizes all rows to the same height 

Expand All This expands all [+] symbols displayed in the PDM 

(groupings) 

Collapse All This collapses all [+] symbols displayed in the PDM 

(groupings) 

 

Product Explorer 

 

This interface allows you to view both the Products and Packages in your database.  To open a 

Product or Package from the Product Explorer interface, double-click on the Model number or 



 SI5 User and Administration Guide 117

Package Name in the tree on the left-hand side of the interface .  You can expand the [+] 

symbols to view your data: 

 

Each Product or Package that you have open will display on its own tab on the right-hand side of 

the screen .  There are buttons  along the top that allow you to add, edit, copy and delete 

any Product or Package from your database.  You also have the option to change the Hierarchy of 

how your Products display as well as Filter your Products to narrow down your search. 

....Add a new Product or Package to the MasterTable database.  Use the arrow to add a 

Package. 

 

.......Edit an existing Product 

.......Copy an existing Product 

.......Delete an existing Product 

.......Manage your Product Explorer – use to determine the hierarchy in which your Products 

display 
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.......Filter your Product Explorer – use to narrow down what you are looking for 

.......Refresh your Product Explorer 

Example: You want to display only the Speakers that are in your database and you 

want them to display by Type->Manufacturer->Model.   

Click the  button.  The Filter Product Selection Tree form will open: 
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Click the Category tab, click the Speakers checkbox and then click [OK].  Notice 

that your selected Filter options display in the “Filter:” section of the form. 

 

Click the  button.  The Manage your Product Explorer form will open. 
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Use the dropdowns to select the following configuration then click [OK]. 

 

Click the [+] next to Products and the interface will only show Speakers and the first 

level of the hierarchy is Type.  Click the [+] next to any Type to see the next level 

(in this example, the next level is “Manufacturer”). 
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Adding Products to Your Database 

Downloading Products  

Downloading data is one method for adding Products to your database.  There are two types of 

data available for download: MVP Manufacturers and Subscription Manufacturers.  The MVP 

(Manufacturer Vantage Point) data is free.  Subscription Manufacturer data is available for 

download only if your company has opted for D-Tools’ Data Subscription service.  A gold symbol  

indicates an MVP manufacturer while a silver symbol  indicates a Subscription Manufacturer. 

To download data, open the MMPD interface and click the Download tab.  The following screen will 

display: 

 

Download Tree 
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Clicking this option will open the following screen: 

 

Show me: This dropdown allows you to select: “All D-Tools Manufacturers” or “New and 

Updated Content for My Manufacturers”.  “All D-Tools Manufacturers” displays everything 

that is available for download and “New and Updated Content for My Manufacturers” filters 

the list to only the manufacturers that are currently in your database.  This section of the screen 

displays all of the data that D-Tools has available for download.   You can expand a manufacturer 

name to view a list of categories followed by a list of model numbers.  Some manufacturers may 

have a Visio Stencil or an AutoCAD drawing available for download: 
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You can preview the data for any Product prior to downloading.  Right-click the Product and choose 

“Preview”:  
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A web browser will open and display a preview of the data. 

 

Download Options: this section of the screen allows you to select what data fields you wish to 

download/update.  On your initial download, leave all checked but when updating existing data, 

uncheck any data fields you do not want updated.  Use caution if you are updating data because 

you are at risk of overwriting changes you may have made to your data post download.   

 

Mark downloaded records as unapproved:  This will flag the Products you are downloading so 

that they will not be synchronized through LANSync.  This allows you to approve the data before 

releasing to all users. 

To quickly review and approve Products: 
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1) View Products in the Product Grid screen. 

2) Check the box “Display only unapproved products” 

3) If you do not see the Status column, click  to add it to the view 

4) Select the Products you wish to approve 

5) Select the dropdown and click “Approved” as shown below 

 

Example:  You want to download all the products that you sell for a particular 

manufacturer. 

Open MMPD, select Download and filter with the “Show me products for:” 
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dropdown if desired.  In this example I chose Request Multimedia->Distributed 

Audio->Server.  I then checked the three Models that I sell (they display in the 

“Products you have selected for download” section).  Notice that there is a Visio 

Stencil available for download.  Since this is the initial download for this 

manufacturer, all fields should remain checked in the “Download options” section. 

 

Click [Download].  When finished, you will get a “Download Complete” message. 

 

Another option for downloading products is to click the “Go to D-Tools DataXChange” link.  

DataXChange is a database hosted by D-Tools, Inc. that allows all users of it to share data.  Data 

from your machine that does not already exist in the DataXChange will be transferred to the 

database so that other users can download that data.  In exchange, you have unlimited access to 

download any product data from the DataXChange database that you choose.  This service is free. 
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Data in the DataXChange database is not verified or modified by D-Tools, Inc.  As always, verify 

the validity of any data that you download. 

   

Once you accept the rules, you can choose a Manufacturer, Category, and Model of the product you 

wish to download. 

 

Once you’ve selected the product, click [Retrieve].  The Product Properties form will open so that 

you may edit the product if desired. 

Product Download Search 
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Instead of using the Download Tree, you may opt to use the Product Download Search. 

 

Clicking this option will display the following interface: 
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There are four things you can search for: Products, Packages, Stencils and Blocks, and User 

Contributed Data.  There are buttons along the top of the form and these options are also available 

from the View menu: 

 

This interface defaults to the [Products] download screen.  This interface allows you to search for 

products in the D-Tools database that are available for download.   
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MSRP: When expanded, you can set minimum and maximum pricing criteria for your search. 

 

Preferences: Allows you to choose what fields are searched, what type of data (MVP or Data 

Subscription), and whether or not to include discontinued products in your search. 

 

Download Options: Allows you to choose what fields will be downloaded.  You will most likely 

leave all of these checked on your initial download.  You also have the option of marking the 

products you download as unapproved.  Unapproved products do not synchronize with LANSync. 
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Products that are found that match your search criteria are displayed in the grid.  You can choose 

what fields display by clicking the Field Chooser button and the columns can be sorted or filtered 

 

You can change the position of the columns by dragging and dropping or by using the arrow in the 

column heading to swap column positions: 

 

There are checkboxes next to each product as well as [Select All]/[Clear All] buttons along the 

bottom of the screen: 
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You can also select or deselect a product for download by right-clicking.  This menu offers a few 
additional functions as well: 

 

Manufacturer Product Preview: launches a web browser directed to the manufacturer’s website 

for this product 

D-Tools Product Preview: launches a web browser directed to a D-Tools server that shows the 

data that we have for the product 

View Extended Data:  launches a web browser directed to a D-Tools server that shows what 

additional data we have for the product such as brochures, manuals, and images.  This option is for 

Data Subscription users only 

View Accessories: displays additional products if the product is pre-accessorized 

You have two options for downloading: Direct or EZ Match 
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“Direct” will download the products to your local SI 5 database.  “EZ Match” will pull the data down 

into the EZ Match interface.  Use this option if you are updating existing data in your database or if 

you want to merge data from the D-Tools download to data that you may have entered into SI 5 

manually.  See “Importing via EZ Match” pg. 149 for functionality. 

[Packages] allows you to download manufacturer specified packages (only some manufacturers 

provide us with package data).  [Stencils and Blocks] allows you to search for and download any 

available manufacturer specific Visio stencils and AutoCAD blocks.  The functions available on these 

screens are similar to those on the Products screen.  [User Contributed Data] is another way to 

get to DataXChange. 
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Adding Products via the Product Grid 

Another way to manually add a Product is through the Product Grid screen.  Open the MMPD 

interface and click the Product Explorer button.  The following screen will display: 
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Click  and the following form will open: 

 

Enter the information on the various tabs for the Product you wish to add to your database.  There 

are three required fields, eight recommended fields, and the rest are optional.  The required fields 

are Manufacturer, Model, and Category. The recommended fields are Phase, Unit Labor Hrs, 

Unit Cost (for at least one of the Price Types), Unit Price (for at least one of the Price Types), 

Taxable, Height, Width, and Depth.  When finished, click [Save].   
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Adding Products via the Product Explorer 

To add a Product manually to your Master Table database, open the MMPD interface and click the 

Product Explorer button.  The following screen will display: 
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Click .  An Add Product tab is added to the right side of the screen: 

 

Enter the Product’s data following the guidelines in the Product Grid section above. 

Labor Products 

Another way to add labor to a Project is to add a Labor Product (also called Labor Items or Labor 

Line Items).  A Labor Product is a product in your database that is assigned to the Category 

“Labor”.  These are commonly used to add programming and other non-install related labor to a 

Project.  However, you may choose to use Labor Products to estimate all labor for a project if your 

project managers are involved in the estimating process.  It really depends on how you wish to run 

your business. 

Creating a Labor Product in your Database 
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In the Manage My Product Data (MMPD) interface, select the Product Grid tab (can be done from 

Product Explorer as well).  Click the Add Product button: 

 

Select “Labor” from the Category dropdown.  And fill in at least the required fields: 

 

Fill out this form as you would for any other Equipment that you add to your database.  However, 

this form is slightly different than that of other Equipment in your database, primarily due to the 

Labor Price tab. 
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There are four options for the pricing for this Labor Item: 

Fixed – applies whatever value entered in the Fixed Sale field.  There are no hours associated with 

Fixed Labor.  This is good for marking up fixed price subcontract labor, such as the use of a third 

party programmer or wire pull crew. 

Variable – calculates Sale/Hr x Labor Hrs 

Both – calculates Fixed Sale + Sale/Hr x Labor Hrs 

The fourth option is the “Use the labor cost and selling price based on the phase” checkbox.  This 

option calculates the labor values based on the rates for the selected Phase x Labor Hrs and.  When 

this option is checked the Variable fields gray out except for the Labor Hrs field.  This option 

charges the Base, Misc, Mgmt., and Design rates that you have set for the Phase. 

When you  check “Use the labor cost and selling price based on the phase”, the  Cost/Hr and 

Sale/Hr fields are grayed out and not used in the calculations.  The  “Fixed Cost” and “Fixed 

Sale” are added to in the labor calculations in the “Programming” phase.  The total labor selling 

price is displayed in the “Install Price” field .  
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Click the [View] button  to see a detailed breakdown of all the elements that make up the Labor 

Product “Installed Price”. 

 

In the example above, the model “Programming” is broad.  You would use this if you 

plan to add one Labor Line Item to a project to account for the programming. Once 

the item is added to the PDM, you would then modify the number of Labor Hours on 

the item to account for the entire project, i.e. – 30 hours.   If you plan to add a 

Labor Line Item as an Accessory to an item in your database, for example a 

processor, you would to create a specific Labor Line Item for the number of hours 

involved.  This way you don’t have to modify the Labor Line Item within each 

project.  For detailed information regarding Accessories, see the Accessories section 

of this guide. 
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Labor Line Items are often used in Packages.  If you do not want Labor to be 

calculated for each individual item in a Package, you would check the box shown 

below.  For detailed information regarding Packages, see the Packages section of 

this guide, page 93. 

 

Adding Labor Line Items to a Project 

These items are added to project the same way as any other item from your database.  They do 

show as line items in the PDM as opposed to the “behind the scenes” labor calculations for each 

item in a Project. 
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Copying Products 

Yet another way to add a Product to your database is by copying another Product that already 

exists in your database.  This is an easy way to save you the trouble of entering redundant data 

between similar Products. 

From either the Product Explorer screen or the Product Grid screen, select the Product you 

want to copy and click .  A copy of the Product will be opened and available to edit. The only 

differences between the copied Product and original are that the model number has “Copy of” 

added to the field (of course this editable). 

 

If you are on the Product Explorer screen, the copy of the Product will not open in a separate 

form; instead a tab is added to the display area: 

 

Importing Products 

By importing an Excel spreadsheet you can add multiple Products to the database at one time. You 

can use your own spreadsheet or you can use our template.  When you click the Import tab in the 

MMPD interface, you have three options: [CSV Import], [EZ Match], and [DMPI Import]. 
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The Import Template 



Application Setup Wizard  

Revised February 19, 2009 

144 

Open the MMPD interface, click the Import tab, and then click the [CSV Import] button.  The 

following screen will display: 
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Click the “Click here to create a new empty import file” link.  The “Save empty CSV file” 

from will open: 

 

Select your save location, enter a file name and click [Save].  Excel will open the file you created. 

Edit the form and Import the data into your SI 5 database. 

At this point, there are only three required fields: Manufacturer, Model, and 

Category.  Make sure that the Category is spelled exactly as it is in SI 5.  If the 

Category is misspelled you will be prompted to create the Category: 
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Clicking [No] will void the import while clicking [Yes] will open the New Category 

form: 

 

Enter an ID and select Type: Equipment, Labor, Speaker, or Wire. 

Importing via CSV Import 

1) Open the MMPD interface, click the Import tab, and then click the [CSV Import] button.  The 

following screen will display: 
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2) Select your “Field Delimiter” from the dropdown to match the format of your spreadsheet: 

Comma, Semi-colon, Tab, or Pipe. If you are using our template, leave this field set to 

Comma.  

3) [Browse…] to your file.  The Products in the spreadsheet will display in the grid. 
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4) Click [Options…]. The Import Options form will open: 

 

5) Select the Options, Fields to Import, and Field Mappings (if you are using our template, there is 

no need to change anything in the Field Mappings section) then click [OK]. 

If this is your initial import for the products in your spreadsheet, leave all the fields 

checked in the “Field Mappings” section.  However, if you are importing an update 

to your existing data, e.g. a price change, only select the fields in the spreadsheet 

that you actually modified.  This will prevent you from accidentally overwriting a 

field.  There are so many ways to edit data in SI 5, there is no way to guarantee 

that other fields haven’t been modified at some point so be very aware of what you 

are importing. 

6) Click [Import].  You will be prompted to backup your database: 
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When the import is complete you will be notified: 

 

Importing via EZ Match 

EZ Match allows you to import a spreadsheet where Category values are not present.  This option 

is nice for when you have a spreadsheet directly from a manufacturer or even from another 

application.  Most other applications do not provide a Category field, or if they do, they may not 

match your SI 5 Category list.  Category is a required field in SI 5 so this option allows you to 

assign category during the process.  When you click the [EZ Match] button on the main Import 

screen, the following screen will display: 
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This looks very similar to the CSV import but the steps are different.  The text on the form helps 

guide you through the process.  Click here to see a video demonstration. 

Step 1 is to browse to the .CSV file you want to import.  From my CSV file, only two columns were 

mapped to the SI 5 database: Model and Description. 

http://downloads.d-tools.com/si5/videos/ezmatch/import.htm


 SI5 User and Administration Guide 151

 

 

Step 2 allows you to see what fields match exactly, which are close, and which are unmapped.  

You can override or assign new mappings using the dropdown menu in each row. 
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Step 3 will show you either exact matches or close matches for the manufacturer names in your 

spreadsheet: 
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Step 4 shows you exact matches to existing products in your SI 5 database, in my example I have 

none. 

 

Step 5 will show you close matches to existing products in your database. 

 

Step 6 shows you unmatched products from the spreadsheet. 
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If you can’t find the products via the Details link, discussed below, you still need to assign the 

products a Category, one of SI 5’s required fields.  Use the dropdown in the Category column for 

one or multiple products: 

 

In steps 4-6 you have the following common options: 

Details – this link in the View column opens a window that allows you to choose any other product 

from your database to match the selected import record. 
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Select All/Deselect All buttons allow you to choose the products to import.  You can also 

individually check the desired rows. 

Step 7 allows you to verify your selections for import, when ready, click the [Import] button: 
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You will receive a confirmation of the import: 

 

Importing via DMPI Import 

D-Tools SecureConnect provides an automated way for MVP manufacturer partners and the D-Tools 

user community to communicate directly from within D-Tools System Integrator software.  Use 

SecureConnect to request your confidential dealer pricing file from your authorized manufacturers, 

or use it to contact a manufacturer directly to become a dealer or request more information.  MVP 

members can respond confidentially through their web portal environment directly to any 

requests.  SecureConnect creates value for D-Tools MVP manufacturers and D-Tools users by 

establishing an easy-to-use communication vehicle that can be accessed by the D-Tools system 

integrator community.  For more information, please contact mvp@d-tools.com 

Editing Products 

You can edit Products either in the Product Explorer or Product Grid screens. 
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In the Product Explorer screen, select a Product in the Product Tree and either click  or 

double-click the Product so it is displayed as a tab on the right side of the screen.  Make changes 

and then click [Save]. 

 

In the Product Grid screen, select a Product in the grid and either click  or double-click the 

Product.  The Product Properties form will open and be editable. 
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Another way to edit Product in the Product Grid screen is by editing directly in the grid instead of 

opening the Product Properties form.  Many fields will have a dropdown menu of options when 

you left-click in the field: 

 

If you are wanting to edit a field that does not have a dropdown menu in the grid, left-click once in 

the field and then press [F2] on your keyboard.  This will put a cursor in the field.  

You cannot have the Product Properties open for edit for the same Product in both 

the Product Explorer and Product Grid screens. If you attempt, you will see the 

following message: 

 

Exporting Products 

A way to edit multiple Products at one time is to export your data to an Excel spreadsheet.  This is 

particularly useful for updating prices for a large number of Products. 



 SI5 User and Administration Guide 159

Open the MMPD interface and click the Product Grid tab.  The Product Grid screen will display: 

 

Use the tabs to filter your Products to the ones you want to export.  The Products will display in the 

grid: 
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Click .  The Export form will open. 

 

Accept the license agreement and click [Next]: 

 

Choose your path and filename and change the Field Delimiter if necessary.  When ready, click 

[Export].  If you left the “Open in Microsoft Excel after export” options checked, Excel will 

launch and the file will be ready for editing. 

After you have made your modifications to the spreadsheet, follow the instructions in 

the Import Products section of this guide to import your changes.  See Importing 
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Products on pg. 142. 

Administration 
This section of the MMPD interface offers many options to customize and maintain your database.  

There are six “sections”: Categories, Manufacturers, I/O Lists, Formatting, Custom 

Properties, and Database.  To access this screen, click the Administration in the MMPD 

interface.  The “sections” are listed as buttons beneath the main tabs. 

 

Categories 

[Categories] allows you add, edit, or delete Categories from your database.  There are [Add] and 

[Delete] buttons.  If you want to edit a field, click once in the field and the press [F2] on your 

keyboard or double-click in the field. 

 

We don’t recommend that you modify the existing Categories in SI 5. You will lose 

links to Visio Stencils and AutoCAD Drawings if you change the name of an existing 

“stock” Category.  If you create your own Categories, you may wish to create Visio 

Stencils and/or AutoCAD Drawings for the Categories.  See the Visio/AutoCAD 

sections of this guide for info. 
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Manufacturers 

[Manufacturers] allows you add, edit, or delete manufacturers from your database.  There are 

[Add] and [Delete] buttons.  If you want to edit a field, click once in the field and the press [F2] 

on your keyboard or double-click in the field. 

 

I/O Lists 

 [I/O Lists] allows you add, edit, or delete inputs and outputs from your database.  There are 

[Add] and [Delete] buttons.  If you want to edit a field, click once in the field and the press [F2] 

on your keyboard or double-click in the field.  Inputs and outputs in SI 5 are composed of three 

parts: Terminal, Signal, and Label.   Select which one you would like to edit from the “Select 

list type” dropdown. 
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These I/O Lists are used in two places in SI 5.  The first and most obvious place they are used is 

when editing the inputs and outputs for Products in your database via the I/O Studio: 

 

The second place that the Terminal list is used is on the Assign Head End dialog. These values are 

passed to the Bulk Wire Termination Report: 
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The Assign Head End dialog opens for Products added to a Project that are of 

Category “Wire and Cable” and of Phase “Rough-In”. 

Formatting 

This tab allows you to set the default case settings for Category, Manufacturer, Model, and 

Description for consistency throughout the SI 5 application.  The Exception List section is used 

for abbreviations and acronyms that you do not want to be affected by your case settings. 

 

These settings take precedence over what you enter in those four fields for a 

Product. 

Example: You create a new Product in your database and you type “Surround X28” 

in the Model field.  The Formatting for the Model field is set to “UPPER CASE” as in 

the screenshot above.  When you print your reports, the Model for this Product will 

display as “SURROUND X28”. 
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Custom Properties  

Custom Properties is where you can rename the ten Custom Properties for Products in your 

database.  The first five in the list are formatted for text, the next three are formatted for 

numbers, and the last two are formatted for dates.  Custom Properties are not used or reported by 

SI5, however with the ability to now easily generate custom reports you have find many uses for 

the Custom Properties.  To edit a field, click once in the field and the press [F2] on your keyboard 

or double-click in the field. 
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Database 

Database Management has four sections:  

1) Backup your local Product database. 

2) Restore your local Product database from a backup. 

3) Compact your local Product database.  

4) Convert a local Product database from a previous version of System Integrator. 

 

The local backup functions are not overly useful and will not likely be used much.  The main way to 

backup your SI 5 data is via the SI 5 Administration Console.   See the SI 5 Installation and 

Administration Guide for details.   
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LANSync 

LANSync is the name of the synchronization functions within SI 5. The primary function of LANSync 

is to allow you to keep your Product Data consistent on all PCs running SI 5. 

 

The graphic below represents a typical LANSync configuration: 

 

Configuring LANSync 

When you initially installed and configured SI 5, you already configured LANSync when you 

performed the “Sync product data” step in the Start Here guide.  Everyone followed the 

instructions on the Start Here doc and in the SI 5 Installation and Administration Guide, right? 

Right. 
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Here under the LANSync tab in the MMPD interface you have functions that allow you to re-

configure your data on the server should you need to. 

 

The steps for re-configuring LANSync are listed below.  Following these steps is a description of all 

of the LANSync functions on this page. 

From the machine with the most accurate database: 

1. Click [Copy Up To Server]. 
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On all other machines: 

2. Click [Copy Down To Local]. 

LANSync Synchronization 

 

Synchronize with LANSync server – we recommend that you check both of the boxes: 

“Automatically synchronize when MMPD starts” and “Automatically synchronize when 

MMPD closes”.  This saves you the trouble of having to remember to synchronize.  When you 

open and/or close MMPD, you will be prompted to sync: 

 

If you want to manually synchronize, click [Synchronize Now].  When you synchronize, data 

between your local database and the SQL database are compared and updated with the most 

recent data based on the date/time stamp: 

 

The [Synchronize Now] button and the “Sync product data” link in the Navigator perform the 

same function: 
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Copy LANSync server database to your local machine – the [Copy Down To Local] button 

will copy the contents of the database on the SQL server to your local database.  This action must 

be done on all machines following the use of the [Copy Up To Server] function (see below). 

LANSync Server Management 
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Copy product data to LANSync server – clicking [Copy Up To Server] will copy the records in 

your local database to the database on the SQL server.  This step must be performed in order for 

LANSync to operate and is generally only done once, during the initial setup of SI 5.  This step 

should be performed on the machine that has the “best” or “most current” database.  The data that 

is transferred is your Product data, Phases, Tax Rates, and Client List.  When you click this button, 

you will asked to verify the action: 

 

Progress will display: 

 

You will be notified when this completes: 
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Below is a graphic representation of what just happened: 

 

Copy project defaults to LANSync server – clicking [Copy Project Defaults] will transfer data 

that is not synched automatically from your local database to the SQL database.  Examples of this 

data are Status List, Location List, Project Staff, etc.  This would only be done from a machine 

where the data has been verified and a decision has been made to share this data with all users.  If 

changes are made to the data under the Setup tab in the Navigator after you have established 

your data on the server, you must use this function to push the changes to the server as the 

“Project Defaults” are not synchronized every time you use the sync function in SI 5.  However, 

after using this function, the very next time a machine synchs, the “Project Default” data will be 

transferred to their machine.  
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Conflict Resolution – Click [Resolve Conflicts] to check to see if any conflicts occurred during 

synchronization.  Conflicts are rare but can occur when the following scenario takes place: 

The date is 6/26/2007.  The data on the SQL database has a Date/Time Stamp of 

“6/25/2007 5:35 PM” from the previous day’s work. Reed and Seth arrive at work, 

open MMPD, and synchronize with LANSync on each of their machines. Reed edits 

the pricing on a few items in the database at 11:59 AM and then heads out the door 

to lunch, leaving MMPD open on his machine.  Seth edits the same items at 12:35 

PM and then synchronizes.  When he synchronizes, the data that was edited was 

pushed out to the SQL database with a Date/Time Stamp of “6/26/2007 12:35 PM.  

Reed returns from lunch and decides to synchronize.  The edits to the data that Reed 

made earlier are pushed out to the SQL database with a Date/Time Stamp of 

“6/26/2007 11:59 AM” which is earlier than the date of the data on the server 

(“6/26/2007 12:35 PM”).  This is a “Conflict”. 

 

Clients and Contacts 
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The Clients and Contacts button in the Navigator opens the interface for adding/editing/deleting 

Clients and Contacts within SI 5.  A Client is considered and entity like a business or a company 

and Contacts are individuals.  Clients and Contacts are only available for edit when you are working 

online. 

There are two tabs along the bottom of the interface: Clients and Contacts.   

 

The left side of the screen contains a Navigation Bar with functions that vary depending on which 

tab you have selected and whether or not you have a Client or Contact Selected in your list.  First 

we discuss the functions available to you for Clients. 
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Adding/Editing/Deleting a Client 

When adding or editing a Client the form is the same and will be referred to as the Add New/Edit 

Client form.  This form has four tabs: General, Addresses, Contacts, and Notes.  To add or edit a 

Client, click the appropriate link and the Add New/Edit Client form will open: 
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The General tab, as shown above, has fields for: Name, Phone, Fax, Account Number, Accounting 

ID. 

Field Description 

Name Client name 

Phone Client phone number 

Fax Client fax number 
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Field Description 

Account Number If you wish to identify a Client by a number use this 

field 

Accounting ID This field auto-generates when you import a Client 

from QuickBooks 

The Addresses tab allows you to enter as many addresses for the Client as needed. 

 

Use the  button to add an address and the  button to delete an address.  You can view your 

addresses by using the navigation buttons .  To add or edit the Address 
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Type list use this button .  There are Only one address can be the primary address for a Client 

and is designated by a checkmark “Primary Address”.  The  button will launch IE in its 

own window and display Google Maps for the address. 

The Contacts tab of the Add New/Edit Client form allows you to add as many Contacts to a Client 

as desired. 

 

You can click the  button to manually enter a Contact or you use the dropdown arrow to 

associate an existing Contact to the Client or you can import Contacts from Outlook.  Use the  
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button to delete a Contact.  You can view your Contacts using the navigation 

 buttons or you can use the “Quick Select” dropdown 

. 

 

Contacts must be assigned to a Contact Group.  You can Add/Edit your Contact Groups by 

clicking the  button. 

  

When you click either the [New] or the [Edit] buttons, the following form opens. 
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The Notes tab of the Add New/Edit Client form is one big editable field and there is a spell check 

function. 

 

To delete a Client select an entry in the list can click the “Delete Client” link. 
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Import Client from Outlook 

When you click this link, the first thing that will appear will be a message from Outlook letting you 

know that a program is trying to gain access Outlook.  Click the checkbox, select a time, and click 

[Allow]: 

 

 

The Import Client from Outlook form will open.  Select a Contact from the list and click the 

 button: 

 

The Add New Client form will open for any changes you wish make: 
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Import Client from QuickBooks 

Your company must have a QuickLinks license in order to use this functionality and you must have 

the “Allow QuickLinks” permission assigned to your Group. See QuickLinks on pg. 582 for info as 

well as the SI 5 Installation and Administration Guide for information on permissions. 

When you click the option “Import Client from QuickBooks” the following form will open: 

 

Select the QuickBooks Customer from the grid and click the  button.  You can only 

import one QuickBooks Customer to an SI 5 Client at a time. 

The Add New Client form will open in case you wish to make any changes.  When done, click the 

 button. 
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Export Clint to QuickBooks 

Your company must have a QuickLinks license in order to use this functionality and you must have 

the “Allow QuickLinks” permission assigned to your Group. See QuickLinks on pg. 582 for info as 

well as the SI 5 Installation and Administration Guide for information on permissions. 

This will export a Client from SI 5 to a Customer in QuickBooks.  There is no form, just a message 

that the operation completed.  If a Customer exists in QuickBooks of the same name, a form will 

give you options. 
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Create New Project for Client 

This link will open up the New Project Wizard with the Client name and address information already 

filled in.  The Primary Contact information will be populated in the Project Contact and Staff section 

of the wizard: 

 

Send an E-mail 

You must have Outlook 2007 installed for this function.  This will open up a new Outlook email 

addressed to the primary Contact for the Client. 

Create an Appointment 

You must have Outlook 2007 installed for this function.  This will open up a new Outlook 

Appointment addressed to the primary Contact for the Client. 

Manage Address Types 

This allows you to add to the stock list of Address Types in SI 5.  The three types in the stock list 

are Billing, Site, and Other and these three are not editable. 
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Adding/Editing/Deleting a Contact 

Make sure that you have the Contacts tab selected: 

 

The interface is similar to the Clients interface.  You can move columns around, click the Field 

Chooser button to change what displays, and filter most columns: 
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The functions for Contacts are similar to those of Clients as well: 
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When you click the New Contact link the Navigation bar, the following form opens: 



Application Setup Wizard  

Revised February 19, 2009 

188 

 

A Contact Group is required and you can modify your list using the  button.  The  

button will launch IE in its own window and display Google Maps for the address. 

Import Contact(s) from Outlook 

This form is similar to the one for importing Clients but you may import more than one Contact 

from Outlook: 
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Export Contact to Outlook 

This function will open a Contact entry in Outlook.  You must choose to Save in Outlook or the 

transfer is not complete. 
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Create Client from Contact(s) 

This function opens up the Add New Client form with the Contact tab already filled in.  Fill out the 

rest of the form then click . 

Send an E-Mail 

You must have Outlook 2007 installed for this function.  This will open up a new Outlook email 

addressed to the Contact. 

Create an Appointment 

You must have Outlook 2007 installed for this function.  This will open up a new Outlook 

Appointment addressed to the Contact. 

Manage Contact Groups  

This is another way to manage your Contact Groups: 
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Projects 
The Projects button displays a screen that allows you to create and manage Projects.   

 

The display area has two tabs: Project Grid and Selected Project Details: 

 

The Project Grid tab section lists all of your projects based on your selection from the Show 

dropdown menu.  There are five options in the list: Projects changed in last week, 5 most recently 

changed projects, All projects, Local projects, and Archived projects: 
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All of the columns in either section can be sorted ascending or descending when you click the 

header for the column.  The translucent arrow ( ) indicates the sort order: 

 

Other functions are shown in the screenshot above.  Click the  button to add/remove columns 

from the grid.  Click the  button to filter the column.  Click the  button to swap a columns 

position with another column.  You can also move columns around by dragging them: 
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If you wish to group your projects by a column heading, drag the column to the “Drag a column 

header here to group by that column” area.  To reverse this simple drag the column header outside 

of the area: 

 

The Projects area view will change: 

 

There is a refresh button along the top of the screen that will refresh your project list: 

 

The Selected Project Details tab displays information about the project in three sections; Project 

Details, Project Summary, and the Project Files/Revisions section: 
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When the Project Files tab is selected, all of your Visio, AutoCAD, and “other” files are displayed.  

You can use the [New] button to add Visio or AutoCAD drawings or you can use the [Add File] to 

add any other files such as .pdf files or Word docs.  A project must be checked out to add files.  

See Project Functions pg. 205 for details on these functions. 
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The Revisions tab shows all revisions for a project and you can “Promote Revision” or Delete any 

revisions in this interface.  See Project Functions pg. 205 for details on these functions. 
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Project Files 
Every SI 5 Project starts out with one Project file and the file extension for this file is .dtl.  This file 

is considered “THE” Project file or “Current” revision.  When opened, this file opens in the SI Text 

interface.  Every Project in SI 5 can have only one .dtl file.  And only one .dtl file may exist in the 

same folder. 

Once the .dtl file exists for a Project, you can create as many Visio or AutoCAD files for the Project 

as you wish.  Visio files have a file extension of .vsd and AutoCAD files have a file extension of 

.dwg.  For Visio files, multiple drawing pages may exit in one Visio file as shown below: 

 

For AutoCAD files, each drawing page exists in a separate .dwg file, e.g. JF125 Audio 

Schematic.dwg, JF125 Video Schematic.dwg, JF125 First Floor Plan.dwg, etc.  (The 

“JF125” is an example of a “unique tag”, the file names will be discussed in an example below). 

File Naming Convention 
There is no mandatory naming convention for Project files in SI 5.  However, coming up with a 

naming convention could prove to be extremely useful.  Establishing a common “tag” for each file 

name could prove vital for identifying which files are associated with a Project.  If you’ve ever 

“lost” a file before, and you have, you know that having a meaningful search string can save you 

time when you “misplace” a file.  Establishing a file naming convention is highly recommended. 

In addition to a Project file naming convention, a naming convention and folder hierarchy standard 

should be established as well.  The default folder structure for SI 5 is C:\Documents and 

Settings\username\My Documents\D-Tools SI5 Projects\Client Name\Project Name where 

“username”  is your Windows login name. 

VISTA:  C:\Users\username\Documents\D-Tools SI 5 Projects\Client Name\Project Name. 
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Key Fields: Client Name, Project Name, Project Number 

When creating a Project, there are two required fields: Client Name and Project Name.  Project 

Number is optional but useful.  Because these fields are very “project specific”, they make excellent 

choices for use in a file naming convention. 

Company XL uses the Client and Project Name fields to establish their folder 

hierarchy.  They establish Project Numbers in their accounting software.  They create 

a Project for Jem Finer’s boathouse.  In step one of the new projects wizard, they 

type in the Client Name and Project Name as shown below and enter the Project 

Number (for instructions on creating a Project see “Creating an SI 5 Project” page 

224): 

 

When they get to step 10 and [Save] the Project, the save location in the form is 

pointing to the following folder: C:\Documents and Settings\username\My 

Documents\D-Tools SI 5 Projects\Client Name\Project Name. 

VISTA:  C:\Users\username\Documents\D-Tools SI 5 Projects\Client Name\Project 

Name. 
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They designate all file names to begin with the Project Number so they can easily 

track what files are associated with a Project.  Since this initial file creation is for THE 

Project file (.dtl), their standard also requires that the Project name follow the 

Project number for this file as shown below. 

 

After saving the Project file, it shows in the Projects tab of the Navigator: 

 

They keep all of their Visio drawings on pages within a single Visio Project file so 

they only create one.  Their convention for the Visio file in which they intend to do 

their drawing pages is the same as for the main .dtl file (the Project Number followed 

by the Project Name, in this case: JF125 Finer Boat House.vsd). 

They choose to create two schematic drawings in AutoCAD for this project, one for 

the audio, and one for the video systems.  Their convention for naming these files is 

to use the Project Number followed by a description of the drawing.  In this example 

they create two files: JF125 Audio Schematic.dwg and JF125 Video 

Schematic.dwg.   
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They received a couple of floor plans from the architect and will use these on Plan 

drawing pages.  They are AutoCAD .dwg files and they are named: 0_1 Finer First 

Level.dwg and 0_2 Finer Loft.dwg.  Their standard states that all non-SI 5 files 

are stored together in the same location as the SI 5 files.  To differentiate non-SI 5 

files from SI 5 files, they use an underscore (_) before the Project Number in file 

name.  These files above were renamed: _JF125 Finer First Level.dwg and 

_JF125 Finer Loft.dwg 

They also keep copies of all reports that they present to clients in .pdf format with all 

of the SI 5 files.  They name these in a similar fashion as above, i.e. _JF125 

Contract.pdf and _JF125 Detail Cost Summary by Phase.pdf.  

See “Viewing a Report” starting on page 488 for details on creating .pdf copies of 

reports 

Once they have created and added all of the files, the project files display in the 

Navigator as shown below: 

  

Project File Location(s) 
SI 5 Projects can be composed of multiple files.  All files for a Project must be stored together in 

the same folder.  Managing how and where you store your Project files is up to you, so make sure 

you develop and maintain a strategy for Project file management. 

Local Projects Folder 

Every SI 5 is install must have a local Projects folder.  The default location for this folder is: 
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XP: C:\Documents and Settings\username\My Documents\D-Tools SI5 Projects  

VISTA: C:\Users\username\Documents\D-Tools SI 5 Projects 

*username= your Windows login name 

You will have a local projects folder for each unique user login, however, they will all share the 

same local database.  

Within this folder, all Project files must be in their own folder.  You can have as many subfolders 

within the root of the default Projects folder as you wish.  

Server Projects Folder 

When you installed your SI 5 Server Components, a shared project folder was created on that 

machine, see the SI 5 Installation and Administration Guide for details.  This is where project 

reside when they are “checked in”.  See Checked In vs. Checked Out on pg. 203.  Project files 

transferred to the server maintain the folder structure of the local Projects folder. 

Project File Rules Overview 
SI 5 provides maximum flexibility in file naming.  As a result this puts the responsibility on the user 

to adhere to good file management practices. 

1) There can only be one .dtl file for a Project.  It is THE Project file or “Current” revision and it is 

what opens when you launch the SI 5 Text interface.  In every Project folder there can be only 

ONE .dtl file. 

All Project files must be stored in a subfolder within the default Projects folder.  They can be stored 

in any number of subfolders but they cannot be stored in the root of the default Projects folder.  

Expressed another way: C:\Documents and Settings\*username\My Documents\D-Tools 

SI5 Projects\Howard Stern\Manhattan Flat\Kitchen Upgrade\HS100 Kitchen 

Upgrade.dtl is fine, while C:\Documents and Settings\*username\My Documents\D-Tools 

SI5 Projects\HS100 Kitchen Upgrade.dtl is not acceptable.   

VISTA:  C:\Users\*username\Documents\D-Tools SI 5 Projects\Client Name\Project Name 

2) Two different users cannot have the same project open at the same time for edit.  For example, 

you may have the following files created for a Project:SE024 Beach House.dtl, SE024 Beach 

House Line.vsd, SE024 Beach House First Level Plan.dwg.  You cannot have one user 
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working on SE024 Beach House Line.vsd and one user working on SE024 Beach House 

First Level Plan.dwg at the same time. 

3) On any given machine, you can have as many Projects open at the same time in the SI Text 

interface.  Each Project will open in its own instance of the SI Text Interface. 

4) On any given machine, you can have as many Visio Project files open at the same time as you 

wish.  The limitation is that only one Visio Project file per Project may be open at the same 

time.  The individual Visio Project files will open in sub-windows within one instance of Visio.  

For example, you can have the following files open at the same time SE024 Beach House 

Line.vsd, HS100 Kitchen Upgrade.vsd open at the same time but can not open SE024 

Beach House Elevation.vsd while SE024 Beach House Line.vsd is open. 

5) On any given machine, you can have as many AutoCAD Project files open at any given time as 

long as the files are for the same Project.  Each AutoCAD file opens in its own instance of 

AutoCAD.  For example: you could have SE024 Beach House First Level Plan.dwg, and 

SE024 Beach House Second Level.dwg open at the same time but you can not open HS100 

Kitchen Upgrade Lighting Schematic.dwg until you close all of the other Project files open 

in AutoCAD.  

Checked In vs. Checked Out 
It is important to understand that there are two main “states” of an SI 5 Project: checked in or 

checked out.  When a user checks out a project, they have the ability to modify the project.  Other 

users will see the project in the Lookup grid but will only be able to open the project in Read-Only 

mode.  When a project is checked out to a user it is indicated in the CheckedOutTo column in the 

Project Grid.  The user’s login name will display followed by their machine’s name in brackets: 

 

It is important that you check out any projects that you wish to work on prior to taking yourself 

offline.  An example of when you would take yourself offline would be if you are working on a 

laptop and wish to work away from your office network.  When you choose to take yourself offline 

you will see the following prompt reminding you to check out any projects that you wish to edit 

while offline: 



Projects  

Revised February 19, 2009 

204 

 

If you want to be able to review but not edit a project while you are offline, you must use the 

“Make project available offline” function. 
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Project Functions 
The functions that display in the Navigation Bar will vary depending on whether the project you 

have selected is checked in our checked out and whether you are on the Product Grid tab or the 

Selected Project Details tab.  The following sections will detail all possible functions. 

 

 

 

Open this Project in SI Text – this launches the project in the SI Text interface.  The SI Text 

file is the “main” or “primary” file associated with every project.  This interface does not show any 

drawings that have been created for the project. 
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Open this revision in SI Text – opens the selected revision in the SI Text Interfaces.  

Revisions are read-only. 

View Project Information – opens a window that displays all of the information related to the 

selected Project.  You can Check Out/In the project or Edit any of the information: 

 

Check In this Project – this will check the project in to the server.  You must do this for most of 

the Orders and Accounting and Scheduling functions. 

Check Out this Project – this will check out the project from the server to your local machine.  

You must do this to edit a project.  If you attempt to open a project that is “checked in” you will be 

prompted to check out the project before opening.  If you choose [No], the project will open in a 

Read-Only state. 
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Undo Check Out - this function is here as a safety measure.  This allows you to essentially 

discard any changes that you have made locally and restore the status of the project on the server 

to “checked in”.  This would be used if you made a mistake while working on a project.  This may 

also be used if a project was checked out to a machine that no longer exists (crashed, got stolen). 

You will see the following prompt when you select this option: 

 

Create a New Project - this begins a ten step wizard that is detailed in the Projects section of 

this guide, see “Creating an SI 5 Project” on page 224. 

Copy This Project - allows you to make a copy of the selected Project.  You will be prompted to 

choose a folder to store the Project files.  Although you have the option to create the file anywhere 

you want, you should create a folder within your default Projects folder.  We recommend sticking 

with the Client Name->Project Name Format.  If you are copying a project for the same client, you 

should create a new folder under the existing Client Name folder.  There can only be one .dtl per 

folder, see Project File Rules Overview on pg. 202.  
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This creates a copy of all of the Project files.  All project files will retain their names.  The Project 

name will have “Copy of” added to it.  Only the most current revision of the project will be copied: 

 

Move this Project – this allows you to move a project to a new folder.  This is the ONLY method 

of moving project files that is supported by D-Tools.  DO NOT manually move files around.  When 

you move a project, it should still reside in the same folder where you store you SI 5 projects. 

Create a New Revision of This Project – this creates a revision of the selected Project.  

When a project is created it is by default Rev 0.  When the first revision is made, Rev 0 is stored 
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and a new copy of the project is created called Rev 1, or Current Project.  This process is repeated 

each time a revision is created.  As shown below, the current revision number is incremented and 

the next revision becomes the Current Project. 

 

For more information on revisions (and visual representations), see “Change and Revision 

Management” on pg 247. 

Delete this revision – This function will delete the selected revision. 

Archive this project – This function will archive the project. In order view your Archived 

projects you must select that view: 
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Import a project – this allows you import a project into the SI 5 application.  A wizard will open 

where you browse to the .dtl file for the project.  Once the .dtl is selected, a Project Summary will 

show what files will be converted: 

 

If the project is in a format from a previous version of SI it will be converted to SI 5 format during 

the import. 

If you are converting an SI 4 project that has Visio or AutoCAD files associated with 

it, those applications will open during the conversion process.  Prior to conversion, 
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you must make some changes to your Visio settings. 

6) Open Visio and select Tools->Macros->Security… 

7) Verify that your Security level is set to Medium or Low: 

 

8) Click the Trusted Publisher tab and check the “Trust access to Visual Basic 

Project” option. 
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9) Click [OK]. 

10) Close Visio. 

During the conversion, you will be prompted by two messages shown below.  Click 

[OK] for both messages: 

 

 

If you were using Business Manager in SI 4, you have the option of converting just 

the project file or converting the project files and the SQL data (Sales Orders, Work 
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Orders) for the project. Revisions for the project will NOT be converted.  This is due 

to the new format for Revisions in SI 5. 

 

When you select “Convert DTL and Business Manager Database” and click [Next], 

you are then prompted to select the location of your SI 4 database.  The dropdown 

will list the machine names of all the machines on your network that have instances 

of SQL installed.  Select the machine name of the “server” machine you were using 

for SI 4. If you used the default MSDE SQL Server that was included with the SI 4 

LANSync install you will need to add “\DTOOLSMSDE” after the machine name.  In 

the example below, the machine where my SI 4 SQL instance is located is named 

“DT4136”.  The User Name and Password are automatically filled in for you on this 

form. 
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Open this file – opens the selected file. 

Add a file to this project – when you click this option, you will be prompted whether you are 

sure 

Delete this Project – when you click this option, you will be prompted whether you are sure  
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Remove local project files – use this option if you just want to remove the local project files 

from your machine.  You would use this if you wanted to clean up hard disk space on your local 

machine.  The project still exists on the server. 

 

Add a File to This Project – This allows you to store additional files for the selected Project in 

the same folder as the Project Files other than “SI 5 linked” files.  Examples: .pdf files, AutoCAD 

floor plans, etc. 

Definition time – “SI linked” means that the file has a connection to the main SI 5 

Project file for a Project (the .dtl file). There can be only one .dtl file per Project in SI 

5.  When a drawing file, either Visio (.vsd) or AutoCAD (.dwg) are created using the 

“Create new Visio/AutoCAD drawing for this project” functions (described below), 

those files are considered “SI linked”.  You may, however, choose to have .vsd and 

.dwg files for a Project that are NOT “SI linked”.  These files would be ones not 

created from within the Navigator interface, i.e.- they were created directly in Visio 

and/or AutoCAD launched externally of SI 5. 
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Delete This File – This will delete the selected file from the project.  This can be used for Visio, 

AutoCAD or other files associated with a project. 

Create New Visio Drawing for This Project – This will create a new “SI 5 linked” Visio file 

for the Project.  You will be prompted to select a template: 

 

In SI 5, you can have multiple Visio project files for a Project. You can choose to do 

all of the drawing pages in one Visio file or you may choose to do the drawing pages 

in separate Visio files. 

Example: You may choose to have one file SE024 Enos Home.vsd that has all of 

the Plan, Line, Elevation and Schematic pages or you could have a separate Visio file 

for each drawing page: SE024 Enos Home AV Schematic.vsd, SE024 Enos 

Home First Level Plan.vsd, etc. 

The stock templates that ship with SI 5 have six pages but you can easily create 

your own Templates.  For information on creating a Visio template see Creating SI 

5 Visio Templates on pg.400. 
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Create New AutoCAD Drawing for this Project - This will create a new “SI 5 linked” 

AutoCAD file for the Project.  You will be prompted to select a template: 

 

Get latest version of this file – this updates the local project files with the latest project files 

from the server without checking the project out.  This function should be used if you wish to have 

the latest project files on your machine and do not want to check out the project from the server. 

Make project available offline – this will cache the project locally to your machine in a read-

only state.  This will allow you to view the project while disconnected from your network.  If you 

want the product to be editable while you are offline, you would use the “Check Out this project” 

function rather than this one.  You will see the following message when you use this function: 

 

Restore this archived project – This function will restore an archived project to an active 

project. 

Example: You have archived a project that you wish to restore an active project. 

1) On the Projects tab within the navigator, select to show “Archived Projects”: 
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2) Select the archived project that you wish to restore and click “Check Out this 

project”: 

 

Project Task Pane Right Click Options 

You can also access these options by right-clicking anywhere in the Projects section of the Display 

Area.  There are some additional options on this right-click menu that are not available in the 

Task Pane: 
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Open in Visio->New Drawing – This will create a new Visio file for the Project. 

 Open in AutoCAD->New Drawing – This will create a new AutoCAD file for the Project.  

Refresh Project – This will refresh the Projects section of the Display Area.  Use this function if 

you do not see the expected values for the project: Installed Price, Status, etc. 

Force Undo Check Out – This is for Administrators of SI 5 that need to undo the check out of a 

project that was checked out by another user (see the SI 5 Installation and Administration guide 

for information on setting a user as Administrator).  This function will check a project in to the 

server without any of the changes that were made while it was checked out.  This would be used if 

a project was checked out to a machine that no longer exists (crashed, got stolen).  You will see 

the following prompt when you use this function: 
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Standard SI 5 Client Server Rules 
SI5 uses an intelligent file management process to determine which files will move between client 

and server.  The following is a high level description of this interaction. 

1) Projects can only be checked out by one user at a time. 

2) Projects must be checked out to Add files to the project 

3) Reports can be run on projects that are checked out by another user.  

4) The first time a project is checked out, all dtl and dtlrev files are copied to the local projects 

folder. 

5) Drawings and Other Project files are copied to the Local folder when: 

6) User opens the file 

7) User executes the “Get Latest” command 

8) Only files that have changed will be copied to/from the server.  If you modify the Project File 

and check in the project, the Dtl file will be copied the server.  If you open this project before it 

is modified by another user, the local project file will be used and no data is copied from the 

server. 

Files and Projects 
All file management will be handled in the Navigator.  The Import Project function on the Projects 

tab of the Navigator allows the user to browse to SI 4 and SI 5 projects to import.  SI 4 project will 

be converted to SI 5 format during this process.  

Only one application (Text, Visio or AutoCAD) can be open at a time for a given project. 

Text dtl files and Visio vsd files have similar functionality.  In Text and Visio you can have multiple 

projects open but only one file can be open per project at a time.  In AutoCAD you can have 

multiple drawings (dwg files) open for the same project but only one project can be open at a time. 
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To create a new project you can select Create Project, or go to File - New Project, or use right click 

– New Project..  The Project Information dialog will open.  After entering the data, a dtl file for the 

new project will be created.  Visio and AutoCAD files can then be created by right clicking New 

AutoCAD or New Visio, or by selecting New AutoCAD or New Visio from the Explorer bar on the left. 
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File 

Classifications 

Ext Server 

Action 

Description 

Project File Dtl Standard 

SI5 rules 

apply. (see 

below) 

This file contains data for the Current 

Revision of a project.  There can only 

be ONE Project file in a project folder.  

This file can be read by most report 

writers and Office applications such as 

Excel.    

Project Visio File vsd Standard 

SI5 rules 

apply. 

One or more Visio files created with 

SI5 Visio Interface.  These files are 

considered “linked” to the Project File.  

These files must live in the same 

folder as the Project File. 

Other Visio File vsd Standard 

SI5 rules 

apply. 

Visio files created outside of SI5 and 

added to the project using the 

Navigator > Projects > “Add a file to 

this project” function.  There is no way 

to distinguish these files from Project 

Visio Files.  These files must live in the 

same folder as the Project File. 

Project AutoCAD 

File 

dwg Standard 

SI5 rules 

apply. 

AutoCAD files created with SI5 

AutoCAD Interface.  These files are 

considered “linked” to the Project File.  

These files must live in the same 

folder as the Project File. 
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File 

Classifications 

Ext Server 

Action 

Description 

Other AutoCAD 

File 

Any  Standard 

SI5 rules 

apply. 

AutoCAD files created outside of SI5 

and added to the project using the 

Navigator > Projects > “Add a file to 

this project” function.  There is no way 

to distinguish these files from Project 

AUtoCAD Files.  These files must live 

in the same folder as the Project File. 

Other Project Files Any Standard 

SI5 rules 

apply. 

Files added to the project using the 

Navigator > Projects > “Add a file to 

this project” function.  These files 

must live in the same folder as the 

Project File.  Folders cannot be added 

to a project. 

Project Revision 

File 

dtlrev Standard 

SI5 rules 

apply. 

Project File of a specific Revision 

Revision Zip File zip Standard 

SI5 rules 

apply. 

Includes all Project Visio and Project 

AutoCAD files zipped into one folder.  

These are created by the system each 

time a new revision is created. 

Other Files/Folders 

not “added” to the 

project via the 

Navigator 

interface. 

 

 Not 

managed by 

SI5.  These 

files will not 

be copied to 

the client by 

SI5.   

The user may choose to store other 

files and folders on the server within 

the project folder.  These could 

include, client photos, architectural 

drawings, cut sheets or any other data 

that needs to be stored with a project.  

These files and folders will not be 

visible within the SI5 interface.  

Check-in/out of these files are not 

controlled by SI5.  
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Creating an SI 5 Project 
To create an SI 5 Project, launch SI 5 and then click the Projects tab.  Click the “Create a new 

project” link in the Project Tasks Pane.   
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The New SI 5 Project wizard will open: 

 

Use the [Previous] and [Next] buttons to navigate between the steps of the wizard.  At any time 

during these steps, click [Save] to save the Project. 
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Step 1:  Project Information 

There are two required fields at this point: Client and Project Name.  It is also advised that you 

provide a Project Number. 

 
 

Item Description 

Client Who the Project is for 

Project Name 

 

This should be descriptive enough to be able to identify the 

Project 

Project Number This can be any String of your choosing.  If you leave this field 

blank, a Project number will be generated based on your 
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Item Description 

 
settings for Project Number ID. (see “Project Number 

Format:” on page 55 for more information about Project 

Number ID 

Status This is a dropdown list to identify what milestone you are at in 

a Project’s lifestyle.  (see “Project Statuses:” on page 46) 

Assigned To This is the person within your organization that is responsible 

for this project.  It is up to you to define “Responsible”. 

Name This is where you fill in the name of the decision maker for a 

Project.  This field will automatically populate on the client 

signature line in reports. 

Title The title of the person you entered in the Name field. 

Phone Phone number of the person you entered in the Name field. 

Email Email address of the person you entered in the Name field. 

Sales Rep, Designer, 

Project Manager, and 

Other 

These are dropdown lists to identify who in your company is 

involved in the Project.  (see “Staff Types and Members:” 

page 45). 

If the Client already exists under Clients and Contacts within SI 5, many of the above fields will 
populate with information from the Client.  See Clients and Contacts on pg. 173. 
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Step 2:  Site Address 

 

Fill in all appropriate fields for the Project’s site address.  If you used the [Import] button on the 

last step, and you had address information in Outlook, these fields will be filled in.  This address 

will show on many client reports. 
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Step 3:  Billing Address 

 

Fill in all appropriate fields for the Project’s billing address.  Select [Copy Site Address] if the Site 

address and the Billing address are the same. 
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Step 4:  Project Contacts 

 

You must have your Contacts setup under Clients and Contacts in order to enter them here, see 

Clients and Contacts on pg. 173.  Use the  to add to the list.  To delete a contact, select them 

in the list and click the  button. The “Group” dropdown allows you to identify who the contact is.  

(see “Staff Types and Members:” page 45). 
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Step 5:  Scope of Work 

 

Entering a Scope of Work is optional.  The contents of this field will print on the Scope of Work 

client report.  This form has a spell check that you can run by clicking the  button. 

You can type in this field; copy and paste in this field, or use snippets.  A snippet is a section of 

text, usually a paragraph.  Create snippets for commonly sold Packages that you have created in SI 

5.  (see page 93 for information on “Packages”) 
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To create a snippet, click the  button.  A window will open: 

 

Enter a name and then the text.  You can copy and paste in this field.  

To add a saved snippet to the Scope of Work statement, use the  button.  This will open the 

Insert Snippet form: 

 

To add a snippet to the Scope of Work statement, select the snippet from the column on the left 

and click [OK]. 
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To create a new snippet from this form use the  button.  To delete a snippet from your saved 

list, select the snippet in the column and click the  button. 

Step 6:  Location Types 

 

You can use up to five levels to identify your Location Types hierarchy.  In the screen shot above, 

only three levels have been added to the Location Types hierarchy: Building, Floor, and Room. 

Use the Use the , ,  to add, edit, and delete Location Types and use the  to move 

Location Types up and down in the list.  These buttons are handy because this is a hierarchy and 

should flow from the top down.  In the screen shot above, the Location Types hierarchy of Building-

>Floor->Room is proper but a hierarchy of Building->Room->Floor would not be proper. 

If you have saved Location Configurations, you can use the  button to import them.  See Step 7 

below for more information. 

See “Location and Zone Configuration” on page 241 for more information on managing Location 

and Zone Information. 
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Step 7: Locations 

 

This step is where you add the locations for a Project.  A location can and should be assigned to 

every Product that you add to a Project to identify where the Product is being installed. 

The first Location that you can add must be related to your top level Location Type.  For example, 

if you have a Location Type hierarchy of Building->Floor->Room, you must first add a Building 

Location before you can add any Floor Locations. 
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To add a Location, click the  button.  If you just click the button, a field will 

become available: 

 

Any name that you type in this field will apply to the Project but will not be saved in the default 

Locations list.  (see page 47 for info on “Location Types and Locations:”) 

To add a Location name to the default list or to choose from existing saved Locations, click the 

arrow next to this button: 

 

Only four Locations will list.  To get the complete list of your default Locations select “More Location 

Type Locations…”.  This will open a box where you can check multiple Locations at once: 
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Once you add at least one Location name for a Location Type, you will see the next available 

Location Type in your hierarchy listed in this dropdown as well: 

 

Use the  and  to edit or delete Locations that you have added to the Project.  Use the  

buttons to move the Location names up or down in the list.  The  buttons are used to 
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Export/Import Location Configuration.  A Location Configuration is essentially a template that can 

be imported to any project.  When you click the  button, you are prompted to enter a name: 

 

When you click the  button, you can select from your previously saved Location Configurations: 

 

There are three fields for every Location: Comp ID, Name, and Description. 

Item Description 

Comp ID This is a required filed and is usually an abbreviation of the name.  This field 

will have the default value of the first five characters of the Location name but 

you can override this default if you wish.  You may wish to use the Comp ID 

field in your Component ID format. 

Name Enter the name of the Location.  This is a required field. 

Description This is an optional field.  Describe the Location. 
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Step 8:  Zones 

 

This where you can add the Zones for a Project.  (see page 48 for info on “Zones:”) 

Use the  and  buttons to add or delete Zones for the Project.  Use the  buttons to move 

the Zone names up or down in the list.  When you click the  button, you have the option of 

adding a new Zone name or you can use the dropdown in the Name field to select a Zone name 

from your default list: 
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For Zones, the Name field is required, the Description field is optional. 

The  buttons are used to Export/Import Zone Configuration.  A Zone Configuration essentially 

a template that can be used imported to any project.  When you click the  button, you are 

prompted to enter a name: 

 

When you click the  button, you can select from your previously saved Zone Configurations. 

Step 9:  Contract Percentages 

 

The list for contract percentages will display your default settings.  Use the  and  buttons to 

add or rows.  To edit any field, left-click in the field.  Use the  to repopulate this grid with your 

default contract percentage values. 



Projects  

Revised February 19, 2009 

240 

Step 10:  Custom Properties 

 

This step is where you can add any information to the Project Custom Properties that you have 

defined.  (see page 46 for more information on “Project Custom Property Name Settings:”) 
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In order to finish creating the Project, you must click [Save].  You will be prompted to choose a 

location to save the Project: 

 

Once the Project is saved, it will display in the Projects Grid. 

Location and Zone Configuration 
A consistent pain point within SI regarding the creation of projects has been the need to re-create 

location structures and zone lists for every project.  Historically, this has been handled by users 

creating a “base” project and then using the “Import System” functionality in order to pre-load the 

locations and zones desired for a project.  While this works, it leads to the user having a number of 

projects in SI that exist solely for the purpose of acting as templates for project location structures.  

Within SI5 we have implemented the ability to save and consume Location and Zone 

configurations.  

An SI user can save the location structure or zones for any given project as a configuration.  The 

user is not limited to the number of configurations they can save or how they are named.  It should 

be noted that the configurations must be named, but the name does not have to be unique. 

Users will only be allowed to import configurations only into new projects or projects that currently 

have no items in the bill of materials.   Importing configurations into existing projects would have a 
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massive impact on the items that exist in a project, therefore, it has been deemed out of scope for 

this functionality.  

Users can save configurations from new projects or existing projects. 

Creating Location and Zone Configurations 

As stated above, a user can save configurations from an existing project or a new project.  

Saving a Configuration From and Existing Project 

The following steps demonstrate saving a configuration from an existing project: 

1) Open SI5 Navigator, Selects “Projects”. 

2) Select “View Project Information”. 

3) Navigate to the “Locations” or “Zones” tab. 

 
 

4) Click the “Export Location/Zone Configuration” toolbar button.  

5) Enter a “Name” for the configuration and click “OK” 
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6) Repeat for Zones on the Zones tab. 

Saving a Configuration From a New Project 

The steps for saving a configuration are effectively the same. With the following exceptions: 

1) The user will launch the “New Project Wizard” 

2) Add zones/locations to the project. 

3) Pick up at step 4 above.  Please note that a user will not be able to save a zone/location 

configuration unless one or more zones/locations exist in the project. 

Using a Configuration in a Project 

As stated above, a once a configuration has been saved, the user will be able to use this 

configuration when creating new projects or on an existing project that has no items in the bill of 

materials. 

The steps for consuming a configuration in a project are as follows: 

1) Open SI5 Navigator, Selects “Projects”. 

2) Select “Create a new project”/”View Project Information”. 

3) Step through the project wizard (or navigate to the proper tab). 

a) On the Locations (or Location Types) Step: 

i) Click the “Import Location Configuration” toolbar button.  

ii) Select the configuration to use in the project.  Please note that you can preview 

configurations.  Also, locations and location types must be consumed together as the 

locations are tied to the defined types. 
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iii) Click “Import” to add the locations to your project. 

b) On the Zones Step 

i) Click the “Import Zone Configuration” toolbar button.  

ii) Select the configuration to use in the project.  Please note that you can preview 

configurations. 

 

iii) Click “Import” to add the zones to your project. 

Additional Functionality of the “Import” Screens 

When looking at existing configurations, users have the opportunity to do the following tasks: 
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1) Rename a configuration.  

2) Deleting a configuration.  

3) Adding configurations from an external file.  

Adding Configurations From External Files 

Location and Zone configurations are stored in XML documents.  The configurations exposed 

through the UI are stored in the following files: 

• Location Configurations:  

C:\Documents and Settings\All Users\Application Data\D-

Tools\SI5\LocationConfigurations.xml 

• Zone Configurations: 

C:\Documents and Settings\All Users\Application Data\D-Tools\SI5\ZoneConfigurations.xml 

These files may be sent to other users (manual process).  The users can then choose to replace 

their existing file or add the configurations contained in the file received.   

The steps to add the configurations to your existing configurations are as follows: 

1) Copy the new file to disk (anywhere except the locations listed above). 

2) Click the “Add Configurations from File” toolbar button.  

3) Browse to the received file.   

Please note:  The only file that can be selected for locations has the name 

“LocationConfigurations.xml” and zones; “ZoneConfigurations.xml”. 
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4) Click the “open” button once the file has been selected. 

Please note:  If the file is invalid (format or otherwise), the user will receive the following 

message: 

 

General Functional Notes 

• Once saved, configurations are not directly modifiable in version 5.  That said, if a user 

wants to modify a configuration, they may import it into a new project (as outlined above), 

make the necessary changes, save it as a new configuration (outlined above), and delete (if 

they choose) the old version of the configuration. 

• As stated above, configurations cannot be imported into existing projects unless there are 

no items in the projects bill of materials. 

• Configurations are per machine installation, not per user on a machine. 
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Change and Revision Management 
SI5 supports a linear sequential design and engineering process.  Only one person at a time may 

modify a project.  It is possible to engineer two or more projects and combine them into one.  

However, once combined, only one person at a time may modify the project.  Change occurs 

continuously throughout the complete process from conception to completed red lined drawings.  

Proper change management can mean the difference between chaos and a well controlled project.  

More importantly, managing and documenting change is necessary to keep the client informed and 

to improve your chances of getting paid in a timely fashion. 

SI5 introduces some major enhancements to the revision control and change management 

process.  In SI5 you can now: 

5) Create revisions for any reason, not just for Change Orders, such as managing multiple 

proposal revisions. 

6) Allow one revision to track the As-Sold items and another revision to track the As-Built.  More 

on this later) 

7) Make any previous revision the current revision. 

8) View and explore the differences between any two revisions (Difference View).  The view will 

allow you to see what changed such as: 

a) Added / Removed Products 

b) Modified Product cost or selling price 

c) Changed Phase information 

d) Labor Rates or Factors 

e) Diff Factor 

f) Misc Parts 

g) Equipment +- 

h) Changed Global factors 

i) Tax 

j) Equipment +- 

k) Misc Parts 
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l) Misc Costs 

9) From the Difference View you can select any subset of what has changed and 

a) Run Difference Report 

b) Create Change Order 

c) Run Change Order report 

d) Create Sales Order 

e) Create Work Order 

f) Reverse out any change 

Proposals 

As you know clients can be very fickle.  You may create several proposals before the client settles 

on a particular set of functionality.  You will be able to pick any previous revision from which to 

create a new Current Revision and apply the new set of requirements.  Pick the previous revision 

that makes it easiest to complete the proposal.  For instance, deleting is always easier than adding.  

Also at any time the client may wish to know what changed from one proposal to the next.  With 

SI5 you will be able to manage this process and provide the answers to the client’s questions.  The 

following chart is a high level view of the proposal process in SI5. 
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The Proposal Process 

1) Gather requirements 

2) Create a New Project  (This will be Rev(0)) 

3) Client Information 

4) Statement of Work (Restatement of requirements) 

5) Products 

6) Review labor hour forecast with the Project Manager 

7) Review projected profit analysis with Senior Management 

8) Present proposal to the client 

9) If the client approves the design then move to the Engineering Process.  If not, create a 

Current Revision from a previous revision that makes the best starting point for applying the 

new requirements.  Go to Step 3.  If the client wants to see what changed between any of the 

revisions, use the Difference View to run a “Client Difference Report”  

Current Project

Compare Revisions

ProjectName 
Rev(1)

ProjectName 
Rev(0)

ProjectName 
Rev(2)

ProjectName 
Rev(3)

Item1 Added

Item2 Added

Item3 Added

Item4 Modified

Item 5 Removed

Choose the Items 
you wish process

Revision Difference
(What Changed)

Compare ANY Two 
Revisions and show 
the Difference

Compare ANY Two 
Revisions and show 
the Difference

Processes:

Difference Report

Change Order Report

Customized Report

Sales Order

Work Order

Reverse Transaction

Apply changes to a Previous Revision

Accounting Reconciliation Report

 

10) Once the client chooses the revision to implement, set the Project Status on that revision to “As 

Sold”.  You will need to identify the “As Sold” revision later in the process if you ever need to 

implement a Change Order.  
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11) Create a new revision from the “As Sold”.  This will become your Current “As Built”Project.  All 

future revisions will be considered the As Built project.  Changes in the As Built do not affect 

the price of the project and are not included in the As Sold revision.  Change Orders will affect 

both the As Sold and As Built revisions.  This will be covered later.  

 

Engineering Process 

There are two types of change that may occur during the delivery of a project 

1) Client Change:  Change in scope that is reflected on a Change Order report and is paid for by 

the client, 

2) Internal Change (Engineering Change):  Change that is generated as a result of engineering 

and order management processes.  These types of changes include 

3) Change in wire detail as engineering drawings are refined. 

4) Substitution of functionally equivalent parts (proposed product on back order) 

5) Redesign yielding the same functionality in a more cost effective solution (value engineering). 
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The following chart is a high level view of the engineering process.  
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Always create a revision before starting the engineering process.  This will allow you to rerun client 

reports from the As Sold revision after changes have been made to the Current or As Built revision. 
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Change Order Process 

The only other time a revision is required is when managing Changes Orders.  Create a new 

revision before initiating the Change Order process.  The revision will become the new As Built 

revision.  It is possible to work on more than one CO at a time, but it may not be practical in the 

current SI5.0 release. If you continue to make Internal or Engineering changes during the CO 

process that will not be reflected in the client billing, these changes will need to be excluded when 

running the Change Order client report.  You only want to include CO related items in the CO.  SI5 

gives you the ability to pick the Products to include on the Change Order.  The following chart 

provides a high level view of the Change Order process.  If the client rejects the change order, you 

have two choices: 

1) Select and reverse out the changes 

2) Promote a previous revision to the Current Revision (Promote Revision).  If you choose this 

method you will also throw away any Internal Changes that may have occurred during the CO 

process. 

If the Change Order is accepted, you will promote (copy) all CO related changes to the “As Sold” 

revision.  This will allow you and the client to always know exactly what is in the As Sold proposal.  

Internal or engineering changes will not be promoted to the As Sold revision.  You may rerun the 

complete client proposal at any time which will accurately reflect the products and services that the 

client has agreed to purchase.  
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About Project Revisions 

There are many times when creating a revision is appropriate.  These could include: 

Prior to modifying a proposal that has already been presented to the client 

• After the client has signed off on the proposal 

• Prior to quoting a change order 

When a project is first created it is considered Rev 0.  The Revision with the highest revision 

number is considered the “Current Revision”.   

 

The new Revision number is always one higher than the highest revision number prior to the 

creation of the new revision.  The drawing files associated with the project are copied, zipped and 

stored in the Project Folder as shown below.  ONLY drawing files are zipped.  For example the user 

provided Revision History.doc document is not included in the zip folder.  See examples later in the 

chapter. 

  

Create a Project Revision 

1) Select the desired project (Project row will turn blue) 

2) Choose one of the following options: 

3) Right-Click on the project and select “Create Revision” 
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4) Select “Create a new revision of this project” from the Project functions list: 

 

Enter an appropriate file name and click [OK].  Changing the file name is not recommended. 

Changing the Rev number in the file name is definitely not recommended. 

 

5) The Current Revision number is now “1”. 

 

Viewing your Revisions 

To view and work with your revisions: 

1) Select the project in the Project Grid. 

2) Click the Selected Project Details tab: 
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3) Click the Revisions tab at the bottom of the form: 
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Tracking Revisions 

SI 5 does not include a built in method for tracking information about each revision.  We suggest 

that you create a Word document similar to the one show below and attach it to each new project.  

The following is just an example.  Feel free to include any information that will help you better 

track and manage project revisions. 

 

Promote Revision 

Use Promote Revision to make a previous Revision the Current Revision.  This may be useful if 

after presenting five or six proposals the client selects proposal number two as the one they would 

like to purchase. 

1) Select the Revision you wish to promote: 
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2) Click the [Promote Revision] button.  You will be prompted to verify this action: 

 

When you click [Yes], the Create Revision form will open.  Changing the file name is not 

recommended. Changing the Rev number in the file name is definitely not recommended.  Click 

[OK]:  

 

3) You will notice that Rev 1 now displays in your list of revisions and if you go back to the 

Product Grid tab you will see that the project’s revision number has been incremented: 
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Rename Revision File 

Once a Revision has been created you may change the file name if you desire. Changing the file 

name is not recommended. Changing the Rev number in the file name is definitely not 

recommended. If you must, select the revision and right-click and select “Rename Revision File” 
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Text Interface 
When you open the .dtl file for a Project, you will be working in the SI 5 Text interface: 

 

This interface resembles a cross between the Product Explorer and Product Grid screens within 

the Manage My Product Data (MMPD) interface.  There are three major sections of this 

interface.  The left hand side of the screen is called the Product Explorer and the right hand side 

of the screen is called the Project Data Matrix (PDM).  There are also Menu Options on the 

menu bar along the top of the screen. 
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Product Explorer 

 

The Product Explorer displays all of the Products and Packages from your Master Table 

database.  Use the [+] symbols to expand your selections. 

You can customize the view of the Products listed in the Product Explorer section by modifying 

the hierarchy and/or by filtering the Products in your database.  The  button allows you to 

choose a display structure for your data up to four levels deep: 
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The  button allows you to pick and choose the Products that display based on Manufacturer, 

Category, Type, and Phase: 

 

Click  to edit a selected Product or Package.  The Master Table Product Properties form will 

open: 
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If you add any Products or Packages in the Manage My Product Data (MMPD) interface while 

you have a Text project open, click  to refresh the Products and Packages listed in Product 

Explorer section.  

Project Data Matrix (PDM)  

  

This section is where all of the Products that have been added to a Project are displayed. There are 

various buttons along the top of this section: 

 

....Add Product/Package – if you click the button, the Add Product form opens.  Use the 

dropdown arrow to add a Package. 

.......Edit Selected Product/Package – once you have selected a Product or Package in the 

PDM, clicking this button will open the Product Properties or Package Properties 

form.  Double-clicking the Product or Package in the PDM results in the same action. 

.......Delete All Selected Products/Packages – you can select multiple Products or Packages 

in the PDM by using the [Shift] or [Ctrl] keys on your keyboard. 

.......Save – Saves your progress in the Project.  Use frequently. 

.......Filter – allows you to filter your PDM by Manufacturer, Category, Type, Phase, Location, 

or Zone.  You also have the ability to Search for Product based on the Model, SKU, and 

Product Description fields. 
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.......Refresh – Changes made to Products and Groups may not immediately show in the PDM 

view.  Use this button to refresh the PDM view.   

.......Add and Remove Columns/Groups – allows you to customize the view of the PDM, 

very similar to how you customize the view on the Product Grid screen in the Manage 

My Product Data (MMPD) interface.  You can choose what columns display in the PDM 

as well as choose how you want the Products and Packages to be grouped. 

.......Sort – allows you to sort the Products and Packages in your PDM by various fields up to 

three levels deep. 

…….Line Item Summary – allows you to modify the display of the PDM as well launch 

different views of the data in separate windows.  Details below. 

Project Summary – displays a summary of the project in a separate window 

 

Line Item Summary – displays an aggregated view of the PDM based on Category 

Manufacturer, and Model 

 

 Flat Grid – displays the products in the PDM without grouping on Packages or Accessories 
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 Package/Accessory Grid - displays the products in the PDM without grouping by Packages or

 Accessories 

Show/Hide All Accessories – will expand or collapse accessories in the PDM.  Products that 

have accessories have a “+” next to them in the PDM when you choose to group on 

Packages and Accessories 

 Expand/Collapse All Rows – expands or collapses all rows in the PDM 

....Assign – This button allows you to assign Locations, Zones, and Head Ends to Products in 

the PDM.  The default is to assign Locations and Zones, use the drop-down menu to make 

other selections.  

.......Print – prints the PDM 

.......Export to Excel – export the contents of the PDM to an Excel spreadsheet.  This file can 

be used for making additional calculations on the Products.  This spreadsheet is not 

importable back into the software through the MMPD interface. 

.......Update Price – This allows you update the price of multiple Products in the PDM based 

on Discount, Margin, and Markup. 

.......Update Case – Use this to update the case settings within a project if you have made 

changes to your default case settings in the MMPD interface.  A window will open showing 

what will be changed.  You can uncheck any products you do not wish to change: 

 

.......Open in I/O Studio – opens the I/O Studio for the product that is selected in the PDM.  

See the MMPD section of this guide for specs on the I/O Studio. 
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Another way to customize the view of the PDM other than clicking  is to right-

click any Column heading in the PDM.  The right-click menu that displays gives you 

multiple options for customizing the view of the PDM: 

 

 

Command Description 

AutoFit Column Resizes the selected column to the width of the longest 

string 

AutoFit Rows Resizes all rows to the same height 

Sort Ascending Sorts the selected column by value: lowest to highest 

(alternative = left mouse click once in a column heading) 

Sort Descending Sorts the selected column by value: highest to lowest 

(alternative = left mouse click once in a column heading) 

Expand All This expands all [+] symbols displayed in the PDM 

(groupings) 

Collapse All This collapse all [+] symbols displayed in the PDM 

(groupings) 
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Menu Options 

 

These menu options are fairly consistent across all three of the Project interfaces: Text, Visio, and 

AutoCAD.  The Visio and AutoCAD interfaces have some unique options that will be detailed in their 

corresponding sections of this guide. 

File->New 

This will create a new SI 5 Project .dtl file.  When you choose to save the new Project, you will be 

prompted to add a Client Name and Project Name if you have not already done so.  The default 

path for the Project file will be Client Name\Project Name within your default local Projects 

folder.  You can, of course, change this path if you wish. 

File->Open 

This allows you to browse to another SI 5 .dtl file and open it.  If you currently have a Project open 

in this instance of the SI 5 Text interface, you will be prompted to close that Project as only one 

Project can be open at a time per instance of the SI 5 Text interface.  If you wish to have more 

than one instance of SI 5 Text open at the same time, do not open Projects this way.  Instead open 

additional .dtl files through the Navigator interface.  

File->Save 

Saves the Project. 

File->Exit 

Closes the SI 5 Text interface. 
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D-Tools->Project Information 

All of the information entered in steps 1-10 of the New SI 5 Project wizard is displayed here across 

the various tabs.  You may add or edit information as needed.  In addition to the information 

entered in steps 1-5 of the New Project Wizard, some of your global default settings are displayed 

on this form, e.g. Component ID.  These can be edited here and will ONLY apply to this Project, 

i.e. your global default settings will not be changed.  

Project 
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Many of the following fields are used in one or more standard SI 5 reports.  However, ALL of the 

following fields are available for use in custom or user modified standard reports.  See “Report 

Designer” on page 500 for more details on report customization. 

Project Number – Optional.  Alpha-numeric, 255 character limit. 

Project Name – Required.  This will also be the Project file name 

Status – Optional.  Use this field to mark “milestones” in a Project’s lifecycle.  The dropdown menu 

here can be modified under Navigator Setup tab. 

Start Date – Optional.  Use the dropdown calendar to select the start date for a Project 

End Date – Optional.  Use the dropdown calendar to select the start date for a Project 

Client Name – Required.  This field is used as the primary folder for storing project files.   

Contact section – Optional. The Contact is the name that will print on the standard Client reports.  

The [Import] button will open a window that allows you to pick from your Outlook Contacts list. 

If you have a large number of Outlook Contacts the search time associated with the 

Import may be extensive.  Create a New Contacts folder in Outlook to use as your 

Project Contact Folder.  Before creating a new project in SI 5, copy the contact from 

your Outlook Contacts to the Project Contact folder in Outlook.  Use the [Folder] 

button on the Import Contact form to select the Project Contact Folder. 

Site/Billing Address section – Optional.  These fields are used on reports. 

Contacts 
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Owner – Optional.  Typically is used to identify the key internal contact for the project.  However 

this field may be used in any way you like. 

The following field names are editable and may appear differently in your User 

Interface (UI). 

Sales Rep – Optional.  This dropdown list may be edited via the Navigator>Setup>Application 

Settings tab. 

Designer – Optional.   This dropdown list may be edited via the Navigator>Setup>Application 

Settings tab. 
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Project Manager – Optional. This dropdown list may be edited via the 

Navigator>Setup>Application Settings tab. 

Other – Optional. This dropdown list may be edited via the Navigator>Setup>Application Settings 

tab. 

External Project Contacts section – Optional. Use the [New], [Edit], and [Delete] buttons to 

manage external project contacts.  These contacts could be architects, general contractors, etc.  

Clicking [New] opens a form where you can import contacts from your Outlook Contacts list. 

 

Scope of Work 
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This lists the text for a Scope of Work report.  These fields ONLY accept plain text.  No text 

formatting is available including tabs.  You may type directly in this field; copy and paste directly in 

this field, or you can use the [Insert Snippet…] button.  The Add Snippet form will open 

allowing you to add any previously saved Snippets.  You may select text in this field and use the 

[Save Selected Text as New Snippet] button if you type something particularly clever that you 

want to use on future Projects. 

Use your favorite word processor to create and spell check the Scope of Work, then 

copy and paste to the above form or Snippet. 
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Location Types 

  

Here you can change the hierarchy for the Location Types for a Project.  You can have up to five 

levels or as few as one.  When deleting, start from the bottom and work your way up.   

Locations 
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Here you can assign the specific Locations for Project.  The [New…] buttons will change 

depending on what you have selected in the Locations field.  Use the [Move Up] and [Move 

Down] buttons to position Location names up or down for each Location Type.  The client “By 

Location” reports will present the locations in the order they are listed above. 

The Details section at the bottom allows you to add a description and ID for each Location. For 

more information on “Location Types and Locations:” see page 47. 

These location descriptions may be shown on client reports.  Keep in mind that each 

Location at every level (Building, Floor, and Room for example) may have a 

description.  On the reports these descriptions are concatenated together in the 
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order presented in the hierarchy.  So the description that shows up on a report for a 

particular room will be Building Description + Floor Description + Room Description.  

See pg 471 for more details. 

Zones 

 

 

This is where you manage your Zones within a Project.  The [Move Up] and [Move Down] 

buttons allow you to position the Zones in a preferred order for reporting.  See “Zones:” on page 

48 for details. 
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Component ID 

  

See “Component ID Format:” on page 55 for details on the Component ID.  The added 

functionality here within a project is the [Recalculate] button.  This will recalculate the 

Component IDs for all products already in the project.  You would use this option if you changed 

your Component ID Format part way through the creation of a project and want the change to 

reflect on the existing products in the project. 

Custom Properties 



Text Interface  

Revised February 19, 2009 

280 

  

These are ten text fields for adding additional information to a Project.  The labels for these fields 

are defined under the setup tab in navigator, see “Project Custom Property Name Settings:” 

page 46.  

D-Tools->Options 

This opens the D-Tools SI Project Options form and allows you to modify your Phases, Payment 

Schedule, Misc Costs, Estimated Taxes, and General settings.  

Phases 
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Phases are discussed in detail in the Navigator->Setup section of this guide, see Application 

Project Settings on pg. 47.  Project specific functions are discussed below.  

The “Project defaults” section lists your default or “global” preferences for Misc Parts, Equipment 

+/-, and Pricing Default.  The “Equipment” section allows you to override the Project defaults for 

any Phase.  For info on Misc Parts and Equip +/- see “Price:” on page 44. 

Pricing Default: Sets your default selling price.  The default names for these levels are “A”, “B” 

and “C”.  These names may be changed to suit your business requirements.  See “Price:” on page 

44 for how to change the name of a pricing level. 

When you select a Phase from the dropdown list, you will see the default values that you have set 

for that Phase, Application Project Settings on pg. 47 for more information.  The “Labor” 

section has an editable grid.  The white cells are editable while the gray ones are not.  Clicking 

[Save Phase] will save your changes and your Default settings will not be affected.  If you want 

to replace your Default settings with the changes made on this form, click [Save Default].   
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[Restore Default] does the opposite, i.e. it replaces the values in the Project with your Default 

settings. If you have added or renamed Phases in your Default setting after a Project has been 

created, use the [Add Phase] button to add or rename the Phases for the Project.   

Example: You are working on a proposal for a client.  During this time, you make 

changes to your Default labor settings for various Phases. You add a Phase to your 

default settings and rename the Phase “Rough-In” to “Pre-Wire”. 

The changes that you made to your Default settings will not affect your existing 

projects.  In order to change these settings for an existing Project you would open 

the Project and manually make all changes or you may click the [Restore Defaults] 

button. 

In this example, you want to add the Phase “Warranty Service” to an existing Project 

and rename the “Rough-In” phase to match your global settings. 

1) Open the Project and then select D-Tools->Options 

2) Select the Phase tab (should be selected by default) 

3) Click the [Add Phase] button.  The Project Phases form will open:  
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4) Select “Warranty Service” in the “Add Phase(s) to project” section and then click 

[Add].  The “Service” Phase will be added to the “Phase(s) in project” section. 

5) Although “Pre-Wire” is showing in the “Add Phase(s) to project” section, you 

would only add it to the Project if you want to keep your existing Products listed 

as “Rough-In” and any newly added Products as “Pre-Wire”.  More than likely, 

you simply want to rename the existing “Rough-In” Phase to “Pre-Wire”.  To do 

this, highlight the Phase in the “Phase(s) in project” section and click [Rename]. 

6) Click [Close] when done. 

Payment Schedule 

 



Text Interface  

Revised February 19, 2009 

284 

Here you can modify the Payment Schedule for a Project by using the [New] and [Delete] 

buttons.  If you want to replace your Default settings with the changes made on this form, click 

[Save Default].  Clicking in a Billing Date cell will display a drop-down calendar.  These values will 

show up on the Client Contract Report.  

 

Misc Costs 

  

This tab allows you to recover additional Project costs that are not accounted for in the PDM.  

Phase is completely optional on this form and has no bearing on the stock reports in SI 5.  These 

costs are NOT taxed.  Typical items may include reimbursed travel expenses or lift rentals.  These 

items will show up just before the project summary on client proposal reports. 

Estimated Taxes 
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Here you can modify your Tax Code, Sales Tax, and Labor Sales Tax for the Project.  For detailed 

information on taxes, see page 471. 

General 
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Here you can change Wiring options for a Project.  The “International” section settings are 

determined by your Window’s Regional and Language Options.  The “Wiring” section allows you to 

set the default wire length for the project.  You can also choose to turn off the “Head End” prompt 

for the project if you wish.  You can also choose to reset or save to the Default settings. 

D-Tools->Reports 

This will launch the Reporting interface for SI 5.  

 

See page 471 for more detail. 

If you upgraded from a previous version of SI, you will be able to access your legacy 

reports by selecting File->Legacy Reporting System:  
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This will open a familiar looking form: 
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D-Tools->Find and Replace 

This allows you to find any Products in your PDM and replace them with other Products from your 

Master Table database. 

 



 SI5 User and Administration Guide 289

Use the tabs to filter to the Products(s) that you wish to replace.  Check the boxes next to the 

Product(s) and then click [Replace].  A similar form will open: 

 

Use the tabs to find the “replacement” Product(s) and then click [OK]. 
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D-Tools->Insert System 

This form allows you to choose another Project that you have already created and insert it into the 

current Project.  Generally you would not insert an entire Project’s data into another Project unless 

you are doing production or “cookie cutter” projects.  However, you can create individual Projects 

for specific systems that you sell frequently, e.g. a multi-zone distributed audio system.  Instead of 

adding all of the Products or Packages individually to the “new” project, you can simply insert the 

system. 

 

To use, browse to the Project you want to import into the current Project, select your options, and 

click [Import].   

Save your Project before using Insert System.  If you are not happy with the options 

you chose for your Insert, simply close the Project without saving, re-open the 

Project, then use Insert System with a different set of options checked. 

Pay attention to the sections on the form: Import (Append in Project) and Import 

(Replace in Project).  Be careful with the replacement option if you are importing into 

an established Project.  For example, your Phase Rates may have changed since you 

created the Project you are inserting as a system and you wouldn’t want the old 

rates to apply to the new Project. 
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This function is also available within the Visio and AutoCAD interfaces.  The 

difference is that you can also import drawing pages into the new Project.  This is a 

very big time saver!  More detail is in the Visio and AutoCAD sections of this manual. 

D-Tools->Update Case 

Use this to update the case settings within a project if you have made changes to your default case 

settings in the MMPD interface.  A window will open showing what will be changed.  You can 

uncheck any products you do not wish to change: 

 

D-Tools->OrderTools 

OrderTools is a built in purchase order tool in SI 5.  You first setup your list of Representatives.  

Representatives are the vendor’s from which you purchase products.  They may or be rep firms, 

distributors or manufacturers.  Once your Representatives are setup, you can then produce a 

purchase order from any Project. 

OrderTools does NOT link to your accounting software.  This tool is for user’s who do 

not use accounting software to issue purchase orders. 
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D-Tools->OrderTools->Representative Management 

This form is where you will add/edit your Representatives.  A Representative is essentially a vendor 

from which you buy Products. 

 

You can use the [New] button to add a Representative manually or use the [Import] button to 

pull from your Contact List in Outlook 2003.  Click [Edit Types] to add additional Types if desired 

(this is not a required field). Use the [>] to add Manufacturer’s from the “My Manufacturer(s)” 

section to the “Representative’s Manufacturer(s)” section and use the [>] to reverse the process.  

The purpose of this is that you are creating a filter for when you create a purchase order.  A single 

Representative may sell products for many Manufacturers.  The Products in the Project are 

referenced by Manufacturer.  This interface maps the Manufacturer to a particular Representative.  

If you buy direct, the Manufacturer and the Representative would be the same company. 
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D-Tools->OrderTools->Purchase Orders 

This form displays the history of purchase orders for the Project. 

 

If you have purchase orders in the list, use the [Edit PO], [Delete PO], [Preview], [Print], or 

[Email] buttons as needed.  

The email function only works with Outlook 2003.  A .pdf formatted purchase order 

will automatically be attached to the email 
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To create a new purchase order, click [New PO].  You must accept the terms of the OrderTools 

File Transfer agreement in order to create a purchase order. 
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The D-Tools OrderTools PO form opens: 

 

Once you select a Representative, the available Products to add to the PO are filtered to only the 

Manufacturers you have assigned to the Representative through Representative Management.  

Use the [Add], [Edit], and [Delete] buttons to create the Purchase Order.  You can [Preview] 

and [Print] from this form as well.  Once a Product is added to a purchase order, the Product is 

“flagged” within the Project to prevent you from ordering the same Product multiple times 
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View->Various Functions 

This menu has all of the functions of the Line Item Summary button ( ) : 

 

Project Summary – displays a summary of the project in a separate window 

 

Line Item Summary – displays an aggregated view of the PDM based on Category Manufacturer, 

and Model 

 

Flat Grid – displays the products in the PDM without grouping on Packages or Accessories 
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Package/Accessory Grid - displays the products in the PDM without grouping by Packages or 

Accessories 

Show/Hide All Accessories – will expand or collapse accessories in the PDM.  Products that have 

accessories have a “+” next to them in the PDM when you choose to group on Packages and 

Accessories 

Expand/Collapse All Rows – expands or collapses all rows in the PDM 

Help->Contents\Index\Search 

 

Here you can access the Installation and Administration guide, the User Guide, and the Tutorial. 
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Help->About 

This opens a form showing information about SI 5.  You should have this screen and the data 

provided when you click [System Info…] open when calling technical support. 

 

Adding Products and Packages to a Project 
There are multiple ways to add Products and Packages to the PDM within a Project. 

The first method is to left-click with your mouse and then drag and drop Products or Packages from 

the Product Explorer section to the PDM. 

 

When you release the left mouse button, the Product or Package is added to the PDM.   
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Assigning Locations and Zones 

Now is a good time to discuss all of the ways that you can assign a Location and/or Zone to a 

Product.  Once a Product has been added to the PDM you have three ways that you can assign 

Locations/Zones:  

1) Double-click the Product in the PDM and assign the Location and Zone on the Product Properties 

form. 

  

2) Select the Product then right-click->Assign->Location and Zone/Location/Zone: 

  

Depending on your choice, a form will open allowing you to select a Location and/or Zone. 
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3) Use the dropdowns to assign Location and Zones directly in the PDM.  To do this, make sure 

that the proper columns are displaying.  Click in the cell and use the dropdown arrow to make 

your selection. 

 

You can save yourself a few steps assigning Locations and Zones by choosing to 

group the Products in the PDM by Location and Zone.  You can then drag and drop 

other Products directly into that Location and Zone group heading in the PDM.  You 

must have at least one Product for each Location/Zone already in the PDM before 

this will work. 

Assigning Locations and Zones by Drag Drop 

The following example groups by both “Location” and “Zone”, however you may choose to group by 

only one Product property. 

1) Click .  The Columns and Grouping form will open.  

2) Click the Groups tab and then check “Location” and “Zone” in the list then click [OK]: 
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The Products in the PDM are now grouped by Location and System. 
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3) Left click a Product or Package in the Product Explorer section and drag and drop the Product 

or Package to the Location and System grouping in the PDM. 

 

4) The Product will automatically be assigned to that Location and Zone. 

A second way to add Products or Packages to a Project is to use the  button. 

Clicking the page icon will open the Add Product form.  If you want to add a 

Package, use the dropdown arrow section of the button and select “Add Package” 

from the menu: 
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The Add Product form allows you to filter using the tabs to locate the Product(s) to add to the 

Project.  You can select multiple Products to be added at one time to your Project. You can also 

assign the Location and Zone as well. 
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If you chose to add a Package with the dropdown arrow, the Add Package form will open.  This 

form allows you to choose a Package to add to the Project as well as a place for you to select your 

Location and/or Zone for the Package. 

 

The “Products in package can be in different Location/Zones” option disables the Location 

and Zone selections on this form.  You would then assign the Locations and Zones in the PDM as 

described in the “Assigning Locations and Zones” section of this chapter. 
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A third way to add a Product or Package to a Project is to right-click any Product in the PDM and 

select Add->Product (or Package): 

 

Either the Add Product or Add Package form will open. 
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Additional Right-Click Options 
Right-Click Options can apply to individual products, multiple selected products and Product 

Groups.  The screenshot below shows the other available options when you right-click a Product or 

Group Heading that is selected in the PDM. 

 

Some of these options will apply across multiple Products, some only for the primary 

selected Product or Group.  Selected Products are indicated by a gray row color, and 
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the primary selected Product is indicated with an arrow in the PDM. 

 

To select multiple items in the PDM, use your [Ctrl] or [Shift] keys. 

 

Right-Click->Edit 

This works for the primary selected Product or Package in the PDM.  This will open a Product or 

Package Properties form: 

 

The Edit right-click option is the same as double-clicking a Product or Package in the 

PDM.  You can also select the Product or Package and then click the  button at 

the top of the PDM. Hitting Esc will close this window. 
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Right-Click->View Extended Data* 

*(Data Subscription is required) 

This works for the primary selected Product in the PDM. This will launch a web browser directed to 

a D-Tools server where Product manuals, brochures, and images can be downloaded, saving you 

the trouble of having to search manufacturer’s websites for this information. Extended data is part 

of our Data Subscription program. A product that has extended data displays a  in the Extended 

Data column within the PDM.  You MUST maintain the D-Tools provided Manufacturer, Model and 

Category settings/spelling to access the Extended data. 

 

Another way to access Extended Data if available for a given product is through the 

Product Properties form.  At the bottom of the form, there is an [Extended Data] 

button: 

 



 SI5 User and Administration Guide 309

Right-click->Duplicate 

This works for Packages and multiple Product selections in the PDM.  You will first be prompted 

with a message similar to this: 

 

Clicking [Yes] will then open this prompt: 

 

Enter the quantity you wish to add and then click [OK].   
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Right-click->Replace Product 

This works for the primary selected Product in the PDM. This allows you to change the selected 

Product to any other Product in your database. 

 

Right-click->Delete 

This works for Packages and multiple Product selections in the PDM.  This will remove the selected 

Products or Packages from the Project. 

You can also delete Products or Packages by selecting them and clicking the 

[Delete] key on your keyboard or by clicking the  button at the top of the PDM. 

Right-click->Assign->Location and Zone/Location/Zone/Head End 

This works for Packages and multiple Product selections in the PDM.  You have four assignment 

options here: “Location and Zone”, “Location”, “Zone”, and “Head End”. 

Locations and Zone: 
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Use this command to change the Location and Zone for the selected Products and/or Packages. 

Generally you would use this option instead of selecting “Location” or “Zone” individually.  The 

Assign Location and Zone form opens: 

 

Use the tabs to make your selections. 

Head End: 
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The Head End assignment only applies to Wire and Cable, and only to Wire and Cable assigned to a 

Phase that has the associated Head End action.  Confused?  Head End is the “end point” of the 

wire.  By default, the “Rough-In” phase is the only SI 5 phase that ships with the Head End action.  

When a “Rough-In” Wire is added to a Project, the Head End dialog box opens as shown below: 

 

 

If you ever want to reassign a Head End once the Product is added to the PDM, use this right-click 

option. 

Right-click->Refresh Data from Master Table 

This works for multiple Product selections in the PDM.  This will refresh the selected Products with 

data from the Master Table database. 

Example: You update the pricing Products for a manufacturer in your Master Table 

database.  However, some of these Products have already been added to Projects 

that are in process.  To update the pricing for all of the Products for that 

manufacturer, select them in the PDM, right-click->Refresh From Master Table. 
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Use the  button to filter the PDM to easily find the Products you want to refresh.  

 

Right-click->Update Data to Master Table 

This works for Packages and multiple Product selections in the PDM.  This does the exact opposite 

of the Refresh Data from Master Table command.  This takes the selected Product and/or 

Package data from within the Project and updates the Master Table database.  This function is 

used less often than Refresh Data from Master Table since the following form is presented each 

time you edit Product data using the Product Properties form: 
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However, if you edit Product data directly in the PDM grid, you will not be asked to update the 

Master Table.  If you wish to update the Master Table, use the Update Data to Master Table 

function. 

To edit data directly in the PDM grid, left-click once on the field you wish to edit. The 

pencil icon on the left indicates that you are editing the product, and the field you 

selected will have focus allowing you to edit.  If you intend to replace the data in the 

field, press F2 to select and highlight the contents.  Your first keystroke will delete 

the field’s contents and insert the typed character. 

 

Some fields have dropdown menus: 
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Right-click->Regenerate Component ID 

This works for multiple Product selections in the PDM.  It will recalculate the Component ID for 

ONLY the selected Products in the PDM based on the Component ID format for the Project.  To 

modify the Component ID format within a Project, select D-Tools->Project Information and 

then click the Component ID tab. 

 

The [Recalculate] button will recalculate the Component ID for ALL Products in the PDM.  If you 

only want to recalculate specific Products, use the right-click option instead of using the 

[Recalculate] button on this form. 

If wire labels have already been installed that reference the Component ID, care 

should be taken before deciding to recalculate the IDs. 



Text Interface  

Revised February 19, 2009 

316 

Right-click->Web Specs 

This works for the primary selected Product in the PDM.  This will launch a web browser directed to 

the URL in the “Hyperlink” field for the Product: 

 

Right-click->Open in I/O Studio 

This opens the I/O Studio for the product that is selected in the PDM.  See the MMPD section of this 

guide for specs on the I/O Studio. 

 

Right-click->Select All/Deselect All 

These options will either select all of the Packages and/or Products in the PDM, or deselect them 

all. 

Right-Click->Expand Row/Collapse Row 

This will work for Group headers or multiple row selections in the PDM.  This option works in 

conjunction with grouping.  When you group Products in the PDM, [+] and [-] options display in 
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the PDM for each Grouping ([+] = Expand row, [-] = Collapse row).  You can use this right-click 

command to Expand or Collapse the selected rows in the PDM. 

 

To Expand or Collapse all of the rows in the PDM, right-click any column heading in 

the PDM and select Expand All/Collapse All from the right-click menu. 
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Visio Interface 
The Visio Project Interface is a tool for creating graphical representations of Projects.  The interface 

is composed of five major parts: the Product Explorer, the Project DataMatrix (PDM), the Stencil 

Tree, the Drawing Area, and the Menu Options.  

 

Your Visio interface may look different than the screenshot below.  To change what 

windows display, use the D-Tools->View menu. 

Product Explorer  
For a complete description of the Product Explorer see page 264 of this manual. 

Project Data Matrix (PDM)  
For a complete description of Project Data Matrix (PDM) functionality see page 266 of this 

manual. 
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Stencil Tree  
This section displays all of the stock SI 5 Stencils and downloaded Stencils available. 

Terminology: Stencils are "containers" for Shapes.  Shapes are what is actually displayed on the 

Drawing Pages within Visio. 

There are three “sections” in the Stencil tree: Standard, Manufacturer, and Custom.   

 

 

The Standard category lists the stock D-Tools Stencils based on Category.  These stencils contain 

Generic Shapes.  Generic Shapes have a one-to-many relationship with Products in the SI 5 

database. 
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There are a few ways to view the Shapes within a stencil.  To view the Shapes by name, click the 

[+] next to the stencil name: 

 

If you want to see icon representations of the Shapes, right-click the Stencil name and select 

“Display Docked Stencil” from the right-click menu.  This will open the Shapes window and display 

the Shapes. 
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The Manufacturer section lists any D-Tools Manufacturer Stencils that you have downloaded.  

These stencils contain specific Shapes created for the particular manufacturer.  Most of the Shapes 

in these stencils have a one-to-one relationship with Products in your SI 5 database.   

 

The Custom section lists the D-Tools stencils that don’t relate to a particular Category or 

Manufacturer.  These stencils will be discussed later in the “Drawing Page Types” section of this 

chapter. 

 

 

Drawing Area  
This section of the interface is where you will create your drawing pages.  The drawing pages for 

the Project are listed as tabs along the bottom.  There are six page types in the stock SI 5 Visio file 
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templates:  Cover Sheet, Line Diagram, Elevation View, Plan View, Schematic View, and 

Background Title Page.  These page types and their properties are discussed on page 325. 

 

Creating a Visio file for an SI 5 Project 
Creating a Visio file for an SI 5 Project takes place in the Projects tab of the SI 5 Navigator.  Select 

a Project in the Projects section of the form and then click the “Create new Visio drawing for this 

project”: 
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The Select Template form will open: 

 

When you select a template, the default name for the file will be “Drawing1.vsd”.  We recommend 

that you change this to something a little more specific to the Project.  When finished, click [OK].  

The Visio file will display in the Project Files section of the Projects tab: 
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Each one of the stock SI 5 Templates creates a Visio file with six default drawing pages set to the 

size indicated in the name of the Template.  The six types of drawing pages are: Cover Sheet, Line 

Diagram, Elevation View, Plan View, Schematic View, and Background Title Page.  Each page type 

has unique properties, all of which are detailed in the “Drawing Page Types” in the following 

section. 

You can create your own Visio templates.  See Creating SI 5 Visio Templates on pg. 400.  

Drawing Page Types 
The six types of drawing pages are: Cover Sheet, Line Diagram, Elevation View, Plan View, 

Schematic View, and Background Title Page.  You may add as many drawing pages as you want to 

a Visio Project.   

Example: To add a drawing page to a Visio file –  

1) Right-click an existing drawing page tab and select Insert Page… 

 

2) The Page Setup form will open: 
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3) Name the page and make any modifications to Drawing Scale, Page Size, etc. 

then click [OK].  The defaults for Drawing Scale, Page Size, etc. will be the same 

as the page you right-clicked in step 1.  You will be prompted to select a Page 

Type that will determine what shapes display by default on the page. 

 

Cover Sheet 

The Cover Sheet page is not intended for use with most SI 5 Shapes.  It is a page that you can use 

to add legends you may have created, add notes, etc.  You may choose to use some of the legend 

shapes already created in the DT Annotations stencil: 
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Line 

The line page type is used to create a flow chart of systems within a Project.  An example of a Line 

Diagram drawing page is below: 

 

The shapes that are intended for use on this page are either the default Line Image shape that 

populates with the Image that you have assigned to the Product or the Line shape: 
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Line shapes are intended for use on a line diagram drawing page to provide a conceptual overview 

of the system. Line shapes are not to scale and can be resized. 
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Right-click options specific to Line shapes 

Large/Medium/Small Point Spacing: allows you to change how many connection points display on 

the shape. 
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If you do not see any Connection points, you can turn them on by selecting View-

>Connection Points: 

 

The shape can be resized using any of the Selection handles.  The Connection points are there for 

attaching line connectors between Products to show the signal flow of a system.  Although you 

could use Wire shapes on this page, it is not necessary.   

There a few options for adding line connectors.  One option is to use the D-Tools created Line 

Connector shapes in the Wire and Cable Stencil:  
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These line connector shapes are not linked to Products in the SI 5 database like the Wire shapes 

are but they are linked to the Type table for wire Products.  When you drag and drop the Line 

Connector shape onto a drawing page, you will be prompted to pick a Type for the wire you are 

representing with this shape: 

 

The colors assign based on this legend: 

 

The color and the “Type” text will display on the shape: 
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Each end of the line connector shape has a connection point that you can attach to a connection 

point on another shape: 

 

Another option for adding a line connector is to use the Visio Connector Tool function: 
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Elevation 

The elevation page type is used to create a scaled representation of systems within a Project.  The 

most common use for an elevation page is for building racks. An example of an Elevation drawing 

page is below: 

 

The shapes that are intended for use on this page type are either the generic Elevation shapes 

from the Category stencils or a Product specific shape from a Manufacturer stencil.  

 

Even though the shape on the left is a generic representation of the Product, the 
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shape populates with the Manufacturer, Model, Component ID, and Type fields.  The 

fields that display vary between shapes. 

Elevation shapes are scaled shapes based on the height and width of the Product.   

 

These shapes cannot be resized using any of the Selection handles.  In order to resize them, you 

must make changes to the properties of the Product.   

The Connection point is there for connecting to other shapes, i.e. a rack shape. 
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Depending on what Category the Product is assigned, there will be different right-click options.  

Anything that can be rack mounted like an amplifier, video source, receiver, etc. will have a Rack 

Mount option: 

 

Rack Mount - when checked, the shape will display screw shapes, when unchecked the shape 

displays feet 

 

Display Devices have specific options depending on the Type assigned to the Product.  Remember 

the Type field? 
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For example, the Type “CRT” will display only the “Choose Screen Fill” option while Type “LCD” or 

“Plasma” will display “Adjust Speaker and Stand Size” and “Show Shadow” options: 

 

Adjust Speaker and Stand Size – opens a Custom Properties form for edit.   

 

 

Show Shadow – displays a shadow for the shape (see Example 1 above) 

Choose Screen Fill – allows you to choose a fill image for the screen 
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PANASONIC TH-42PX500UDIS-006

 

In order for the “Choose Screen Fill” option to function you must right-click the 

Display Devices stencil and select “Display Docked Stencil”: 
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When you select “Choose Screen Fill”, the Fill form opens and the fills will be 

available for selection from the “Pattern” dropdown: 

  

Speakers have specific right-click options: 
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Show Grill Cloth – displays a grill pattern on the shape 

 

Show Shadow - displays a shadow for the shape 

Choose Material (Fill) - allows you to choose a fill pattern for the speaker 

The Cabinet Tools stencil under the Custom section of the Stencil Tree is intended for use on this 

page. 

 

These shapes are not linked to Products in the database so nothing is added to the PDM when you 

use these shapes. 
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Right-clicking these shapes once they are on a drawing page lists some sizing and 

display options that are specific to these shapes in addition to the standard right-

click options.  The standard right-click options are discussed on page 370. 

 

Choose Wood Fill - allows you to choose a wood fill pattern for the cabinetry 

In order for the “Choose Wood Fill” option to function you must right-click the 

Cabinet Tools stencil and select “Display Docked Stencil”: 

 

When you select “Choose Wood Fill”, Fill form opens and the fills will be available for 

selection from the “Pattern” dropdown: 
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Plan 

The plan page type is generally used with a floor plan to show an overhead view of where products 

are installed in a Project.  An example of a Plan drawing page is below: 
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The shapes that are intended for use on a plan drawing page type are very basic shapes.  There 

are two different style shapes you can use on this page type:  Plan shapes and Scale Plan shapes.    

 

Plan shapes are not to scale and can be resized.  Most stencils also have a Scale Plan shape that is 

to scale based on the Products width and depth.  Scale Plan shapes cannot be resized using the 

selection handles. In order to resize them, you must make changes to the properties of the 

Product. 

 

The connection points on these shapes are intended for use with Wire and Cable shapes.  The 

connections made with Wire and Cable shapes are recorded for reporting.  Example reports are the 
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Brother Wire Labels and the Wire Checklist reports.  See “Brother Wire Labels” on page 526 for 

more detail. 

 

The wire and cables shape that drops by default on a plan page is the Rough-In Wire shape: 

 

 

There is a connection point at each end of the wire and the text block displays the Component ID, 

Model, and Head End.  Right-clicking allows you to hide the text block:  
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The Rough-In Wire 2 shape is straight, not squiggly: 

 

To change a shape, see the Right-Click->D-Tools->Shape->Change option on page 379. 

If a wire shape is connected to another shape on a Visio page, if you drag that product to another 

page the wire will automatically on the page as well. 

Inserting a file of the floor plan is ideal on this page because it saves you the trouble of drawing 

out rooms.  Ideally you would insert an AutoCAD file onto the Visio page or you can insert an 

image of the floor plan if that is all you have. 

Inserting a CAD drawing saves a ton of time and it is a function of Visio:  

 



 SI5 User and Administration Guide 345

The form will default to Custom scale because Visio makes an attempt to fit the CAD 

drawing on the page.  

 

You can leave it if you are not worried about scale or you can select Pre-defined 

scale, select Architectural, and then select 1/4” = 1’ (if you know what scale the CAD 

drawing is, use that instead).  Click [Apply] to see if this size works.  If it does not, 

then you can change your Visio drawing page scale and try inserting the CAD 

drawing again. 

 

Once the AutoCAD drawing is on the page, you will want to lock it so you don’t 

accidentally select the CAD image.  To do this, right-click anywhere on the drawing 

page and select View->Layer Properties… Click the cell in the “Lock” column. 
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The AutoCAD file must be “cleaned” before it can be inserted into Visio.  This 

cleaning must be done in AutoCAD.  If you do not have a copy of AutoCAD, the 

architect or builder will do this for you.   

The most common error you will see when importing an AutoCAD file into Visio is 

this: 

 

The most common reason for this error is that the AutoCAD file is not in AutoCAD 

2000 (or earlier) format.  The method described below will take care of this error as 

well as other issues that are encountered when inserting an AutoCAD file into Visio. 

1) Verify that the Drawing (.DWG) is in Model Space (not Paper Space).  

2) Run the Command: zoom extents  

3) Verify that there is only one “image” in the Drawing.  Many AutoCAD Drawings 

have multiple “images” as shown below: 
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To create a new separate drawing file for each view that you want, follow these 

steps: 

a) Run the command wblock.  The Write Block form will open:  

 

b) Click the [Select objects] button . 

c) Select the objects that you want and then click [Enter] on the keyboard.  You 

will be returned to the Write Block form.  Choose a file name and path, and 

change the Insert units to “Unitless”.  
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d) Now you would open the new file you just created in AutoCAD and start over with 

the “Preparing an AutoCAD file for insertion into Visio” process. 

4) Run the Command: units The Drawing Units dialog will open. Verify that the 

“Type” is set to Architectural and the “Units to scale inserted content” is set to 

Unitless.  

5) Run the Command: xref The Xref Manager dialog will open. If there are xrefs, 

you can Bind them or if the Status of the xrefs is “Not Found” or “Unloaded”, 

Detach them.  

6) Run the Command: purge The Purge dialog will open. Check “Purge nested 

items” and uncheck “Confirm each item to be purged”  

7) Run the Command: audit  

8) Type “y” to fix any errors.  

9) Save the drawing as an R14 DWG or an R12 DXF file if these are options in your 

version of AutoCAD. If you don’t have one of these options you can save as an 

AutoCAD 2000 DWG. 

The procedure described above will work for most AutoCAD Drawings.  For 

instructions on importing an AutoCAD Drawing into Visio, adding Visio Shapes, then 

exporting back to AutoCAD (“Round Tripping”) see the “Round Tripping: AutoCAD 

to Visio…then back to AutoCAD” section in this chapter pg 403. 
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Schematic 

The schematic page type is used to create the wiring diagrams for systems within a Project.  An 

example of a Schematic drawing page is below: 

 

The shapes intended for use on this drawing page type list the inputs and outputs for the Product.  

 

The Schematic shape will drop by default for all Categories except Speakers and Wire and Cable. If 

you want to change the default shape that drops, see the Right-Click->D-Tools->Shape-

>Change Shape option pg 379. 
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Schematic shapes size vertically automatically based on the number of inputs and outputs for a 

Product.  The selection handles can be used to size the shapes horizontally.  Each input and output 

listed has a connection point. 

 

Wire and Cable shapes are used on this page to connect Products. The connections made with Wire 

and Cable shapes are recorded for reporting.  Example reports are the Brother Wire Labels and the 

Wire Connection reports.    See “Brother Wire Labels” on page 526 for more detail. 

 

 

The wire and cables shape that drops by default on a schematic page is the Finish Wire shape: 

 

There is a connection point at each end of the wire and the text block displays the Component ID.  

Right-clicking allows you to hide the text block: 
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The Finish W/Mod+ID  shape displays the Model and Component ID fields separated by an 

underscore: 

 

To change a shape, see the Right-Click->D-Tools Shape->Change Shape option on page 379. 

If a wire shape is connected to another shape on a Visio page, if you drag that product to another 

page the wire will automatically on the page as well. 

Background Title Page 

The Background Title Page is intended for use with the D-Tools created Smart Frame L-Scape 

shape in the DT Annotation stencil.  However, you can use any way you like. 

 

Any shape put on this page will automatically display on the other default pages (Cover Sheet, Line 

Diagram, Elevation View, Plan View, and Schematic View).  The reason for this is due to the Page 

Setup properties for this page: 
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The Type selected is “Background”.  Every other page in the stock SI 5 templates is linked to this 

page in their Page Setup properties: 

 

To view the Page Setup properties, select File->Page Setup: 
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When you drag the Smart Frame L-Scape shape to this page, it will automatically display on every 

page linked to it. 

To edit the Smart Frame L-Shape shape, follow these instructions: 

1) In the Stencil Tree, right-click the DT Annotations stencil and select “Display 

Docked Stencil” 

 

2) The stencil will display in the Shapes window.  Right-click the stencil name and 

select “Edit stencil” 
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3) Make a copy of the Smart Frame L-Scape shape and paste into the docked 

stencil.  Use any of the standard Windows commands to accomplish this copy and 

paste.  The reason you are making a copy of the original is so you can simply 

delete the shape if you make a mistake.  You can rename the shape anything you 

wish: 

 

4) Double-click the new shape to open it.  The green background indicates that this 

is a grouped shape: 
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5) Select the shape by left clicking any of the individual shapes in the group.  You 

will know you can select the shape when the cursor turns into a double arrow: 

 

When the shape is selected, you will see a dashed green border around the shape: 

 

6) Select Edit->Open Landscape Title Frame from the menu options.  The yellow 

background now indicates that the shape is not grouped and can be edited: 
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7) You can now modify the shape to your liking, e.g. remove the D-Tools logo and 

insert your own.  When finished, close the edit window by clicking the X in the 

upper right-hand corner: 

 

8) You will now be back on the grouped shapes screen (green background).  Close 

the window by clicking the X in the upper right-hand corner: 

 

9) When prompted to save changes to the shape, click [Yes]: 

 

10)   Right-click the stencil name in the Shapes window and select “Edit stencil” to 

take the stencil out of edit mode.  Click Yes when prompted to save changes to 

the stencil: 
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You can make any page a background page and link any other page to a background page.  This is 

particularly handy when inserting AutoCAD floor plans.  You may wish to use the floor plan on 

multiple Visio pages.  Insert the AutoCAD file on one background page and then link the Plan pages 

the background page.  This will keep the file size down in size since you only insert the AutoCAD 

file once instead of multiple times.   

Adding Products and Packages  
There are multiple ways to add Products to the PDM.  One way to add Products and/or Packages to 

a Visio Project is to use the  button in the PDM section of the screen.   

Clicking the page icon will open the Add Product form.  If you want to add a Package, 

use the arrow section of the button and select “Add Package” from the dropdown 

menu: 
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The Add Product form allows you to filter using tabs to find the Product(s) you want to add to the 

Project.  You can select multiple Products to be added at one time to your Project. You can also 

assign the Location and/or Zone as well. 
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If you chose to add a Package with the dropdown arrow, the Add Package form will open.  This 

form allows you to choose a Package to add to the Project as well as a place for you to select your 

Location and/or System for the Package.  
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Another way to add Products or Packages to the PDM is to right-click a Product in the PDM and 

select Add->Product (or Package).   

 

 

In the methods described above, adding a product to the PDM does not automatically 

add a Product shape to any of the drawing pages. 
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Another way to add Products to the PDM is to add a shape to the project on one of the Drawing 

Pages.  You can do this a few different ways.  The first way is to drag a stencil from the Stencil 

Tree over to a Drawing Page: 

 

You will then be prompted to select a Product from your database: 

 

The default shape for that page type will drop on the page and the Product will be added to the 

PDM. 

The default shape will drop for a particular page type unless you have specifically 

assigned a particular shape to drop for that Product.  You can assign a specific shape 
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to drop for a particular page type on the Visualizations tab in the Product 

Properties for a Product.  

 

You can also drag over a particular shape to the drawing page instead of dragging the stencil if you 

prefer.  You can do this from the names displayed the stencil, or if you have the stencil docked, 

you can drag the image of the shape to the page: 
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To get shapes on the drawing page for Products already in your PDM, you simply have to drag the 

Product from the PDM to a drawing page (use the grey block next to each Product): 

 

Notice that the Visio icon will display in the far left column in the PDM to indicate that 

the Product is on the selected drawing page. 
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Assigning Locations and Zones 

For a complete description of how to assign Locations and Zones, see “Assigning Locations 

and Zones” page 299 of this manual. 

Menu Options  
For a complete description of “Menu Options” see page 270 of this manual. 

D-Tools->Project Information 

For a complete description of the information contained under the “D-Tools->Project 

Information” tab see page 271 of this manual. 

D-Tools->Options 

For a complete description of “D-Tools->Options” see page 280 of this manual. 

D-Tools->Reports 

For a complete description of Reports see page 471. 
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D-Tools->Insert System 

See page 290 for an introduction to Insert System functionality. 

 

The “Import Visio Pages” option adds enhanced functionality to import only the Products and 

Packages that are on particular drawing page(s), rather than all Products and Packages from the 

Project that you are inserting.  Once you [Browse…] to the Project that you want to insert and 

click [Import], you will be prompted to select what drawing pages you want to insert and what 

Products and/or Packages you want to insert. 
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D-Tools->Export To->Microsoft PowerPoint 

This option is only available with the Professional version of SI 5 and with Microsoft Office 2007 

installed.  This will create a PowerPoint presentation based off of the Project.  All drawing pages will 

be exported to their own slide and a project summary follows on additional slides. 

D-Tools->Export To->Microsoft Project 

This option is only available with the Professional version of SI 5 and with Microsoft Project 2007.  

This will export the SI 5 Project information to Microsoft Project. 
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D-Tools->Export To->HTML 

This function will create an html document and an images folder that you can use to post your 

Projects on your website. 

 

Select the drawing pages and Properties that you want to export.  Then select the path where you 

want the files to be created and click [Export]. 

The Properties that you selected will be viewable on the html doc by holding down 

[Ctrl] and then clicking on a Product shape. 

Since the output file is html, it can be opened in a browser to view. 
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You may need to right-click and select “Allow Blocked Content…” if IE displays the 

message below: 

  

 

D-Tools->Find and Replace 

For a complete description of Find and Replace see “D-Tools->Find and Replace” page 288 of 

this manual. 
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D-Tools->Update Case 

For a complete description of Update Case see D-Tools->Update Case” on page 291 of this 

manual. 

D-Tools->View 

There are five options: Display Project DataMatrix, Display Product Explorer, Display Stencil Tree, 

Display Project Summary, and Display Line Item Summary.  Use these commands if you chose to 

close or open any of those windows at some point while working in Visio. 

D-Tools->Utilities->Create Stencils 

If you have created your own Categories in SI 5, you may want to create a stencil with some 

shapes for those Categories.  This option will allow you to select the Category to create a stencil 

for, and then list the available shapes from the Generic.vss stencil. 

 

When you click [Create], the stencil will be created and placed in the proper folder: 
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D-Tools->Utilities->Change Page Type 

There are four page types in an SI 5 Visio Project: Plan, Elevation, Line, and Schematic.  Each of 

these page types have specific shapes that are designed to work with them.  More details on these 

page types are available in the “Drawing Page Types” section of this chapter.  Use this function if 

you want to change the page type for any page. 

 

D-Tools->Utilities->Populate ‘Location’ and ‘Zone’ in Shapes 

This will populate the Location and Zone on custom shapes to which the Location and Zone field 

have been added. 

D-Tools->OrderTools 

For a complete description of OrderTools see “D-Tools->Update Case 

Use this to update the case settings within a project if you have made changes to your default case 

settings in the MMPD interface.  A window will open showing what will be changed.  You can 

uncheck any products you do not wish to change: 

 

D-Tools->OrderTools” on page 291 of this manual. 
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Help->Contents\Index\Search 

 

This opens an electronic version of the SI 5 User’s Guide. 

Right-Click Options 
In addition to the Add Product/Package option described above in this section of the guide, there 

are additional right-click options available to you.  Your right-click menus will vary depending on 

whether you right-click a Product in the PDM or if you right-click a shape in the Drawing Area. 
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When you right click selected Product(s) or Package(s) in the PDM, the right click menu displays as 

shown below: 

 

Most of these options were discussed in the Text Project Interface section of this guide. For a 

complete description of Right-Click Options, see “Additional Right-Click Options” page 306 of 

this manual.  The Visio Project Interface specific options are discussed below. 

Some of these options will apply across multiple Products, some only for the primary 

selected Product.  A selected Product is indicated by a grey row color, and the 
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primary selected Product is indicated with an arrow in the PDM: 

 

Right-Click->Find Shape 

This works for the primary selected Product in the PDM.  This option will find the shape for that 

product on the drawing page.  The drawing page will zoom out to full screen and the Product shape 

will be selected on the page. 

Right-Click->Dock->Left/Right/Top/Bottom/Float 

This option applies to the PDM and will dock or float the window based on your choice. 
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When you right click selected Product shapes on a drawing page, the right click menu displays as 

shown below: 

  

The right-click options will vary depending on what kind of shape you select. 

For the following four options, a Line-Image shape is used for the screenshots: Show Text Blocks, 

Merge Text Blocks, Snap Text Block Position, and Show Text Callout. 
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Right-Click->Show Text Blocks 

Displays the Manufacturer, Model, and Component ID for the Product: 

 

Right-Click->Merge Text Blocks 

There are two text blocks, one that displays Manufacturer and Model and one that displays the 

Component ID.  Check this option to keep both of them together or uncheck this option to keep 

them separated.  In the example below, the text blocks are not merged: 
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Right-Click->Snap Text Block Position 

When this option is checked, the yellow handle for the text block will snap to the handles of the 

shape.  When unchecked, they don’t snap.  In both of the screenshots above the text blocks are 

“snapped” to the shape handles. 

Right-Click->Show Text Callout 

This displays a line from the shape to the text block when checked: 

 

Right-Click->D-Tools->Find in Project DataMatrix 

This option works for only one selected Shape at a time.  This will find and select the Product in the 

PDM. 

Right-Click->D-Tools->Shape->Insert Alternate View 

This option allows you to add a second shape to represent the selected Product to the drawing 

page.  The shapes will have the same Component ID as each other.  You can choose any shape 

from any stencil for this second shape. 
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Example: You price your speakers by the pair in your database.  When you add the 

Product to the PDM and then drag the Product to a drawing page, you only get one 

shape to represent the pair of speakers: 
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Select the shape and then Right-click->D-Tool->Shape->Insert Alternate 

View.  Select your Stencil and Shape from the form: 

 

A second shape will display on the drawing page: 
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Right-Click->D-Tools->Shape->Change Shape 

If the default shape that displays on a drawing page is not the shape you want, you can change the 

shape to any shape from any stencil. 

 

The “Save as default…” checkbox will save this setting for future use.  The setting is displayed on 

the Visualization tab of the Product Properties form: 
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Right-Click->D-Tools->Shape->Generate Side View 

This option will only work on an elevation page type.  This will add a very basic side view of the 

selected Product.  The side view shape is to scale based on the Height and Depth of the Product. 

 

Right-Click->D-Tools->Shape->Link To D-Tools 

This option allows you to link a shape that you have created to a Product in the SI 5 database.  

Once you create a shape and link it to a Product in SI 5, you may want to add the shape you 

created to a stencil so that you can use it in future Projects. 

Example: In this example, I created a very simple 8-button plate shape using 

standard Visio drawing tools that I want to link to a Product in my SI 5 database. 

1) Select the shape you want to link then Right-Click->D-Tools-> Shape->Link To 
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D-Tools: 

 

2) Select the Product that you want to link this shape to on the Add Product form: 

 

3) The shape is now linked to the Product that you selected and the Product has 

been added to the PDM. 

4) To add this shape to a stencil for use on future Projects: 
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5) Right-click the stencil and select “Display Docked Stencil”.  In this example, I 

chose the Plates stencil: 

 

6) Once the stencil is docked, right-click where the stencil name is displayed in the 

Shapes window and select Edit Stencil: 
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7) Now drag the shape from the drawing page into the docked stencil: 

 

8) The shape will now display inside of the stencil.  Rename the shape to an 

appropriate name. 

 

9) Right-click the stencil name and select “Edit Stencil” to take the stencil out of edit 

mode.  Save changes to the stencil. 
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10) Now anytime that you drag this shape over to a drawing page, you will be 

prompted to select the Product you assigned to this shape. 

This function is a one-to-one relationship with a Product in the SI 5 database as 

opposed to a one-to-many relationship like the standard SI 5 shapes. 

Right-Click->D-Tools->Shape->Note 

This option lets you add a note about a particular shape on a drawing page.  The note will appear 

as a text box on the drawing page and can be moved/edited on the drawing page. 
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Right-Click->D-Tools->Terminal Options 

This option is only available for use on a schematic page type.  This form allows you to pick and 

choose what signal points display on the shapes on the drawing page. 

 

You can choose to “Show connected terminals only” when you are finished with a drawing page.  

This will “collapse” the schematic shapes on the page by hiding unused inputs and outputs.  The 

“Show I/O terminals from top to bottom” will invert the I/Os on the shape. 

Instead of using the “Display connected ports only” and “Show I/O ports from top to 

bottom” options globally for the schematic page, you can right-click specific 

schematic shapes on the drawing page and select “Display Connected Ports” and/or 

“Show IO Ports Top Down”:  
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Right-Click->D-Tools->Wire Options->Assign Head End 

The Head End assignment only applies to Wire and Cable, and only to Wire and Cable assigned to a 

Phase that has the associated Head End action.  Confused?  Head End is the “end point” of the 

wire.  By default, the “Rough-In” phase is the only SI 5 phase that ships with the Head End action.  

When a “Rough-In” Wire is added to a Project, the Head End dialog box opens as shown below: 

 

 

If you ever want to reassign a Head End once the Product is added to the PDM, use this right-click 

option. 

Right-Click->D-Tools->Wire Options->Check Connections 

This function is a part of the wire auditing in SI 5.  If you have turned off the “Prompt on Conflict” 

setting on your Wire Connection Options (see below) you would use this function to verify that you 

have no conflicting wire connections. 
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Right-Click->D-Tools->Wire Options->Wire Connection Options 

This function gives you flexibility on how wire connections behave and whether or not they are 

recorded for reporting purposes.  These settings let you choose how the wire auditing in SI 5 

functions. 

 

Prompt on Conflict –When this option is checked you will see a similar prompt to the one below 

letting you know that there is a conflict.  The [Change Setting…] button will open the Wire 

Connection Setting shown above.  Even if you do not have this box checked, your settings in the 

“Connection” section of the form still apply. 
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Connection Settings – there are two main options here: Store New Connection or Store Old 

Connection.  Only one connection can be “stored” for each end of a wire.  This “stored” connection 

is what gets passed to our reporting engine.  The two sub-options for each of the main options 

deals with how you want the old or new connection to display on the drawing.  You can either leave 

it connected by using the “Keep old/new connection on drawing” option or you can have the shapes 

separate by using the “Remove old/new connection from drawing” option.  This is aesthetic only 

since only one connection can be “stored” as stated above. 
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Right-Click->D-Tools->Wire Options->WireWizard 

This option is only available for use on a schematic page type.  This wizard will allow you to make 

wire connections between schematic shapes without having to zoom in on the drawing page.  There 

are three steps to the WireWizard: choose an output, choose and input, and choose a wire. 

 

The first screen of the WireWizard form lists all of the Products on the schematic page that have 

outputs.  You may filter by signal type if you wish by checking the boxes in the “Signal type filter” 

section: 
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The colored icons next to the signal types reflects the color the wire shape will drop 

when a wire of that type is dropped on a schematic page.  Remember the “Type” 

field? 

 

Once the wire shape is on the page, you can use the Visio function “Line Color” to 

change the color of the shape: 

 

The icons that display next to outputs are colored based on the Signal assigned to 

the output.  These colors are matched to the Signal type based on a text 

comparison: 
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Products display in the format: Manufacuter;Model;Component ID.  Click the [+] next to the 

Products to display the output list.  An output that has a wire connected to it on a schematic page 

will display with a (1) next to it: 

 

There are two additional filters on this form: 

Show product by location - groups Products based on their location assignment   

Show open terminals only – filters the output list so that outputs that are already connected on the 

drawing page with a wire shape do not display in the list 

With the exception of the “Show product by location” filter, we do not recommend 

using the filtering options unless you have verified all Product data as being 

consistent in naming conventions, e.g. all Audio wire is listed as Type “Audio” and 
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not a mix of “Audio” and “Aud”.  This is because our filtering is text based and 

matches on exact terminology only. 

The [RestoreDefaults] button clears any filters that you have selected. 

The “Record connections as golden rules” option applies to the AutoWire function that is discussed 

on page 396.  The [History…] button also applies to the AutoWire function.  It allows you to 

manage the rules you’ve created.  This is discussed in more detail on page 396.  

The colored icons that you see next to the outputs for the product are based on the “Type” 

assigned to the product.  The legend is at the top of the form in the “Signal filter type” section. 

Click an output to select then click [Next]. 

 

The Product and output terminal that you selected is displayed at the top of the form.  The output 

is displayed in the following format: Label – Signal – Terminal  
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Click the [+] next to a Product to display the inputs.  The icons that display next to inputs are 

colored based on a text comparison between the output Terminal and Signal, and the input 

Terminal and signal:  

green = both the output and input Terminal and Signal match 

yellow = either the output or input Terminal or Signal match 

red = neither the output or input Terminal or Signal match 

Again, there are many filters here that we do not recommend you use unless you have verified all 

of your Product data for consistency.  Most are self explanatory but just for kicks, here is what 

each filter does: 

Filter Description 

Filter per stored rule Filters the input list to only those inputs that are 

associated with a  Standard Rule or Golden Rule, i.e. – 

filters to the inputs that have been connected in the past 

using Wire Wizard 

Show matching signals only Filters the input list to only those inputs where the signal 

matches the chosen output’s signal 

Show matching connectors only Filters the input list to only those inputs where the signal 

matches the chosen output’s signal 

Show open terminals only Filters the input list so that inputs that are already 

connected on the drawing page with a wire shape do not 

display in the list 

Show product by location Groups Products based on their location assignment 
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Select an input and then click [Next].  

 

Now the top of the form displays information for both the output and input Products that you have 

selected.  It also lists the signal from the output you chose in the “Signal Type” field. 

The Wire History section displays a list of every wire that has been used in the WireWizard.  The 

Manufacturer, Model, Signal, Input, and Output list for each wire.  When you make a wire 

connection using the WireWizard, you are prompted with: 
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Choosing [Yes] will populate the Signal, Input, and Output fields for the wire in the Wire History.  

Choosing [No] will not populate the fields: 

 

The colored icons next to the wires indicate whether or not the Signal matches the signals from the 

inputs and outputs you chose:  

green = both the output and input signal match the signal assigned to the wire 

yellow = either the output or input signal match the signal assigned to the wire 

red = neither the output or input signal match the signal assigned to the wire 

Use the [Remove Wire From History] button to clean up the list as needed. 

The filter choices at this point are: 

Filter Description 

Show matching signals only This will filter the Wire History so that only wires assigned 

a signal that matches either the output or input signal 

display, i.e. – only wires with a green or yellow icon will 

display 

Show matching wire terminals This will filter the Wire History so that only wires assigned 

a terminal that matches both the output or input 

terminals display, i.e. – only wires with a green icon will 

display 

You have three options for selecting a wire at this point: [Connect], [Select from Project], and 

[Select New Wire].  

[Connect] – In order to use this button, you must first select a wire listed in the Wire History 

section of this form. This will add the selected wire to the PDM and automatically drop and connect 

the wire shape on the page.  
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[Select from Project] – This option allows you to use a wire shape that you have already added 

to the drawing page from your PDM.  Using this option will not add a wire to your PDM since you 

have already used an existing wire from the PDM.  A dialog will display showing you all available 

wire shapes on the drawing page: 

 

[Select New Wire] – This option allows you to select a wire Product from your MasterTable 

database.  You will be prompted to pick a wire from your database.  This will add the selected wire 

to the PDM and automatically drop and connect the wire shape on the page. 

When you have made your wire selection, the wire shape will connect on the drawing page and the 

WireWizard will reset to the first page of the form so you can make your next connection.  

Right-Click->D-Tools->Wire Options->AutoWire  

This option is only available for use on a schematic page type.  The functionality of AutoWire is 

based of rules that you have “taught” SI 5 through using the WireWizard.  Every connection you 

make using the WireWizard is recorded as a Standard Rule. 
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The connection is also recorded as a Golden Rule if you have the “Record connections 

as golden rules” option checked on the WireWizard form. 

 

Standard Rules – These rules are based off of the Category and Type fields.  This means that if 

you make a connection between a Product of Category “Video Sources” and Type “DVR” to a 

Product of type “Display Devices” and Type “Plasma” with a Monster Cable MVSV3-4M cable, the 

AutoWire function will assume that this same wire is used to connect all Products of Category 

“Video Sources” and Type “DVR” to Products of type “Display Devices” and Type “Plasma” on the 

drawing page. 

Golden Rules – These rules are based of the Category, Manufacturer, and Model fields.  This 

means that these rules are more specific than Standard Rules and may be your best option for 

using AutoWire. 

The AutoWire main form looks like this: 

 

If any shapes are selected on the page prior to running AutoWire, you will see and 

additional option to just run AutoWire for the selected shapes: 
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Here you can choose what rules you want use, Standard or Golden, and whether or not you want 

to [Wire Automatically] or [Wire Manually].  You can also use [Display Rules] to display and 

manage the rules that have been created: 

 

The [Display Rules] button is the same as the [History…] button on the 

WireWizard form: 
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[Wire Automatically] – This will wire the page based on what type of rules you selected.  Always 

double check the connections after they are made using this feature.  Since they are based off of 

rules that you have created, human error still plays a part here. 

[Wire Manually] – This allows you to choose what connections to make based off of the rules that 

you have created.  This gives you a bit more control over the Wire Automatically function.  A form 

opens allowing you to select rules the rules you wish to apply.  Click [Connect] to make the 

connection or click [New Wire] to select a wire from your database. 
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Right-Click->D-Tools->Wire Options->AutoLayout 

This option is only available for use on a schematic page type.  This function will move shapes of a 

particular Category to the quadrant of the drawing page based on your selections. 

 

To use, drag a Category to the desired quadrant column and then click [Auto Layout].  All of the 

shapes on the drawing page will move over and group in the selected quadrant.  Only the 

Categories in the project will display. 

Arrange products vertically by location – arranges the Products based on their location 

assignment and the location hierarchy you have established for the Project  

Arrange products vertically by category per layout below – arranges the Products vertically 

based on their position from top to bottom in each quadrant   

Creating SI 5 Visio Templates 
1) Navigate to the C:\Documents and Settings\All Users\Application Data\D-Tools\SI5\Templates 

folder and select an existing template.  Choose an existing template with the same page sizes 

you intend to use on your template to save yourself time setting up pages and scales.  “Work 

smarter, not harder”, “Don’t re-create the wheel”, etc. 
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The path for Vista users is C:\ProgramData\D-Tools\SI5\Templates. 

2) Double-click the file to open in Visio. 

3) Click [Cancel] when prompted to create a New SI Project: 

 

4) Make any adjustments that you desire, e.g. add pages, change drawing scale, etc. 

5) When finished, select File->Save As… 

 



Visio Interface  

Revised February 19, 2009 

402 

The Save As form will open.  In the “Save in:” section, navigate to the same folder as in step 1.  In 

the “Save as type:” field, select Template (*.vst): 

 

When finished, click [Save]. 

6) Click [OK] when prompted to enter a Project Name: 

 

7) Click [Cancel] on the Project Information form. 

8) The next time you create a Visio file for a Project, the template you created will display in the 

list: 
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Round Tripping: AutoCAD to Visio…then back to 
AutoCAD 
Often the most difficult part of working with an AutoCAD Drawing is getting the AutoCAD file from 

the architect.  The situation may arise when an architect or builder asks that you provide 

installation drawings integrated with an existing AutoCAD based architectural drawing package.  

You could print out a 24” x 36” plot, but ideally you would like to provide an electronic file. 

This method was designed by Adam Stone, President of D-Tools, Inc. to assist you with this task. 

Some of the procedures in this section are repeated elsewhere in this chapter 

because there are additional specific criteria needed for “round tripping” that are not 

necessary when not “round tripping”. 

Basic Facts About Visio and AutoCAD 

Before we jump into the process I should go over some AutoCAD terms and how they relate to 

Visio.  The first thing we need to know about AutoCAD is that there are two ways to view a 

drawing: Paper Space and Model Space.  Basically all drawings are done in Model Space and all 

printing/plotting is done in Paper space.  Drawings in Model space are created in the real world 

scale: 1: 1.  Drawings in Paper Space are represented as a scaled version of Model Space so they 

can fit on paper, typically ¼” = 1’.. 

The important thing to remember is that Visio imports and exports AutoCAD files in Model Space 

but uses Paper Space (scale) to work with shapes and objects.  Visio does not have a Model Space 

equivalent; everything is done in Paper Space.  When importing AutoCAD files into Visio, it is 
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important to always match the Visio and AutoCAD page scale.  If the drawing is saved properly, it 

will export in Model Space at a 1:1 scale.   

Prepare the AutoCAD File for Insertion (requires AutoCAD) 

You will need a current version of AutoCAD and some basic knowledge of AutoCAD or AutoCAD Lt 

to complete this process.  If you don’t have AutoCAD, see if you can get the person who gave you 

the floor plan to follow these instructions.  This process assumes the user is working on an 

Architectural file. 

Open original file in AutoCAD in Model Space.  The following commands will clean up the drawing 

and set the reference point.  

1) Run the Command: zoom extents 

2) Verify that there is only one “view” in the Drawing.  Many AutoCAD Drawings have multiple 

“views” as shown below: 

 

Follow these steps to create a new separate drawing file for each view: 
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a) Run the command wblock.  The Write Block form will open: 

 

b) Click the [Select objects] button . 

c) Select the objects and then click [Enter] on the keyboard.  You will be returned 

to the Write Block form.  Choose a file name and path, and change the Insert 

units to “Unitless”. 

 

d) Now open the new file you just created in AutoCAD and start over with the 

Preparing an AutoCAD file for insertion into Visio” process. 
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3) Run the Command: units.   Verify that the “Type” is set to Architectural and the “Units to 

scale inserted content” is set to Unitless.  

 

You may see the following prompt, click [OK]. 

 

4) Run the Command: zoom  Type e for “extents”.  Zoom extents will fill the page with the entire 

drawing. 

5) Run the Command: xref.  The Xref Manager dialog will open.   

An xref is an external reference to other CAD files.  It is up to the Architect or the 

person putting together the file to determine which files are needed to be added or 

deleted from the drawing. 
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6) If there are xrefs, select all files then click the [Bind] button.  The Bind Xrefs dialog will open.   

 

7) Select the Insert option and then click [OK].  Click [OK] to close the Xref Manager.  This will 

bind any externally referenced files to this file. 
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If the xref Status is “Not Found” or “Unloaded”, then select all files, click the 

[Detach] button and then click [OK].  

 

8) Run the Command: purge  The Purge form will open: 
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9) Purge removes unused entities from the drawings. Check “Purge nested items” and uncheck 

“Confirm each item to be purged”. 

10) Click [Purge All] until all items are purged (you may have to do this more than once) and then 

click [Close] to exit the form. 

11) Run the Command: audit  Type y to fix any errors 

12) Run the Command: Base  Then type 0,0,0.  This sets the insertion base point to 0,0,0. 

13) Run the Command: line 0,0,0.  This will find the origin point of the CAD drawing.  The pivot 

point of the line is the “origin” or “zero point” of the drawing.  This is very important if you want 

the Visio shapes to match the floor plan on export. 

14) Draw the line along the x axis to the right of the ‘zero point’ and then hit the [Esc]. 

15) 10. Run the Command: line 0,0,0 

16) Draw another line at the pivot point along the y-axis to form a 90 degree angle.  The two lines 

will form an “L”.  The corner of the angle is the “0,0,0 point” of the AutoCAD drawing.  This “L” 

will be called the “reference block”  When done, hit the Esc key. 

 

You want the base point to be close to the drawing.  Sometimes the base point will 

be set off of the page.  This is usually an architect’s mistake or the drawing was 

based off of a civil drawing.  To set a new arbitrary point to use as a reference follow 

these commands: 

a) Run the Command: ucs  Type n for new 
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b) Pick the arbitrary point somewhere in the lower left beyond the boundary of the 

drawing 

c) Run the Command: base  Set point to 0,0,0 

17) Run the Command: zoom extents  

18) Select File->Save as… and save the drawing in AutoCAD 2000/LT2000 Drawing format. 

At this stage the file is ready to be exported at its cleanest and most Visio compatible state. 

Insert AutoCAD File into Visio as a Background 

1) Create a new SI 5 Visio project or open an existing SI 5 Visio project.   Make sure you are on a 

Plan Page Type in the Visio Project: 

 

2) Create a background page in Visio.  Right-click on the Plan View tab and select Insert Page.  

The Page Setup form will open. 

3) From the menu bar select File->Page Setup…  The Page Setup form will open. 
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4) Click the Page Properties tab and verify that Measurement Units is set to “Inches”, not 

“Feet and Inches”.  Name the page something appropriate and select the Background radio 

button for “Type”. 

 

5) Click the Drawing Scale tab and verify that the Pre-defined scale: is set to Architectural 

¼” = 1’0”.  This is a good scale to start with.  Click [OK]. 

 

6) You just created a background page in Visio.  Insert the AutoCAD file on this page, then “link” 

the actual pages you will be dropping Visio shapes on to this background page.  This method of 
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creating a background page is convenient when you are using the same AutoCAD floor plan on 

multiple drawing pages, i.e. you want to do a separate page for lighting and a separate page 

for audio. 

7) While the background page is selected, select Insert->CAD Drawing from the menu bar in 

Visio.   

8) Browse to the AutoCAD file and click [Open].  The Insert AutoCAD Drawing dialog box will 

open. 

9) The Custom Scale: radio button is selected by default.  You must change this to Pre-defined 

scale: Page Scale. Click [OK].  The CAD drawing will be inserted into the Visio page. 

 
 

If the AutoCAD drawing is too large for the page size then start the insert over but 

with a smaller scale from the File->Page Setup->Drawing Scale form (step 4 in 

this section). 

If the AutoCAD drawing is too small for the page size then start over with a larger 

scale from the File->Page Setup->Drawing Scale form (step 4 in this section). 

To remove the AutoCAD drawing from the Visio page, double-click the AutoCAD 

drawing in Visio.  The AutoCAD Drawing Properties dialog box will open.  Un-
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check the Lock against deletion box and then click [OK]. Hit the delete key on 

your keyboard to remove the AutoCAD drawing from Visio. 

10) Test the scale by checking a door in the drawing.  Most doors are standard sizes and are usually 

marked 2-4 or 2-6 to represent a 2’4” or 2’ 6” door.  If they measure the same in Visio, you 

have successfully imported the AutoCAD file to scale in Visio. 

11) After you insert the AutoCAD Drawing into the background page, you can then link the 

background page to other pages in Visio.  Select the page on which you would like to use the 

AutoCAD drawing as a background.  In this example, the page named Level One – A/V page 

is selected. 

12) From the menu bar select File->Page Setup and then click the Page Properties tab.  Select 

your background page from the Background: dropdown menu (in this example, the page was 

named Level One - Background).  Verify that the Measurement Units is set to “Inches”.  

Click [OK].  You will now see the AutoCAD drawing displayed on the Visio page. 

 

Creating an AutoCAD Drawing From a Visio Drawing 

The first thing to do is create a “reference shape” in Visio to match the “reference block” created 

earlier in AutoCAD.   

1) Use the standard Visio Line Tool function from the Drawing toolbar to create a backwards “L”.  

This will be called the “reference shape”. 

2) Line up the “reference shape” with the “reference block” so that their corners meet. 
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The reason for this step is when you save the Visio drawing as an AutoCAD drawing 

(upcoming steps), only the Visio shapes will export, not the floor plan.  The architect 

will use this “reference shape” to line up this drawing over the original AutoCAD file 

inside of AutoCAD. 

3) Add Visio shapes to the drawing page.  In this case I added some speakers and wire. 
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4) Save as a DWG by selecting File->Save as… and selecting AutoCAD Drawing from the Save 

as type: dropdown. 

 

If you are using a title frame shape in Visio, you may want to remove it from the 

Visio page before saving the file as an AutoCAD drawing. 

This is the file that you would send back to the architect.  The Drawing only contains the Visio 

shapes that you added, not the original floor plan: 

 

Externally Reference (Xref) the Visio Created DWG to the Original DWG 

1) Open the original AutoCAD file in AutoCAD  

2) From the menu bar select Insert->External Reference…and Browse to the file you just 

saved from Visio.  Click [Open].  The External Reference dialog will open. 
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3) Check the Specify On-screen dialog then click [OK].  You will need to point the cursor to the 

matching CAD reference point. 

4) Verify that the reference points line up.  You may have to move the inserted xref layer to line 

up the reference points. 
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The reason that will have to move line up the “references” is because Visio’s “0,0,0 point” 

(technically just a 0,0 point in Visio) is always at the lower left corner of the drawing page while 

the AutoCAD “0,0,0 point” can be set.   

 

AutoCAD Interface 
The AutoCAD Project Interface is a tool for creating graphical representations of Projects.  The 

interface is composed of three main parts: the Project DataMatrix (PDM)/Block Tree/Product 

Explorer/Project Summary window, the Drawing Area, and the Menu Options. 

 

If you have additional plug-ins associated with AutoCAD, i.e. Adobe Acrobat, the D-

Tools menu may not load.  If this happens, run the command: dtshowmenu 
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Project DataMatrix (PDM)/Block Tree/Product 
Explorer/Project Summary Window  
This window has four tabs for you to select from.  The Project DataMatrix (PDM) view is where 

all of the Products that have been added to a Project are displayed.  See “Project Data Matrix 

(PDM) ” on page 266 for more information. 

The Block Tree tab will display all of the stock SI 5 Drawings and downloaded Manufacturer 

Drawings available.  

Terminology: Drawings are "containers" for Blocks.  Blocks are what are actually displayed on the 

Drawing Sheets within AutoCAD. 

There are three “sections” in the Block Tree: Standard, Manufacturer, and Custom.   

 

Use the  button to refresh the list if you add any Drawings while working on an AutoCAD file. 
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The Standard category lists the stock SI 5 Drawings based on Category.  These Drawings contain 

Generic Blocks.  Most of the Generic Blocks have a one-to-many relationship with Products in the 

SI 5 database. 

 

To view the Blocks by name, click the [+] next to the drawing name: 
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The Manufacturer section lists any D-Tools Manufacturer Drawings that you have downloaded.  

These drawings contain specific Blocks created for the particular manufacturer.  Most of the Blocks 

in these drawings have a one-to-one relationship with Products in your SI 5 database. 
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The Custom section lists the SI 5 Drawings that you create as well as one that we created, Cabinet 

Tools.  Cabinet Tools be discussed later in the “Drawing Sheet Types” section, see page 427. 

 

The Product Explorer tab is very similar to the Product Explorer screen within the Manage My 

Product Data (MMPD) interface.  For a complete description of the “Product Explorer” see page 

264 of this manual. 
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The Project Summary tab displays a summarized view of the Project. 

Drawing Area  
This section of the interface is where you will create your drawings.  Each drawing sheet will 

initially have five tabs along the bottom: one Model space, and one Paper space each for the 

following sizes: ANSI B – 11x17, ANSI C – 17x22, ANSI D – 22x34, and ANSI E – 34x44.   

 

 

 

Menu Options 
For a complete description of “Menu Options” see page 270 of this manual. 

D-Tools->Project Information 

For a complete description of the information contained under the “D-Tools->Project 

Information” tab see page 271 of this manual. 

D-Tools->Options 

For a complete description of “D-Tools->Options” see page 280 of this manual. 

D-Tools->Reports 

For a complete description of Reports see page 471. 
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D-Tools->Insert System 

See page 290 for an introduction to Insert System functionality. 

 

The “Import AutoCAD sheet” option adds a very nice functionality of being able to just import 

the Products and Packages that are on particular drawing sheets, rather than all Products and 

Packages from the Project that you are inserting.  When this is checked and you click [Browse…], 

you have the option of selecting an SI 5 Project AutoCAD file into the current Project.  You will be 

prompted on to the Project that you want to insert and click [Import], you will be prompted for 

what Products and Packages you want to insert: 

 

D-Tools->Export To->Microsoft Project 

This option is only available with the Professional version of SI 5 and with Microsoft Project 2007.  

This will export the SI 5 Project information to Microsoft Project.  
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D-Tools->Find and Replace 

For a complete description of Find and Replace see “D-Tools->Find and Replace” page 288 of 

this manual. 

D-Tools->Update Case 

For a complete description of Update Case see D-Tools->Update Case” on page 291 of this 

manual. 

D-Tools->View 

There are five options: Display Project DataMatrix, Display Block Tree, Display Product Explorer, 

Display Project Summary, and Display Line Item Summary.  Use these options if you have closed 

the window at some point. 

D-Tools->Utilities->Create Blocks 

If you have created your own Categories in SI 5, you may want to create Drawings with some 

blocks for those Categories.  This option will allow you to select the Category to create a drawing 

for, then list the available blocks from the Generic.dwg drawing.   

 

D-Tools->Utilities->Insert Sheet 

This will open a form where you can select a Sheet Type and a Name for the Sheet that you wish to 

add: 
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There are four Sheet Types: Line, Elevation, Plan, and Schematic. 

D-Tools->Utilities->Change Sheet Type 

There are four page types in an SI 5 AutoCAD Project: Plan, Elevation, Line, and Schematic.  Each 

of these page types have specific blocks that are designed to work with them.  More detail on these 

page types is in the “Drawing Page Types” section in this chapter.  Use this function if you want to 

change the page type for any page. 

 

D-Tools->OrderTools 

For a complete description of OrderTools see “D-Tools->Update Case 

Use this to update the case settings within a project if you have made changes to your default case 

settings in the MMPD interface.  A window will open showing what will be changed.  You can 

uncheck any products you do not wish to change: 

 

D-Tools->OrderTools” on page 291 of this manual. 
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D-Tools->Help 

This option provides access to a searchable version of this guide.   

Creating an AutoCAD file for an SI 5 Project 
Creating an AutoCAD file for an SI 5 Project takes place in the Projects tab of the SI 5 Navigator.  

Select a Project in the Projects section of the form and then click the “Create new AutoCAD drawing 

for this project”: 
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The four types of drawing sheets are: Line, Elevation, Plan, and Schematic.  Each sheet type has 

unique properties, all of which are detailed later in this chapter.   

The following form opens: 

 

When you select a template, the default name for the file will be something like “schematic1.vsd” if 

you select the Schematic.dwg template.  We recommend that you change this to something a little 

more specific to the Project.  When finished, click [OK].  The AutoCAD file will display in the 

Project Files section of the Projects tab: 

 

Drawing Sheet Types 
The four types of drawing sheets are: Line, Elevation, Plan, and Schematic.  Each one of these 

Sheet Types have blocks that were created to work with them.  There are really four “kinds” of 

blocks that we created for SI 5: Generic Blocks, Specialized Generic Blocks, Manufacturer 

Specific Blocks, and Low Voltage Icon Blocks. 

Generic Blocks – Generic blocks generally have the Sheet type right in the name, e.g. Elevation 

Plain, Plan Icon, etc.  Generic blocks are very simple blocks that can be used to represent any 
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Product in the Project.  There are a total of six generic blocks with differing behaviors, designed 

specifically for use on different drawing sheet types (Line, Plan, Plan Scale, Elevation, Side, and 

Schematic) 

 

Specialized Generic Blocks - Specialized generic blocks are designed to represent specific 

equipment types on specific drawing pages. Examples of these blocks are: Fixed Screen, Plasma, 

Projector (front and side view), and Rack. 
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To modify the properties of these blocks, select the block on a sheet, right-click and 

select Properties.  The Properties form will open. The “Custom” section is where you 

can modify the block: 

 

Manufacturer Specific Blocks – These are blocks that were created to look exactly like the 

Product.  Most of the Shapes in these blocks have a one-to-one relationship with Products in your 

SI 5 database. 
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Low Voltage Icon Blocks - Low voltage icon blocks are industry standard symbols used to 

represent items in the project, most commonly on plan view sheets (they can be used any sheet 

type you choose).  These blocks have the word “Icon” in front them: 

 

A listing of the low voltage icon blocks available is at the end of this chapter. 

Line 

The line sheet type is used to create a flow chart of systems within a Project.  An example of a Line 

Diagram drawing sheet is below: 
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The blocks that are intended for use on this sheet are the default Line blocks for the each 

Category. 

 

Line blocks are intended for use on a line diagram drawing sheet to provide a conceptual overview 

of the system. Line blocks are not to scale and can be resized. 



AutoCAD Interface  

Revised February 19, 2009 

432 

 

The block can be resized using the Stretch points.  The Selection points can be used to move the 

text fields to another position on the sheet.  The Show Menu triangle gives you the options of 

showing or hiding the text labels for the block. There are two text labels, one that displays 

Manufacturer and Model and one the displays Component ID. 

 

Elevation 

The elevation sheet type is used to create a scaled representation of systems within a Project.  The 

most common use for an elevation sheet is for building racks. An example of an Elevation drawing 

sheet is below: 
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The blocks that are intended for use on this sheet type are either the generic Elevation blocks from 

the Category drawings or a Product specific block from a Manufacturer drawing. 

 

Even though the block on the left is a generic representation of the Product, the 

block populates with the Manufacturer, Model, and Component ID, fields.  The fields 

that display vary between blocks. 
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Elevation blocks are scaled blocks based on the height and width of the Product.   

 

Elevation blocks cannot be resized on the drawing sheets.  In order to resize them, you must make 

changes to the height and width on the Product Properties form for the Product.  The Selection 

points can be used to move the text fields to another position on the sheet.  The Show Menu 

triangle gives you the options of showing or hiding the text labels for the block. 

The Elevation Plain and Elevation with Feet blocks are essentially the same block.  

The only difference is how they initially display on the page: Elevation Plain has 

screws to represent a rack mounted Product and the Elevation with Feet does not.  

The display of both of these blocks can be changed using the Show Menu dropdown:  

 

There is a Cabinet Tools drawing under the Custom section of the Block Tree that is intended for 

use on this sheet. 
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These blocks are not linked to Products in the database so nothing is added to the PDM when you 

use these blocks. 

Use the Stretch points to properly size the cabinet shapes for your needs. Use the 

Show Menu triangle for options such as adding a door or showing a top view. 

 

Plan 

The plan sheet type is generally used with a floor plan to show an overhead view of where certain 

products are installed in a Project.  An example of a Plan drawing sheet is below: 
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The blocks that are intended for use on a plan drawing sheet type are very basic blocks.  There are 

two different style blocks you can use on this sheet type:  Plan blocks and Scale Plan blocks.   
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Plan blocks are not to scale.  Most drawings also have a Scale Plan block that is to scale based on 

the Products width and depth.  Scale Plan blocks cannot be resized on the sheet. In order to resize 

them, you must make changes to the width and depth on the Product Properties form for the 

Product.   
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The Selection points can be used to move the text fields to another position on the sheet.  The 

Show Menu triangle gives you the options of showing or hiding the text labels for the block. These 

blocks are intended for use mainly with Wire and Cable blocks.  The connections made with Wire 

and Cable shapes are NOT recorded for reporting like they are in Visio. 

 

The wire and cables block that drops by default on a plan sheet is the Rough-In Wire block: 
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There is a selection point at one end of the block and on each text label.  The Show Menu triangle 

gives you the options of showing or hiding the text labels for the block. There are two text labels, 

one that displays Manufacturer and Model and one the displays Component ID.  There is a stretch 

point on one end of the wire and a circular handle that can be used to rotate the block. 

Unlike in Visio, connections made with Plan blocks do not generate data for the SI 5 

Installation reports.  Schematic blocks do generate data for the SI 5 Installation 

Reports. 

Inserting a file of the floor plan as an xref is ideal on this sheet because it saves you the trouble of 

drawing out rooms. 

Schematic 

The schematic sheet type is used to create the wiring diagrams for systems within a Project.  An 

example of a Schematic drawing sheet is below: 
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The blocks intended for use on this drawing sheet type list the inputs and outputs for the Product. 

 

Schematic blocks size vertically automatically based on the number of inputs and outputs for a 

Product.  Each input and output listed has a “connection point”. 

Wire and Cable shapes are used on this page to connect Products. The connections made with Wire 

and Cable shapes are recorded for reporting.  Example reports are the Brother Wire Labels and the 

Wire Connection reports.  For a complete description of Reports see page 471. 

 

The default color for an unconnected wire on the Schematic sheet is red.  Once the 

wire is connected between two Product blocks, the color is green. 
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The wire and cables block that drops by default on a schematic sheet is the Schematic block: 

 

 

There are selection points at each end of the block, one in the middle, and one on the text label. 

Paper Space Sheets 

Each AutoCAD file that you create for an SI 5 Project starts with four paper space tabs: ANSI B – 

11x17, ANSI C – 17x22, ANSI D – 22x34, and ANSI E – 34x44.  You do not have to use all or any 

of these pages if you prefer to create your own.  If you want to use the provided sheets, you may 

want to replace the D-Tools logo with your own logo (we don’t mind if you leave the D-Tools logo 

though, ☺). 

Example: In this example, the following logo is used: 

 

The logo that you insert must be in .dwg format. 

1) Browse to the following location: C:\Documents and Settings\All 

Users\Application Data\D-Tools\SI5\Templates\AutoCAD.   

(VISTA:  C:\ProgramData\D-Tools\SI5\Templates\AutoCAD ) Double-click the 

template you wish to edit.  In this example, the Elevation.dwg was selected.  The 

following steps will need to be completed on each template. 
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2) The file will open in AutoCAD. If you are prompted create an SI file, click 

[Cancel]: 

 

3) Select Tools->Block Editor: 

 

4) Select the Logo block and then click [OK]: 
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5) The block editor opens: 

 

6) Select Tools->DesignCenter: 
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7) In the DesignCenter form, browse to your logo file. Expand the [+] next to the 

file and select “Blocks”: 
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8) Drag the block to the Block Editor “page”: 

 

9) Make sure that your logo does not exceed the existing D-Tools logo in size: 

 

10) Delete the D-Tools logo block and move the new logo over into place: 
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11) Save the Block Definition: 

 

12) Close the Block Editor:  

13) Save and close the Elevation.dwg. 

 

Adding Products and Packages  
There are multiple ways to add Products and/or Packages to the PDM.  One way to add Products 

and/or Packages to a AutoCAD Project is to use the   button in the PDM section of the screen.   

Clicking the page icon button will open the Add Product form.  If you want to add a 

Package, use the arrow section of the button and select “Add Package” from the 

menu:  
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The Add Product form allows you to filter using the tabs to find the Product(s) you want to add to 

the Project.  You can select multiple Products to be added at one time to your Project. You can also 

assign the Location and/or Zone as well. 

 



AutoCAD Interface  

Revised February 19, 2009 

448 

If you choose to add a Package with the dropdown arrow, the Add Package form will open.  This 

form allows you to choose a Package to add to the Project as well as a place for you to select your 

Location and/or Zone for the Package. 

 

Another way to add Products or Packages to the PDM is to right-click on any Product in the PDM 

and select Add->Product (or Package). 
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In the methods described above, adding a product to the PDM does not automatically 

add a Product block to any of the drawing sheets. You must drag and drop the 

Product from the PDM to the drawing sheets. 

Another way to add products to the PDM is to add a block for the project to one of the Drawing 

Sheets.  You can do this a few different ways.  The first way is to drag a drawing from the Block 

Tree over to a Drawing Sheet: 

 

You will then be prompted to select a Product from your database: 
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The default block for that sheet type will drop on the sheet and the Product will be added to the 

PDM. 

The default block will drop for a particular sheet type unless you have specifically 

assigned a particular block to drop for that Product.  You can assign a specific block 

to drop for a particular sheet type on the Visualizations tab in the Product 

Properties for a Product. 
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You can also drag over a particular block to the drawing sheet instead of the dragging the drawing 

if you prefer.  You can do this by dragging and dropping from the names displayed when the [+] 

next to the drawing name is expanded: 

 

To get blocks on the drawing sheet for Products already in your PDM, you simply have to drag the 

Product from the PDM to a drawing sheet: 
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Notice that the AutoCAD icon will display in the far left column in the PDM to indicate 

that the Product is on the currently selected drawing sheet. 

 

Assigning Locations and Zones 

For a complete description of how to assign Locations and Zones, see “Assigning Locations 

and Zones” on page 299 of this manual. 

Additional Right-Click Options 
In addition to the Add Product/Package option described above in this section of the guide, there 

are additional right-click options available to you.  Your right-click menus will vary depending on 

whether you right-click a Product in the PDM or if you right-click in the Drawing Area. 
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When you right click selected Product(s) or Package(s) in the PDM, the right click menu displays as 

shown below: 

  

Most of these options were discussed in the Text Project Interface section of this guide, see 

“Additional Right-Click Options” starting on page 306.  The AutoCAD Project Interface specific 

options are discussed below. 

Some of these options will apply across multiple Products, some only for the primary 

selected Product.  A selected Product is indicated by a gray row color, and the 
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primary selected Product is indicated with an arrow in the PDM: 

 

Right-Click->Find Block 

This works for the primary selected Product in the PDM.  This option will find and select the block 

for that product on the drawing sheet.  

Right-Click->Dock->Left/Right/Top/Bottom/Float 

This option applies the entire PDM and will dock or float the window based on your choice. 
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When you right-click in the drawing area on a drawing sheet, the right click menu displays as 

shown below: 

 

Right-Click->D-Tools->Find in Project DataMatrix 

This option works for only one selected Block at a time.  This will find and select the Product in the 

PDM. 
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Right-Click->D-Tools Block->Block->Insert Alternate View 

This will open the Insert Alternate Block form which allows you to choose any block from the Block 

Tree to represent an alternate view of the Product.  The blocks will have the same Component ID 

as each other.  You can choose any block from any drawing for this second alternate view. 

 

Right-Click->D-Tools->Block->Change Block 

If the default block that displays on a drawing sheet is not the block you want, you can change the 

block to any block from any drawing. 

 

There is a “Save as default visualization for this view” option at the bottom of the form: 
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This will fill in the fields on the Visualizations tab of the Product Properties: 
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Right-Click->D-Tools->Block->Link To D-Tools 

This option allows you to link a block that you have created to a Product in the SI 5 database.  

Once you create a block and link it to a Product in SI 5, you may want to add the block you 

created to a drawing so that you can use it in future Projects. 

 Example: 

1) Select the block you want to link then Right-Click->D-Tools-> Block->Link To D-

Tools. The Add Product form opens. 

 

2) Select the Product that you want to link this block to in the Add Product form 

then click [Add to Project]: 

 

3) The block is now linked to the Product that you selected and the Product has 

been added to the PDM. 



 SI5 User and Administration Guide 459

To add this block to a drawing for use on future Projects: 

4) Select the block and then in the command line type: bedit 

The Edit Block Definition form will open: 

 

5) Select the block you created from the list and click [OK].  The block will now 

show in the Block Editor screen: 

 

6) In the command line type: attdef 
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The Attribute Definition form will open.   

 

7) Type “Manufacturer” in the Tag field then click [OK] 

8) The attribute will be displayed on the cursor.  Pick a spot you want this attribute 

and left mouse click to place it page: 
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9) In the command line type: copy 

A copy of the attribute will be made, left click where you want to place the attribute. 

10) Repeat step nine two more times until you have a total of four “Manufacturer” 

attributes on the page: 

 

10)  In the command line type:  ddedit  

Select one of the three copied attributes and change the tag for each as shown 

below.  You will need to complete step ten a total of three times. 
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For the Category attribute, add an appropriate Category name to the Default field. 

When finished, the block should look this: 

 

11)  Use the commands bsave and bclose to close the block editor. 

12)  In the command line type: saveas 
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The Save Drawing As form will open.  Type in a filename and then choose the 

following path in the “Save in:” dropdown: C:\Documents and Settings\All 

Users\Application Data\D-Tools\SI5\Visualizations\Blocks.  Name the drawing.  In 

this example I named the drawing: Custom Plates.dwg 

VISTA:  C:\ProgramData\D-Tools\SI5\Visualizations\Blocks 

 

 

13) Click [Save] 

14) When you open an AutoCAD file for an SI 5 Project, the drawing you created will 

display in the Custom section of the Block Tree: 

 

The block is a one-to-many relationship with  Products in the SI 5 database. 
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Right-Click->D-Tools->Block->Change Color 

This function does not work for SI 5 Schematic blocks.  This will open the AutoCAD Select Color 

form: 

 

Right-Click->D-Tools->Block->Change Layer 

This function does not work for SI 5 Schematic blocks.  This will open the D-Tools Change to Layer 

form.  All SI 5 blocks are assigned to layer “0” by default.  Use AutoCAD functions to create your 

own layers. 



 SI5 User and Administration Guide 465

 

Right-Click->D-Tools->Wire Options->Show ComponentID 

This only applies to schematic sheet types and only to the Schematic block in the Wire and Cable 

drawing: 

 

This option will open a dialog that allows you to choose where the Component ID text label displays 

on the block: 

 

You can do this for just the selected blocks on the sheet or all of the blocks: 
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Listing of Low-Voltage Icon Blocks 

Amplifier Icon

Audio Amplifier Icon

RF Amplifier Icon

Video Amplifier Icon

Aerial FM VHF Radio Icon

Aerial UHF VHF TV Icon

Amplifier Icon

RF Amplifier Icon

TV FM Dual Outlet Icon

Globe CCTV Camera Icon

Video Amplifier Icon

Video Intercom Door Entry
Unit Icon

Bath Control Icon

Control Panel Icon

Dimming Panel Icon

Gate Control Icon

Group Control Panel Icon

Lawn Sprinkler Control Icon

Natural Gas Control Icon

Overhead Door Opener Icon

Plant Watering Control Icon

Pool Control Icon

Shower Control Icon

Snow Melt Control Icon

Spa Control Icon

Sump Pump Icon

Volume Control Icon

TV Screen Icon

Distribution Box Icon

Distribution Box Icon

1 Way Ceiling Switch Icon

1 Way Key Switch Icon

1 Way Switch Icon

1 Way Weatherproof Switch Icon

2 Way Switch Icon

Antenna Icon

Bus Bar Icon

Ceiling Fan Icon

Controlled 3-Way Switch Icon

Controlled 4-Way Switch Icon

Controlled Dimmer 3-Way
Switch Icon

Controlled Dimmer Switch Icon

Controlled Duplex Receptacle 
Outlet (Half Switched) Icon

Controlled Switch Icon

Data Outlet Icon

Dimmer Switch Icon

Door Bell Icon

Double Pole Switch Icon

Duplex Receptavle Outlet
(Both Switched) Icon

Earth Bar Icon

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

36

37

38

39

40

41

42

43

44

45

46

47

48

49

50
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EIA-232 Serial Outlet Icon

Elv Door Bell CW
Transformer Icon

Fiber Outlet Icon

Floor Mounted Socket Icon

Generic AutoMatic Switcher Icon

Generic Source Component Icon

Headphone Jack Icon

Infrared Receiver Icon

Infrared Transmitter Icon

Isolator Icon

Junction Box Icon

Keypad- Music Icon

Keypad- Security Icon

Keypad-Lighting Control Icon

Lighting Management
Switch Icon

Non Standard Outlet Icon

Socket Outlet 2 Icon

Socket Outlet Icon

Stereo Speaker Outlet Icon

Switched Socket Outlet
(RCD Protected) Icon

Switched Socket Outlet Icon

System Component Icon

Tele Junction Box 2 Icon

Tele Junction Box Icon

Tele Outlet Icon 1

Transformer Icon

TV (2) & Phone Outlet Icon

TV FM Dual Outlet Icon

Twin Floor Mounted Outlet Icon

Twin Socket Outlet Icon

Twin Switched Socket Outlet

Video Modulator Icon

Wall Mounted Ceiling Fan Icon

Ceiling Fan Icon

Chime Icon

Wall Mounted Ceiling Fan Icon

Moisture Sensor Icon

Outside Temperature Sensor Icon

Pool Temperature Sensor Icon

Remote Temperature Sensor Icon

Snow Sensor Icon

Spa Temperature Sensor Icon

Thermostat Icon

Weather Sensor Icon

1200 mm 3 or 4 Lamp
Recessed Luminaire Icon

1200 mm Single Lamp
(Surface Mounted) Icon

1200 mm Single Lamp
(Wall Mounted) Icon

1200 mm Single Lamp
Recessed Icon

1200 mm Twin Lamp
(Surface Mounted) Icon

1200 mm Twin Lamp
(Wall Mounted) Icon

51

52

53

54

55

56

57

58

59

60

61

62

63

64

65

66

67

68

69

70

71

72

73

74

75

76

77

78

79

80

81

82

83

84

85

86

87

88

89

90

91

92

93

94

95

96

97

98

99

100
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1200 Twin Lamp Recessed Icon

1500 mm 3 or 4 Lamp
Recessed Luminaire Icon

1500 mm Single Lamp
(Surface Mounted) Icon

1500 mm Single Lamp
(Wall Mounted) Icon

1500 mm Single Lamp
Recessed Icon

1500 mm Twin Lamp
(Wall Mounted) Icon

1500 mm Twin Lamp
Recessed Icon

1500 Twin Lamp
(Surface Mounted) Icon

1550 x 400 Recessed
Luminaire Icon

1800 Twin Lamp
(Surface Mounted) Icon

2 Way Flood Icon

500 x 500 Recessed
Luminaire Icon

600 mm Single Lamp
(Surface Mounted) Icon

600 mm Single Lamp
(Wall Mounted) Icon

600 x 600 Recessed
Luminaire Icon

900 mm Single Lamp
(Surface Mounted) Icon

Emergency Exit Sign Directional 
Luminaire (Left and Down) Icon

Emergency Exit Sign Directional 
Luminaire (Right and Down) Icon

Emergency Exit Sign Directional 
Luminaire (Right and Left) Icon

Emergency Exit Sign Directional 
Luminaire (Right) Icon

Keypad-Lighting Control Icon

Lighting Control Contactor
Time Switch Icon

Lighting Control Icon

Lighting Distribution Box Icon

Lighting Track With
Spotlight Icon

Lighting Transformer Icon

Linear Flouresent
Luminaire Icon

Pendant Luminaire Icon

Surface or Recessed
Luminaire Icon

Track Mounted Luminaire Icon

Wallwasher Luminaire Icon

Xenon Flasher Strobe
Light Icon

Data Outlet Icon

Local Area Network
Outlet Icon

Tele Junction Box 2 Icon

Tele Junction Box Icon

Tele Outlet Icon 1

Telecom Back Box Icon

TV (2) & Phone Outlet Icon

Bell Icon

Buzzer Icon

C02 Warning Lamp Icon

Disabled Alarm Icon

Disabled Alarm Pull Cord Icon

Disabled Alarm Reset Icon

Disbaled Alarm Power
Supply Icon

Door Lock Release Icon

Electric Door Lock Icon

Electric Door Opener Icon

Electromagetic Door Holder Icon

101

102

103

104

105

106

107

108

109

110

111

112

113

114

115

116

117

118

119

120

121

122

123

124

125

126

127

128

129

130

131

132

133

134

135

136

137

138

139

140

141

142

143

144

145

146

147

148

149

150
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DS

Emergency Call Button Icon

Flame Proof Switch Icon

Gate Control Icon

Heat Sensor Icon

Intercom Outlet Icon

Keypad- Security Icon

PA Speaker Icon

Passive Infra-Red Motion
Detector Icon

Photocell Icon

Remote Indicator Lamp Icon

Security - Personnel Attack Icon

Security Area Control Panel Icon

Security- Audio Visual Icon

Security- Card Digital Access 
Control Unit Icon

Security- Electrically
Operated Lock Icon

Security- Emergency Door
Release Button Icon

Security- Keypad Access
Control Unit Icon

Security- Keypad Access Control 
Unit Schematic Icon

Security- Panic Raid Attack
Switch Icon

Security- Shunt Key Switch Icon

Security- Vibration
Detector Icon

Security-Door Contact Icon

Self Contained Emergency
Beam Light Unit Icon

Siren Celing Mounted Icon

Siren Wire Mounted Icon

Smoke Detector Icon

Town Gas Sensor Icon

Voice Alarm Icon

Xenon Flasher Strobe Light Icon

Speaker Icon

Video Amplifier Icon

Video Intercom Door Entry
Unit Icon

Video Modulator Icon

Mimic Fire Indicator Icon

151

152

153

154

155

156

157

158

159

160

161

162

163

164

165

166

167

168

169

170

171

172

173

174

175

176

177

178

179

180

181

182

183

184
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Reports 
The Reports tab allows you to run reports for the selected project.  For additional information about 

reports see this section of the D-Tools Blog: http://www.d-toolsblog.com/si-reports/ 

 

You can also run reports from within an open Project by selecting D-Tools->Reports 

from the menu bar: 
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Although not shown, you can do this from within the Visio and AutoCAD project 

interfaces as well. 

If you were also a V4.6 user and have SI 5 loaded on the same machine where SI 4 

is installed, you may access your legacy reports from within an open project by 

selecting D-Tools-> Reports, then select File-> Legacy Reporting System as shown 

below. 

 

A familiar form will open. While we hope this is comforting to you, you must abandon 

these archaic reports and embrace the new SI 5 reports at some point, the sooner 

the better…seriously. 
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See the SI4 Users Guide for more details on how to use this interface.  

http://www.d-tools.com/update/SI4Installs/eD-ToolsSI45UserGuide.zip 

The Reports interface consists of two main tabs: Projects and Start.  There is a Toolbar with 

buttons that will be described below.  The Navigator Bar displays a list of all of your Reports. 

 

The Projects tab lists all of your projects while the Start tab has help links for Reporting: 

 

http://www.d-tools.com/update/SI4Installs/eD-ToolsSI45UserGuide.zip


Reporting Center  

Revised February 19, 2009 

474 

Toolbar 

 

The toolbar has a collection of icons for quick access to these common actions 

.......Run Report 

.......Run Report with Filters opens the following form.  Click in each column to choose a Field, 

Operator, and Value. 

 

......Edit Report opens the following form and allows you to change the Name, Description, and 

Category of the report. 
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 ......Create New Report Category opens the following form.  Name the Category and then 

select the reports you want to add to the Category.  There are three stock Report 

Categories in SI 5: Client, Management, and Installation. 

 

......Edit Report Category allows you to edit the selected Category. 
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 ......Create New Report Group opens the following form.  Groups run multiple reports at a 

time.  Name the Group, add a Descriptions, and select the reports for the Group. 

 

 ......Edit Report Group allows you to edit a Group. 
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 ......Report Designer opens the interface to customize existing SI 5 reports.  See pg. 500 for 

details on the Report Designer. 

 ......Export Reports allows you to export any custom reports that you have created.  Reports 

do not synchronize so in order to share you must export the report and then transfer to 

another machine and import.  A zip file will be created. 

 

 ......Import Reports allows you to browse to a .zip file created via the  

Export reports function. 

The Export/Import functions here are only for the Standard Reports that display 

within this interface.  To Export/Import custom “Orders and Scheduling” Reports you 

must do this within the “Orders & Scheduling” Report Designer: 
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 ......New Excel Report opens the following form.  See Excel Reports on pg. 532 for details. 

 .....Refresh Project List refreshes the grid. 

 .....View/Change Global Settings opens the following form. 
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ARViewer Page Settings – allows you to choose whether or not to default to MultiPageColumns 

and Multipage Rows view. 

Keep Accessories With Parent Item – Options are “True” or “False”. When set to “True”, 

accessories will be listed beneath the parent item and the price of all the accessories will be 

included in the price displayed next the parent product.  When set to “False”, accessories will be 

listed independently and the price of the accessories will not be included in the price of the parent 

product. 

Location Detail Level - Options are “-1” through “5”.  “-1” will display the full hierarchy of your 

Location Types for a project.  Using any number 1-5 will run the reports to the specified level.  

Remember, you can have up to five Location Types in SI 5. 

Example: You are using a Location Type Hierarchy as follows: Building->Floor-> 

Room.  You only want your reports to show by Room.  Since “Room” is the third 

Location Type in your hierarchy you would choose “3” for this setting. 

Prefilter Items – Options are “True” or “False”.  This function will filter the products in a project 

prior to sending the data over to the report.  The default is “False” (so as not to make a setting 

change for existing users) but you should set this to “True”.   

Example: You have a package in SI 5 with some products in the Rough-In Phase and 

some in the Finish Phase.  If you run a report filtered to the “Rough-In” Phase, the 

products Rough-In products from the package will not display in the report when this 

value is set to “False”.  When set to “True” the filtering will include the products 

within the package on the report. 

Report Tax Descriptions – Expanding this list gives you three text fields for overriding either the 

GST, PST, or Sales Tax Descriptions on your reports. 

Show Packages in Proposals - Options are “True” or “False”.  When set to “True”, the price of all 

the products in a Package will be included in the price displayed next the Package name in the 

report.  When set to “False”, the products will display in the report individually and there will be 

now entry for the package name displayed. 
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Reports List 
This section lists all of the reports available to you.  “Orders and  

 

Report Categories 

Report Categories allow you to organize your reports for quick access. Standard reports are initially 

organized into four categories: Client Reports, Excel Reports, Installation Reports, and 

Management Reports. 
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Click on the  symbol next to the report category name to see which reports can be found. 

 

 Standard reports are noted by a green icon  

 Custom reports you have created or imported have a blue triangle on the icon  

To create a new report category, right-click anywhere in the report list and select New -> Report 

Category. You can then drag and drop reports into your new category. 

Running a Report with Filters 

If you want to filter the project data before running a report, right-click on the report name and 

select Run Report with Filters. The Filter Report dialog will appear. 
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On the row with an asterisk, click on the field column to select which data field you wish to filter 

by. Similarly, click on the Operator and Value fields to determine how this data field will be filtered. 

 

You can select multiple fields to filter by. Each row of the filter is joined by either an AND or an OR 

statement, selected in the column on the far left. The example above will filter by Location = 

Network Closet AND Phase = Rough-In.  Click [Run Report] to run the report with filters. 

Report Definitions 

Many reports have the ability to be run with custom grouping, sorting and parameter options that 

you can define and save. These stored options are called Report Definitions.  

If a report supports report definitions, you can see them by clicking on the  symbol next to the 

report name. 
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To create your own report definition, right-click on the report name and select New -> Report 

Definition. The Report Definition dialog will appear. 

 

Description is the name of the definition that will appear in the report list. 
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To create your own grouping order for this report definition, select the [Grouping] tab and click on 

the grey area next to the asterisk. Some reports (like Line Item Reports) support up to three levels 

of groupings; others support none, one or two levels. 

 

To sort the individual items within groups, click on the [Sorting] tab and select the fields you wish 

to sort by and how they are to be sorted. Note that not all reports can be sorted in this fashion. 
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Report Parameters 

Some reports have parameters that affect the way the report runs. To see which options exist for a 

particular report, go to the [Parameters] tab of the Report Definition dialog. Here you can modify 

the report parameters for this report definition. 

 

Making a Report Definition the Default Definition 

If you would like your report definition to run by default when you double-click on the report name, 

just check the Default Report Criteria box before you save your report definition. 
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Report Groups 

Report Groups are a way for you to define a collection of reports that will run together. Report 

groups are shown at the bottom of the reports list. Click the [+] symbol next to the group name to 

see which reports are included. 

 

To add reports to a report group, drag a report from the top section (Report 

Categories) to the group header. 
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To define a new report group, right-click in the Report List area and select New -> Report Group. 

To run a report group, just double-click on the group name. The results will appear in the Projects 

and Reports area. Individual reports appear in sub-tabs and can be printed or exported separately.  

 

Running a Report 
To generate a report you can: double click a report, right-click the report and choose “Run Report” 

or select a report in the list and click the  button on the function bar: 
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The report will generate and display on a tab in the Display Area: 

 

 

Viewing a Report 
Once you run a report, it will appear as its own tab in the Projects and Reports area. You can have 

a large number of report tabs open at once, which makes it easy to compare reports. 

 

When viewing a report, you have a row of tools at the top for performing different actions. 

 

......Show/hide table of contents and thumbnail view 

 Print the report to a printer 

......Copy the current page onto the clipboard  

......Find text within the document 
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 Single page / multi-page / continuous scroll view 

 Zoom out / Zoom in / Set zoom 

..Go to Next Page / Previous Page 

 Page Number/Total Pages 

 View previously viewed pages 

......Add annotation to report 

 

......Export to Adobe pdf format file, .pdf 

......Export to rich text format file, .rtf 

......Export to html format, .html 

......Export to plain text format, .txt  

......Export to Excel, .xls 

......Excel Report Settings – this launches a window for you to configure how your settings 
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Importing a report into MS Word 
To import a report into MS Word for continued editing, follow these steps: 

1) Click on the Export to Rich Text Format icon or the Export to Plain Text Format icon and select a 

name and location for the file. 
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2) Open Microsoft Word 

3) Go to Insert > File, select “All Word Documents” in the file type dropdown, and browse to the 

file.  

.  
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Using your own Word Templates with Proposals or Line 
Item Reports 
If you want to fine tune the look of your Proposals and Line Item Reports in Word, you can do this 

by running these reports with no headers or footers, then inserting into your own custom-made 

Word template. Follow these steps: 

1) Create a Word template with the desired headers and footers you want to use.  

D-Tools provides sample templates in your Global Application folder (in Windows XP, 

C:\Documents and Settings\All Users\ Application Settings\D-Tools\SI5\Other Files).  

See SI5 Proposal Template 1.dot. VISTA:  C:\ProgramData\D-Tools\SI5\Other Files 

2) Create a custom report definition (see below) and uncheck the “Show Page Header and Footer” 

parameter. 

 

3) Run the report using the custom report definition. 

4) Export to Rich Text Format (see above) 

5) Create a new Word document based on your custom template. 

6) Go to Insert > File and browse to the rtf document (see above) 
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Comparing Two Revisions of a Project 
If you want to compare two revisions of a project with each other, select the revisions in the 

project list and Right-Click to select Create Project Delta. .  The order of the selection is important.  

The difference will always be Delta Amount = (Selection1 – Selection2). 

 

Once you have created a delta project, which only includes the differences between the two 

revisions, you can select the delta project and run reports against it. 
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Projects Interface 
The Reporting Center projects interface allows you to run reports on a project that you have open 

in the Text, Visio, or AutoCAD interfaces. To open, go to the D-Tools > Reports menu option from 

within an open project. 

 

This window is divided into five areas: 1) The Project Details and Reports area, 2) the Reports List, 

3) the Report Details, 4) a Menu Bar and 5) a Toolbar. 
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Project Summary 

Click the [Project Summary] button to see a financial overview of your project as shown below. 
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Project Details and Reports Area 

The lower right area shows you some basic information about the project in the Project Details tab. 

Also, when you run reports, these will appear as tabs in this same area. See “Viewing a Report” 

on page 488 for more details. 

 

Reports List 

The Reports list on the upper left shows all of the defined reports. 

To create a new report definition, report group, or custom report, go to the 

Reporting Center primary interface. You cannot modify the Reports List from within 

the projects reporting interface. 

To Run a Report 

Double-click on the report name in to run the report. This will run the report using the default 

Report Definition. The results will appear in a tab in the Project Details and Reports area. 

If the report has multiple Report Definitions, click on the  symbol next to the report name to see 

the definitions, and double-click on the one you want to run.  See “Report Definitions” on page 

482. 

To Run a Report with Filters 

To filter the project data before running a report, right-click on the definition and select “Run 

Report with Filters”.  Note that not all reports support filtering.  See Running a Report with 

Filters on pg. 481 for details. 

To Run a SI4 Legacy Report 
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If you have SI4 installed on this computer, you can run any non-Business Manager SI4 report, 

including custom reports, for your project. Go to File -> Legacy Reporting System in the menu 

bar and the SI4 Reports interface will open.  

 

 

Report Details 

The report details area shows some basic information about the selected report, such as its name, 

a description, and what the Report Definition settings are. The information in this section changes 

whenever you select a different report in the Report List. See the reporting center primary interface 

guide above for more information. 
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Menu Bar 

The reporting center projects interface has these menu bar options: 

File > Run Report Run the selected report 

File > Legacy Reporting 

System 

If you have SI4 installed, opens the SI4 reporting interface 

Taskbar 

The taskbar has two icons for quick access to these functions: 

 ...... Run Report 

 ...... Run Report with Filters 
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Report Designer 
To access the Report Designer, from the Reports tab select Tools -> Report Designer-

>Standard Reports/Order & Scheduling Reports. 

 

 

Creating custom reports is for advanced users only. It is the sole responsibility of the 

user to debug any custom reports. However, for a great list of help options, check: 

http://downloads.d-tools.com/si5/documents/Custom_Reporting_Documents.htm 

The D-Tools Report Designer is based on ActiveReports for .Net 3.0 by Data 

Dynamics. For a complete user guide on this interface, see the ActiveReports User 

Guide located at 

http://www.datadynamics.com/forums/72/ShowForum.aspx. 

http://downloads.d-tools.com/si5/documents/Custom_Reporting_Documents.htm
http://www.datadynamics.com/forums/72/ShowForum.aspx
http://www.datadynamics.com/forums/72/ShowForum.aspx
http://www.datadynamics.com/forums/72/ShowForum.aspx
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“Standard Reports” display on the Reports tab within the Navigator. “Orders and Scheduling 

Reports” will display on their respective tabs within the SI 5 Navigator.   

The Report Designer interface will open: 

 

This interface consists of these parts: 1) menu bar, 2) shortcut toolbar, 3-4) formatting toolbars, 

5) toolbox, 6) design pane, 7) data and report explorer, 8) properties, and 9) script tab. 

Menu bar 

File -> New  (New Report Wizard) 
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To create a new custom report, go to File… New. The New Report Wizard will open 

 

Select New Report Based on Existing Report to create a custom version of an existing report, 

or New Blank Report to create a report from scratch. 

If you chose New Report Based on Existing Report, you should then select which report you wish to 

modify. 
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If you selected “Orders and Scheduling Reports” this screen will display Orders and Scheduling 

options.  These Reports display in on their respective tabs within the SI 5 Navigator: 

 

The next screen allows you to set the report name, enter a description, and determine which report 

category the report will appear in. It also allows you to mark this report as a Sub-Report or a 

Business Manager report (“Business Manager” is a legacy term, this option means that the report 

will display under your Orders and Accounting Reports lists).  
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From here on, just hit “Next” at every screen to duplicate the report you are 

modifying. 

Note 1: Sub-reports do not appear in your reports list. They are 

generally smaller reports which are included in other reports. An example 

is the Miscellaneous Costs sub-report. 

Note 2: The Report Name is the name that will appear in the Reports List 

Note 3: The “Data Source” field should always say “D-Tools Report Data”.  

 

In the next screen, set the page orientation and margins. 
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Next, choose whether the report will support sorting, filtering, and dynamic grouping. Also, choose 

which fields are available to be grouped and/or sorted by. 

 

Only some of the standard reports are set up to support Dynamic Grouping, 

regardless of whether this checkbox is checked. 
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The next step is to define the required groupings. In Line Item reports this determines how data is 

aggregated.  Just click ‘Next’ if you are uncertain.  The example below would be good for creating a 

BOM where you want a quantity followed by the Manufacturer and Model.  This process would 

group all like Products together.  Other useful groups could include: Category, Location, Phase, and 

Zone. 

 

Next choose a required sorting option, if desired 
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Now, set any required filters, if desired. 

 

The next screen allows you to save report parameters. 

 



Reporting Center  

Revised February 19, 2009 

508 

The final screen is a review of your report definition. Click Finish to save and start editing the 
report. 

 

The report opens and is now an Unpublished Report that can be edited. 

 

 

File -> Open 
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Allows you to open a custom report that you have already created. 

 

Existing reports are published custom reports that appear in your Reports List 

Unpublished reports are custom reports that you are still working on. They do not appear in the 

reports list until you publish them 

File -> Edit DTools Report Information 

To change the report information you entered during the New Report Wizard, use File -> Edit D-

Tools Report Information. This will re-open the wizard and allow you to change the settings, 

including report name, grouping/sorting/filtering settings, and other options. 

File -> Edit Report Definitions 

If you want to create some custom report definitions for your report, go to File -> Edit Report 

Definitions. Report definitions created here will appear in the Reports List beneath the report 

name. 

File -> Preview 

Allows you to preview your report vs. a sample project without having to publish the report or exit 

the report designer. 

File -> Save for Later 
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Use File > Save to save an unpublished copy of your report for future editing. You will need to 

publish your report later if you wish to see it in your Reports List. 

File -> Publish Report 

This will publish the report you have open so that it will appear in your Reports List. Choose this 

when you are satisfied and want to start using your custom report. Note that this will close the 

report for editing. 

There are a few additional options within the “Orders & Scheduling” Report Designer: 

 

File->Unpublish Reports – this will remove a published report from the list of reports 

in their respective interfaces. 

File->Report Permissions – Opens the following form.  Here you can select reports 

and choose what Groups have access to the report.  See the SI 5 Installation and 

Administration Guide for information on Groups. 
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Edit 

The Edit menu has an assortment of commands which are helpful when editing your custom report: 

Undo, Redo, Cut, Copy, Paste, Delete, and Select All. 

Toolbars 

There are two sets of toolbars. The first has one-click shortcuts for most of the items in the Menu 

Bar: New/Open/Save/Preview Report, Cut/Copy/Delete, Undo/Redo, and Zoom In/Out. 

 

The second set of toolbars is used for editing textboxes and other objects within your report: Font 

settings, Colors, Alignment, Indentation, and Grouping. Use these to set the properties of report 

objects when you have one or more objects selected in the Design Pane. 
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Toolbox 

The Toolbox contains a selection of objects that you can drag onto the Design Pane: Labels, Text 

Boxes, Lines, and Pictures are the most common. Text Boxes in particular can be bound to a data 

field for display in your report. 

 

To bind the text in a TextBox to a data field, select the TextBox, then go to the 

Properties area and select DataField. Type in the name of the data field (e.g. 

dtr:Price) you wish to bind to the Text Box. D-Tools Report data field names are 

found in the Data Explorer. 

Design Pane 

The Design Pane, located in the center of the Report Designer, is where you go to modify the 

layout of your report. You can drag and drop objects from the Toolbox or Data Explorer onto the 

design pane for display on your reports. 

Page Headers and Footers 

Objects in the Page Header or Page Footer sections will appear at the top or bottom of each page, 

respectively. 

Group Headers and Footers 
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Group headers affect the way the data is iterated over. Most often, groups are linked to a data 

field, such as dtr:Location or dtr:Category. This causes this section of the report to repeat itself 

once for every member of the group. 

Some reports come with special groups named GrpDynamicHeader1, 2 or 3. DO 

NOT RENAME THESE as they are used to implement dynamic (run-time) grouping. 

Similarly, the group name is in a textbox with name txtDynamicHeader1, 2 or 3, 

which should also not be renamed. 

Detail 

The Detail section shows what happens for each member of the data set. Use this section to add or 

remove data fields for each item in your report. 
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Data Explorer 

The Data Explorer is where you go to find data fields for your report. It is initially located on the 

right, as a tab behind the Report Explorer. Use the Data Explorer to browse through the XML 

structure, then drag-and-drop data fields onto the Design Pane. 

 

The Data Explorer is where you go to find data fields for your report. It is initially located on the 

right, as a tab behind the Report Explorer. Use the Data Explorer to browse through the XML 

structure, then drag-and-drop data fields onto the Design Pane. 

Most of the information you will be looking for can be found under dtr:Project. Data 

fields for specific items are found under dtr:Items/dtr:Item. 

 

D-Tools XML Structure 
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D-Tools report data is based on an XML schema that is defined here: 

http://www.d-tools.com/schemas/si5/reports/dtoolsreport.xsd 

Properties 

The properties window is where you go to change fonts, alignments, and any other properties of 

objects in your Design Pane. Select an object in the design pane first, then go to properties to 

modify the behavior of the object. 

 

http://www.d-tools.com/schemas/si5/reports/dtoolsreport.xsd
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Script 

The Script tab, located behind the Design Pane, is where you go to enter in .Net code. This allows 

you to take programmatic control of your reports. Either C# or VB.NET can be used. Note that all 

D-Tools reports have some amount of script code in them already. 

 

Custom Report Example 

To give a simple example of how to customize a report, let’s change the page header on a 

proposal. Here’s how: 

Step 1: Create a custom report based on an existing report 

1) In the Reporting Center, go to Tools > Report Designer. 

2) In the Report Designer, go to File > New… 
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3) Choose “New Report Based on Existing Report” and click Next 

 

4) Select “Proposal” from the list and click Next 
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5) Name the report “my Proposal” and enter a description 

 

6) Click ‘Next’ at all further screens until you get to ‘Finish’, then click that as well. 
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At this point the report has been created and can be edited. 
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Step 2: Modify the Page Header 

1) In the design pane, in the PageHeader1 section, click on the text that says “Proposal”. 

 

2) With the mouse, move this textbox (TextBox14) until it is aligned with the left side of the page 
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3) With the textbox still selected, go to the Properties window and set Alignment = Left 

 

4) With the textbox still selected, go to the Properties window, scroll down to the Text property, 

and replace “Proposal” with “My Proposal” 
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5) To change the image in the header, first select it with the pointer 

 

6) Now hit Delete to remove the image 
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7) To add a new image, drag and drop the Picture icon from the toolbox to the PageHeader1 

section 

 

8) In the properties window, click on the image property and browse to the desired image file on 

your hard drive 
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9) At this point you will see the image in the design pane 

 

10) You may also need to set the SizeMode and Picture Alignment properties to see all of the 

picture 
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11) Resize the image using the handles on the image. You may need to adjust the size of the 

Header area before or after you do this. 

 

 

Step 3: Preview and Publish the Report 

1) Go to File -> Preview to preview the report vs. a sample project. Close the window when done. 
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2) When satisfied, go to File -> Publish. Click ‘Yes’ at the prompt. You will be returned to the 

reporting center and your custom report will appear in your reports list. 

 

Brother Wire Labels 
When you generate the “Brother Wire Label Printer” report, you have the option of choosing from 

the stock SI 5 templates: 
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When you select a label template, a preview will display: 

 

Click the  button to print all of the labels or select just the labels that you would like to print 

(use Ctrl or Shift to select multiple labels) and click the  button. 
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All of the stock SI 5 templates are designed to work with 1” wide labels.  They are stored in the 

following location: 

XP: C:\Documents and Settings\All Users\Application Data\D-Tools\SI5\Templates 

VISTA: C:\ProgramData\D-Tools\SI5\Templates 

 

If you wish to create your own templates, we recommend that you use on of our stock templates 

as a starting point.  All editing of these templates is done with the Brother P-Touch Editor software 

that comes with your Brother PT-9500 PC/ PT-9600 PC printers. 

Example: You want to change your company logo on the 3” Flag Label. 

1) Launch the Brother P-Touch Editor applications.  If you are prompted for a 

layout, choose “Open an Existing Layout”, otherwise select File->Open: 
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2) XP Users:  Browse to the C:\Documents and Settings\All Users\Application 

Data\D-Tools\SI5\Templates folder, select the template and then click [Open]: 

3) VISTA:  C:\ProgramData\D-Tools\SI5\Templates 
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4) The template will open: 

 

5) Select and delete the existing logos. 

6) Select File->Insert->Picture->From file. 

7) Browse to your logo and click [Open].  The logo will be inserted into the editor. 

Move/resize/flip the logo until you are pleased: 
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8) XP Users:  Select File->Save As…  Name the file and save to the C:\Documents 

and Settings\All Users\Application Data\D-Tools\SI5\Templates folder. 

9) Vista Users:  C:\ProgramData\D-Tools\SI5\Templates 

For detailed information on using the Brother P-Touch Editor software, select Help->User’s Guide 

from within the application. 
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Excel Reports 
It is possible to export data directly to MS Excel by using the Excel Reports feature. This allows you 

create a custom report using Excel and have the data populate automatically based on how the 

report is run in SI. 

The basic steps to using this feature are: 

1. Create an excel file that is linked to the D-Tools SI5 XML Schema (http://www.d-

tools.com/schemas/si5/reports/dtoolsreport.xsd) 

2. Map D-Tools data fields into one or more worksheets in this file 

3. Create pivot tables, graphs, or other reports using this data 

4. Import the report into the Reports List using File > New > Excel Report from the Reporting 

Center 

5. Run the report from the Reports List just like any other report. Excel will open with the 

specific data populated. 

Sample excel reports can be downloaded here, and imported into SI5 using Tools > 

Import Report from the Reporting Center. 

http://downloads.d-tools.com/si5/documents/download_reports.html#Excel 

 

Create a Custom Excel Report File 

Link to D-Tools XML Schema 

In Excel, 

1) Go to View > Task Pane (Developer > Source in Excel 2007) 

2) Go To XML Source (dropdown) (not needed in Excel 2007) 

3) Click on XML Maps… (button) 

4) Click on Add… 

5) Copy this URL into the File Name line: 

http://www.d-tools.com/schemas/si5/reports/dtoolsreport.xsd
http://www.d-tools.com/schemas/si5/reports/dtoolsreport.xsd
http://downloads.d-tools.com/si5/documents/download_reports.html#Excel
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http://www.d-tools.com/schemas/si5/reports/dtoolsreport.xsd  

6) Click Open 

7) Select DToolsReport as the XML root node 

 

8) Click OK 

Note: You can map this same XML source more than once if you wish to map the 

XML data field more than once in the next step. 

Map the Data Fields into Excel Columns 

http://www.d-tools.com/schemas/si5/reports/dtoolsreport.xsd
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The Task Pane shows a list of all data fields available. You can drag and drop data fields directly 

from the Task Pane to an excel spreadsheet. This will add the data field to your report source data. 
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Keep adding fields until you have all of the data you wish to report on. 

 

Load Sample Data into Excel for Design 

In order create a design layout, you will need some sample data. This data will be replaced when 

you run the report from the Reporting Center, but is useful to see how your report behaves prior to 

this. 

D-Tools provides sample data in your SI5 Global Application folder (C:\Documents 

and Settings\All Users\Application Files\D-Tools\SI5\Other Files). Unzip the file 

Excel Report Sample Data.zip to get the sample data.  

VISTA:  C:\ProgramData\D-Tools\SI5\Other Files 

To load the sample data into your report, follow these steps: 

9) Go to XML > Data > Import… (Developer > Import in Excel 2007) 

10) Browse to the XML file containing the sample data (C:\Documents and Settings\All 

Users\Application Files\D-Tools\SI5\Other Files\Excel Report Sample Data.xml in this example) 

VISTA:  C:\ProgramData\D-Tools\SI5\Other Files\Excel Report Sample Data.xml 
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This will load the sample data into the spreadsheet so that you can design your report. 

 

Create Reports Based on Imported Data Columns 

Once you have imported the sample data, you can create your own report using Excel’s reporting 

features, such as Pivot Tables and Pivot Charts. See the Microsoft Excel users guide for details on 

how to do this. 

Sample excel reports can be downloaded here, and imported into SI5 using Tools > 

Import Report from the Reporting Center. 

http://downloads.d-tools.com/si5/documents/download_reports.html#Excel 

 

http://downloads.d-tools.com/si5/documents/download_reports.html#Excel
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Link Excel Report to Reporting Center 

Once you have created a custom Excel report, you can import it into the Reporting Center so that it 

will appear on your Reports List. To do this, go to the Reporting Center and to to New… Excel 

Report in the File Menu. The Add Report Dialog will appear. 

 

Enter the name of the report and a brief description. You can also choose which report category 

this will appear in. Output Format should always be “Excel” for Excel reports. Click [Browse] to 

find your custom Excel report file on your computer, then click OK to add the report to your list. 

Running an Excel Report 
At this point the Excel report will appear in your report list and can be run just like any other 

report. When you do, Excel will open and the data from your D-Tools project will be populated. 
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Report Options 
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Contract 

 None 

Cover Page 

 None 

Line Item Detail 

 Group up to 3 levels 

 Show Labor by Phase 

 Show Page Header and Footer 

 Show Model Numbers 

Project Contact Information 

 None 

Proposal (all stock Proposals) 

 Group up to 3 levels 

 Sort 

 Show Labor by Phase 

 Show Page Header and Footer 

 Show Model Numbers 

 Summarize Packages 

 Summarize Accessories 

Proposal Summary 

 Group up to 3 levels 

Scope of Work Document 

 None 

Avery Walk-Thru 5263 

 None 

Brother Wire Label Printer 

 None 

Bulk Wire Termination Report 

 None 

Wire Checklist 

Group by 1 level 

Sort 
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Wire Connections 
 Group up to 2 levels 

 Sort 

Wire Labels (By …) 

 None 

Wire Termination Report 

 None 

Check List 

 Group by 1 level 

 Sort 

Detail Cost Summary 

 Group by 1 level 

Gross Profit 

 Group by 1 level 

List Blank Items in Project 

 Sort by Price or by Hours 

Pick List 

 Group by 2 levels 

Project Hours 

 Group by 1 level 

Purchase Order Request 

 Group by 2 levels 
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Orders and Accounting 
There are four tabs on the Orders and Accounting screen: Start Page, Sales Orders, Work 

Orders, Service Orders, and Revision Management. 

 

Start Page 
This page displays a summary of existing Sales Order and Work Orders.  It also displays the name 

of the project that was selected on the Projects tab prior to clicking the Orders and Accounting tab.  
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In order to work with Sales, Work, or Service Orders the project must be checked-in.  If it is not, 

you will see a message indicating this as well as a link to check in the project: 

 

Sales Orders 
Sales Orders serve multiple functions.  They are used to track Products that are sold and are ready 

to be installed.  They are also used to pass project data (Products) to other software applications 

such as QuickBooks and Tigerpaw.  Once you have “sold” a Project, you will want to create a Sales 

Order which will include some or all of the Products in the project. 
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Use the Field Chooser button to choose what columns display.  You can also filter most columns: 

 

There are four Sales Order Statuses in SI 5: Open, In-Process, Closed, and Final.  

A Sales Order Status of Final can only be set on a Sales Order using QuickLinks.  

Final is a special status that prevents accidental modification of Sales Order 

information that is shared with the accounting system.  For more information see 

QuickLinks on pg. 582. 

Use the Sales Order Status to keep track of a product’s “Status” throughout the 

accounting process.  For example, use Open to indicate that nothing has been done 

with the Sales Order, In-Process to indicate that some of the Products in the SO 

have been “accounted for”, and Closed once you have “accounted for” all Products 

on the SO. How you choose to use Status indicator is totally up to you. 

Creating a Sales Order 

Before you can create a Sales Order, the project you plan to work with must be selected on the 

Projects tab and the project must be Checked In.  If the project is not checked in, the [New] 

button in the process below will be grayed out. 

To create a Sales Order, select the project you wish to work with on the Projects tab and then 

click the Orders and Accounting tab.  Click [New] and select Sales Order: 
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A tab is opened for the Sales Order: 

 

The “Client Information” section will populate with the client and address information from the 

Project.  The “Sales Order Details” section displays the Order #, Date, and Status (all editable). 

The “Comments (Description)” field can be used to add a description to the Sales Order by Location 

report. 

To add Products to the Sales Order, click [Add Item]: 

 

The following window opens: 
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You can use the [Select All] button or you can check off the Products individually.  Equipment and 

Labor are separated on the tabs.  You can filter a column by clicking the  button in the column of 

choice.  Once you have selected the Products that you want to add to the Sales Order, click [Add 

and Close].  The products then display on the screen: 

 

If you want to delete products, select them in the grid and click the [Delete Item]: 
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When finished, click [Save]: 

 

The Sales Order you created now displays in the grid and you have the option to run a Sales Order 

by Location report if desired: 

 

The report is generated on a tab: 
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When a Sales Order is selected, you have the options to Edit or Delete the Sales Order. 

 

Work Orders 
The Work Order function within Orders and Accounting interface allows you to create Work Orders 

for installation scheduling. We recommend that you create and reconcile Work Orders on a daily 

basis if possible rather than reconciling in bulk.  Accurate tracking of Work Orders will allow your 

product based labor estimates to improve over time. 
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Resources should be setup before creating a Work Order.  A Resource is generally considered to be 

an installer.  Click [Manage Resources]: 
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The Resource Management form opens: 

 

There are four options for a resource: Resource, Group, Type, and Code.  Resource allows you to 

edit or add Resources.  SI 5 does not use Group, Type, or Code anywhere but you may wish to use 

Group to organize your resources.  These fields are there for D-Tools clients who choose to use 

them when working with our SDK.  To edit any of these fields, use the dropdown along the top of 

the form: 
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The following form will allows you to enter information about the Resource.  Here you can enter the 

Name, Email, how much the resource costs you per hour, Type, Group, and Code. 

 

Creating a Work Order 

To create a Work Order, click [New] and select Work Order: 
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The Work Order window opens: 

 

The “Site Information” section will populate with the client and address information from the 

Project.  The “Work Order Details” section displays the Work Order #, Date, Assigned to, and 

Status (all editable). The “Assigned to” dropdown populates with the Resources that you have 

created.  The “Action Required (Description)” field can be used to add a description to the Work 

Order by Location report. 
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Adding Items vs. Adding Tasks 

Adding Items to a Work Order is the “older” methodology within SI 5 for handling Work Order 

assignments.  The newer methodology is Task based.  Work Orders that are assigned Tasks will 

display on the Project Schedule.  Both methods are described below.  Choose the one that works 

best for you. 

To add Items to the Work Order, click the [Add] button and then select Item(s): 

 

The Add Items to Order form will open: 
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To change what columns display, click the  button.  To Filter any column, click the 

 button in the column of choice. 

 

Once a Product is added to a Work Order, the Product is “flagged” so it will no longer 

be available to add to another Work Order.  This saves you the worry of duplicating 

your work.  Once you delete a Product from an existing Work Order, the flag is 

removed so that you can add the Product to another Work Order if required. 

All Estimated Install Date of the products will default to today’s date.  You can use the [Select All] 

button or you can check off the Products individually.  To change the date for the selected 

products, use the Estimated Install Date drop down: 

 

Equipment and Labor are separated on the tabs.  You can filter a column by clicking the  button 

in the column of choice.  Once you have selected the Products that you want to add to the Sales 

Order, click [Add and Close].  The products then display on the Labor and Equipment tabs on the 

Work Order form: 
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You may wish to select products from the list now and assign a resource, or, if you haven’t already, 

select an Expected Install Date.  To select products click the box next them.  Use [Ctrl] or [Shift] 

to select multiple products.  When selected, products display in gray. Click the [Assign] button: 

 

The Work Order Item Properties form opens: 

 

This form also allows you to assign the Actual Install Date and Actual Hours to the selected 

products in Work Order once the work has been done.  If you are just assigning the Assigned To 

and Expected Install Date, make sure you clear out the Actual Install Date and Actual Hrs. fields 

and uncheck the “Actual Install Hrs…” checkbox. 
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When you are finished creating the Work Order, click [Save]: 

 

The Work Order you created now displays in the grid and you have the option to run reports: 

 

You can also reopen the Work Order form once it has been saved and add Tasks: 

 

Using Tasks with Work Orders is the preferred method over adding Items as you will have much 

more control over entering your actual hours and costs.  A Work Order that has been assigned at 

least one Task will display in the Project Schedule for Scheduling purposes.  Add->Task will open 

the New Task form: 
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See New->Task on pg. 615 for details on entering Tasks. 

The Work Order form allows you to Send an Email of any of the Work Order Reports (see below): 

  

Also on this form you can generate any of the Work Order Reports for viewing and printing. 
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The reports available to you are: Job Costing by Phase, Packing List by Location, Project Analysis 

by Phase, Ship List by Location, Warehouse Labels, and Work Order by Location. Two of the reports 

require that you enter Actual Hours to the Items and/or Tasks in order to provide you data: Job 

Costing by Phase and Project Analysis by Phase. 

Save the Work Order when you are finished adding Items and/or Tasks. 

 

When a Work Order is selected you have that option of running  

 

The reports that could be run at this point are: Work Order by Location, Packing List 

by Location, Ship List by Location, and Warehouse Labels.  The Job Costing by Phase 

and Project Analysis by Phase reports require that “Actual Hours” be entered for the 

Work Order.  See “Closing out a Work Order” on below for details on adding 

Actual Hours. 
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When a Work Order is selected, you have the options to Edit or Delete the Work Order: 

 

Closing out a Work Order 

Once the work is complete, you can add your actual hours to the Work Order Items or to the Items 

assigned to the Tasks associated with Work Order.  Once actual hours are entered you can run the 

two comparison reports: Job Costing by Phase and Project Analysis by Phase. 

Open the Work Order for edit and enter Actual Hours for Equipment Items added directly to the 

Work Order and/or for the Items assigned to Tasks.   

For Equipment Items you can enter individual values in the “Act. Inst. Hrs.” column or you can 

select multiple products (use Ctrl and/or Shift keys) and click [Assign]: 
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The [Assign] button will open the following form and allow you to enter the data across multiple 

products: 

 

For Items assigned to Tasks, open the Task from within the Work Order tab and select either the 

Labor or Equipment tabs.  You can enter individual values in the “Actual Work” column or you can 

select multiple products (use Ctrl and/or Shift keys) and click [Assign]: 
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The following form will open: 

 

You can fill in the Install Date fields if you desire: 
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Change that Status of the Work Order to Closed if desired and when you are finished, click [Save]. 

 

Service Orders 
Service orders are used to schedule a time for a technician to go out to a job site, for something 

other than normal project installation. It is important to be able to quickly specify where to go, 

what to do, when to do it, what equipment to bring, and how much it will cost to do it. When the 

order is completed the technician needs to be able to update the order with how much time it 

actually took, and bill the client appropriately.  Service Orders can be pushed over to QuickBooks 

but unlike most QuickLinks functions, Service Orders are not pushed via our QuickLinks interface.  
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New/Edit/Delete – Use these to create, edit, or delete Service Orders. 

Reports – allows you to run Service Order Reports 

New->Service Order 

 

The following form opens: 
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Save – Saves the Service Order 

Add->Labor Items – opens the following form that filters your database to display just your 

Labor Products (see Labor Products on pg. 137).  This allows you to add Labor Products to a 

Service Order. 
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Add->Equipment Items - opens the following form that filters your database to display just your 

Equipment Products (everything that is not a Labor Product).  This allows you to add Products to a 

Service Order that were not part of the original project. 
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Add->Repair Items - opens the following form that allows you to add products from the project 

to the Service Order. 
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Send To: - allows you to send any of the Service Order reports (see below) to Outlook as either an 

Email, Appointment, or Task.  You can also send a Service Order over to QuickBooks, this is 

discussed here Send To->QuickBooks on pg. 574. 

 

Reports - will generate any of the following reports for the Service Order: Service Order, Service 

Order Labor Costing, Service Order Schedule.  The Reports will display on a tab within the Task 

form. 
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Details Tab 

 

Subject – name the Task 

Start/End Time – assign duration of time to the Task 

Duration – Displays the value determined by the Start/End Time fields 

Status – Choose between Not Started, In Progress, Completed, Waiting, or Deferred 
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Priority – Choose between Low, Medium, or High 

%Complete – this field allows you to manually enter how complete the Task is.  If the Status is 

set to “Completed” this will display 100%.  This field is completely independent of any Actual Work 

that you add to Equipment or Labor Items within the Task. 

Description/Job Notes – editable fields for instructions/notes/whatever 

Resources – Clicking the   button opens the following form and allows you to select resources 

to add to the Task 

 

Site Tab 
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This tab contains the Contact information and site address for the project selected.  The Site Notes 

field is another place to add any comments you desire. 

Labor Tab 
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Resources – lists the number of Resources assigned to the Task.  Use the  button to add or 

remove Resources. 

Estimated Duration – populates with the total hours for the Task based on the Equipment and 

Labor Products that you have added to the Task divided by the number of Resources assigned to 

the Task.  The value that displays here is determined by what value you select for the “Projected” 

field’s dropdown menu, see below. 

Duration – editable field that displays the value determined by the Start/End Time fields 

Projected – populates with the total hours for the Task based on the Equipment and Labor 

Products that you have added to the Task.  The value that displays here is determined by what 

value you select for the “Projected” filed, see below.  The dropdown menu allows you to choose 

between: Base, Misc, Design, Management, Install, and Total.  Install = Base + Misc.  Total = Base 

+ Misc + Design + Management. 
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Estimated – populates based on the selection from the dropdown menu.  You can use the 

Projected, Quoted, or User Defined.  “Projected” pulls from the Projected field described above. 

“User Defined” allows you to manually modify this value. “Quoted” does not pull from anywhere 

and is intended for use to “lock down” a User Defined entry.   

  

Actual – populates based on the selection from the dropdown menu.  You can select: From 

Duration, From Items, or User Defined.  User Defined allows you manually modify this field. From 

Duration will pull from the Duration field.  The From Items field populates based on the labor hours 

assigned the items. 

 

The Costs section of the form shows the dollar values of your costs based on your selections on 

this form. 
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In the Labor Items section you can [Add] or [Delete] Labor items. 

 

 

Tax Code and Est. Tax – allow you to add the appropriate tax to Labor if you charge Labor Sales 

Tax. 

 

Warranty – when the warranty column is checked, the Total Price zeros. 

 

Equipment Tab 
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This tab allows you to [Add] or [Delete] Install or Repair items. 

Warranty – when the warranty column is checked, the Total Price zeros. 

 

If you have assigned Resources to a Service Order, the Service Order will display on the Resource 

Schedule.  See Resource Calendar on pg. 627 for more details. 
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Send To->QuickBooks 

This function allows you to transfer the Products that you have added to the Labor tab and the 

Products from the Install Items section of the Equipment tab over to QuickBooks as an Estimate.  

Repair Items from the Service Order are not included in this transfer. 
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See the QuickLinks section starting on pg. 582 for details concerning transferring an Estimate to 

QuickBooks. 

Revision Management 
You may compare any two revisions and explore what was responsible for the change in total 

project installed price.  In the following example we started with the sample residential project, 

created a revision (3).  In Revision 3 we: 

• upgraded a control panel 

• added a Crestron C2N-HBLOCK 

• increased the Misc Parts% for the Finish Phase 

• increased the base labor selling price from $75.00 to $80.00 per hour   

To explore the changes you must 

1) “Check In” the project. 
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2) Select the Project in the Navigator 

3) Click the Orders and Accounting tab 

4) Click the  Revision Management tab 

5) Select any two of the revisions and click “Run” 

Then you will see: 

 

 

Select - To see the difference between two revisions check the two revisions you wish to compare 

and click “Run”.    

File Name -The names listed here are file names.  In this example you see two different names.  

“SI5 Sample” is the name of the file of the sample residential project.  The other names 

were provided by the user when a new revision was requested, which happen to 

correspond to the Project Name.  The name at the top of the list, in this case “SI5 

Sample”, is always the Current Project.  The revisions are listed under the Current Project 

in the order created.  In our example we are comparing the Current Revision with the 

OLDEST revision, (Rev 0), which may also be referred to as the Original Proposal.  

Description – The Current Revision will always be called “Project File”  
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Total Cost & Total Price - Prices shown I color indicate a change in Cost or Installed Price 

between the two revisions. 

View 

Once you “Run” the compare you may view the comparisons in three different ways as shown 

below. 

 

View: Project Overview 

From the project view you are able to identify changes that typical take place at a “Project” level.  

This would include changes to global factors or changes to Phase specific information. Expand the 

desired comparison data by clicking the “+” in the far left column.  A row with a colored font 

indicates a change has occurred for that Phase. 
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Select “Details” > “View” to open Variance Detail form.  Selecting “View” for the Finish Phase will 

open the Phase Variance Detail form.  From here it is easy to see the changes in the Phase 

information that generated a change in Installed Price.  The fields are for viewing only and cannot 

be modified. 

 

View: Equipment and Labor 
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The Equipment and Labor tracks changes to Products (Equipment and Labor).   

  

Types of changes include 

None The Product itself did not change but may be associated with a Phase or other 

global change that would affect Install Price 

Added A Product was added to this revision that was not in the previous revision 

Removed A Product was removed from this revision that was in the previous revision 

Adjusted The Products Price or the Labor Price associated with the product was 

modified.  Select “View” for that Item to see what was adjusted. 

 

View Packages 
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View > Packages allows you to see changes in packages between revisions.  In this case we a) 

increased the selling price of the Wire Assembly by 5%, b) decreased a Home Theater Speaker 

Package by 5% and c) added another Speaker Package to the project.  You Change Order reports 

will allow you to group the changes by Package. 

 

Restore 

Restore is a very powerful feature, and can be used in support a variety of business processes.  

Use restore if you want to: 

• Rollback changes you have made to the current project.  This saves a lot of time if the client 

rejects a particular change order or proposal. 

• Apply changes to a previous revision.  This can be particularly useful if you are tracking “As 

Sold” and “As Built” projects.  This allow you to have one revision that tracks only the 

changes the client has agreed to pay for (“As Sold”) while at the same time maintaining 

another revision that tracks ALL the changes to the project (“As Built”). 
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The Project MUST be Checked-Out before requesting a “Restore”.  After selecting the revisions and 

clicking “Run”, select View: > Equipment and Labor.  To execute a “Restore”, select the 

Products involved in the desired transaction and click Restore.  ONLY check the Products you need 

to complete the desired business process. 
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The following form will open.   

 

QuickLinks 
Quicklinks is a module used with SI 5 to link project information to your accounting software.  This 

module is also sometimes referred to as LinkTools.  The main purpose of QuickLinks is to reduce 

data entry time for many of the routine business tasks associated with managing projects with your 

accounting software.  Using QuickLinks, one can produce Estimates, Invoices and Purchase Orders 

with one of the supported accounting systems.  In order to work with QuickLinks, you must 

establish a connection between QuickBooks and SI 5.  Please see the SI 5 Installation and 

Administration Guide for details. 

In order to work with QuickLinks, all Products in a Project must be assigned to a corresponding 

Item Name/Number in QuickBooks.  
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Terminology – In SI 5, records in your MasterTable database are referred to as 

Products.  In QuickBooks, records in your database are referred to as Items.  SI 5 

and QuickBooks records are linked via the SI 5 Account ID field.  The Product 

Accounting ID field must match the QuickBooks Item Name/Number.  This linking is 

handled automatically by QuickLinks.  One should avoid modifying the Accounting 

ID field unless instructed to do so by your SI 5 administrator. 

With the QuickLinks interface you can create an Estimate, Invoice, or Purchase Order to export to 

QuickBooks.  To open the QuickLinks interface, select Tools->QuickLinks (you can also click the link 

if you are in the Orders and Accounting interface): 
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Interface 

The QuickLinks interface consists of one main form: 

 

View – this dropdown allows you to select whether you want to create an Estimate, Invoice, or 

Purchase Order.   

[New] – create a new Estimate, Invoice, or Purchase Order. 

[Edit] – edit an existing Estimate, Invoice, or Purchase Order. 

[Delete] – delete an existing Estimate, Invoice, or Purchase Order. 

 [Delete] will only delete the Estimate, Invoice, etc. from SI 5, it will not delete it 

from QuickBooks. 
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[Export] – use to export Estimates, Invoices, and Purchase Orders from SI 5 to QuickBooks.  This 

button is only used if you chose not to export when you create the Estimate, Invoice, or Purchase 

Order. 

[Item List] – this will open a form where you may create QuickBooks Items from SI 5 Products or 

link SI 5 Products to existing QuickBooks Items.  You can also map Customized Properties between 

the two databases (SI 5 and QuickBooks) and scan for differences between the two databases. 

[Options…] – this opens a form where you map to your QuickBooks file as well as choose your 

defaults. 

[Close] – closes the form.  

QBW File – this section displays the path to your QuickBooks company file 

Display – this section allows you to filter the display by exported vs. non-exported Estimates, 

Invoices, and Purchase Orders 

Setup and Maintenance 

Click the  [Options…] button: 

 

QBW File path – path to where your QuickBooks company file is stored 

New Item Default Type – set your default type for QuickBooks items that are created through 

QuickLinks: Inventory, Non-Inventory, or Service 
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Item Input Mask – set a mask for how QuickBooks item number will be created through 

QuickLinks.  QuickBooks has a 30 character limit for Item numbers.  See the Pre-Implementation 

section of this guide for examples. 

Add Package Name to Description in Invoices and Estimates? – Packages in SI 5 are broken 

out into the individual items when transferred to QuickBooks.  This option will add the Package 

name from SI 5 to the descriptions for the items. 

When creating Estimates and Invoices display Misc. Parts and Equip +/- on separate line 

items? – This option will add a single line item for the Misc. Parts % and a single line item for the 

Equip +/-  % to Estimates and Invoices.  Without this checked, each item’s price will reflect the %. 

When creating Estimates and Invoices use Client Description if available? – the default is 

to use the Product Description. 

You must setup the connection between Products in your SI 5 database and Items in your 

QuickBooks database.  This is an ongoing process since you will most likely be adding new Products 

to your SI 5 database all the time.  However, you only have to make the connection one time for 

each Product in your SI 5 database. 

You have two options: link Products from your SI 5 database to Items that already exist in your 

QuickBooks database or you can have SI 5 create the Items in your QuickBooks database.  Either 

of these options can be done while creating an Estimate/Invoice/Purchase Order or 

independently via the [Item List] shown below. 
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To link a Product from your SI 5 database to an existing Item in your QuickBooks database, click 

[Item List].  The SI 5 Master Table Products List form opens: 
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The left side of the form has tabs that allow you to filter the Products in your SI 5 database.  You 

can assign products to existing QuickBooks Items using the dropdown in the “Use Existing QB 

Item” section to select an item from your QuickBooks database and then click [Update].  The SI 5 

product and QuickBooks item are now linked. 

When you are creating new QuickBooks Items you can assign products one at a time or you can 

select multiple products to do a bulk transfer by holding down the [Ctrl] and [Shift] keys when 

selecting in the grid.  When you click [Create New] the following form will open where you will 

select your Item Type, Vendor, Sales Tax Code, and Accounts. 
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Although not shown in the form above, descriptions also transfer, see below for details. 

If you want to link an SI 5 Product to an existing QuickBooks Item from within an Estimate, 

Invoice, or Purchase Order, use the dropdown located the in the Item field on the form as shown 

below: 

 

If you want to create a QuickBooks Item from an SI 5 Product from within an Estimate, Invoice, or 

Purchase Order, click [Assign] on the form to open the Add QuickBooks Item form. 
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This form looks different than the form for doing a bulk a transfer but the information transferred is 

the same with one exception.  The “This item is purchased for and sold to a specific 

Customer:Job” option is only available on the form within an Estimate, Invoice, or PO. 
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The fields that populate from the SI 5 Product data are listed below: 

Add QuickLinks Form/QuickBooks 
Fields 

SI 5 Product Fields 

Description Product Description 

Sale Desc Client Description 

Cost Unit Cost 

List Unit Price 

Custom Fields 1-5 Mapped fields.  See below for details. 

The dropdown fields that populate with data from your QuickBooks company file are Sales Tax 

Code, Vendor, Income Account, Asset Account, and COGS Account. 

The fields on this form will vary depending on whether you are creating an 

Inventory, Non-Inventory, or Service Item. Remember, QuickBooks does not store a 

Cost for Non-Inventory parts, just a List.  If you would like the Cost to be transferred 

to QuickBooks when you are creating an Item, make sure you check the “This item 

is purchased for and sold to a specific Customer:Job” option on the form.  

When this is checked, an Expense Account field is added to the form.  You do not 

have this option when doing a Bulk transfer of products. 
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The Item Number/Name populates with data based on the Mask you set when you configured 

QuickLinks.  Please see the SI 5 Installation and Administration guide for details. 

Make all selections on this form and then click [OK].  The Item will be created in your QuickBooks 

database. 

Also on the SI 5 Master Table Products List form there are two additional function buttons: [Map], 

and [Sync]. 

 

Clicking [Map] will open up the QuickLinks Match Item Custom Fields form: 

 

Highlight a QB Item Property on the left, select an SI 5 Product data field from the “Match To” 

dropdown, then click [Update].  This does not play a role in overall functionality, it is just an 

optional way to add more data to the QuickBooks Items that you create via the QuickLinks 

interface. 
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Clicking [Sync] will open the “Sync SI 5 and QuickBooks” form: 

  

When you click [Scan…], a comparison takes place between all linked SI 5 Products and 

QuickBooks Items.  If differences are found, the Products/Items will list in the appropriate fields.  

Use the [Select All] button or manually check the boxes next to the Products/Items that you want 

to synchronize and then choose either [Sync from SI 5 to QuickBooks] or [Sync from 

QuickBooks to SI 5].  

Estimates 

Estimates are the main “export” from SI 5 to QuickBooks.  Once an Estimate has been exported to 

QuickBooks, you can use QuickBooks functions to create Invoices and Purchase Orders from the 

Estimate. 

A Sales Order must exist before you can use QuickLinks functionality.  See  Sales 

Orders on pg. 542 for details. 
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To create an Estimate, select “Estimate” from the View dropdown on the D-Tools QuickLinks form: 

 

Click [New].  The Select Sales Order form opens.  Select the Sales Order you want to use and 

click [OK]. 
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The QuickLinks Estimate form will open: 

  

Terminology: In SI 5, we use the terms “Client” and “Project”.  Their equivalents 

over in QuickBooks are “Customer” and “Job”. 

The “Client” section populates with information from the Sales Order.  The Customer:Job field has 
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a dropdown that is populated with Customer:Jobs from your QuickBooks database.  If you have 

created an Estimate, Invoice, or Purchase Order for this Client and Project before, you can select 

the Customer:Job from this dropdown menu.  If this is a new Customer that does not exist in 

QuickBooks, click [New Customer].  The Customer form will open.  Make edits if needed and then 

click [OK].  This will create a Customer:Job entry in QuickBooks. 

  

The “:” represents a “Parent/Child” or a “sub-item of” relationship between 

Customer and Job in QuickBooks. This format lists all Jobs beneath a “parent” 
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Customer. 

 

If the Customer already exists in QuickBooks but has not been linked to this Job, click the [New 

Job] button instead of the [New Customer] button.  You will be prompted to select a Customer: 

 

Once you select a Customer from the dropdown menu and click [OK], the Customer form (as 

shown above) will open. 

The Customer Message, Tax, and Tax Code fields have dropdown menus that populate from 

your settings in QuickBooks.  The Memo field corresponds to the Memo field in QuickBooks. 

The [Add] button opens up the Select Products form: 
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The [Check QuickBooks Inventory] button will check the inventory in QuickBooks for a selected 

Product and report how many you have on-hand and how many are on-order.  Use the 

Manufacturer, Phase, and Category filters if desired.  Check the Products that you want to add 

to the Estimate or use the [Select All] button.  Once you have made your selections, click [Add].  

The Products that you selected will display on the QuickLinks Estimate form: 

 

Once you have added a Product from the Sales Order that Product is “flagged” so 

that you cannot accidentally add it to another Estimate.  You can add it to an Invoice 

or a Purchase Order in the QuickLinks interface but you cannot add it to another 

Estimate.  

If all Products (including Labor) have been assigned Item numbers in QuickBooks, click [Save].  If 

there are any that have not been assigned, follow the procedure in the Setup and Maintenance 

section of this chapter that applies to you. 
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You cannot save an Estimate where all of the Products have not been assigned to an 

Item in QuickBooks. 

When you click [Save], you will be asked whether you want to export at this time: 

 

Clicking [Yes] will export the Estimate to QuickBooks while clicking [No] will allow you to export 

the Estimate at a later time from the main QuickLinks form (Estimates that have not been exported 

will not have a checkmark next to them.  Select the Estimate and click [Export] when ready): 

 

You will be asked if you want to mark the Sales Order’s Status to “Final”: 

 

The QuickLinks interface is the only place in SI 5 that you will be prompted to mark a Sales Order’s 

Status as “Final”.  Once a Sales Order has been marked as “Final” it locks the Sales Order i.e. all 

editing functionality for that Sales Order ceases.  Having said that, use this option only once you 

are comfortable with SI 5 functionality.  
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If you have already exported the Estimate to QuickBooks and then attempt to [Edit] or [Delete] 

the Estimate, you will be notified that any changed made here will not be reflected in QuickBooks: 

 

 

Invoices 

QuickLinks can create an Invoice to export to QuickBooks.  This function is convenient if you want 

to create an Invoice for an entire Project as opposed to an Invoice for a percentage of the entire 

Project.  This is because Invoices in QuickLinks are created by adding Products to the form as 

whole quantities only. 

If you want to create an Invoice for a percentage of a Project, create an Estimate in 

QuickLinks and export it to QuickBooks.  In QuickBooks you can convert an Estimate 

to an Invoice based on a percentage of the Estimate. 

To create an Invoice, select “Invoice” from the View dropdown on the D-Tools QuickLinks form: 
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Click [New].  The Select Sales Order form opens.  Select the Sales Order you want to use and 

click [OK]. 

  

The QuickLinks Invoice form will open: 

 

This form is almost identical to the QuickLinks Estimate form except for the added Class and Terms 

field.  This dropdown populates with Terms as they are setup in your QuickBooks company file.  

The procedure for creating an Invoice is identical to that of creating an Estimate.  Please see the 

Estimates section of this guide (see page 593) for specifics on adding Products to the 

Invoice…replace the word “Estimate” with “Invoice” in your head while reading.  
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Purchase Orders 

QuickLinks can also create Purchase Orders to export to QuickBooks. 

To create a Purchase Order, select “Purchase Order” from the View dropdown on the D-Tools 

QuickLinks form: 

 

Click [New].  The QuickLinks Purchase Order form will open: 

 

Notice that you are not prompted for a Sales Order when creating a Purchase Order.  

You will be prompted to choose a Sales Order when you begin adding Products to the 

Purchase Order. 

The Shipping Address populates with the address information you have setup in QuickBooks.  

The Vendor Name, Class, and Customer:Job fields all have dropdowns that populate based on 
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lists that you have setup for these fields in QuickBooks.  The FOB and Memo fields will transfer the 

contents that you enter to the corresponding field in QuickBooks. 

If the vendor you need does not exist, click [New Vendor].  The Vendor form will open: 

 

Fill in the fields and click [OK].  The Vendor will be created in QuickBooks. 
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To add Products to the Purchase Order, click [Add].  The Select Products form will open:  

 

Use the Sales Order dropdown menu to select the Sales Order that you want to use. 

You can create a Purchase Order for a Vendor that spans multiple Projects. Simply 

choose the Sales Order from the dropdown that contains Products that you want 

order from a particular vendor, add the Products, then choose another Sales Order... 
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The [Check QuickBooks Inventory] button will check the inventory in QuickBooks for a selected 

Product and report how many you have on-hand and how many are on-order. Use the 

Manufacturer, Phase, and Category filters if desired.  Check the Products that you want to add 

to the Purchase Order or use the [Select All] button.  Once you have made your selections, click 

[Add].  The Products that you selected will display on the QuickLinks Purchase Order form: 

 

If all Products have been assigned Item numbers in QuickBooks, click [Save].  If there are any 

that have not been assigned, follow the procedure in the Setup and Maintenance section of this 

chapter that applies to you. 
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You cannot save a Purchase Order where all of the Products have not been assigned 

to an Item in QuickBooks. If you attempt, you will be notified. 

When you click [Save], you will be asked whether you want to export at this time.   

You can also [Edit] and [Delete] Purchase Orders from the main QuickLinks form.  If you have 

already exported the Purchase Order to QuickBooks, you will be notified that any changed made 

here will not be reflected in QuickBooks: 
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Scheduling 
The Scheduling tab consists of a Project Schedule and Resources Calendar to manage your 

projects. 

 

Before proceeding, definitions are needed: 

Project Schedule - where users can create, schedule, and assign Tasks and Work Orders.  The 

Project Schedule displays as a Gantt chart 

Task – the basic unit of work to be performed for a project. They have a start date, finish date, 

estimated time, actual time, associated equipment and/or labor items, and assigned resources. 

Tasks are also a communication tool since they allow a project manager to tell a resource that they 

need to do something. This communication either happens inside of SI 5 (the resource looks up all 

tasks assigned to him), or via Outlook (tasks are pushed to Outlook, where they appear on the 

users calendar or task list). 

Summary Task – a grouping of individual Tasks and Work Orders that can be used to help 

organize and plan your Gantt chart 

Work Orders - a collection of one or more Tasks, which can be tied to a Sales Order for the 

purpose of using actual labor for billing. The primary purpose of a Work Order is to group a number 

of related Tasks for communication and reporting purposes.  See Work Orders, on pg 547 for 

more details. 

Service Orders – are billable objects that contain labor and equipment items. They are very 

similar to tasks in that they can be scheduled and appear on the resource schedule; however, they 

are different in these important ways: 

• Service orders are associated to clients, not projects  
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• They can be associated to a project but do not have to be  

• Service orders do not appear on the project schedule  

• They appear on the resource schedule only  

• Items on service orders can be entered manually or pulled from the catalog. Items on tasks 

must come from a project  

• Items on a service order can either be warranty (included free) or non-warranty (billable)  

• Service orders can be exported to QuickBooks as an invoice and/or purchase order, just like 

sales orders  

Resource – something that can only be doing one thing at a time.  Generally a resource is a 

person that is assigned a specific thing to do.  You can manage resources either via the Resource 

Calendar tab or via the Work Orders tab.   

Resource Calendar – this is where it all scheduling data comes together.  It allows project 

managers to see when Tasks and Service Orders can be scheduled based on the availability of 

resources. 

Project Schedule 
This tab allows you to create Tasks, Summary Tasks to add to the project schedule which then 

displays as a Gantt chart. You can also associate an existing Work Order to the Project Schedule as 

long as that Work Order has at least one Task associated with it.  

 

 – allows you add a Task, Summary Task, or Work Order to the schedule. 

 – edit the selected Task or Work Order 
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 – delete the selected Task, Summary Task, or Work Order 

 – find Tasks by searching 

– Move up/down selected Tasks, Summary Tasks, and Work Orders 

 – Add/Delete Resources to selected Tasks 

- prints the data in the Gantt chart 

 – two main options: Project Reports and Task Reports. The Task Reports option 

becomes active when a Task is selected in the Project Schedule. These reports will display in a tab 

within the Scheduling interface. 

 

 

 – Send to Outlook allows you email Task Reports when a Task is selected in the 

Project Schedule.  
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 – Working Hours opens a window on the right hand side of the interface that 

allows you to change the Working Hours for the project: 
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Here you set the days and hours that your Resources work.  Choose your Start Time, Week Work 

Days, Hours/Day, and Add Holidays as needed.  There are two calendar fields for adding a holiday 

range. 

 – Scale allows you to choose how much of the Gantt chart displays and is related to 

the Scale Type setting.  This accuracy of this setting is affected by how much of the display you 

have dedicated to the Gantt chart. 

 – Scale Type allows you to choose between Weeks, Months, Quarters, or 

Years. 
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 – Jump To displays a calendar that allows you to navigate the Gantt 

chart. 

To begin scheduling a project you must first select a project from the list on the left hand side of 

the interface.  You will be warned if the project you select has not been checked in.  To check in 

the project you can use the links in the upper right hand corner of the interface 
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New->Task 

 

This opens the following form: 

 

Save – Saves the Task 
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Add – allows you to add Labor Items, Install Items, or Other Items to the Task. 

 

Regardless of which you select, the Add Items to Task form will open.  The order of the tabs will 

reflect your selection: 

 

Send to Outlook - allows you to send any of the Task reports (see below) to Outlook as either an 

Email, Appointment, or Task: 

 

Reports - will generate any of the following reports for the Task: Task Item Labels, Task Labor 

Analysis, Task Labor Costing, Task Packing List, Task Ship List, and Task Summary.  The Reports 

will display on a tab within the Task form. 
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Details Tab 

 

Subject – name the Task 

Start/End Time – assign duration of time to the Task 
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Duration – Displays the value determined by the Start/End Time fields 

Use Working Hours – this will limit the time available for the Task to those hours set in the 

Working Hours interface. 

Status – Choose between Not Started, In Progress, Completed, Waiting, or Deferred 

Priority – Choose between Low, Medium, or High 

Phase – assign the Task a Phase if you desire.  This dropdown only displays the Phases that exist 

within the Project selected. 

%Complete – this field allows you to manually enter how complete the Task is.  If the Status is 

set to “Completed” this will display 100%.  This field is completely independent of any Actual Work 

that you add to Equipment or Labor Items within the Task. 

Description/Job Notes – editable fields for instructions/notes/whatever 

Resources – Clicking the   button opens the following form and allows you to select resources 

to add to the Task 
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Site Tab 

 

This tab contains the Contact information and site address for the project selected.  The Site Notes 

field is another place to add any comments you desire. 

Labor Tab 
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Resources – lists the number of Resources assigned to the Task.  Use the  button to add or 

remove Resources. 

Estimated Duration – populates with the total hours for the Task based on the Equipment and 

Labor Products that you have added to the Task divided by the number of Resources assigned to 

the Task.  The value that displays here is determined by what value you select for the “Projected” 

field’s dropdown menu, see below. 

Duration – editable field that displays the value determined by the Start/End Time fields 

Projected – populates with the total hours for the Task based on the Equipment and Labor 

Products that you have added to the Task.  The value that displays here is determined by what 

value you select for the “Projected” filed, see below.  The dropdown menu allows you to choose 

between: Base, Misc, Design, Management, Install, and Total.  Install = Base + Misc.  Total = Base 

+ Misc + Design + Management. 
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Estimated – populates based on the selection from the dropdown menu.  You can use the 

Projected, Quoted, or User Defined.  “Projected” pulls from the Projected field described above. 

“User Defined” allows you to manually modify this value. “Quoted” does not pull from anywhere 

and is intended for use to “lock down” a User Defined entry.   

  

Actual – populates based on the selection from the dropdown menu.  You can select: From 

Duration, From Items, or User Defined.  User Defined allows you manually modify this field. From 

Duration will pull from the Duration field.  The From Items field populates based on the Actual 

Work that you have entered for the Equipment and Labor Products in the Task. 

 



LinkTools  

Revised February 19, 2009 

622 

The Costs section of the form shows the dollar values of your costs based on your selections on 

this form. 

In the Labor Items section you can [Add] or [Delete] Labor items.  You can also use the 

[Assign] button to assign Actual Work to one or more items: 

 

 

 Equipment Tab 
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This tab allows you to [Add] or [Delete] Install or Other items.  You can also use the [Assign] 

button to assign Actual Work to one or more items: 
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New->Summary Task 

 

This adds a Summary Task line to the Project Schedule.  A Summary Task really contains no other 

data than the Tasks assigned to it.  A Summary Task can contain one or more Tasks.  They can 

also contain Work Orders that in turn have Tasks associated with them.  You can move Tasks in or 

out of a Summary task by using the Move Up/Down arrows in the interface.  You can move 

Summary Tasks along with all associated Tasks up or down in the list using the Move Up/Down 

arrows.  All that is editable on a Summary Task is the name.  Summary Tasks display with a [+] 

or a [-] depending on whether it is expanded or not. 
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New->Work Order 

 

This option becomes available when: 

1) A Work Order with at least one Task exists for the Project.  

2) You have selected one or more Tasks or Summary tasks in the Project Schedule. 

The Work Order form will open.  See Work Orders pg. 547 for details. 
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Resource Calendar 

 

This interface allows you to view and manage your Resources that have been assigned Tasks or 

Service Orders.  The menu bar allows you to choose set your view to Day, Week, or Month.  You 

can also Manage Resources.  The Reports button will generate the Resource Schedule report based 

on what Resources you have selected: 
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Once you have selected the Resources you wish to view, a calendar will open for each Resource.  

Only two calendars display at a time but you can toggle between Resources using the dropdown 

option at the top of each calendar: 

  

You can hover over a Task or Service Order on the calendar to see a summary or you can double-

click to open the Task or Service Order: 
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Appendix A: Data Considerations 
The following tables define the data attributes associated with the SI 5 product family. 

Product Data 
Each Product in SI 5 each must be unique.  Uniqueness is determined by combining Category, 

Manufacturer and Model (CMM).  How you choose to set up your data will be determined by what is 

most important to your particular business model.  There are tradeoffs for each of the choices.  All 

have their particular strengths and weaknesses.   

1) You wish to rely on D-Tools web data (MVP etc.):  In this case you will need to use the CMM 

provided by D-Tools.  This will allow you to receive updates as product information changes.  

However, the Categories provided may not be the ones that you would choose.  This may be 

particularly true if you elect to show Categories on you client reports.  Also, the Model#s 

provided by the Manufacturers are not always the ones you will use for order processing.  

Models may come in several colors (wall plates etc.) and as a result, a SKU or Part# is used for 

order entry.  You will need to study the data to see if this approach works best for you. 

2) You wish to use the identifier that is preferred by order processing in the Model field.  In many 

cases this is Part # not Model# (Crestron, AMX, Extron, Shure, etc.).  Using the Part# will help 

cut down on order processing errors, but you will not be able to update these Products using 

the D-Tools online data.  You may start by downloading the D-Tools data and images and then 

modifying the Model and/or Category to suit your needs. 

3) You wish to define your own Categories to make it easier to locate Products or group them on 

client reports.  This is basically the same as (2) above.   

Since Category is used to determine uniqueness, it is possible for the same Manu/Model may show 

up in multiple Categories.  This should be avoided if at all possible.  Also, a Category will be 

required for any Product that is imported via the CSV process.   
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Appendix B: Software License Agreements 
End-User License Agreement for D-Tools System Integrator 5 
 
DO NOT INSTALL OR USE THE SOFTWARE UNTIL YOU HAVE READ AND ACCEPTED ALL OF THE LICENSE TERMS.  
Permission to use the software is conditional upon your agreement with these license terms (the "License").  Installation or use of the 
software by you will be deemed to be acceptance of the License and will create a legally enforceable contract with D-Tools, Inc.  IF YOU DO 
NOT AGREE TO THE TERMS OF THIS AGREEMENT, DO NOT INSTALL THE ACCOMPANYING SOFTWARE. IF YOU HAVE INSTALLED IT, 
PROMPTLY REMOVE ALL COPIES OF IT FROM YOUR COMPUTER.    IF YOU PAID FOR THE RIGHT TO USE IT, RETURN IT IN ITS ORIGINAL 
CONDITION, WITH YOUR RECEIPT, TO THE POINT OF PURCHASE FOR A FULL REFUND. 
The installation of this program will install files necessary to operate the program onto your computer. Other system files, such as DLLs may 
be installed or updated and Windows registry entries will be made. Uninstalling the program will not remove all of the installed files or registry 
entries. As with all installations, it is recommended that you back up your hard drive before you install this program. 
  
Software License and Limited Warranty 
 
1.    GRANT OF LICENSE. D-Tools, Inc., as Licensor, grants to you, the Licensee, a non-exclusive right to use a single copy of this software 
program in object code form (hereinafter the "SOFTWARE") in accordance with the terms contained in this License Agreement. You may not: 

a. Use the SOFTWARE on more than one computer or workstation at a time, or use it on a device functioning as a file server in a 
network or a multi-user system, or in any manner make it accessible to others, including via an electronic bulletin board, web site or other 
form of electronic distribution system;  

b. Modify, translate, reverse engineer, decompile, disassemble, create derivative works based on, or copy the SOFTWARE or the 
accompanying documentation, except to the extent, if any, that this limitation or any portion of it is expressly prohibited by applicable law and 
provided that you may make a single copy of the SOFTWARE for backup purposes only;  

c. Rent, lease or sublicense any rights in the SOFTWARE or accompanying documentation in any form to any person without the 
prior written consent of D-Tools, Inc., which, if given, is subject to the transferee's consent to the terms and conditions of this License;  

d. Remove any proprietary notices, labels, or marks on the SOFTWARE, documentation, and containers. 
 
2.    OWNERSHIP OF SOFTWARE. D-Tools, Inc. retains the copyright, title and ownership of the SOFTWARE and the written materials 
regardless of the form or media in or on which the original and other copies may exist. 
 
3.    TRANSFERS. You may transfer the SOFTWARE from one of your computers to another computer or person provided that the SOFTWARE 
is transferred without modification and, if the SOFTWARE is transferred to another person, that person agrees to be bound by the terms of 
this License, you obtain the written consent of D-Tools, Inc. prior to transferring the SOFTWARE, and you deliver to that person all existing 
copies of the SOFTWARE (or destroy any copies that are not delivered to that person), including the original and any installed or backup 
copies.  
 
4.    TERM. The license granted under this License commences upon the installation of the SOFTWARE after acceptance of the terms of this 
License and is effective until terminated as provided herein. You may terminate this License at any time by destroying all copies of the 
SOFTWARE or by returning them to D-Tools, Inc.  D-Tools, Inc. may terminate this License if you fail to comply with any of the terms and 
conditions of this License Agreement.  Upon such termination, you agree to destroy or return the original and all copies of the SOFTWARE. 
 
5.    US GOVERNMENT RIGHTS. The SOFTWARE is commercial computer software developed exclusively at private expense, and in all 
respects is proprietary data belonging to D-Tools, Inc. or its suppliers.  (a) Department of Defense End Users. If the SOFTWARE is acquired 
by or on behalf of agencies or units of the Department of Defense (DoD), then, pursuant to DoD FAR Supplement Section 227.7202 and its 
successors (48 C.F.R. 227.7202) the Government's right to use, reproduce or disclose the SOFTWARE is subject to the restrictions of this 
Agreement.  (b) Civilian Agency End Users. If the SOFTWARE is acquired by or on behalf of Civilian agencies of the U.S. Government, then, 
pursuant to FAR Section 12.212 and its successors (47 C.F.R. 12.212), the Government's right to use, reproduce or disclose the SOFTWARE is 
subject to the restrictions of this Agreement. 
 
6.    LIMITED WARRANTY.  D-Tools, Inc. warrants the media on which the SOFTWARE is furnished to be free of defects in material and 
workmanship, under normal use, for a period of ninety (90) days following the date of delivery to you. In the event of defects, D-Tools Inc.' 
sole liability shall be to replace the defective media which has been returned to D-Tools, Inc. or the supplier with your dated invoice, and is 
shown to be defective. In the event that D-Tools, Inc. is unable to replace defective media, D-Tools, Inc. shall refund your money upon your 
termination of this License.  THE ABOVE IS THE ONLY WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT 
LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, THAT IS MADE BY D-TOOLS, 
INC., ON THIS D-TOOLS, INC. PRODUCT.  NO ORAL OR WRITTEN INFORMATION OR ADVICE GIVEN BY D-TOOLS, INC., ITS DEALERS, 
DISTRIBUTORS, AGENTS OR EMPLOYEES SHALL CREATE A WARRANTY OR IN ANY WAY INCREASE THE SCOPE OF THIS WARRANTY AND 
YOU MAY NOT RELY ON ANY SUCH INFORMATION OR ADVICE. YOU MAY HAVE OTHER RIGHTS, WHICH VARY FROM STATE TO STATE. 
 
7.    THE SOFTWARE AND ACCOMPANYING DOCUMENTATION (INCLUDING INSTRUCTIONS FOR USE) ARE PROVIDED "AS IS" WITHOUT 
WARRANTY OF ANY KIND EXCEPT FOR THE EXPRESS MEDIA WARRANTY IN SECTION 6 ABOVE.  FURTHER, D-TOOLS, INC. DOES NOT 
WARRANT, GUARANTEE, OR MAKE ANY REPRESENTATIONS REGARDING THE USE, OR THE RESULTS OF USE, OF THE SOFTWARE OR 
DOCUMENTATION IN TERMS OF CORRECTNESS, ACCURACY, RELIABILITY, CURRENTNESS, OR OTHERWISE. YOU ASSUME THE ENTIRE 
RISK AS TO THE RESULTS AND PERFORMANCE OF THE SOFTWARE. IF THE SOFTWARE OR WRITTEN MATERIALS ARE DEFECTIVE YOU, 
AND NOT D-TOOLS, INC. OR ITS DEALERS, DISTRIBUTORS, AGENTS, OR EMPLOYEES, ASSUME THE ENTIRE COST OF ALL NECESSARY 
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SERVISCNG, REPAIR OR CORRECTION.  YOU ACKNOWLEDGE THAT THE SOFTWARE IS INTENDED TO BE USED SOLELY FOR COMMERSCAL 
BUSINESS PURPOSES AND IS NOT A CONSUMER PRODUCT. 
 
8.    NEITHER D-TOOLS, INC. NOR ANYONE ELSE WHO HAS BEEN INVOLVED IN THE CREATION, PRODUCTION OR DELIVERY OF THIS 
PRODUCT SHALL BE LIABLE FOR ANY DIRECT, INDIRECT, CONSEQUENTIAL OR INSCDENTAL DAMAGES (INCLUDING DAMAGES FOR LOSS 
OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, AND THE LIKE) ARISING OUT OF THE USE OR 
INABILITY TO USE SUCH PRODUCT EVEN IF D-TOOLS, INC. HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. 
 
9.   Should any other warranties be found to exist, such warranties shall be limited in duration to ninety (90) days following the date of 
delivery to you. In no event will D-Tools, Inc.' liability for any damages to you or any other person exceed the amount paid for the license to 
use the SOFTWARE. 
 
10. This License shall be governed and construed in accordance with the laws of the State of California and shall be binding on and inure to 
the benefit of D-Tools, Inc., its successors and assigns.  
 
Database License Agreement 
Use of the data in the D-Tools, Inc.  database is subject to the following terms and conditions: 
 
Rights in Data: D-Tools, Inc. is providing limited access to the data contained in this database (the "Data") under the licensed described 
below.  Except for the limited use rights granted through this license, all right, title and interest in the Data are and will continue to be the 
exclusive property of D-Tools, Inc. and its licensors. 
 
Registered Customers Only:  In order to use the Data, you must be an authorized licensee of a D-Tools, Inc. application and must have 
registered as a D-Tools, Inc. customer with the appropriate passwords for the "members only" section of the D-Tools, Inc. www site.  Such 
authorized customers are referred to as "Licensees." 
Limited License:  D-Tools, Inc. hereby grants Licensee a non-exclusive, non-transferable, limited license to access the Data solely for use with 
the D-Tools, Inc. applications and for no other purpose.  This license includes the right to download, install and store the Data ("Downloaded 
Data") using the D-Tools, Inc.  installer application provided for this purpose to a storage device under Licensee's exclusive control solely (i) to 
display internally such Downloaded Data and (ii) to quote and excerpt from such Downloaded Data by electronic cutting and pasting or other 
means in work product created by Licensee in the regular course of its work using the D-Tools, Inc. application. Licensee may also create 
printouts of Data for internal use and for distribution to third parties only for purposes of planning and implementing individual projects using 
the Data in connection with the planning, bidding, purchasing, constructing and billing processes. 
 
Limitations:  No person or entity who does not qualify as a Licensee under the above definition may access the Data or use the Data for any 
purpose.  With respect to Licensees: Except as expressly provided in this License Agreement, Licensee may not copy, download, store, 
publish, transmit, transfer, sell or otherwise use the Data, or any portion of the Data, in any form or by any means. Downloaded Data shall 
not be stored or used in an archival database or other searchable database except as part of the D-Tools, Inc.  application. Licensee shall not 
sell, license or distribute Data (including printouts and Downloaded Data) to third parties or use Data as a component of or as a basis for any 
material offered for sale, license or distribution. 
 
Notice to SI4 and SI3 upgrade users  
If you are upgrading from a previous version of System Integrator, the licenses for your previous versions will expire 180 days after you install 
SI5 and will not be available after that date. Contact D-Tools support for more information. 
 
 
 
End-User License Agreement for Microsoft Office Visio® 2007 

These license terms are an agreement between the licensor of the software application or suite of applications with which you acquired the 

Microsoft software (“Licensor”) and you.  Please read them.  They apply to the software that accompanies these license terms, which includes 

the media on which you received it, if any.  The terms also apply to any Microsoft 

updates, 

supplements, and 

Internet-based services 

for this software, unless other terms accompany those items.  If so, those terms apply. Microsoft Corporation or one of its affiliates 

(collectively, “Microsoft”) has licensed the software to Licensor. 

BY USING THE SOFTWARE, YOU ACCEPT THESE TERMS.  IF YOU DO NOT ACCEPT THEM, DO NOT USE THE SOFTWARE.  

INSTEAD, RETURN IT TO THE PLACE OF PURCHASE FOR A REFUND OR CREDIT.   
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AS DESCRIBED BELOW, USING THE SOFTWARE ALSO OPERATES AS YOUR CONSENT TO THE TRANSMISSION OF CERTAIN 

COMPUTER INFORMATION DURING ACTIVATION, VALIDATION AND FOR INTERNET-BASED SERVICES. 

These terms supersede any electronic terms which may be contained within the software. If any of the terms contained within the software 

conflict with these terms, these terms will control.  

IF YOU COMPLY WITH THESE LICENSE TERMS, YOU HAVE THE RIGHTS BELOW FOR EACH LICENSE YOU ACQUIRE. 

OVERVIEW.  These license terms permit installation and use of one copy of the software on one device, along with other rights, all as 
described below. 

INSTALLATION AND USE RIGHTS.  Before you use the software under a license, you must assign that license to one device.  That device 
is the “licensed device.”  A hardware partition or blade is considered to be a separate device.   

Licensed Device.  You may install and use one copy of the software on the licensed device. 

Portable Device.  You may install another copy on a portable device for use by the single primary user of the licensed device. 

Separation of Components.  The components of the software are licensed as a single unit.  You may not separate the components 
and install them on different devices. 

      ADDITIONAL LICENSING REQUIREMENTS AND/OR USE RIGHTS. 

Remote Access. The single primary user of the licensed device may access and use the software installed on the licensed device 
remotely from any other device.  You may allow other users to access the software to provide you with support services.  You do 
not need additional licenses for this access. No other person may use the software under the same license at the same time for any 
other purpose. 

Media Elements and Templates.  You may copy and use images, clip art, animations, sounds, music, shapes, video clips and 
templates provided with the software and identified for such use in documents and projects that you create.  You may distribute 
those documents and projects non-commercially.  If you wish to use these media elements or templates for any other purpose, go 
to www.microsoft.com/permission to learn whether that use is allowed. 

Font Components. While the software is running, you may use its fonts to display and print content. You may only 

embed fonts in content as permitted by the embedding restrictions in the fonts; and 

temporarily download them to a printer or other output device to help print content. 

Multiplexing.  Hardware or software you use to 

pool connections, or 

reduce the number of devices or users that directly access or use the software 

(sometimes referred to as “multiplexing” or “pooling”), does not reduce the number of licenses you need. 

Trial and Conversion.  Some or all of the software may be licensed on a trial basis.  Your rights to use trial software are limited to the 
trial period.  The trial software and length of the trial period are set forth during the activation process.  You may have the option to 
convert your trial rights to subscription or perpetual rights.  Conversion options will be presented to you at the expiration of your 
trial period.  After the expiration of any trial period without conversion, most features of the trial software will stop running.  At that 
time you can continue to open, view and print any documents you created with the trial software. 

Subscription Software.  If you licensed the software on a subscription basis, your rights to use the software are limited to the 
subscription period.  You may have the option to extend your subscription or convert to a perpetual license.  If you extend your 
subscription, you may continue using the software until the end of your extended subscription period.  See the software activation 
screens or other accompanying materials for subscription details.  After the expiration of your subscription, most features of the 
software will stop running.  At that time you can continue to open, view and print any documents you created with the software. 

Pre-Activation. If you acquired an edition other than Microsoft Office Ultimate 2007, some functionality is licensed for your use only 
until you activate the software or the end of the time recommended for activation, whichever comes first.   

Home Use Rights Edition.  If you licensed a Home Use Rights edition, the licensed device must be used primarily within your home. 

Development Tools.  The software may contain Microsoft Visual Studio Tools for Applications or other development tools.  You may 
use any development tools included in the software only to design, develop, test, use and demonstrate your programs with the 
software. 

MANDATORY ACTIVATION.  Activation associates the use of the software with a specific device. During activation, the software will send 
information about the software and the device to Microsoft. This information includes the version, the license version, language and the 
product ID of the software, Internet protocol address of the device and information derived from the hardware configuration.  For more 
information, see www.microsoft.com/piracy/activation.mspx.   BY USING THE SOFTWARE, YOU CONSENT TO THE TRANSMISSION OF 
THIS INFORMATION.  After the time recommended for activation expires, your rights to use the software will be limited until the 
software is activated.  This is to prevent its unlicensed use.  You can activate the software by Internet or telephone; Internet and 

http://www.microsoft.com/permission
http://www.microsoft.com/piracy/activation.mspx
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telephone service charges may apply.  Some changes to your computer components or the software may require you to reactivate the 
software.  THE SOFTWARE WILL REMIND YOU TO ACTIVATE UNTIL YOU DO. 

VALIDATION. 

The software will from time to time update or require download of the validation feature of the software.  Validation verifies that the 
software has been activated and is properly licensed.  Validation also permits you to use certain features of the software or to 
obtain additional benefits. For more information, see www.microsoft.com/genuine/office/WhyValidate.aspx. 

During a validation check, the software will send information about the software to Microsoft. This information includes the version of the 
software and the product key.  Microsoft does not use the information to identify or contact you.  BY USING THE SOFTWARE, YOU 
CONSENT TO THE TRANSMISSION OF THIS INFORMATION.  For more information, see 
www.microsoft.com/genuine/office/PrivacyInfo.aspx. 

If the software is not properly licensed, the functionality of the software may be affected.  For example, you may need to reactivate the 
software, or receive reminders to obtain a properly licensed copy of the software, or not obtain certain updates, upgrades or 
services from Microsoft. 

You may only obtain updates or upgrades for the software from Microsoft or authorized sources.  For more information on obtaining 
updates from authorized sources, see www.microsoft.com/genuine/downloads/faq.aspx. 

INTERNET-BASED SERVICES.  Microsoft provides Internet-based services with the software.  Except as otherwise noted in materials 
accompanying a service, it may change or cancel them at any time. 

Consent for Internet-Based Services.  The software features described below connect to Microsoft or service provider computer 
systems over the Internet.  In some cases, you will not receive a separate notice when they connect.  Unless otherwise noted, you 
may switch off these features or not use them.  For more information about these features, see www.office.microsoft.com/en-
us/FX010986541033.aspx.  BY USING THESE FEATURES, YOU CONSENT TO THE TRANSMISSION OF THIS INFORMATION.  
Microsoft does not use the information to identify or contact you. 

Computer Information.  The following features use Internet protocols, which send to the appropriate systems computer information, 

such as your Internet protocol address, the type of operating system, browser and name and version of the software you are using, 

and the language code of the device where you installed the software.  Microsoft uses this information to make the Internet-based 

services available to you. 

Web Content Features.  Features in the software can retrieve related content from Microsoft and provide it to you.  Examples of 

these features are clip art, templates, online training, online assistance and Appshelp.  You may choose not to use these web 

content features. 

Digital Certificates.  The software uses digital certificates.  These digital certificates confirm the identity of Internet users sending 

X.509 standard encrypted information.  They also can be used to digitally sign files and macros to verify the integrity and 

origin of the file contents.  The software retrieves certificates and updates certificate revocation lists using the Internet, when 

available. 

Information Rights Management.  The software contains a feature that allows you to create content that cannot be printed, copied 

or sent to others without your permission. You may need to connect to Microsoft to use this feature for the first time. Once a 

year, you may need to re-connect to Microsoft to update it. For more information, go to www.office.microsoft.com/en-

us/assistance/HA010397891033.aspx.  You may choose not to use this feature. 

Misuse of Internet-based Services.  You may not use these services in any way that could harm them or impair anyone else’s use of 
them.  You may not use the services to try to gain unauthorized access to any service, data, account or network by any means. 

SCOPE OF LICENSE.  The software is licensed, not sold. This agreement only gives you some rights to use the software.  Licensor and 
Microsoft reserve all other rights.  Unless applicable law gives you more rights despite this limitation, you may use the software only as 
expressly permitted in this agreement.  In doing so, you must comply with any technical limitations in the software that only allow you to 
use it in certain ways.  For more information, see www.microsoft.com/licensing/userights.  You may not: 

work around any technical limitations in the software; 

reverse engineer, decompile or disassemble the software, except and only to the extent that applicable law expressly permits, despite 

this limitation; 

make more copies of the software than specified in this agreement or allowed by applicable law, despite this limitation; 

publish the software for others to copy; 

http://www.microsoft.com/genuine/office/WhyValidate.aspx
http://www.microsoft.com/genuine/office/PrivacyInfo.aspx
http://www.microsoft.com/genuine/downloads/faq.aspx
http://www.office.microsoft.com/en-us/FX010986541033.aspx
http://www.office.microsoft.com/en-us/FX010986541033.aspx
http://www.office.microsoft.com/en-us/assistance/HA010397891033.aspx
http://www.office.microsoft.com/en-us/assistance/HA010397891033.aspx
http://www.microsoft.com/licensing/userights
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use the software in any way that is against the law; 

rent, lease or lend the software; or 

use the software for commercial software hosting services. 

BACKUP COPY.  You may make one backup copy of the media.  You may use it only to reinstall the software. 

DOCUMENTATION.  Any person that has valid access to your computer or internal network may copy and use the documentation for your 
internal, reference purposes. 

NOT FOR RESALE SOFTWARE.  You may not sell software marked as “NFR” or “Not for Resale.” 

ACADEMIC EDITION SOFTWARE.  You must be a “Qualified Educational User” to use software marked as “Academic Edition” or “AE.”   If 
you do not know whether you are a Qualified Educational User, visit www.microsoft.com/education or contact the Microsoft affiliate 
serving your country. 

HOME USE RIGHTS SOFTWARE.  You must be a “Home Use Rights User” to use software marked as “Home Use Rights Edition.”  To be a 
Home Use Rights User, you must be both: 

an employee of an organization that has a Microsoft Volume License agreement with Software Assurance, and 

the user of a licensed copy of the software, or a product that includes the software, with active Software Assurance.   

UPGRADE OR CONVERSION.  To upgrade or convert software, you must first be licensed for the software that is eligible for the upgrade or 
conversion.  Upon upgrade or conversion, this agreement takes the place of the agreement for the software you upgraded or converted 
from.  After you upgrade or convert, you may no longer use the earlier version of the software you upgraded or converted from. 

REASSIGN TO ANOTHER DEVICE.  You may reassign the license to a different device any number of times, but not more than one time 
every 90 days.  If you reassign, that other device becomes the “licensed device.”  If you retire the licensed device due to hardware 
failure, you may reassign the license sooner. 

TRANSFER TO A THIRD PARTY.  The first user of the software may make a one-time transfer of the software, and this agreement, directly 
to another end user as part of a transfer of the integrated software turnkey application or suite of applications (the “Unified Solution”) 
delivered to you by or on behalf of the Licensor solely as part of the Unified Solution.  The first user must uninstall the software before 
transferring it separately from the device.  The first user may not retain any copies. Before any permitted transfer, the end user must 
agree that this agreement applies to the transfer and use of the software. 

EXPORT RESTRICTIONS.  The software is subject to United States export laws and regulations.  You must comply with all domestic and 
international export laws and regulations that apply to the software.  These laws include restrictions on destinations, end users and end 
use.  For additional information, see www.microsoft.com/exporting. 

ENTIRE AGREEMENT.  This agreement, any addendum or amendment included with the software, and the terms for supplements, updates 
and Internet-based services that you use, are the entire agreement for the software. 

LEGAL EFFECT.  This agreement describes certain legal rights.  You may have other rights under the laws of your state or country.  You may 
also have rights with respect to the Licensor from whom you acquired the software.  This agreement does not change your rights under 
the laws of your state or country if the laws of your state or country do not permit it to do so. 

NOT FAULT TOLERANT.  THE SOFTWARE IS NOT FAULT TOLERANT.  LICENSOR HAS INDEPENDENTLY DETERMINED HOW TO 
USE THE SOFTWARE IN THE INTEGRATED SOFTWARE APPLICATION OR SUITE OF APPLICATIONS THAT IT IS 
LICENSING TO YOU, AND MICROSOFT HAS RELIED ON LICENSOR TO CONDUCT SUFFICIENT TESTING TO DETERMINE 
THAT THE SOFTWARE IS SUITABLE FOR SUCH USE. 

NO WARRANTIES BY MICROSOFT.  YOU AGREE THAT IF YOU HAVE RECEIVED ANY WARRANTIES WITH REGARD TO EITHER 
(A) THE SOFTWARE, OR (B) THE SOFTWARE APPLICATION OR SUITE OF APPLICATIONS WITH WHICH YOU ACQUIRED 
THE SOFTWARE, THEN THOSE WARRANTIES ARE PROVIDED SOLELY BY THE LICENSOR AND DO NOT ORIGINATE FROM, 
AND ARE NOT BINDING ON, MICROSOFT. 

NO LIABILITY OF MICROSOFT FOR CERTAIN DAMAGES.  TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, 
MICROSOFT SHALL HAVE NO LIABILITY FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL OR INCIDENTAL DAMAGES 
ARISING FROM OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THE SOFTWARE OR THE SOFTWARE 
APPLICATION OR SUITE OF APPLICATIONS WITH WHICH YOU ACQUIRED THE SOFTWARE, INCLUDING WITHOUT 
LIMITATION, PENALTIES IMPOSED BY GOVERNMENT.  THIS LIMITATION WILL APPLY EVEN IF ANY REMEDY FAILS OF 
ITS ESSENTIAL PURPOSE.  IN NO EVENT SHALL MICROSOFT BE LIABLE FOR ANY AMOUNT IN EXCESS OF TWO HUNDRED 
FIFTY U.S. DOLLARS (US$250.00). 

Microsoft is a registered trademark of Microsoft Corporation in the United States and/or other countries. 

http://www.microsoft.com/education
http://www.microsoft.com/exporting


Appendix B  

Revised February 19, 2009 

638 

Appendix C:  D-Tools Contact Information 
Offices 

Western U.S. Office 
1850 Gateway Blvd – Suite 1060 
Concord, CA  94520 
Phone: 925.681.2326 
Fax: 925.681.2900 
Web: http://www.d-tools.com 
 
Mid-Western U.S. Office 
2001 Crocker Road – Suite 220 
Westlake, OH  44145 
Phone: 925.681.2326 
Fax: 925.681.2900 
 
Eastern U.S. Office 
2839 Paces Ferry Road – Suite 370 
Atlanta, GA  30339 
Phone: 770.444.3101 
Fax: 770.444.3991 

Sales: 
Phone: 866.386.6571, Option 1 
Email: sales@d-tools.com 

Training: 
Phone: 866.386.6571, Option 3 
Email: training@d-tools.com 

Consulting: 
Phone: 866.386.6571, Option 1 
Email: consulting@d-tools.com 

Administration 
Phone: 866.386.6571, Option 0 
Email: info@d-tools.com 

Technical Support 
Phone: 866.386.6571, Option 2 
Email: support@d-tools.com 
Web: http://www.d-tools.com/site/support/contact.html 
Forum: http://www.d-tools.us 

Manufacturer Vantage Point (MVP) Program: 
Phone: 866.386.6571, Option 5 
Email: mvp@d-tools.com 

Index

http://www.d-tools.com/
mailto:sales@d-tools.com
mailto:training@d-tools.com
mailto:consulting@d-tools.com
mailto:info@d-tools.com
mailto:support@d-tools.com
http://www.d-tools.com/site/support/contact.html
http://www.d-tools.us/
mailto:mvp@d-tools.com
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A 
Abbreviations 

Proper Case, 31 
Accessories 

Add Using MMPD, 82 
Add Using Product Tree, 83 
Adding via MMPD Interface, 85 
Appearing automatically on drawings, 87 
Automatically Add or Not, 87 
Delete Using MMPD, 82 
Edit Visualizations, 87 
How They Show Up On Visio Drawings, 87 
Managing Acccessories Example, 88 
Packages, 94 
Prompt Checkbox, 87 
Recommend Checkbox, 87 

Accessories Tab, 82 
Accessory 

Defined, 22 
Management, 23 

Accounting 
Item Number, 76 
Vendor Name, 76 

Accounting Considerations, 26 
Accounting Data, 76 
Accounting ID, 29 
Accounting Rates, 26 
Active Reports, 500 
Add 

Accessories to Product w/ MMPD, 82 
Accessories to Product With MMPD, 85 
Adding Products to the Database, 121 
Columns in MMPD Grid View, 113 
Image to Product, 72 
Manufacturer to Database, 71 
Package, 305, 357 
Packages to Project, 298, 357 
Product, 305, 357 
Product Category to Database, 71 
Product To Database by Copying Product, 

142 
Product to Database using MMPD, 112, 117 
Product To Database w/Product Explorer, 136 
Product To Database w/Product Grid, 134 
Product to Estimate, 599 
Product to Page using Shape, 362 
Product to PDM (Drag Drop), 361 
Product/Package to PDM, 266 
Products to Project, 298, 357 

Products/Packages, 360 
Add a File to The Project, 215 
Add Package Form, 359 
Add Product Form, 358 
Add Product w/Stencil Tree, 361 
Administration, 67 
Alternate View, 378 
Amps, 77 
Approve Products, 124 
Approved 

Product Status, 71 
Asset Account, 591 
Assign 

Head End, 312, 386 
Assign Locations and Zones by Drag Drop, 300 
Assigning Locations and Zones, 364 
Australia 

GST, 59 
AutoCAD, 70, 77, 78, 83, 161, 270, 344, 345, 

346, 348, 403, 404, 405, 409, 410, 411, 412, 
413, 414, 415, 417, 418, 425, 452, 458 
Add Packages, 446 
Add Products, 446 
Assign Locations, 452 
Assign Zones, 452 
Block Mapping, 83 
Block Tree, 418 
Block Types, 427 
Change Block, 456 
Change Sheet Type, 425 
Correcting Common Errors, 346 
Create Drawing From Vision, 413 
Create Package, 103 
Design Center, 444 
Dock, 454 
Drawing Area, 422 
Elevation Blocks, 433 
Elevation Sheet, 432 
Find Block, 454 
Find In Project, 455 
Generic Blocks, 427 
Insert Alternate View, 456 
Insert Sheet, 424 
Insert Units, 347 
Line Sheet, 430 
Link To D-Tools, 458 
Low Voltage Icon Blocks, 430 
Manufacturer Specific Blocks, 429 
Model Space, 346 
New Project, 426 

Paper Space, 346 
Paper Space Sheets, 441 
Plan Blocks, 436 
Plan Sheet, 435 
Project Summary, 422 
Replace Logo, 441 
Right-Click Commands, 453 
Scale Plan Blocks, 436 
Schematic Blocks, 440 
Schematic Drawing Sheet, 439 
Specialized Generic Blocks, 428 
Wire and Cable Blocks, 438, 440 
Wire Options, 465 
Write Block, 347 
Zoom Extents, 346 

AutoCAD Command 
audit, 409 
Base, 409 
purge, 408 
units, 406 
wblock, 405 
xref, 406 
zoom, 406 

AutoCAD Drawing Properties, 412 
AutoCAD File 

Insert Into Vision, 410 
AutoCAD Files, 198 
AutoCAD to Visio, 403 
AutoLayout, 400 
AutoWire, 392, 396, 397 

B 
Background Page 

Creating a, 357 
Background Title Page, 351 
Billing 

Percentage, 26 
Progress, 26 

Block Tree, 418 
Refresh, 418 

Blocks, 418 
By Manufacturer, 420 
Create w Categories, 424 
Custom, 421 

Brother Wire Labels, 526 
Brother Wire Labels, 440 
BTU, 77 
Bug Reporting, v 
Business Manager, 541, 547 
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Reports, 503 

C 
Cabinet Tools, 421, 434 

Choose Wood Fill), 340 
Cabinet Tools), 339 
Canada 

PST, 59 
Canada GST, 59 
Case Exceptions, 31 
Case Settings, 31, 70 
Categories Defined, 31 
Category 

Add, 161 
Add to Database, 71 
Delete, 161 
Edit, 161 
Filter Products By Category in MMPD, 119 
Labor, 137 
Use in AutoLayout, 400 
Use in Standard Rules, 397 

Change Management, 247 
Change Order Process, 254 
Change Page Type, 370 
Change Shape, 379 
Change Sheet Type, 425 
Chart 

Change Management, 249 
Change Order Process, 255 
Engineering Process, 252 

Choose Screen Fill, 336 
Class 

Product, 68 
CLient, 226 
Client Description, 73 
Client Name, 199, 272 
COGS Account, 591 
Color Indicators for Terminal Match, 393 
Columns, 112, 267, 300 

Add Columns in MMPD Grid View, 113 
Remove From Grid View Using MMPD, 113 

Columns and Grouping, 300 
Company Information, 30 
Company Logo, 30, 44 
Component ID, 56, 271, 279, 315 

Defined, 30, 55 
Format, 30 
Recalculate, 315 

Regenerate, 315 
Set Default, 55 
Type Field, 55 
Value Selection, 56 

Contract Percentages, 239 
Set Defaults, 54 

Copy 
Make Copy of a Product Using MMPD, 112, 

117 
Product, 142 

Copy Project, 207 
Cover Page, 323, 325, 351 
Cover Sheet, 326 
Create New AutoCAD Drawing, 217 
Create New Project, 207, 224 
Create New Visio Drawing, 216 
Creating a AutoCAD Project, 426 
Creating a Visio Project, 323 
Creating a Wiring Diagram. See Schematic 
CSV 

Adding Product w/CSV, 142 
Currency Symbol, 26, 286 
Current Project, 209 
Current Revision 

Defined, 256 
Custom Properties, 47, 161, 165, 280 

Data Types, 165 
Name or Rename, 165 
Project, 240 
Reports, 47 

Custom Reports 
Based on Existing Reports, 502 
Bind Data to Text Field, 512 
Brother Wire Labels, 526 
Create Pivot Tables, 536 
Data Explorer, 514 
Data Properties, 515 
Data Structure, 515 
Edit Existing, 509 
Edit Report Definition, 509 
Edit Report Info, 509 
Example, 516 
Excel, 532 
Excel Import, 537 
Filters, 507 
Grouping Data, 506, 513 
Parameters, 507 
Publish, 510 

Tips for Creating, 504 
Toolbox, 512 
Unpublished, 509 

Custom Scale, 412 
Cut Sheets, 71 

D 
Data 

Download D-Tools Data Example, 125 
Downloading Online Data, 121 
Managing Online Data, 122 
MVP, 121 
Previewing Before Download, 123 
Subscription Service, 121 

Data Management, 22 
Data Subscription, 121, 308 
Database 

Add Product by Copying, 142 
Add Product From Product Grid, 134 
Add Product w/Product Explorer, 136 
Adding Products, 22, 121 
Administration, 161, 166 
Backup & Restore (local), 166 
Compact (local), 166 
CSV Import Template, 144 
Display Products and Packages, 264 
Edit Category, 161 
Edit I/O Lists, 162 
Edit Manufacturer, 162 
Exporting Products to Excel, 158 
Importing From Excel, 142 
Importing Products w/Spreadsheets, 142 
Set Case Format, 164 
Starting From Scratch, 22 

Database Deployment, 21 
Date Format, 26, 286 
Death & Taxes, 26 
Default 

Pricing Method, 75 
Default Settings, 41 
Default Shape, 361 
Default Wire Length, 44, 286 

Defined, 31 
Delete 

Accessories w/MMPD, 82 
Products From Database w/MMPD, 117 
Products/Packages in PDM, 266 

Delete File, 216 
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Deployment Guide, 19 
Depth, 77, 135, 380 
Disconnecting from the Network, 22 
Discontinued Products, 71 

Display in MMPD, 112 
Display Docked Stencil, 321, 382 
Documentation 

Online, v 
Tutorial, v 

Download, 67 
Drawing Area, 319, 322, 371, 417, 452 
Drawing Page 

Adding Accessories to..., 87 
Drawing Scale, 326, 345, 411, 412 

Architectural, 411 
Drawing Template, 325 
Drawings 

Export to html, 367 
D-Tools 

Options, 280 
D-Tools Product Database, 22 
D-Tools Server, 19 
D-Tools Support, 298 
Duplicate 

Package, 309 
Product, 309 

E 
Edit 

Category, 161 
Custom Report Info, 509 
Data in PDM, 314 
Location, 311 
Manufacturer, 162 
Package, 307 
Product, 307 
Product Data Using Grid, 158 
Product in Database Using MMPD, 112, 117 
Product/Package in PDM, 266 
Zone, 311 

Edit Stencil, 382, 383 
Editing Products, 156 
Elevation, 77, 83, 110, 323, 325, 333, 351, 370, 

425, 427, 428 
Elevation Blocks, 434 
Elevation Page, 333, 380 

Use of Product Dimensions, 77 
Elevation Shape 

Connection Point, 334 

Generic, 333 
Product Specific, 333 

Elevation Shapes, 334 
Rack Mount), 335 

Equipment % Adjustment, 27 
Equipment +/-, 281 
Equipment +/-% 

Defined, 27 
Estimates, 582, 585, 593, 600, 602 
Example 

Add a Phase, 282 
Changing Labor Setting, 282 
Create Custom Report, 516 
Creating a Package w/MMPD, 94 
Download D-Tools Data, 125 
Inserting CAD Drawing in Plan View, 344 
Labor, 25 
Link Shape to Product, 380 
Managing Accessories, 88 
MMPD 

Filter Product View, 118 
Modify Markup (Multiple items), 114 
Speaker Pairs, 377 
Using Margin, 74 
Using Markup, 74 

Excel 
Adding Products to the Database, 142 
Export PDM, 268 
Exporting Products from MMPD to Excel, 158 
Product Import Template, 144 

Excel Reports, 532 
D-Tools Data, 532 
Import, 537 
Sample Data, 535 

Exception List. See Text Formatting 
Expand/Collapse Row in PDM, 316 
Exporting Products, 158 
Extended Data, 308 
Extents, 346, 404, 406, 410 
External Reference, 415 

F 
Feedback, 69 
File 

New, 270 
Open, 270 
Save, 270 

File Management 
Client Server Rules, 220 

File Manegement, 202 
File Naming Convention, 198 
Filter 

Products in MMPD, 111 
Using Filters to Select Products, 86 

Filter Product View, 266 
MMPD, 118 

Find and Replace Product, 288 
Find Drawing Shape in PDM, 376 
Find Shape on Drawing Page, 373 
Floor Plan, 344 
Form 

Wire Wizard, 394 
Format Active Field, 70 
Forms 

Accessory Visualizations, 87 
Add Accessories, 87 
Add Package, 359 
Add Product, 86, 358 
Add QuickBooks Item, 590 
Assign Head End, 163, 312, 386 
Assign Location and Zone, 311 
Component ID, 279 
Component ID Format, 315 
Create Stencil, 369 
Custom Properties, 280 
Drawing Template, 324 
Edit Block Definition, 443 
Estimated Taxes, 285 
Filter Product Selection Tree, 265 
Filter your Product Explorer, 118 
Find, 288 
General, 285 
Head End, 98 
Import Options, 148 
Input List, 78 
Insert System, 290 
LinkTools, 584 
Location Types, 276 
Locations, 277 
Manage your Product Explorer, 119 
Master Table Product Properties, 85, 157, 

265 
MasterTable Item List, 587 
Misc Costs, 284 
MMPD, 112 
New Report Wizard, 503 
OrderTools POs, 293 
OrderTools Rep List, 292 
Package Form, 93 
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Payment Schedule, 283 
Price Setting, 74 
Project Information, 272 
QL Match Item Custom Fields, 592 
QL Match Item in D-Tools with QuickBooks, 

593 
QuickBooks Customer/Job, 596 
QuickLinks Estimate, 595 
QuickLinks Invoice, 602 
QuickLinks Purchase Orders, 603 
Replace Product, 289 
Scope of Work, 275 
Select Sales Order, 594, 602 
Select Visio Pages to Import, 365 
Shapes, 321 
Stencil Tree, 320, 321 
Update Price, 75, 115 
Wire and Cable Stencil, 330 
WireWizzard, 389 
Write Block, 347 
Zones, 278 

Freight Charges, 27 
Froms 

Auto Layout, 400 

G 
Generate Side View, 380 
Generic Shapes, 333 
Golden Rules, 392, 397 
Group 

Data 
Using MMPD Grid View, 113 

Group Headers, 513 
Grouping, 300, 317 
GST, 61, 62, 63, 65 

H 
Hardware Configuration 

Small LAN, 20 
Hardware Recommendations, 19 
Head End, 98, 310, 312, 386 

Action, 312, 386 
Assigning in PDM, 268 
Prompt, 286 
Reassign, 312, 386 

HeadEnd, 164 
Terminal Assignment, 163 
Turn on Prompt for Phase, 53 

Height, 77, 135, 380 
Converting to Rack Units, 77 

Help, 69 
About, 298 

Help Video 
MMPD – Download Data, 121 

Hyperlink Product Field, 71 

I 
I/O 

Label, 162 
Signal, 162 
Terminal, 162 

I/O Lists 
Edit, 162 

I/O Studio, 78, 268, 316 
Ignore Labor Calculations. See Phase, See 

Phase 
Implementation Guidelines, 19 
Import, 67 

Field Mappings, 148 
Import from CSV, 144 
Import Template, 144 
Import Visio Pages, 365 
Importing Products, 142 
Income Account, 591 
Infrastructure Planning, 19 
Inputs/Outputs 

Editing, 78 
Insert AutoCAD Drawing, 412 
Insert AutoCAD File into Visio, 410 
Insert Sheet, 424 
Insert System, 290, 365, 423 

Import Options, 290 
Inserting CAD Drawing, 345 
Install Hours 

Unit Labor Hours. See Unit Labor Hours 
Installation Tab, 76 
International Options, 76 
International Settings, 77 

Dimensions, 77 
Inventory, 591, 599, 606 
Inventory Management, 28 
Invoice 

Based on Percentage, 601 
Export to QB, 601 
Terms, 602 

Item Number, 76, 592 

J 
Job Cost Analysis, 29 
Job Costing, 29 

K 
Keywords, 84 

L 
Label, 162 
Labor, 51, 60, 61, 63, 64, 68, 76, 88, 90, 91, 94, 

101, 137, 138, 146, 281, 285, 599 
Adding to Project, 141 
As an Accessory, 140 
Calculations Overview, 76 
Choosing a Method, 24 
Cost per Hr, 51 
Determining an Approach, 24 
Determining Rates, 25 
Don’t Trust our Numbers, 23 
Estimating, 24 
Example, 25 
Factor, 51 
Factors, 25 
Fixed, 53, 139 
Fixed & Variable, 139 
Forecast vs Actual, 24 
Four Options, 139 
Guess & Check Method, 24 
Hours, 139, 140 
In Packages, 23, 141 
Line Item, 137, 141 
Margin, 51 
Methodology, 23 
New Labor Item, 138 
Other Direct Costs, 25 
Overview, 23 
Phase Factors, 25 
PMs Know Best, 24 
Price Tab, 138 
Programming, 140 
Selling Price, 51 
Use Phase Data, 139 
Variable, 139 

Labor Hours, 76 
Labor Sales Tax, 59, 60, 63, 76, 285 
Labor SKU. See Labor: Line Item 
LANSync, 21, 22, 71, 124 
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Configuration, 167 
Handling Unapproved Products, 71 
Unapproved Data, 124 

Legacy Reports, 472 
License Administration, 19 
License Agreement, 160 
License Assignment, 19 
Line, 83, 88, 94, 110, 323, 325, 327, 328, 330, 

351, 370, 413, 425, 427, 428 
Line Blocks, 431 
Line Connector, 332 
Line Connector Shapes, 330 
Line Shapes, 328 
Link Product to QuickBooks Item, 587 
LinkTools, 72, 76, 543, 582, 583, 593, 600, 607 

Check Inventory, 606 
Create Extimate, 583 
Create Invoice, 583, 601 
Create Purchase Order, 583 
Create QB Items from SI Data, 585 
Delete Estimate, 584 
Delete Invoice, 584 
Delete Purchase Order, 584 
Edit Estimate, 584 
Edit Invoice, 584 
Edit Purchase Order, 584 
Export Estimate, 585 
Export Invoice, 585 
Export Invoice to QB, 601 
Export Purchase Order, 585 
Map Custom Fields, 592 
New Estimate, 584 
New Invoice, 584 
New Purchase Order, 584 
Setup, 586 
Work With, 584 

Local Project Folder, 201 
Location 

Add Name, 235, 237 
As Shown on Reports, 277 
Assigning in PDM, 268 
Description, 277 
Descriptions, 32 
Names, 32 
Package Assignment, 108 
Type, 235 

Location and Zone Configuration, 241 
Creating, 242 
Saving, 242 

Location Type, 32 

Order on Client Reports, 277 
Overview, 277 

Location Types, 31, 276 
Add/Delete, 48 
Setting Defaults, 48 

Locations 
Defined, 31 
Setting Defaults, 48 

Lock Drawing, 345 
Logo 

Company, 30, 44 

M 
Manuals 

Online, v 
Manufacturer 

Add to Database, 71 
Edit Data, 162 

Manufacturer Stencil, 333 
Manufacturer Vantage Point. See MVP 
Margin, 73 

Formula, 74 
Markup, 73 

Formula, 74 
Master Table, 88, 106, 136, 265, 312, 313, 314, 

396, 583, 587, 592 
Managing Change, 22 
Update, 102 

MasterTable, 112, 117, 264, 288 
Refresh Data From, 312 

Measurement Unit, 26, 286 
Measurement Units, 44 
Menu Options 

Text Interface, 270 
Microsoft Project, 366, 423 
Millimeters, 44 
Misc Costs, 280, 284 

Tax Status, 60 
Misc Equip Factor, 44 
Misc Parts, 60, 281 
Misc Parts Factor, 45 
Misc Parts% 

Defined, 27 
MMPD 

Administration, 161 
Columns, 113 
Edit Products, 117 
Filter Products, 117 
Manage Grid Layout, 113 

Package Editing, 105 
Package Management, 111 
Product Explorer, 116 
Product Grid, 111 
Search, 111 
Sort Data in Grid View, 113 

Model Space, 346, 403, 404 
Modify 

Markup 
Product Grid, 114 

MSRP, 73 
MVP, 121, 631 

N 
Navigator, 35 

Display Area, 36 
Project Files, 193 
Projects View, 193 
Start Screen, 40 
Task Pane, 36, 40 

Network Configuration, 19 
New AutoCAD Drawing, 219 
New Visio Drawing, 219 
New Zealand 

GST, 59 
Non-Inventory, 591 

O 
OrderTools, 28, 291, 294, 295, 370, 425 

Edit PO, 293 
Email PO, 293 
Purchase Orders, 293 
Representative Management, 292 

Outlook, 272, 274, 292, 293 
Importing Contacts, 272 

Output Terminal, 392 
Overhead View. See Plan 

P 
Package 

Across Multiple Locations, 108 
Add, 95 
Add Package from PDM, 104 
Adding to a Text Project, 104 
Adding Wire, 98 
Assigning Locations, 108 
Base Price, 101 
Change Location, 311 
Controlling Drawing Visibility, 110 
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Create in AutoCAD, 103 
Create in Visio, 103 
Creating From Within a  Project, 101 
Creating w Rt-Click, 102 
Creating w/MMPD, 94 
Discount, 101 
Duplicate, 309 
Equipment +/-, 100 
Example, 94 
Image, 100 
Labor, 96 
Labor Management, 99 
Managing Accessories, 94 
Misc Parts, 100 
Select All in PDM, 316 
Taxes, 100 
Total Selling Price, 100 

Packages, 93 
Defined, 23 
In Different Location/Zones, 304 
Managing Labor, 94 
Planning For, 23 
Revision Management, 580 
Summarize in Reports, 94 
Viewing Packages in Database, 116 

Page Properties, 411, 413 
Page Setup, 410, 412, 413 
Page Types, 322, 325, 370, 425 
Paper Space, 346, 403 
Payment Schedule, 280, 283 
PDM, 266 

Add Product/Package, 266 
Assign Head End, 268 
Assign Location, 268 
Assign Zone, 268 
AutoCAD, 418 
Column Rt-Click Commands, 269 
Delete Product/Package, 310 
Delete Products/Packages, 266 
Dock/Float, 373 
Duplicate Product/Package, 309 
Edit Data, 314 
Edit Product/Package, 266 
Expand/Collapse Row, 316 
Export to Excel, 268 
Filter Product View, 266 
Grouping Products, 267 
Manage Columns/Groups, 267 

Managing Accessories, 88 
Print, 268 
Refresh Product View, 267 
Replace Product, 310 
Rt-Click Commands, 306 
Update Price, 268 

Phase, 51, 53, 76, 111, 135, 164, 265, 266, 280, 
281, 282, 283, 284, 290, 312, 386 
Assign a Product to a Phase, 76 
Ignore Labor Calculations, 53 

Phases 
Set Defaults, 50 
Set-up, 30 

Pivot Tables, 536 
Plan, 77, 110, 323, 325, 341, 351, 370, 410, 425, 

427, 428 
Plan Page Type \t, 341 
Plan Shapes, 342 
Plan View 

Scaled Plan, 77 
Use of Product Dimensions, 77 

Plan View \t, 341 
Planning Guide, 19 
PowerPoint, 366 
Price 

Cost From MSRP, 75 
Margin, 73 
Markup, 73 
Phase, 76 
Pricing Options, 74 
Selling Price From MSRP, 75 
Unit Cost, 73 
Unit Price (Selling Price), 73 
Update Form - MMPD, 115 
Update in PDM, 268 
Update Price, 75 
Updating Multiple Products, 114, 268 

Price Levels. See Price Type 
Naming, 44 

Price Type, 73 
Pricing 

Sync with QuickBooks, 593 
Pricing Method. See Price:Options 
Print 

PDM, 268 
Product Grid From MMPD, 114 

Product 
Accounting ID, 599 

Add to Database Using MMPD, 112, 117 
Add to PO, 605 
Amps, 77 
Assign Locations, 299 
Assign Phase, 76 
Assign Shape, 83 
Assign Stencil, 83 
Assign Zones, 299 
Categories Defined, 31 
Change Location, 311 
Class Speakers, 68 
Client Description Field, 73 
Custom Properties, 84 
Data, 22 
Delete From Database, 117 
Depth, 77 
Description Field, 72 
Details, 70 
Dimensions, 77 
Discontinued, 71 
Duplicate, 309 
Edit, 112, 117 
Edit Attributes, 156 
Editing Data Using Grid, 158 
Exporting to Excel, 158 
Filter Techniques, 111 
Find and Replace, 288 
Grid View, 111 
Height, 77 
Hyperlink, 316 
Hyperlink Field, 71 
Image, 70, 72 
Inputs and Outputs, 78 
Link to QB Item, 589 
Make a Copy, 112, 117 
Manage Display Hiearchy, 117 
MSRP Price, 73 
Pricing, 22, 73 
Properties, 157 
Required Fields, 71 
Select All in PDM, 316 
Status 

Approved, 71 
Unapproved, 71 

Tax Status, 76 
Taxable, 59 
Unit Labor Hours, 76 
Updating Prices w/PDM, 268 
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URL, 316 
Viewing Products in Database, 116 
Width, 77 

Product Class 
Equipment, 68 
Labor, 68 
Wire & Cable, 68 

Product Explorer, 67, 94, 105, 111, 116, 117, 
118, 119, 134, 136, 142, 157, 158, 263, 264, 
266, 298, 302, 319, 369 
Filter, 118 

Example, 118 
Filter Products, 264 
Refresh View, 69 

Product Explorer XE "Product Explorer:Filter 
Products"  
Customize View, 264 

Product Grid, 67, 111, 114, 134, 156, 158, 159, 
263, 267 

Product Specific Shapes, 333 
Product Tree, 97, 157 

Add Acceesories, 83 
Productivity Tips, 23 
Products 

Downloading from D-Tools, 121 
Progress Billing, 26 
Project 

Add a File To, 215 
Add Packages, 298, 357 
Add Products, 298, 357 
Add Zones, 238 
Billing Address, 229 
Checked-In, 22 
Checked-Out, 22 
Client Email, 227 
Client Name, 227 
Client Phone, 227 
Client Title, 227 
Clint Name (Required), 272 
Contacts, 230, 272 
Contract Percentages, 239 
Copy, 207 
Create New, 207, 224 
Create Revision, 208 
Current, 209 
Custom Properties, 280 
Default Folder, 201 
Default Pricing, 281 
Defaults, 281 
Delta, 493 

Designer, 273 
Editable Field Names, 273 
End Date, 272 
Export to MS PowerPoint, 366 
Export to MS Project, 366 
External Contacts, 274 
File Location, 201 
File Rules, 202 
Folder, 44 
Folder File Names, 272 
General Tab, 286 
Going Mobile, 22 
Information, 226 
Insert System, 290 
Labor, 281 
Local Folder2, 201 
Location Type, 277 
Location Types, 233, 276 
Locations, 234 
Manager, 274 
Misc Costs, 284 
Name, 226 
Name (Required), 272 
New AutoCAD, 426 
New Visio, 323 
Number, 226, 272 
Options, 280 
Owner, 227, 273 
P&L, 29 
Payment Schedule, 284 
Phases, 281 
Phases Defined, 30 
Project Address, 272 
Sales Rep, 273 
Save, 266 
Scope of Work, 275 
Scope Of Work, 231 
Setting Tax Rates, 285 
Sharing, 22 
Site Address, 228 
Staff, 274 
Start Date, 272 
Status, 29, 227, 272 
Statuses Defined, 46 
Zones, 278 

Project Custom Properties, 240 
Project Data Matrix. See PDM, See PDM 
Project File 

Defined, 222 
Project File Description, 576 

Project Files, 193 
Defined, 198 
DTL, 198 

Project Folder Names, 272 
Project ID 

Set Default, 57 
Project Information, 271 

Modifying, 271 
Project Tab, 272 

Project Name, 199 
Project Number, 199 
Project Number Format, 30 
Project Revision, 576 
Project Settings, 47 
Project Summary, 496 
Projects View, 193 
Promote Revision, 259 
Prompt for Missing Fields, 286 
PST, 63, 65 
Purchase Order 

Across Multiple Projects, 605 
Purchase Orders, 28, 582, 585, 593, 603, 607 

Edit/Delete, 607 
Purchase Prder 

Add Product to PO, 605 
Purchase Tax Code, 63, 76 
Purchasing, 28 

Q 
QuickBooks, 72, 76, 542, 583, 584, 585, 586, 

587, 588, 589, 591, 592, 593, 595, 596, 597, 
599, 600, 601, 602, 603, 604, 606, 607 
Add Items, 592 
Add Product to Estimate, 599 
Class, 603 
Create Customer/Job, 596 
Customer/Job, 603 
Estimate, 600 
Estimates, 593 
Fields, 591 
File Path, 585 
Inventory, 599 
Inventory Part, 29, 590 
Item Created, 592 
Item Mask, 29, 592 
Item Number, 606 
Item Numbers, 599 
Link Items to SI Database, 586 
New Job, 597 
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Non-Inventory Part, 29, 590 
Setup, 586 
Sync Items with SI 5, 593 
Sync Sync Pricing w Master Table, 593 
Tax Code, 597 
Vendor, 603 

QuickLinks 
Estimate, 599 
Invoice Terms, 602 

R 
Rack Mount), 335 
Rack Units 

Product RUs Required, 77 
Read Me First, 19 
Reference Shape, 413, 414 
Refresh 

Product Explorer View, 69 
Refresh Data From MasterTable, 312 
Refresh Groups, 267 
Refresh Project Pane View, 219 
Remove 

Columns From Grid View Using MMPD, 113 
Rename Revision, 262 
Replace Product, 310 
Report 

By Location, 32 
Report Wizard, 502 
Reporting Center 

Add Annotation, 489 
Comparing Revisions, 493 
Create Default Definition, 485 
Create New Report Group, 487 
Creating a Proposal Package, 486 
Crystal Reports, 498 
Custom Grouping, 482 
Custom Reports, 481 
Export to html, 490 
Export to pdf, 489 
Export to rtf, 489 
Filters, 497 
Find Text, 488 
Go To Next Page, 489 
Grouping Order, 484 
Importing into Word, 490 
Legacy Reports, 498, 499 
Menu Bar, 499 
Parameter Options, 482 

Print Report, 488 
Project Summary, 496 
Projects Interface, 495 
Report Categories, 480 
Report Definitions, 482 
Report Details, 498 
Report Groups, 486 
Report Parameters, 485 
Report View, 489 
Reports List, 497 
Run Report Group, 487 
Running a Report, 497 
Running a Report w Filters, 481 
Show Page#/Total Pages, 489 
Show/Hide TOC, 488 
Sort Products Within Groups, 484 
Sorting, 482 
Storing Options, 482 
Taskbar, 499 
Using Word Templates, 492 
View Previous/Next Page, 489 
Viewing a Report, 488 
Zoom Out/In, 489 

Reports, 286 
Client Contract, 284 
Custom Properties, 47 
Legacy, 472 
Legacy, 286 
Misc Costs, 284 
Packages, 94 
Running, 480 
Scope of Work, 275 
Wire Connection, 78 

Reports Lists, 497 
Required Field 

Project Name, 272 
Required Fields 

In Database, 71 
Resources, 30, 33 
Restore, 580 
Revision 

Create, 256 
Create New, 256 
Current, 257 
Current Defined, 256 
Documentation, 259 
Managing Drawings, 256 
Number, 256 

Promote, 259 
Rename, 262 

Revision Management, 247, 575 
Change Orders, 254 
Enginerring Process, 251 
Packages, 580 
Proposals, 248 
Restore, 580 

Revision Mgt, 208 
Revisions 

Compare, 250 
Comparing With Reports, 493 
Make Current Project, 251 
Promote, 251 

Right-Click 
Add Note to Shape, 384 
Add Product/Package, 360 
Assign Head End, 310 
Assign Location, 310 
Assign Zone, 310 
Change Shape, 379 
Create New Package, 102 
Data Preview in MMPD, 123 
Delete Product/Package, 310 
Dock/Float PDM, 373 
Find Shape, 373, 376 
Generate Side View, 380 
Insert Alternate View, 376 
Link Shape to Product, 380 
Merge Text Blocks, 375 
New AutoCAD Drawing, 219 
New Visio Drawing, 219 
PDM Commands, 306 
Project Task Pane, 218 
Refresh, 219 
Rename Revision File, 257, 260, 262 
Show Text Blocks, 375 
Show Text Callout, 376 
Snap Text Block Position, 376 
Update Data to MasterTable, 313 
Vision Options, 371 

Rough-In, 98, 164, 282, 283, 312, 386 
Rough-In Wire Shape, 343 
Round Tripping, 403 

S 
Sales Order, 543, 593, 595, 599, 602, 603, 605 

Creating a Sales Order, 544, 551 
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Locked marked Final, 600 
Status, 543 
Status Final, 600 

Sales Tax, 59, 60, 61, 62, 63, 64, 76, 285 
Australia, 61 
Australia, 59 
Canada, 63 
Canada, 59 
Choosing the Appropriate Method, 59 
Equipment, 45 
How to…, 58 
Labor, 45, 60 
Make Product Taxable, 59 
New Zealand, 61 
New Zealand, 59 
On Reports, 60 
Overview, 57 
Rates, 60 
Set Defaults, 59 
Standard, 59 
Standard Method, 60 
What is not Taxed, 60 
What is Taxed, 60 

Save 
Project, 266 

Save as, 379, 410, 415 
Scale Plan Shape, 342 
Scale Plan Shapes, 342 
Scaled Plan, 77 
Schematic, 78, 110, 325, 349, 370, 425, 427, 428 
Schematic Page 

Hide Unused I/Os, 385 
Use of I/Os, 78 
Wiring Options, 385 

Schematic Shapes, 349 
Scope of Work 

Insert Snippet, 275 
Overview, 275 

Scope Of Work 
Snippet, 232 

Select Sales Order, 594 
Selected Product Indicator, 372 
Selling Price. See Unit Price 
Shape 

Define Specific Shape, 361 
Resize, 330 

Shapes, 320, 321, 322, 326, 348, 382, 429 
Placing on Drawing Page, 363 

Show Shadow, 336 
SI 5 

Data Architecture, 22 
Side View 

Assigning Visio Shapes To, 83 
Signal, 162 
SKU, 71 
Smart Frame L-Scape 

Editing, 353 
Sort 

Data in MMPD Grid View, 113 
Speaker and Stand Size), 336 
Speaker Elevation Shape 

Choose Material), 339 
Rt-click Options), 338 
Show Grill Cloth), 339 
Show Shadow), 339 

Speaker Pairs, 377 
Specifications Tab, 77 
Spell Check, 275 
SQL Server, 21 
Staff 

Members, 46 
Types, 46 

Staff List, 30 
Staff Type, 30 
Standard Rule, 396 
Standard Rules, 397 
Stencil 

By Manufacturer, 322 
Custom, 322 
Display Docked Stencil, 321 
One-To-One, 322 

Stencil Tree, 319, 320, 339, 369 
Stencils, 161, 320, 322 

Create Utility, 369 
Stencils Defined, 320 
Sub-Report, 503 

T 
Tax 

Labor Sales Tax, 76 
Purchase Tax Code, 76 
Sales Tax, 76 

Tax Code, 26, 45, 58, 59, 60, 61, 63, 285 
Canadian, 76 

Tax Rates, 285 
Taxable, 76 
Taxes. See Sales Tax 

We Estimate, 26 
Technical Support, 298 

Terminal, 162, 163 
Test Project Interface, 263 
Text Formatting 

Exception List, 164 
Tigerpaw, 542 
Time Tracking, 29 
Title Frame 

Editing, 351 
Training Options, 33 
Tutorial, v 
Type, 55, 56, 71, 73, 111, 114, 115, 118, 120, 

146, 265, 266, 277, 326, 331, 334, 391, 397, 
406, 411, 424 

U 
Unapproved 

Product Status, 71 
Products and LANSync, 71 

Unapproved Data, 124 
Unapproved products 

Display in MMPD, 112 
Unit Cost, 73 
Unit Labor Hrs, 135 
Unit Price, 73 
Unpublished Reports, 509 
Update 

Price, 75 
Price of Multiple Products, 114 

Use Existing QB Item, 588 
Users 

Defined, 33 
Utilities 

Change Page Type, 370 
Create Stencils, 369 

V 
Vendor, 76, 584, 591, 605 
Vendor Name, 76 
Visio 

Connection Point Spacing, 329 
Connector Tool, 332 
Cover Page, 323 
Drawing Page Types, 322 
Insert Page, 325 
Layer Properties, 345 
New Project, 323 

Visio Files, 198 
Visio Project Interface, 319, 372 
Visio stencil, 83 
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Visio to AutoCAD, 403 
Vista, 202 
Visualization Tab, 379 
Visualizations 

Setting Defaults, 87 
Visualizations Tab, 83, 362 
Voltage, 77 

W 
Web Specs, 316 
Weight, 77 
Width, 77, 135 
Wire 

Automatically Connect, 395 
Color by Type, 390 
Color Legend, 331 
Length, 98 
Select From Project, 396 
Select New Wire, 396 
Text Block, 350 

Wire & Cable 
Adding to a Package, 98 

Wire and Cable, 164, 312, 330, 386 
Shapes, 342 
Stencil, 330 
Type, 331 

Wire and Cable Shapes, 350 
Wire Automatically, 398, 399 
Wire History, 394, 395 

Color Key, 395 
Remove Wire, 395 

Wire Length 
Default, 44 

Wire Manually, 398, 399 
Wire Shape, 343 

Default, 343 
Hide Text Block, 343 
Schematic Default, 350 

Wire Wizard 
Restore Defaults, 392 
Show Open Terminals Only, 391 
Show Product By Location, 391 

WireWizard, 389, 396, 397 
About, 389 

Wiring 
AutoLayout, 400 
Options, 385 

Wizard 
Create New Project, 225 
Setup and Configuration, 41 

Word 
Report Template, 491 

Work Order, 541, 547, 553 
Add Products to, 552 
Assign Resource, 554 
Manage Resources, 548 
Resources, 33 
Time Tracking, 29 

Work With 
Invoice, 601 
Purchase Orders, 603 

Write Block, 347, 405 

X 
XML Data, 515, 532 
Xref, 348, 406, 407, 415 

Z 
Zone 

Assigning in PDM, 268 
Zones 

Add, 238 
Defined, 32, 49 
Description, 239 
Descriptions, 32, 49 
Name, 239 
Possible Uses, 33, 49 
Set Defaults, 49 
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