
Reporting Center 
The Reporting Center is where you will go to run or create reports on projects. It can be accessed 

in any of the follow ways, each with a slightly different user interface and functionality.  
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1) 

2) 

3) 

As a separate window – open by clicking on Tools -> Reporting Center in the tool bar of the 

Navigator. This is the primary Reporting Center interface and is described in detail below. Used 

to organize, create and run reports on one or more projects. 

From within a project – open by going to D-Tools -> Reports in the menu bar of Text, Visio, 

or AutoCAD interfaces. Runs reports on the current project only. Also, if SI4 is installed, allows 

you to run Legacy Reports, including custom reports created in SI4. 

From within the Navigator – open by clicking on the  tab in the Navigator. See “For 

more information on projects please see “Projects” on pg 95. 

4) Reports” tab for more details. 

Primary (Stand-Alone) Interface 
The Reporting Center primary interface allows you to run, organize and create custom reports for 

one or more projects. To open, click on Tools -> Reporting Center in the Navigator. 

 



The Reporting Center interface will open: 

 

There are five different areas of this interface:  the Projects and Reports area,  the Reports 

List,  the Report Details,  the Menu Bar and  the Taskbar. 

To run a report, first select the project(s) in the Project List, then double-click on the 

report in the Report List. The results will appear as a tab in the Projects and Reports 

area. 

Projects and Reports Area 

The Projects and Reports area is where you go to select which projects to run reports on, as well as 

to view reports that you have run. When you first open the Reporting Center, all you will see is the 

Project List. 
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Project List 

The project list shows you all of your SI5 Projects. Use this grid to select the project or projects 

you wish to run a report on. You can always come back to the project list by clicking on the D-Tools 

Projects tab at the top. 

Refresh your project list by clicking on the Refresh icon in the toolbar ( ). This will 

allow you to see new projects and other changes made via the Navigator. 

 

 

If you click on the  symbol next to a project, you will see a list of past revisions for this project. 

You can then select one of these past revisions and run a report on it. 
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Comparing Two Revisions of a Project 

If you want to compare two revisions of a project with each other, select the revisions in the 

project list and Right-Click to select Create Project Delta. .  The order of the selection is important.  

The difference will always be Delta Amount = (Selection1 – Selection2). 

 

Once you have created a delta project, which only includes the differences between the two 

revisions, you can select the delta project and run reports on it. 
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Viewing a Report 

Once you run a report, it will appear as its own tab in the Projects and Reports area. You can have 

a large number of report tabs open at once, which makes it easy to compare reports. 

 

When viewing a report, you have a row of tools at the top for performing different actions. 

 

......Show/hide table of contents and thumbnail view 

 Print the report to a printer 

......Copy the current page onto the clipboard  

......Find text within the document 

 Single page / multi-page / continuous scroll view 

 Zoom out / Zoom in / Set zoom 

..Go to Next Page / Previous Page 
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 Page Number/Total Pages 

 View previously viewed pages 

......Add annotation to report 

......Export to Adobe pdf format file, pdf 

......Export to rich text format file, rtf 

......Export to html format, html 

......Export to Excel 

......Excel Report Settings – this launches a window for you to configure how your settings 

 

You can continue editing any report in MS Word or any other document editor by 

exporting to rich-text format, then importing the rtf file from within the editor. 
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Importing a report into MS Word 

To import a report into MS Word for continued editing, follow these steps: 
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1) Click on the Export to Rich Text File icon, ( ) and select a name and location for the rtf file. 

 

2) 

3) 

Open Microsoft Word 

Go to Insert > File, select “All Word Documents” in the file type dropdown, and browse to the 

rtf file.  



.  

Using your own Word Templates with Proposals or Line Item Reports 

If you want to fine tune the look of your Proposals and Line Item Reports in Word, you can do this 

by running these reports with no headers or footers, then inserting into your own custom-made 

Word template. Follow these steps: 

1) Create a Word template with the desired headers and footers you want to use.  

D-Tools provides sample templates in your Global Application folder (in Windows XP, 

C:\Documents and Settings\All Users\ Application Settings\D-Tools\SI5\Other Files).  

See SI5 Proposal Template 1.dot. VISTA:  C:\ProgramData\D-Tools\SI5\Other Files 
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2) Create a custom report definition (see below) and uncheck the “Show Page Header and Footer” 

parameter. 

 

3) 

4) 

5) 

6) 

Run the report using the custom report definition. 

Export to Rich Text Format (see above) 

Create a new Word document based on your custom template. 

Go to Insert > File and browse to the rtf document (see above) 



Reports List 

The reports list is where you go to select which report you want to run. It is organized into Report 

Categories and Report Groups. 

 

Report Categories 

Report Categories allow you to organize your reports for quick access. Standard reports are initially 

organized into four categories: Client Reports, Excel Reports, Installation Reports, and 

Management Reports. 

Click on the  symbol next to the report category name to see which reports can be found. 

 

 Standard reports are noted by a green icon  

 Custom reports you have created or imported have a blue triangle on the icon  
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To create a new report category, right-click anywhere in the report list and select New -> Report 

Category. You can then drag and drop reports into your new category. 

You can customize the report list by moving reports to new categories. Simply grab 

the report name and drop it on a category name. 

Running a Report 

To run a report, first select the project(s) you want to run the report on in the Project List. Then, in 

the Report List, either double-click on the report name or right-click and select Run Report. This 

will run the report using the default Report Definition, and the results will appear as a tab in the 

Projects and Reports area. 

Running a Report with Filters 

If you want to filter the project data before running a report, right-click on the report name and 

select Run Report with Filters. The Filter Report dialog will appear. 
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On the row with an asterisk, click on the field column to select which data field you wish to filter 

by. Similarly, click on the Operator and Value fields to determine how this data field will be filtered. 

 

You can select multiple fields to filter by. Each row of the filter is joined by either an AND or an OR 

statement, selected in the column on the far left. The example above will filter by Location = 

Network Closet AND Phase = Rough-In.  Click [Run Report] to run the report with filters. 

Report Definitions 

Many reports have the ability to be run with custom grouping, sorting and parameter options that 

you can define and save. These stored options are called Report Definitions.  

If a report supports report definitions, you can see them by clicking on the  symbol next to the 

report name. 
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To create your own report definition, right-click on the report name and select New -> Report 

Definition. The Report Definition dialog will appear. 

 

Description is the name of the definition that will appear in the report list. 
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To create your own grouping order for this report definition, select the [Grouping] tab and click on 

the grey area next to the asterisk. Some reports (like Line Item Reports) support up to three levels 

of groupings; others support none, one or two levels. 

 

To sort the individual items within groups, click on the [Sorting] tab and select the fields you wish 

to sort by and how they are to be sorted. Note that not all reports can be sorted in this fashion. 
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Report Parameters 

Some reports have parameters that affect the way the report runs. To see which options exist for a 

particular report, go to the [Parameters] tab of the Report Definition dialog. Here you can modify 

the report parameters for this report definition. 

 

Making a Report Definition the Default Definition 

If you would like your report definition to run by default when you double-click on the report name, 

just check the Default Report Criteria box before you save your report definition. 
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Report Groups 

Report Groups are a way for you to define a collection of reports that will run together. Report 

groups are shown at the bottom of the reports list. Click the [+] symbol next to the group name to 

see which reports are included. 

 

To add reports to a report group, drag a report from the top section (Report 

Categories) to the group header. 

 

 

To define a new report group, right-click in the Report List area and select New -> Report Group 
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To run a report group, just double-click on the group name. The results will appear in the Projects 

and Reports area. Individual reports appear in sub-tabs and can be printed or exported separately.  
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Report Details 

The report details area shows some basic information about the selected report, such as its name, 

a description, and what the Report Definition settings are. The information in this section changes 

whenever you select a different report in the Report List. 

 

Menu Bar 

 

The menu bar at the top allows you to access some of the basic features of the Reporting Center 

File Menu 

New -> Report Category Creates a new Report Category, which is allows you to organize the 

reports in the Reports List 

New -> Report Group Creates a new Report Group, which allows you to run a collection of 
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reports with a single click 

New -> Excel Report Allows you to import an Excel file you have created into the 

Reporting Center. Available to Pro users only. See Excel Reports 

below.  

Run Report Runs the Report selected in the Reports List on the project(s) 

selected in the Project List 

Run Report With Filters Opens the Filter Report form 

Exit Closes the Reporting Center 

Edit Menu 

Report Edit the Name, Description, and Category of a report 

Report Category Edit the definition of the Report Category selected in the Reports List 

Report Group Edit the definition of the Report Group selected in the Reports List 

Tools Menu 

Report Designer Opens the Report Designer interface, which allows you to create 

custom reports from scratch or based on existing reports. See 

Report Designer users guide. Available to Pro users only.  

Export Reports Allows you to export any number of custom reports to a zip file for 

distribution to others. Also a good method for backing up your 

custom reports.  

Import Reports Allows you to import a number of custom reports from a zip file 

created using the Export Reports function.  

Refresh Project List Refreshes the project list to include any changes to projects 

Global Settings Allows you to set global settings for your reports, see below 

Back up your custom reports to a local zip file by utilizing the Tools -> Export 

Reports feature.  
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Selecting Global Settings will open the following form: 

 

Keep Accessories With Parent Item – Options are “True” or “False”. When set to “True”, the 

price of all the accessories will be included in the price displayed next the parent product.  When 

set to “False”, the price of the accessories will not be displayed lumped in with the parent product’s 

price. 

Location Detail Level - Options are “-1” through “5”.  “-1” will display the full hierarchy of your 

Location Types for a project.  Using any number 1-5 will run the reports to the specified level.  

Remember, you can have up to five Location Types in SI 5. 

Example: You are using a Location Type Hierarchy as follows: Building->Floor-> 

Room.  You only want your reports to show by Room.  Since “Room” is the third 

Location Type in your hierarchy you would choose “3” for this setting. 

Prefilter Items – Options are “True” or “False”.  This function will filter the products in a project 

prior to sending the data over to the report.  The default is “False”. 

Example: You have a package in SI 5 with some products in the Rough-In Phase and 

some in the Finish Phase.  If you run a report filtered to the “Rough-In” Phase, the 

products Rough-In products from the package will not display in the report when this 

value is set to “False”.  When set to “True” the filtering will include the products 

within the package on the report. 
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Report Tax Descriptions – Expanding this list gives you three text fields for overriding either the 

GST, PST, or Sales Tax Descriptions on your reports. 

Show Packages in Proposals - Options are “True” or “False”.  When set to “True”, the price of all 

the products in a Package will be included in the price displayed next the Package name in the 

report.  When set to “False”, the products will display in the report individually and there will be 

now entry for the package name displayed. 

Toolbar 

 

The toolbar has a collection of icons for quick access to these common actions 

.......Run Report 

.......Run Report with Filters 

 ......Create New Report Category 

......Edit Report Category 

 ......Create New Report Group 

 ......Edit Report Group 

 ......Report Designer 

 ......Export Reports 

 ......Import Reports 

 .....Refresh Project List 
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Projects Interface 
The Reporting Center projects interface allows you to run reports on a project that you have open 

in the Text, Visio, or AutoCAD interfaces. To open, go to the D-Tools > Reports menu option from 

within an open project. 

 

This window is divided into five areas: 1) The Project Details and Reports area, 2) the Reports List, 

3) the Report Details, 4) a Menu Bar and 5) a Toolbar. 
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Project Summary 

Click the [Project Summary] button to see a financial overview of your project as shown below. 
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Project Details and Reports Area 

The lower right area shows you some basic information about the project in the Project Details tab. 

Also, when you run reports, these will appear as tabs in this same area. See “Viewing a Report” 

on page 5 for more details. 

 

Reports List 

The Reports list on the upper left shows all of the defined reports. See ”Reports List” on page 10 

for how to customize this area. 

To create a new report definition, report group, or custom report, go to the 

Reporting Center primary interface. You cannot modify the Reports List from within 

the projects reporting interface. 

To Run a Report 

Double-click on the report name in to run the report. This will run the report using the default 

Report Definition. The results will appear in a tab in the Project Details and Reports area. 

If the report has multiple Report Definitions, click on the  symbol next to the report name to see 

the definitions, and double-click on the one you want to run.  See “Report Definitions” on page 12. 

To Run a Report with Filters 

To filter the project data before running a report, right-click on the report name or report definition 

and select “Run Report with Filters”.  Note that not all reports support filtering.  See “Running a 

Report with Filters” on page 11. 
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To Run a SI4 Legacy Report 

If you have SI4 installed on this computer, you can run any non-Business Manager SI4 report, 

including custom reports, on your project. Go to File -> Legacy Reporting System in the menu 

bar and the SI4 Reports interface will open.  

 

See the SI4 Users Guide for more details on how to use this interface.  

http://www.d-tools.com/update/SI4Installs/eD-ToolsSI45UserGuide.zip 

Report Details 

The report details area shows some basic information about the selected report, such as its name, 

a description, and what the Report Definition settings are. The information in this section changes 

whenever you select a different report in the Report List. See the reporting center primary interface 

guide above for more information. 

Menu Bar 

The reporting center projects interface has these menu bar options: 

File > Run Report Run the selected report 

File > Legacy Reporting If you have SI4 installed, opens the SI4 reporting interface 
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System 

Taskbar 

The taskbar has two icons for quick access to these functions: 

 ...... Run Report 

 ...... Run Report with Filters 
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Report Designer 
Pro users have the ability to create custom reports using the Report Designer. To open the report 

designer interface, go to Tools > Report Designer in the menu bar of the Reporting Center. 

 

 

Creating custom reports is for advanced users only. It is the sole responsibility of the 

user to debug any custom reports. However, for a great list of help options, check: 

http://downloads.d-tools.com/si5/documents/Custom_Reporting_Documents.mht

 

The D-Tools Report Designer is based on ActiveReports for .Net 3.0 by Data 

Dynamics. For a complete user guide on this interface, see the ActiveReports User 

Guide located at 

http://www.datadynamics.com/forums/72/ShowForum.aspx. 
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The Report Designer interface will open: 

 

This interface consists of these parts: 1) menu bar, 2) shortcut toolbar, 3-4) formatting toolbars, 

5) toolbox, 6) design pane, 7) data and report explorer, 8) properties, and 9) script tab. 
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Menu bar 

File -> New  (New Report Wizard) 

To create a new custom report, go to File… New. The New Report Wizard will open 

 

Select New Report Based on Existing Report to create a custom version of an existing report, 

or New Blank Report to create a report from scratch. 
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If you chose New Report Based on Existing Report, you should then select which report you wish to 

modify. 

  

The next screen allows you to set the report name, enter a description, and determine which report 

category the report will appear in. It also allows you to mark this report as a Sub-Report or a 

Business Manager report.  
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From here on, just hit “Next” at every screen to duplicate the report you are 

modifying. 

 

Note 1: Sub-reports do not appear in your reports list. They are generally 

smaller reports which are included in other reports. An example is the Miscellaneous 

Costs sub-report. 

Note 2: The Report Name is the name that will appear in the Reports List 

Note 3: The “Data Source” field should always say “D-Tools Report Data”.  

 

In the next screen, set the page orientation and margins. 
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Next, choose whether the report will support sorting, filtering, and dynamic grouping. Also, choose 

which fields are available to be grouped and/or sorted by. 

 

Only some of the standard reports are set up to support Dynamic Grouping, 

regardless of whether this checkbox is checked. 
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The next step is to define the required groupings. In Line Item reports this determines how data is 

aggregated.  Just click ‘Next’ if you are uncertain.  The example below would be good for creating a 

BOM where you want a quantity followed by the Manufacturer and Model.  This process would 

group all like Products together.  Other useful groups could include: Category, Location, Phase, and 

Zone. 

 

Next choose a required sorting option, if desired 
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Now, set any required filters, if desired. 

 

The next screen allows you to save report parameters. 
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The final screen is a review of your report definition. Click Finish to save and start editing the 
report. 

 

The report opens and is now an Unpublished Report that can be edited. 
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File -> Open 

File… Open allows you to open a custom report that you have already created. 

 

Existing reports are published custom reports that appear in your Reports List 

Unpublished reports are custom reports that you are still working on. They do not appear in the 

reports list until you publish them 

File -> Publish 

File -> Publish will publish the report you have open so that it will appear in your Reports List. 

Choose this when you are satisfied and want to start using your custom report. Note that this will 

close the report for editing. 

File -> Edit D-Tools Report Information 

To change the report information you entered during the New Report Wizard, use File -> Edit D-

Tools Report Information. This will re-open the wizard and allow you to change the settings, 

including report name, grouping/sorting/filtering settings, and other options. 
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File -> Edit Report Definitions 

If you want to create some custom report definitions for your report, go to File -> Edit Report 

Definitions. Report definitions created here will appear in the Reports List beneath the report 

name. 

File -> Preview 

File -> Preview will allow you to preview your report vs. a sample project without having to publish 

the report or exit the report designer. 

File -> Save 

Use File > Save to save an unpublished copy of your report for future editing. You will need to 

publish your report later if you wish to see it in your Reports List. 

Edit 

The Edit menu has an assortment of commands which are helpful when editing your custom report: 

Undo, Redo, Cut, Copy, Paste, Delete, and Select All. 

Toolbars 

There are two sets of toolbars. The first has one-click shortcuts for most of the items in the Menu 

Bar: New/Open/Save/Preview Report, Cut/Copy/Delete, Undo/Redo, and Zoom In/Out. 

 

The second set of toolbars is used for editing textboxes and other objects within your report: Font 

settings, Colors, Alignment, Indentation, and Grouping. Use these to set the properties of report 

objects when you have one or more objects selected in the Design Pane. 
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Toolbox 

The Toolbox contains a selection of objects that you can drag onto the Design Pane: Labels, Text 

Boxes, Lines, and Pictures are the most common. Text Boxes in particular can be bound to a data 

field for display in your report. 

 

To bind the text in a TextBox to a data field, select the TextBox, then go to the 

Properties area and select DataField. Type in the name of the data field (e.g. 

dtr:Price) you wish to bind to the Text Box. D-Tools Report data field names are 

found in the Data Explorer. 

Design Pane 

The Design Pane, located in the center of the Report Designer, is where you go to modify the 

layout of your report. You can drag and drop objects from the Toolbox or Data Explorer onto the 

design pane for display on your reports. 

Page Headers and Footers 

Objects in the Page Header or Page Footer sections will appear at the top or bottom of each page, 

respectively. 
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Group Headers and Footers 

Group headers affect the way the data is iterated over. Most often, groups are linked to a data 

field, such as dtr:Location or dtr:Category. This causes this section of the report to repeat itself 

once for every member of the group. 

Some reports come with special groups named GrpDynamicHeader1, 2 or 3. DO 

NOT RENAME THESE as they are used to implement dynamic (run-time) grouping. 

Similarly, the group name is in a textbox with name txtDynamicHeader1, 2 or 3, 

which should also not be renamed. 

Detail 

The Detail section shows what happens for each member of the data set. Use this section to add or 

remove data fields for each item in your report. 
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Data Explorer 

The Data Explorer is where you go to find data fields for your report. It is initially located on the 

right, as a tab behind the Report Explorer. Use the Data Explorer to browse through the XML 

structure, then drag-and-drop data fields onto the Design Pane. 

 

The Data Explorer is where you go to find data fields for your report. It is initially located on the 

right, as a tab behind the Report Explorer. Use the Data Explorer to browse through the XML 

structure, then drag-and-drop data fields onto the Design Pane. 

Most of the information you will be looking for can be found under dtr:Project. Data 

fields for specific items are found under dtr:Items/dtr:Item. 
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D-Tools XML Structure 

D-Tools report data is based on an XML schema that is defined here: 

http://www.d-tools.com/schemas/si5/reports/dtoolsreport.xsd

Properties 

The properties window is where you go to change fonts, alignments, and any other properties of 

objects in your Design Pane. Select an object in the design pane first, then go to properties to 

modify the behavior of the object. 
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Script 

The Script tab, located behind the Design Pane, is where you go to enter in .Net code. This allows 

you to take programmatic control of your reports. Either C# or VB.NET can be used. Note that all 

D-Tools reports have some amount of script code in them already. 

 

Custom Report Example 

To give a simple example of how to customize a report, let’s change the page header on a 

proposal. Here’s how: 

Step 1: Create a custom report based on an existing report 

1) 

2) 

In the Reporting Center, go to Tools > Report Designer. 

In the Report Designer, go to File > New… 
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3) Choose “New Report Based on Existing Report” and click Next 

 

4) Select “Proposal” from the list and click Next 
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5) Name the report “my Proposal” and enter a description 

 

6) Click ‘Next’ at all further screens until you get to ‘Finish’, then click that as well. 

Revised April 29, 2008 44 



 

At this point the report has been created and can be edited. 
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Step 2: Modify the Page Header 
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1) In the design pane, in the PageHeader1 section, click on the text that says “Proposal”. 

 

2) With the mouse, move this textbox (TextBox14) until it is aligned with the left side of the page 



 

3) With the textbox still selected, go to the Properties window and set Alignment = Left 

 

4) With the textbox still selected, go to the Properties window, scroll down to the Text property, 

and replace “Proposal” with “My Proposal” 
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5) To change the image in the header, first select it with the pointer 

 

6) Now hit Delete to remove the image 
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7) To add a new image, drag and drop the Picture icon from the toolbox to the PageHeader1 

section 

 

8) In the properties window, click on the image property and browse to the desired image file on 

your hard drive 
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9) At this point you will see the image in the design pane 

 

 You may also need to set the SizeMode and Picture Alignment properties to see all of the 

picture 

10)
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11) Resize the image using the handles on the image. You may need to adjust the size of the 

Header area before or after you do this. 

 

 

Step 3: Preview and Publish the Report 

1) Go to File -> Preview to preview the report vs. a sample project. Close the window when done. 
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2) When satisfied, go to File -> Publish. Click ‘Yes’ at the prompt. You will be returned to the 

reporting center and your custom report will appear in your reports list. 

 

Brother Wire Labels 
When you generate the “Brother Wire Label Printer” report, you have the option of choosing from 

the stock SI 5 templates: 

 



When you select a label template, a preview will display: 

 

Click the  button to print all of the labels or select just the labels that you would like to print 

(use Ctrl or Shift to select multiple labels) and click the  button. 
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All of the stock SI 5 templates are designed to work with 1” wide labels.  They are stored in the 

following location: 

XP: C:\Documents and Settings\All Users\Application Data\D-Tools\SI5\Templates 

VISTA: C:\ProgramData\D-Tools\SI5\Templates 

 

If you wish to create your own templates, we recommend that you use on of our stock templates 

as a starting point.  All editing of these templates is done with the Brother P-Touch Editor software 

that comes with your Brother PT-9500 PC/ PT-9600 PC printers. 

Example: You want to change your company logo on the 3” Flag Label. 

1) Launch the Brother P-Touch Editor applications.  If you are prompted for a 

layout, choose “Open an Existing Layout”, otherwise select File->Open: 
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2) XP Users:  Browse to the C:\Documents and Settings\All Users\Application 

Data\D-Tools\SI5\Templates folder, select the template and then click [Open]: 

3) VISTA:  C:\ProgramData\D-Tools\SI5\Templates 
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4) The template will open: 

 

5) Select and delete the existing logos. 

6) Select File->Insert->Picture->From file. 

7) Browse to your logo and click [Open].  The logo will be inserted into the editor. 

Move/resize/flip the logo until you are pleased: 
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8) XP Users:  Select File->Save As…  Name the file and save to the C:\Documents 

and Settings\All Users\Application Data\D-Tools\SI5\Templates folder. 

9) Vista Users:  C:\ProgramData\D-Tools\SI5\Templates 

For detailed information on using the Brother P-Touch Editor software, select Help->User’s Guide 

from within the application. 



Excel Reports 
It is possible to export data directly to MS Excel by using the Excel Reports feature. This allows you 

create a custom report using Excel and have the data populate automatically based on how the 

report is run in SI. 

The basic steps to using this feature are: 

1. Create an excel file that is linked to the D-Tools SI5 XML Schema (http://www.d-

tools.com/schemas/si5/reports/dtoolsreport.xsd) 

2. Map D-Tools data fields into one or more worksheets in this file 

3. Create pivot tables, graphs, or other reports using this data 

4. Import the report into the Reports List using File > New > Excel Report from the Reporting 

Center 

5. Run the report from the Reports List just like any other report. Excel will open with the 

specific data populated. 

Sample excel reports can be downloaded here, and imported into SI5 using Tools > 

Import Report from the Reporting Center. 

http://downloads.d-tools.com/si5/documents/download_reports.html#Excel

 

Create a Custom Excel Report File 

Link to D-Tools XML Schema 

In Excel, 

1) 

2) 

3) 

4) 

5) 

Go to View > Task Pane (Developer > Source in Excel 2007) 

Go To XML Source (dropdown) (not needed in Excel 2007) 

Click on XML Maps… (button) 

Click on Add… 

Copy this URL into the File Name line: 
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http://www.d-tools.com/schemas/si5/reports/dtoolsreport.xsd  

6) 

7) 

Click Open 

Select DToolsReport as the XML root node 

 

8) Click OK 

Note: You can map this same XML source more than once if you wish to map the 

XML data field more than once in the next step. 
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Map the Data Fields into Excel Columns 

The Task Pane shows a list of all data fields available. You can drag and drop data fields directly 

from the Task Pane to an excel spreadsheet. This will add the data field to your report source data. 
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Keep adding fields until you have all of the data you wish to report on. 

 

Load Sample Data into Excel for Design 

In order create a design layout, you will need some sample data. This data will be replaced when 

you run the report from the Reporting Center, but is useful to see how your report behaves prior to 

this. 

D-Tools provides sample data in your SI5 Global Application folder (C:\Documents 

and Settings\All Users\Application Files\D-Tools\SI5\Other Files). Unzip the file 

Excel Report Sample Data.zip to get the sample data.  

VISTA:  C:\ProgramData\D-Tools\SI5\Other Files 

To load the sample data into your report, follow these steps: 

9) 

10)

Go to XML > Data > Import… (Developer > Import in Excel 2007) 

 Browse to the XML file containing the sample data (C:\Documents and Settings\All 

Users\Application Files\D-Tools\SI5\Other Files\Excel Report Sample Data.xml in this example) 

VISTA:  C:\ProgramData\D-Tools\SI5\Other Files\Excel Report Sample Data.xml 
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This will load the sample data into the spreadsheet so that you can design your report. 

 

Create Reports Based on Imported Data Columns 

Once you have imported the sample data, you can create your own report using Excel’s reporting 

features, such as Pivot Tables and Pivot Charts. See the Microsoft Excel users guide for details on 

how to do this. 

Sample excel reports can be downloaded here, and imported into SI5 using Tools > 

Import Report from the Reporting Center. 

http://downloads.d-tools.com/si5/documents/download_reports.html#Excel
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Link Excel Report to Reporting Center 

Once you have created a custom Excel report, you can import it into the Reporting Center so that it 

will appear on your Reports List. To do this, go to the Reporting Center and to to New… Excel 

Report in the File Menu. The Add Report Dialog will appear. 

 

Enter the name of the report and a brief description. You can also choose which report category 

this will appear in. Output Format should always be “Excel” for Excel reports. Click [Browse] to 

find your custom Excel report file on your computer, then click OK to add the report to your list. 

Running an Excel Report 
At this point the Excel report will appear in your report list and can be run just like any other 

report. When you do, Excel will open and the data from your D-Tools project will be populated. 
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Report Options 
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Contract 

 None 

Cover Page 

 None 

Line Item Detail 

 Group up to 3 levels 

 Show Labor by Phase 

 Show Page Header and Footer 

 Show Model Numbers 

Project Contact Information 

 None 

Proposal (all stock Proposals) 

 Group up to 3 levels 

 Sort 

 Show Labor by Phase 

 Show Page Header and Footer 

 Show Model Numbers 

 Summarize Packages 

 Summarize Accessories 

Proposal Summary 

 Group up to 3 levels 

Scope of Work Document 

 None 

Avery Walk-Thru 5263 

 None 

Brother Wire Label Printer 

 None 

Bulk Wire Termination Report 

 None 

Wire Checklist 

Group by 1 level 
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Sort 

Wire Connections 
 Group up to 2 levels 

 Sort 

Wire Labels (By …) 

 None 

Wire Termination Report 

 None 

Check List 

 Group by 1 level 

 Sort 

Detail Cost Summary 

 Group by 1 level 

Gross Profit 

 Group by 1 level 

List Blank Items in Project 

 Sort by Price or by Hours 

Pick List 

 Group by 2 levels 

Project Hours 

 Group by 1 level 

Purchase Order Request 

 Group by 2 levels 
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