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Report Designer

Pro users have the ability to create custom reports using the Report Designer. To open the report

designer interface, go to Tools > Report Designer in the menu bar of the Reporting Center.
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;'ﬁA Creating custom reports is for advanced users only. It is the sole responsibility of the

user to debug any custom reports.

“Tj The D-Tools Report Designer is based on ActiveReports for .Net 3.0 by Data
Dynamics. For a complete user guide on this interface, see the ActiveReports User

Guide located at

http://www.datadynamics.com/forums/72/ShowForum.aspx.
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The Report Designer interface will
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Please select 'New'

or 'Open’ from the menu to begin designing a report.
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This interface consists of these parts: 1) menu bar, 2) shortcut toolbar, 3-4) formatting toolbars,

5) toolbox, 6) design pane, 7) data and report explorer, 8) properties, and 9) script tab.
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Menu bar

File > New (New Report Wizard)

To create a new custom report, go to File... New. The New Report Wizard will open

'Q' Hew Report Wizard

New Report Wizard

How do pou want to create a new repoit?
P Please select one of the options below and click Nest' to start creating your
hEwW report

() New Report Baszed on Existing Report

Select thiz option if you want to create a report that is baged on a curently defined
report, The report designer will start with the layout of the report that wou select and
you will be able to change the design on the new repart,

(") Mew Blank Repart

Select this option if you want to create a blank report.

Select New Report Based on Existing Report to create a custom version of an existing report,
or New Blank Report to create a report from scratch.
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If you chose New Report Based on Existing Report, you should then select which report you wish to
modify.

Hew Report Wizard

New Report Wizard

‘e will create a new report based on an existing report

Please select a report below that you want to base thiz new report on and
click Mext' to begin modifying the new report.

Feports avalable to base your new report on

Feport Mame Description Categomny Data.. |#
Line Item Report Line Item Feport that supports Dpnami..  Client Repo... DTool..
Purchaze Order Request Purchage Order Request Document tdanageme..  DTool..
Purchaze Order Request [P..." Purchase Order Request Document tanageme.. OTool..
Pick: Ligt Pick List Manageme... DToal..
Proposal Summary Project Summary [nformation showing ... Client Repa...  DTool..
Contract DToals Standard Contract Docurnent Client Aepo... DToal..
Contract Payment Subrepart far payment periods DToal
Contract Phases Subrepoit for price by phase periods DOTool

Caver Page [T ools Standard Cover Page Client Repo... DToal..
Project Contact Information List of all contacts for a project. Client Repo... OTool..
Scope of Work Document Ligt of all contacts for a project. Client Repo... DToal..
Misc. Costs Subrepaort for Project Misc. Costs Client Repo... DToal..
ProjectT axD etail Surarary of taxes for a project Client Repo... DToal..
Project Summary Detail Breakdown of labar price for a praject Client Repo... DToal
Project Install Summan Detail  Installation price summary for a project Client Repo...  OTool

Gross Profit By Phase Grosz profit of project grouped by phase  Manageme.. DTool..
Gross Profit By Categomny Grogz profit of project grouped by cate..  Manageme.. DTool..

List Blank ltems In Praoject Items in a project with values of zero f...  Manageme... DTool.. |»

Cancel

Prewvious (7 T]
ah

The next screen allows you to set the report name, enter a description, and determine which report
category the report will appear in. It also allows you to mark this report as a Sub-Report or a

Business Manager report.

Hew Report Wizard

New Report Wizard

How zhould we identify this new repart?

In order to find this repart in the Reporting Center, we will need to give it &
name, description, category and the data source it will uze ta render the
report.

[] Thisis a Sub Report [[] List this report in the Business Manager

Report Name:

my Custom Line Item Repor] Ib

Description:

Line [tem Repart that supparts Dynamic Grouping and Filkering with item quantities aggregated. I:}

Categary:
my Custom Category

Data Source:

DTools Report Data -

Previous J l Next g I Cancel

Revised August 29, 2007



SI5 User and Administration Guide 531

From here on, just hit "Next” at every screen to duplicate the report you are
@ modifying.

Note 1: Sub-reports do not appear in your reports list. They are generally

smaller reports which are included in other reports. An example is the Miscellaneous
Costs sub-report.

Note 2:  The Report Name is the name that will appear in the Reports List

Note 3:  The "Data Source” field should always say “"D-Tools Report Data”. For
future compatibility.

In the next screen, set the page orientation and margins.

- New Report Wizard 4

New Report Wizard

How waill i report print?
pIA “Y'ou can set up the orientation and maiging of the page here.

Page Setup;

Orientation

= (®) Polrait
— () Landscape

b arging
Top |1.00 > Battom |1.00 -

Left [1.00 s Right 1.00

<

Prevmusl I et - I Canicel

\
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Next, choose whether the report will support sorting, filtering, and dynamic grouping. Also, choose
which fields are available to be grouped and/or sorted by.

t‘ Hew Report Wizard

New Report Wizard

Diaes this new report support sarting, filkering and grouping?

i If wou want thig report to have the ability ta gor, filter and group your data,
select the appropriate options below. [f your report will support Diynamic
Grouping, you will also be required to select the properties on which pour

report will be allowed to group.

Suppart Sorting Suppart Filkering
Support Dpnamic Grouping

Lwailable Properties: Azzigned Properties:

Accountingl terlD -~ Category
AccountingendorM ame Lacation
AssignedResource Zaone
Categony T ype

Cost *
EquipmentT ype

Expected nstslD ate
HeadEnd

InstallD alsl}

Imstalled
Fepwordl

Fepword2

Fepword3

LocationD etail

Manufacturer
Model v

@

Previous | [ Nest— Cancel
I J N I |

A \1
T 9@ Only some of the standard reports are set up to support Dynamic Grouping,

regardless of whether this checkbox is checked. See the ™
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Report Options” on page 559 to see which reports are.

It does not always make sense to group or sort by all fields, depending on the

report. Experiment and see which fields work with which reports.

The next step is to define the required groupings. In Line Item reports this determines how data is
aggregated. Just click ‘Next’ if you are uncertain. The example below would be good for creating a
BOM where you want a quantity followed by the Manufacturer and Model. This process would

group all like Products together. Other useful groups could include, Category, Location, Phase and
Zone.

# Hew Report Wizard X

New Report Wizard
Dioes this repart require a specific grouping?

2 IF this report requires specilic groupings in order to sum up totals conectly or
break on certain values, please assign the approniate properties to the
required groupings list box,

Fequired Groupings.

Awailable Properties; Assigned Properties;

AccauntingltermlD ~ Manufacturer

AccountingyendorM ame Model

AssignedResource R
Categary &
Categony Type

Cost

EquipmentT ype

ExpectedinstalDate ¥
HeadEnd

InstallD ate

Installed

Fepword]

Kepword2 S

Fepword3

Location

LocationDetail

OwnerFumnizhedE quipment

PackagelD

PackageMame

Phase b

Previous J l Next Jlb I Cancel
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Next choose a required sorting option, if desired

New Report Wizard
Does this repart require a specific sort order?
If thiz report requires that your data is sorted in a specific way, you can define
your soit arder here
Required Sorting:
Sort Order Direction
" Price %‘Ascaﬂdmg +
*
+
Previous I l Mewt— 4 I Canicel
s
Now, set any required filters, if desired.
F Mew Report Wizard X

New Report Wizard

“will this report require filkers at run ime?

You can define a set of data fikers that this report will run prior to rendering

the output. You can exclude certain records from the report by setting up the
filters here.

Fiequired Filkers:

Field Operator Walue
% Phaze Equal To Finish
*

Previous J l Next ]\i I Cancel
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The next screen allows you to save report parameters.

Hew Report Wizard

New Report Wizard

“will this report support parameters?

You can control how a report renders during runtime by supplving and
consuming parameters. For example, you can define a "Show Details”
parameter and hawve the report look at that parameter at runtime to determine
if it should be a detail report or just a summary repoit

Fieport Parameters:

Narme Description [rata Type alid Y alues Default W alue
» LaborByPhaze Show labor by phage in the. Boolean [}
ShowPageHeader  Show Page Headers and F.. Boolean
*
l Frevious J l Next J I Cancel I

The final screen is a review of your report definition. Click Finish to save and start editing the
report.

Hew Report Wizard

New Report Wizard

‘W are almost done creating your new repart,

Fieview the summany information and werify that all pour options have been
set comectly. Click the Finish' button to start designing your new report in the
report designer or click the Previous' button to change your oplions.

Report Type A
‘You have opted to create & new report based on the Line Tkem Report’ report with the Following
configuration:

Report Information

Report Type:

Sub-Report: Mo

List Report in Business Manager: No

Report Name: my Custonn Line Ikem Report

Description: Line Item Report that supparts Dynamic Grouping and Filkering with item quantities
aggregated,

Category: my Cuskom Category

Data Source: DTools Report Data

Page Setup
Orientation: Portrait
Margins: Top = 1,00 Left = 1.00 Botkom = 1.00 Right = 1.00

Sorting, Filtering and Grouping
: Mo

q: Yes
Nunamic Grouninn: Yes

PrewousJ l Finish- 4 I Cancel

la
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The report opens and is now an Unpublished Report that can be edited.

Vv Un-published report: my Custom Line Rem Report (Lineltem_39209.0805823148.rpx)

File  Edit A
EI @ El i;i > i > ) > 5 Gk 100% v B2 (
BIU A®#* ==== 4
¢
Toolbox 4 | 1 z 1 3 | Report Explarer | Data Explorer i
ActiveReports 3.0 ] PageHeader! A Report Explorer I
A Label =0 Repot
#- = PageHeader!
TextBox #-= GroupHeader] ¢
CheckBosx = [ GroupHeaderl +-= gpHeadings /
RichTextBox - #-= GrpDynamicHeader! -
— #- = GrpDynamicHeader2 A
(| Shape B +EI GrpDynamicHeader3 /
& Ficture +EI arplternH eader
/ _ : = Detal {
Line 1 i= grplternFooter
= PageBreak . - = GrpDynamicFooter3
I earcade : - = GrpEynamichoter? \
[ subReport _ o Properties X.
@ DleObject o= (5 ,
sl ChartCantral 2 [ ataM ember ‘/
Repotinfo — [ DataSource DataDynamics.A
- ExpressmnErrorMe
oy Ny -, - e e ——
\ﬂ, Y o N e 4 =

File > Open

File... Open allows you to open a custom report that you have already created.

Reporting Center
Fle Edt Todls *
LG D P8R )
Reparts List i

—-—= Report Categories
—_J EIlentHeporls

Eile Edit
- Contract ,
Lover Page B new... b2l 7 G G 100% [v|
Line Item Report * Open » Open Existing Report = .
my Proposal Edit DTools Report Informati Open Unpublished R t% i
J Project Contact Information it DToalks Report Information pen Unpublished Repor

Proposal Edit Repart Definitions
J Proposal Summary Tc , ol B i
= . P
-89 Propozal \With Images i m reviEn S eader]

Scope of Work Document Bl Save for Later

_—J Excel Reports “ E'I;l Publish Report
-8 Excel - Component Uzage R

Header1 /

Existing reports are published custom reports that appear in your Reports List

: -8 Excel - lbem List B Exit
* ------ tB) Excel - Projects By Staff = H
. 4 -.\LJ' "“IIDYLH@DEQE..#‘ P @E}iﬂﬂ""\ Y e
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Unpublished reports are custom reports that you are still working on. They do not appear in the

reports list until you publish them

File > Publish

File > Publish will publish the report you have open so that it will appear in your Reports List.
Choose this when you are satisfied and want to start using your custom report. Note that this will

close the report for editing.

File > Edit D-Tools Report Information

To change the report information you entered during the New Report Wizard, use File > Edit D-
Tools Report Information. This will re-open the wizard and allow you to change the settings,

including report name, grouping/sorting/filtering settings, and other options.

File > Edit Report Definitions

If you want to create some custom report definitions for your report, go to File > Edit Report
Definitions. Report definitions created here will appear in the Reports List beneath the report

name.

File > Preview

File > Preview will allow you to preview your report vs. a sample project without having to publish

the report or exit the report designer.

File > Save

Use File > Save to save an unpublished copy of your report for future editing. You will need to

publish your report later if you wish to see it in your Reports List.
Edit

The Edit menu has an assortment of commands which are helpful when editing your custom report:
Undo, Redo, Cut, Copy, Paste, Delete, and Select All.

Toolbars

There are two sets of toolbars. The first has one-click shortcuts for most of the items in the Menu

Bar: New/Open/Save/Preview Report, Cut/Copy/Delete, Undo/Redo, and Zoom In/Out.

B B W 7 ABEX ma | & G| v 5
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The second set of toolbars is used for editing textboxes and other objects within your report: Font
settings, Colors, Alignment, Indentation, and Grouping. Use these to set the properties of report

objects when you have one or more objects selected in the Design Pane.

Impact vlojv] B T U A = ===

e
L]
4

[Hl

1ry = m|

H B e

Toolbox

The Toolbox contains a selection of objects that you can drag onto the Design Pane: Labels, Text
Boxes, Lines, and Pictures are the most common. Text Boxes in particular can be bound to a data

field for display in your report.

Toolkox 4 Vvl v e a2 o 03 o e vd o v 5 o [ Report Explorer | Data Explorer ’
ActiveReports 3.0 ] PageHeader # |||Report Explorer '
A Label =~ [Repot i
Tot +-= PageHeader f
57| TentE ok e +-= GroupHeaderl ‘
EheckBok‘\\“'- + = gpHeadings ’
RichT extBos = GrpDynamicHeader]
+ = GrpDynamicHeader2 b
[ shape +- = GrpDynamicHeader3 ?
&= Pictue = gipltemHeader .
. : Detaill
é Line arpltemF oater /
™ PageBreak : GrpDynamicFoaoter3 J
Il Barcode + = GrpDynamicFooter? F
[ SubReport Properties (
@ DleObject =21 ,
ulll ChartControl [Marne] TextBox2 ,
Reportinfo Alignment Left -
BackCalor 1 Transpa(r
CanlGrow True }
= [] GrpDynarnicH eaderl CanShrink Falze
......... L s [T ClassMame Marmal )_‘
* Masn et B el a1 MY Dl satmabd it © 00000 fiiieioitiiiiil Deiiiiiiiiiiei Dol ) CountMullvalues | Falss &
- = D ataField dtr:Price .+
s I\ il 433\_'?5’9”_'_3[ | 4 xSC”DtJ’M Y \NIA KT 3 e N N ™~ LT TPV S ‘I}
ot To bind the text in a TextBox to a data field, select the TextBox, then go to the

Properties area and select DataField. Type in the name of the data field (e.g.
dtr:Price) you wish to bind to the Text Box. D-Tools Report data field names are

found in the Data Explorer.

Design Pane

The Design Pane, located in the center of the Report Designer, is where you go to modify the
layout of your report. You can drag and drop objects from the Toolbox or Data Explorer onto the

design pane for display on your reports.
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Page Headers and Footers

Objects in the Page Header or Page Footer sections will appear at the top or bottom of each page,

respectively.

Group Headers and Footers

Group headers affect the way the data is iterated over. Most often, groups are linked to a data
field, such as dtr:Location or dtr:Category. This causes this section of the report to repeat itself

once for every member of the group.

1'\9(! Some reports come with special groups named GrpDynamicHeader1, 2 or 3. DO
@ NOT RENAME THESE as they are used to implement dynamic (run-time) grouping.
Similarly, the group name is in a textbox with name txtDynamicHeader1, 2 or 3,

which should also not be renamed.

Detail

The Detail section shows what happens for each member of the data set. Use this section to add or

remove data fields for each item in your report.

= = [retaill
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Data Explorer

The Data Explorer is where you go to find data fields for your report. It is initially located on the

right, as a tab behind the Report Explorer. Use the Data Explorer to browse through the XML

structure, then drag-and-drop data fields onto the Design Pane.

S R T T N T T T S IO B |

—
Feport Explorer  (( Data Explores |

Data Explorer

= Bound =ML Data
“ujir: D T oolzR epart
. dir:Created
- dirc: FleportCriteria

idtr: Project

|} dir:M arne

kr:Project D

i dir:Project urnber

+|- dir:PresentedBly

+- dirPresentedTa

+- dir:Billing&ddress

= dir:ltems

- dir:ltem
dtr:ternl O
. dirParentlD
- dir:Cantity
- dir:Component|D
dtr:Cateqaory L

< »

Propetties a
=)
[Marme]

Alignrment
BackColor

TextBox2 L
Right
[ 1 Transparent

Canla row

S

L True P

A e o et st — f

The Data Explorer is where you go to find data fields for your report. It is initially located on the

right, as a tab behind the Report Explorer. Use the Data Explorer to browse through the XML

structure, then drag-and-drop data fields onto the Design Pane.

et

@

—

Most of the information you will be looking for can be found under dtr:Project. Data

fields for specific items are found under dtr:Items/dtr:Item.
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D-Tools report data is based on an XML schema that is defined here:

http://www.d-tools.com/schemas/si5/reports/dtoolsreport.xsd

Properties

The properties window is where you go to change fonts, alignments, and any other properties of

objects in your Design Pane. Select an object in the design pane first, then go to properties to

modify the behavior of the object.

p—

=l u:I_tr:I-‘n:qeu:t

s ( Fropeties

me- Alighment
. B ackColor
CaniGrom
rrror, CanShrink,
jan ClazzMame
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Font
ForeColor
HyperLink,
Location
MultiLire
OutputFormat
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Size
Style
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SumnmaryGroup

Summany T ype
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Test

igible
Sl Wordwrap

? = [Mame]
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Falze
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A Adu:Project/dir:Hame

Arial. 12pt. style=Bold

Il Elack
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Falze
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font-weight: hold; font-size: 12pt;

Sum
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Mone

Project Hame
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True
True

The name property for the component
Jxﬁ.'-._ .-'-\"\ x__.-’f . ‘q‘."-\_.-""'-__.’\ﬂ-“-\ﬁ 4

g
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Script

Reporting Center

The Script tab, located behind the Design Pane, is where you go to enter in .Net code. This allows
you to take programmatic control of your reports. Either C# or VB.NET can be used. Note that all

D-Tools reports have some amount of script code in them already.

# Un-published report: my Proposal (Proposall evellltems_39208.9352678241.rpx)

Filz  Edit
B & B HE
Toolbox 7

ActiveReports 3.0

A Label
TextBox
CheckBox
RichTextB ox
D Shape

& Picture

/' Line

=)

1 PageBresk
Il Earcode
[Ec] SubReport
@ DleObject
ol ChartCantral
Feportinfo

£

Arial 1z

=
[
I
=
I
Il
il
il

B | -

"%

. Project Name ..

_:@ Dz‘asign 6 Scriptl
L=y,

= el
Report Expl ... Drata Explarer
|||Data Explarer n
= Bound %ML Data -
Properties n
@z [A ]
ez[24

Custom Report Example

To give a simple example of how to customize a report, let’s change the page header on a

proposal. Here’s how:

Step 1: Create a custom report based on an existing report

1) In the Reporting Center, go to Tools > Report Designer.

2) In the Report Designer, go to File > New...
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[

W Report Designer

File  Edit
E Mew. .. 1 »» *»

ﬂq i & fok |00 || 0

= Open

eader]

E Exit

{

! 4

4

. i

m oy
,

-

v

3) Choose “"New Report Based on Existing Report” and click Next

 Hew Report Wizard

New Report Wizard -
How do pou want to create a new report? (

Pleaze select one of the options below and click 'Mest' to start creating your g

new repark ;

‘81 ew Feport Based on Existing Feport f

elect thiz aptian if pou want to create a repart that iz bazed on a curently defined

port.  The report designer will start with the layout of the report that you select and ’
ol will be able to change the design an the new repart.

- ...-\.\__,__L__""‘- - ..,.\_--* e -..L__..h . .-_ﬂ, "-"., ____4."“"._\_?"\.’\.“ _4"' A -\-/

4) Select “Proposal” from the list and click Next
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Reporting Center

fmmen

o LI, g

R eports available t& Base yaLr Fiin report an

Report Hame

Check List

Wire Checklizt

Wire Connections

Wire Termination Report
Wire Labels Bo wire Mumber
“Wire Labelz By Head End
Wire Labelz By Location
e WalkThru - 5263

Item Accezson Report

Item Accessan Repart With .

Fropozal

Fropozal Level3 [tems
Propozal Level2 Items
Fropozal “with Images

g

Fropozal Lewvel3 [tems 'aith ...
Propozal Levels [tems With ...

Propozal with Skin 1
Fropozal with Skin 2

PR P g ., TR
o H\-\U /.-" e W e

Dezcrption

Equipment Checklist

Wire Checklizt. This report iz dynammic. ..
Wire Connechions

Wéire Termination Report

Wire Labelz By Wire Mumber

“Wire Labelz By Head End

Wire Labelz By Location

Avern Labels

Sub report used to zhow the detail [or ...
Sub repart uzed ta shaw the detail [or ..
Propozal that allows showing of packa...
Acceszony kems of equipment where t...
equipment items in a package or acce. .
Propozal that allows showing of packa...
Acceszony kems of equipment where t..
equipment ikems in a package or acce. ..
Propozal that allows showing of packa...
Fropozal that allows showing of packa...

Category

banageme...
Inztallation ..
Inztallatior ..
Inztallatior ..
Inztallatiorn ..
Inztallatior ..
Inztallatior ..
[nztallatior ..
Client Repo...
Client Repo...
Client Repo...

Client Repo...

Client Repo...
Client Repo...

Drata...

DTaal..
DTaal..
DTaoal..
DTaal..
DTaoal..
DTaoal..
DTaal..
DTaoal..
DToal..
DTaal..
DTaool..
CToal..
DTaal..
DTaoal..
DTaal..
DTaoal..
DTaoal..
DTaal..

S

-~

F'reviu:uus| | Ne:-ct_rﬂ_liq | Cancel

5) Name the report "my Proposal” and enter a description

6) Click ‘Next” at all further screens until you get to ‘Finish’, then click that as well.

BT e

Repart Mame:

my Propozal

Description:

Category:
Client Reports

Data Source:

DTools Report Data

pmm e T

[] This is & Sub Repart

T = N .
EEET P e

[] List this repart in the Business Manager

Custom propozal with my page header

Mewxt |

| Cancel |
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. Report Wizard

Report Wizard

we are almost done editing wour report,

Review the summary information and verify that all your options have been
zet comectly.  Click the Finish' button to save wour report definition or click
the Previous' buttan to change pour options.

Report Type -~
‘fou are editing the definition of the ‘my Proposal' report with the Following configuration: M

Report Information

Report Type:

Sub-Report: Mo

List Report in Business Manager: Mo

Report Name: my Proposal

Description: Customn propasal with my page header
Category: Client Reports

Data Source: DTools Report Data

Page Setup
Orientation: Partraik
Margins: Top = 1.00 Left = 1,00 Bottom = 1,00 Right = 1,00

Sorting, Filtering and Grouping
Supports Sorking: Yes
Suppotts Filtering: Yes
Dynamic Grouping: Yes
Location
Frne

I Previous‘ [ Finizh ] l Cancel

At this point the report has been created and can be edited.

¥ Un-published report: my Proposal {Proposallevellltems_39224.1327967269.1px)

File  Edit
BEE- B 7 BX ;AT L G [v] G
BIUA® ====
Toolbox n DL b 2 b 3 e b d a8 a6 o (|| Repaort Explorer | Data Explorer
ActiveReports 3.0 [=] PageHeaderl ~ |||pata Explorer 7
A Label R = Bound #ML Data
- Pr_w i =l dir. DT oolsReport
TestBox - - dirCreated
CheckBox =| [ GroupHeader! - dirc:RepontCiiteria
. - o =- dir:Project
RichTextBox - dirName
[ shape - - dir:ProjectiD
& Picture - dt:Projecthumber
X - - dir:PresentedBy
7 Line . #l- dir:PresentedTo
# PageBreak & + dir:Billinghddress
Il Barcode il E!l[.|_[l.3ITIS ) b
[ subReport - s Fropetties
@ Dlebject CCompany Addres l| .
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Step 2: Modify the Page Header

1) In the design pane, in the PageHeaderl section,

Un-published report: my Proposal (Proposallevellitems_39224.1327987269.rpx)

click on the text that says “Proposal”.
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2) With the mouse, move this textbox (TextBox14) until it is aligned with the left side of the page

Un-published report: my Proposal (Proposalleveliitems_39224.1327987269.rpx)
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3) With the textbox still selected, go to the Properties window and set Alignment = Left

n-published report: my Proposal (ProposalLevelltems_39224.1327987269.rpx)
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4) With the textbox still selected, go to the Properties window, scroll down to the Text property,

and replace “Proposal” with “My Proposal”

Un-published report: my Proposal (Proposallevellitems_39224.1327987 269 .rpx)
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5) To change the image in the header, first select it with the pointer

Un-published report: my Proposal (Proposalleveliitems_39224.1327987269.rpx)
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6) Now hit Delete to remove the image

Un-published report: my Proposal {Proposallevellitems_39224.1327987269.rpx)
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7) To add a new image, drag and drop the Picture icon from the toolbox to the PageHeaderl

section

# Un-published report: my Proposal {Proposallevellltems_39224.1327987269.rpx)
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9) At this point you will see the image in the design pane

Un-published report: my Proposal (ProposalLevellitems_39224.1327967269.rpx)
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10)You may also need to set the SizeMode and Picture Alignment properties to see all of the
picture
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11)Resize the image using the handles on the image. You may need to adjust the size of the
Header area before or after you do this.

% Un-published report: my Proposal (Proposall evellltems_39224.1327987269.rpx)

© Fie Edt

- » | > -
B B W sBREX| aaf oo
© Impact 20 BIU A
@ FEE Fiel B
Taalkox 4 Vol e b 2 b a2 g a5 a6 oo || Report Explorer | Data Explarer
ActiveReparts 3.0 ~ ||Report Explorer a
Label 5 g R B = = GrpDynamicHearer! [»]
- ARE NN o I = GrpDynamicHeader2
Tl R R L = GmDynamicHeader3
CheckBox —' 1 GroupHeader! i—change header size here - = Detail
=] RichTexteiox = GrpDynamick ooter3
- Presented By il TN DI S e ModitedDate = GrpDynamicFooter?
[ Shape T  Revision:)[1ii0 iRewill = GrpDynamicFoaterl
=] Picture = ! 8 = GroupFooler2
Vs - Y 1 = gipSubTotal
u L N F i - = PageFoater!
ol PageBreck : b — i -5 Fields
[ & arcode R i i Parameters
0] SubReport Tommmmmmmnomnn Properties
@ Dot - Company Name broject Company
bl ChatContral - Company Address: Project Address: 1o i i (Mame) Picturel ~
Aepatinfa e T BackColar [ Transparent
=| [ apHeadings DataField
~ 0 Description
S| Deserdpton e nPrlea) hyperlink =
= [ GrpDynamicHeader! =
Dvhiamic¢ Binding DCCNOT Renams : o Diiioiiiiiiiiliiiioriiiiiiinfiraiiiiiiinin]iiiifis ’il The name propety for the component

7@ Designer 6 Script \

Step 3: Preview and Publish the Report

1) Go to File > Preview to preview the report vs. a sample project. Close the window when done.
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2) When satisfied, go to File > Publish. Click ‘Yes’ at the prompt. You will be returned to the

reporting center and your custom report will appear in your reports list.
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